The Adobe Flash authoring tool is frequently updated to correspond with security and general updates for Adobe Flash Player and the Adobe AIR runtime. This document tracks all the updates and installation steps required for each release (beginning with Flash Player 9). In most cases, you only require the most recent update for your authoring application. However, in some cases, installation Prerequisites are called out.

In many cases, this information is also duplicated in a previously published TechNote, but is repeated here. Both installation steps match for that particular update.  In general, the most recently dated update is the only one you require. 

IMPORTANT: How to Use this Document

Find your version of the Flash authoring tool in the following Table of Contents. Follow the instructions in the most recent update link. If any previous updates are required, they are noted in a Prerequisites section.  If no prerequisite is shown, then only the most recently dated update is necessary.

Adobe Flash Player 10 Security Release Update for Flash CS4 Professional 

Feb 11 2010: This download contains fixes for critical vulnerabilities identified in Security Bulletin APSB10-06  Flash Player update available to address security vulnerabilities. The update replaces the Debug and Release versions of Flash Player 10 browser plug-ins and stand-alone players included in the initial release of Flash CS4 Professional (player version 10.0.2.54). All users apply this update. These new players are version 10.0.45.2.

Instructions for installing Flash Player 10 Security Update for Flash CS4 Professional APSB10-06

  1. Quit Flash CS4 Professional.
  2. Open the downloaded ZIP file.
  3. Extract the contents of the file to:

    Windows: C:\Program Files\Adobe\Adobe Flash CS4\

    Macintosh: <drive>Applications:Adobe Flash CS4
  4. When asked to replace the existing Players folder, choose Yes.

Adobe Flash Player 9 Security Release Update for Flash CS3 Professional

Feb 11 2010: This download contains fixes for critical vulnerabilities identified in Security Bulletin APSB10-06 Flash Player update available to address security vulnerabilities. The update replaces the Debug and Release versions of Flash Player 9 browser plug-ins and stand-alone players. All users apply this update. These new players are version 9.0.262.0.

Instructions for installing Flash Player 9 Security Update for Flash CS3 Professional APSB10-06

  1. Quit Flash CS3 Professional.
  2. Open the downloaded ZIP file.
  3. Extract the contents of the file to:

    Windows: C:\Program Files\Adobe\Adobe Flash CS3\

    Macintosh: <drive>Applications:Adobe Flash CS3
  4. When asked to replace the existing Players folder, choose Yes

Adobe Flash Player 10 Security Release Update for Flash CS4 Professional 

Dec 08 2009: This download contains fixes for critical vulnerabilities identified in Security Bulletin APSB09-19  Flash Player update available to address security vulnerabilities. The update replaces the Debug and Release versions of Flash Player 10 browser plug-ins and stand-alone players included in the initial release of Flash CS4 Professional (player version 10.0.2.54). All users apply this update. These new players are version 10.0.42.34. 

Instructions for installing Flash Player 10 Security Update for Flash CS4 Professional APSB09-19

  1. Quit Flash CS4 Professional.
  2. Open the downloaded ZIP file.
  3. Extract the contents of the file to:

    Windows: C:\Program Files\Adobe\Adobe Flash CS4\

    Macintosh: <drive>Applications:Adobe Flash CS4
  4. When asked to replace the existing Players folder, choose Yes.

Adobe Flash Player 9 Security Release Update for Flash CS3 Professional 

Dec 8 2009: This download contains fixes for critical vulnerabilities identified in Security Bulletin APSB09-19  Flash Player update available to address security vulnerabilities. The update replaces the Debug and Release versions Flash Player 9 browser plug-ins and stand-alone players. All users apply this update. These new players are version 9.0.260.0.

Instructions for installing Flash Player 9 Security Update for Flash CS3 Professional APSB09-19

  1. Quit Flash CS3 Professional.
  2. Open the downloaded ZIP file.
  3. Extract the contents of the file to: 

    Windows: C:\Program Files\Adobe\Adobe Flash CS3\

    Macintosh: <drive>Applications:Adobe Flash CS3
  4. When asked to replace the existing Players folder, choose Yes

Adobe Flash Player 10 Security Update for Flash CS4 Professional 

July 30 2009: This player update contains fixes for critical vulnerabilities identified in Security Bulletin APSB09-10. This update replaces the Debug and Release versions of Flash Player 10 browser plug-ins and stand-alone players included in the initial release of Flash CS4 Professional and the 10.0.2 authoring update. All users apply this update. The new player versions are 10.0.32.18.

Instructions for installing Flash Player 10 Security Update for Flash CS4 Professional APSB09-10

  1. Quit Flash CS4 Professional.

  2. Open the downloaded ZIP file.
  3. Extract the contents of the file to:

    Windows: C:\Program Files\Adobe\Adobe Flash CS4\

    Macintosh: <drive>:Applications:Adobe Flash CS4
  4. When asked to replace the existing Players folder, choose Yes.

Adobe Flash Player 9 Security Update for Flash CS3 Professional

July 30 2009: This player update contains fixes for critical vulnerabilities identified in Security Bulleting APSB09-10. This update replaces the Debug and Release versions of Flash Player 9 browser plug-ins and stand-alone players that are included in Flash CS3 Professional. All users apply this update. The new player versions are 9.0.246.0.  

To install:

  1. Quit Flash CS3 Professional.
  2. Open the downloaded ZIP file.
  3. Extract the contents of the file to:

    Windows: C:\Program Files\Adobe\Adobe Flash CS3\

    Macintosh: <drive>Applications:Adobe Flash CS3
  4. When asked to replace the existing Players folder, choose Yes. 

Adobe Flash CS4 Professional Update (10.0.2)

May 13 2009: This update for Flash CS4 Professional (10.0.2) addresses issues related to compiling large projects and other issues.  This update is for anyone working with Flash CS4 Professional.  Most customers get it via Adobe Update Manager:

  1. Launch Flash CS4 Professional.
  2. Choose Help > Updates.
  3. The Adobe Update Manager application launches and determine what updates to install. This process checks for all CS4 updates, and can take a few minutes.
  4. To install CS4 updates available for your system, choose Download And Install Updates.

Manual installs are also available as EXE and Mac OS X DMG at http://www.adobe.com/support/flash/downloads.html

Adobe AIR 1.5 Update for Flash CS4 Professional (10.0.1)

November 17 2008: This update for Flash CS4 Professional supports the release of Adobe AIR 1.5. Adobe AIR is the Adobe cross-operating system runtime that allows you to deliver personal, interactive experiences to the desktop. Among the many new features of Adobe AIR 1.5, is support for the capabilities of Flash Player 10. This version of Flash Player includes 3D effects, custom filters, and advanced text support.

This update also provides fixes for problems related to compiling large files and applying motion to multiple objects. It addresses issues related to the Adobe Product Improvement Program on Microsoft Windows Vista. It resizes the document in a Flash slide presentation file, and works with full-screen FLV files. This update is for anyone already working with Flash CS4 Professional.

Note: Also consider installing the previous Flash Player 10 Update for Flash CS4 Professional and the Adobe AIR runtime.

To install the Adobe AIR 1.5 Update for Flash CS4 Professional using Adobe Update Manager, launch the update from Flash CS4 Professional:

  1. Launch Flash CS4 Professional.
  2. Choose Help > Updates.

    The Adobe Update Manager application launches and determine what updates to install. This process checks for all CS4 updates, and can take a few minutes.
  3. To install CS4 updates available for your system, choose Download And Install Updates.

For users preferring a different option to Adobe Update Manager, downloadable updaters are available for Adobe Flash CS4 Professional (10.0.1).

To install the Adobe Flash Player 10 Update for Flash CS4 Professional, see the information below for your operating system:

Note: When performing a manual install, be certain to download the correct installer for your language version of Flash CS4 Professional. There is no warning if the wrong language is installed, but the language-specific files are not installed.

Instructions for Adobe Flash CS4 Professional on Windows

  1. Download the update EXE file for your language from Flash Downloads.
  2. Locate the downloaded updater file. For example, the English Windows update file is named:

    flash10-en_US_10_0_1_Update.exe
  3. Close all Adobe CS4 applications, Instant Messengers, and web browsers.
  4. Run flash10-en_US_10_0_1_Update.exe
  5. Follow the on-screen instructions to complete the update.

Instructions for Adobe Flash CS4 Professional on Mac OS

  1. Download the update DMG file for your language from Flash Downloads.
  2. Locate the downloaded DMG file. For example, the English Mac OS updater file is named:flash10-en_US_10_0_1_Update.dmg.
  3. Close all Adobe CS4 applications, Instant Messengers, and web browsers.
  4. Double-click the DMG to expand. Inside the DMG is the updater file. The English Mac OS update file is named "Setup. Double-click the updater file.
  5. Follow the onscreen instructions to complete the update.

After installing the Adobe AIR update, you can see the following changes in Flash:

  • In the Publish Settings dialog box (File > Publish Settings), on the Flash tab, Adobe AIR 1.1 entry in the Version menu is replaced with Adobe AIR 1.5.
  • New airglobal.swc file that includes all ActionScript 3.0 APIs and Adobe AIR APIs in the ActionScript 3.0/AIR1.5 folder
    • (Windows) HD:\Program Files\Adobe\Adobe Flash CS4\Common\Configuration\ActionScript 3.0\AIR1.5\
    • (Mac OS) HD:/Applications/Adobe Flash CS4/Common/Configuration/ActionScript 3.0/AIR1.5/
  • Adobe AIR Software Development Kit (AIK)
    • (Windows) HD:\Program Files\Adobe\Adobe Flash CS4\AIK1.5
    • (Mac OS): /Applications/Adobe Flash CS4/AIK1.5
  • External library
    • (Windows) HD:\Program Files\Adobe\Adobe Flash CS4\<lang>\Configuration\External Libraries\FLAir1_5.dll
    • (Mac OS) HD:/Applications/Adobe Flash CS4/Common/Configuration/External Libraries/FLAir1_5.bundle
  • Target configuration file
    • (Windows) HD:\Program Files\Adobe\Adobe Flash CS4\Common\Configuration\Players\AdobeAIR.xml
    • (Mac OS) HD:/Applications/Adobe Flash CS4/Common/Configuration/Players\AdobeAIR.xml
  • New AIR API entries in the Actions panel toolbox.

Adobe Flash Player 10 Update for Flash CS4 Professional  ***

*** (This update is superseded by July 30, 2009 Flash Player 10 update
October 15 2008: This update of Adobe Flash Player 10 contains additional bug fixes. The update replaces the Debug and Release versions of Flash Player 10 browser plug-ins and stand-alone players included in the initial release of Flash CS4 Professional (player version 10.0.2.54). All users are encouraged to apply this update. The new players are version 10.0.12.36.

Note: Users who find this page through a search download the Adobe Flash Player 10 Update for Windows and Macintosh (ZIP, 42 MB)

Instructions for installing Flash Player 10 Update for Flash CS4 Professional on Windows

  1. Quit Flash CS4 Professional.
  2. Open the downloaded ZIP file.
  3. Extract the contents of the file to C:\Program Files\Adobe\Adobe Flash CS4\.
  4. When asked to replace the existing Players folder, choose Yes.

Instructions for installing Flash Player 10 Update for Flash CS4 Professional on Mac OS X

  1. Quit Flash CS4 Professional.
  2. Open the downloaded ZIP file.
  3. Extract the contents of the file to <drive>:Applications:Adobe Flash CS4.
  4. When asked to replace the existing Players folder, choose Yes.

Upgrading the Flash Authoring Tool with the Flash Player 9 Security Release

July 10 2008: The Flash Player 9 Security Release is an update of the Flash Player that addresses various security-related concerns of the player. For more information regarding the update, see the Adobe Flash Player security advisory APSB07-12. Updated versions of the player are being provided for the Flash authoring tool to replace the following:

  • Release Flash Player Browser Plug-in Installer (both Netscape-compatible browsers and ActiveX)
  • Release stand-alone Flash Player
  • Release stand-alone Flash Player (Projectors)
  • Debug Flash Player Browser Plug-in Installer (both Netscape-compatible browsers and ActiveX)
  • Debug stand-alone Flash Player
  • Debug stand-alone Flash Player (Projectors)

Installers for the release and debug versions of Flash Player are provided with the Flash authoring tool installation for testing purposes. The release version is the same version freely available to end users on the Adobe website. Flash Content authors use the debug version to help debug their applications. The stand-alone players are used when a SWF file is played from the user's hard drive.

Update these files as the current versions supplied with Flash are insecure.

ZIP files containing the updated players and installers are provided for Windows and Mac for both Adobe Flash CS3 Professional and Flash 8. To update your installation of Flash with the new players and installers, download these files and manually copy them into the appropriate directories. If Flash is open, you close it before continuing.

If you need other languages of the player, see the Flash Player Downloads page to download these items individually. All the items in the Players folder in the Flash installation folder (except Readme.htm) must be replaced.

Adobe Flash CS3 Professional on Windows

  1. Download the new and secure player files from www.adobe.com/support/flashplayer/downloads.html#fp9.
  2. Locate the Players folder in your Flash installation directory. With a typical installation, it is in:

    C:\Program Files\Adobe\Adobe Flash CS3\Players.
  3. Delete the Players folder.
  4. Unzip the Players folder within the Flash-Player-Update2-Flash9-Win.zip into that location replacing the Players folder you deleted.
  5. Run the installers to update your browser plug-ins
    • For the Internet Explorer ActiveX plug-in, run:

      C:\Program Files\Adobe\Adobe Flash CS3\Players\Release\Install Flash Player 9 ActiveX.msi
    • For the Netscape-compatible browsers plug-in, run:

      C:\Program Files\Adobe\Adobe Flash CS3\Players\Release\Install Flash Player 9 Plugin.msi

Adobe Flash CS3 Professional on Mac OS

  1. Download the new and secure player files from www.adobe.com/support/flashplayer/downloads.html#fp9.
  2. Locate the Players folder in your Flash installation directory. With a typical installation, it is in:

    Applications:Adobe Flash CS3.
  3. Delete the Players folder.
  4. Unzip the Players folder within the Flash-Player-Update2-Flash9-Mac.zip into that location replacing the Players folder you deleted.
  5. Update your current browser plug-in by running:

Flash 8 on Windows

  1. Download the new and secure player files from www.adobe.com/support/flashplayer/downloads.html#fp8.
  2. Locate the Players folder in your Flash installation directory. With a typical installation, it is in:

    C:\Program Files\Macromedia\Flash 8\
  3. Delete the Players folder.
  4. Unzip the Players folder within the Flash-Player-Update2-Flash8-Win.zip into that location replacing the Players folder you deleted.
  5. Run the installers to update your browser plug-ins.
    • For the Internet Explorer ActiveX plug-in run:

      C:\Program Files\Macromedia\Flash 8\Players\Release\Install Flash Player 8 ActiveX.msi
    • For the Netscape-compatible browsers plug-in run:

      C:\Program Files\Macromedia\Flash 8\Players\Release\Install Flash Player 8 Plugin.msi

Flash 8 on Mac OS

  1. Download the new and secure player files fromwww.adobe.com/support/flashplayer/downloads.html#fp8.
  2. Locate the Players folder in your Flash installation directory. With a typical installation, it will be located in:

    Applications:Macromedia Flash 8
  3. Delete the Players folder.
  4. Unzip the Players folder within the Flash-Player-Update2-Flash8-Mac.zip into that location replacing the Players folder you just deleted.
  5. Update your browser plug-in by running:

    Applications:Macromedia Flash 8:Players:Release:Install Flash Player 8 OSX.dmg

Installing Adobe Air 1.5 Update for Flash CS3 Professional

November 3 2009

Prerequisite: To install this update, make sure that you already installed the original Adobe AIR update for Adobe Flash CS3 Professional. It is not possible to install this update without installing the previous update. To install AIR update for Adobe Flash CS3 Professional, select Help > Updates. Follow the steps to update. 

To install the Adobe Air 1.5 Update for Flash CS3 Professional:

  1. Locate the folder named "AIK":
    • Windows: C:/Program Files/Adobe/Adobe Flash CS3
    • Mac OS X: Macintosh HD: Applications: Adobe Flash CS3
  2. Remove all the files from the AIK folder. Do not remove the folder itself.
  3. Download the Adobe AIR SDK  from http://www.adobe.com/products/air/tools/sdk/
  4. Unzip the contents of the AIR SDK and place them inside the AIK folder.
  5. Download the Adobe AIR 1.5 Runtime from http://get.adobe.com/air/.
  6. Install the runtime to your machine.

     

What doesn't work with AIR 1.5 in Flash CS3 Professional:

  • Features only in AIR 1.5 such as Flash Player 10 capabilities. (These features include 3D effects, custom filters, and effects such as PIxel Bender, Advanced text support, dynamic sound generation, and so on)
  • Compiler issues with AIR 1.5 update in Flash CS3 Professional. Air 1.5 API don't compile in Flash CS3 even if airglobal.swc in AIR 1.5 SDK is added to the class path. Do not add airglobal.swc in AIR 1.5 SDK to the class path! 



    AIR 1.0 API will continue to function after this udpate. 

To publish multiple language AIR files using the AIR 1.5 update:

Note: Updating to the AIR 1.5 application descriptor file is only necessary if you want to use the localization features of AIR 1.5 to develop multilingual AIR applications. (It's also necessary if you require AIR 1.1 to be your minimum version.) Developers without multilingual needs can use AIR 1.5 to develop AIR 1.0 files, but in those cases the following steps aren't necessary.

  1. Create the initial application descriptor file, as follows:
    1. Open an existing AIR FLA file, or create one by selecting Flash File (Adobe AIR) on the Welcome screen.
    2. Choose Commands > Create AIR File.
    3. Choose Commands > AIR Application & Installer Settings, and then click Publish AIR File.
  2. Rename "App Name-app.xml" to a different name, such as "My-app.xml."
  3. Select "My-app.xml" as a custom descriptor file, as follows:
    1. Choose Commands > AIR Application & Installer Settings.
    2. Select the Use Custom Application Descriptor File option.
    3. Browse to your renamed XML file, My-app.xml.
    4. Click Open to select your custom application descriptor and close the dialog.
    5. Select OK to close the AIR Application & Installer Settings dialog box.
  4. Update the new application descriptor file "My-app.xml" file for multiple languages, as follows:
    1. Open "App Name-app.xml" in your XML or text editor.
    2. Change the namespace from to 1.0 to 1.5.2
    3. Find the <name> tag. Change it to include the application name in the languages you want to support. For example:



      <name><text >English App Name</text><text >French App Name</text><text >ž App Name</text></name>

       
    4. Repeat step c for the <description> tag.
    5. Fix the <icon> tag by either:
      1. Copying icons into a local folder (such as "icons) and updating the paths in the XML.



        Note: Icons placed in "AppIconsForAIRPublish" are temporary only -- they are deleted when you republish.

         
      2. Removing the <icon> tag to use the default system icons
    6. Change the Encoding to UTF-8.
    7. Save the XML file.
  5. Publish the final AIR 1.5 application, as follows:
    1. Choose Commands > Create AIR File.
    2. Choose Commands > AIR Application & Installer Settings, and then click Publish AIR File.

Upgrade Flash Authoring for the April 2008 Flash Player Security Update (APSB08-11)

The April 2008 Flash Player Update (APSB08-11) addresses security vulnerabilities in Adobe Flash Player 9.

For more information about the security update, see the Adobe Flash Player security advisoryAPSB08-11.

For information about new features, see the Adobe Flash Player Product Page.

Flash developers, make sure that you're familiar with the Adobe Developer Connection article "Security changes in Flash Player 9." This article covers specific changes that may affect your content.

All Flash CS3 Professional, Flash 8 Professional and Flash 8 Basic developers should install the Adobe Flash Player Update.

To install the Adobe Flash Player Update, see the information below for your operating system:

Adobe Flash Player Update for CS3 Professional on Windows:

  1. Download the new and secure player files from http://www.adobe.com/support/flashplayer/downloads.html:
  2. Locate the Players folder in your Flash installation directory. Typically, it is in:

    C:\Program Files\Adobe\Adobe Flash CS3
  3. Delete the Players folder.
  4. Unzip the flash_player_update6_flash9.zip file, and then open it.
  5. Copy the Players folder to the Adobe Flash CS3 folder you located in step 2.
  6. Run the installers to update your browser plug-ins. This step is not necessary if you use Flash Player 9 as your browser plug-in.
    • For the Internet Explorer ActiveX plug-in, run:

      C:\Program Files\Adobe\Adobe Flash CS3\Players\Release\

      Install Flash Player 9 ActiveX.msi
    • For the Mozilla-based browser plug-in, run:

      C:\Program Files\Adobe\Adobe Flash CS3\Players\Release\

      Install Flash Player 9 Plugin.msi

Adobe Flash CS3 Professional on Mac OS:

  1. Download the new and secure player files from http://www.adobe.com/support/flashplayer/downloads.html.
  2. Locate the Players folder in your Flash installation directory. Typically, it is in:

    Applications/Adobe Flash CS3
  3. Delete the Players folder.
  4. Unzip the flash_player_update6_flash9.zip file, and then open it.
  5. Copy the Players folder to the Adobe Flash CS3 folder you located in step 2.
  6. Update your browser plug-in by running the following (This step is not necessary if you use the Flash Player 9 browser plug-in):
    1. Unzip Applications/Adobe Flash CS3/Players/Release/Install Flash Player 9 UB.dmg.zip
    2. Expand the disk image "Install Flash Player 9 UB.dmg."
    3. Install Flash Player 9 UB.

Adobe Flash Player Update for Flash Professional 8 and Flash Basic 8 on Windows:

  1. Download the new and secure player files from www.adobe.com/support/flashplayer/downloads.html.
  2. Locate the Players folder in your Flash installation directory. Typically, it is in:

    C:\Program Files\Macromedia\Flash 8\
  3. Delete the Players folder.
  4. Unzip the flash_player_update6_flash8_win.zip file, and then open it.
  5. Copy the Players folder to the Macromedia\Flash 8 folder you located in step 2.
  6. Run the installers to update your browser plug-ins. This step is not necessary if you use Flash Player 9 as your browser plug-in.
    • For the Internet Explorer ActiveX plug-in, run:

      C:\Program Files\Macromedia\Flash 8\Players\Release\

      Install Flash Player 8 ActiveX.msi
    • For the Mozilla-based browser plug-in, run:

      C:\Program Files\Macromedia\Flash 8\Players\Release\

      Install Flash Player 8 Plugin.msi

Adobe Flash Player Update for Flash Professional 8 and Flash Basic 8 on Mac OS:

  1. Download the new and secure player files from www.adobe.com/support/flashplayer/downloads.html#fp8.
  2. Locate the Players folder in your Flash installation directory. Typically, it is in:

    Applications/Macromedia Flash 8
  3. Delete the Players folder.
  4. Unzip the flash_player_update5_flash8_mac.zip, and then open it.
  5. Copy the Players folder to the Macromedia Flash 8 folder you located in step 2.
  6. Update your browser plug-in by running the following (This step is not necessary if you use the Flash Player 9 browser plug-in):

    Applications/Macromedia Flash 8/Players/Release/

    Install Flash Player 8 OSX

Installing the Adobe AIR update for Flash CS3 Professional

February 25 2008: The Adobe AIR update for Flash CS3 Professional augments the Flash development environment with elements that allow you to build Adobe AIR applications with Flash. It lets you create, test, and debug Adobe AIR application files in Flash. For usage details, see Adobe Livedocs.

To install the Adobe AIR update for Flash CS3 Professional using Adobe Update Manager:

  1. Launch Flash CS3 Professional.
  2. Choose Help> Updates. The Adobe Update Manager application launches and determines what updates to install. This process checks for all CS3 updates, and can  take a few minutes.
  3. To install CS3 updates available for your system, choose Download And Install Updates.

If you don't want to use the Adobe Update Manager, downloadable updaters are also available for Adobe Flash CS3 Professional (9.0.3).

To install the Adobe AIR update for Flash CS3 Professional stand-alone updater:

Important: Install Adobe Flash Player Updater for Flash CS3 Professional (9.0.2) before you run the AIR Update for Flash CS3 Professional stand-alone installer. Attempting to install the AIR update before the Flash Player update results in an error message:

Install error message

or

Install error message

Note: If you previously installed the Adobe AIR beta from labs.adobe.com, perform a manual uninstall before any attempt to manually install. This step isn't necessary for users using Adobe Update Manager installation. See manual uninstall below.

Adobe Flash CS3 Professional on Windows

  1. Download the update EXE file for your language from the Flash Player Downloads page: Flash Player Downloads.
  2. Locate the downloaded updater file. For example, the English Windows update file is named:

    flash9-en_US_9_0_3_Update.exe
  3. Close all Adobe CS3 applications, Instant Messengers, and web browsers.
  4. Run flash9-en_US_9_0_3_Update.exe
  5. Follow the onscreen instructions to complete the update.

Adobe Flash CS3 Professional on Mac OS

  1. Download the update DMG file for your language from the Flash Player Downloads page: Flash Player Downloads.
  2. Locate the downloaded DMG file. For example, the English Mac OS updater file is named: Install flash9-en_US_9_0_3_Update.dmg
  3. Close all Adobe CS3 applications, Instant Messengers, and web browsers.
  4. Double-click the DMG to expand. Inside the DMG is the updater file. The English Mac OS update file is named "Install AIR Update."
  5. Double-click the updater file.
  6. Follow the onscreen instructions to complete the update.

 Manual Uninstall on Windows

  1. Browse to (Windows) HD:\Program Files\Adobe\Adobe Flash CS3\. Delete AIK folder.
  2. Browse to (Windows) HD:\Program Files\Adobe\Adobe Flash CS3\en\First Run\Commands\. Delete the following files if they exist:

    AIR - Application and Package Settings.jsfl

    AIR - Package AIR File.jsfl
  3. Browse to HD:\Document and Settings\<username>\Local Settings\Application Data\Adobe\Flash CS3\<lang>\Configuration\Commands\. Delete the following files if they exist:

    AIR - Application and Package Settings.jsfl

    AIR - Package AIR File.jsfl



    Note: If you do not see these folders, select "Show hidden files/folder" in Options.

Manual Uninstall on Mac OS

  1. Browse to <drive>/Applications/Adobe Flash CS3. Delete the AIK folder.
  2. Browse to <drive>/Applications/Adobe Flash CS3/First Run/Commands. Delete the following files if they exist:

    AIR - Application and Package Settings.jsfl

    AIR - Package AIR File.jsfl
  3. Browse to <drive>/Users/<username>/Library/Application Support/Adobe:Flash CS3/<lang>/Configuration/Commands. Delete the following files if they exist:

    AIR - Application and Package Settings.jsfl

    AIR - Package AIR File.jsfl

After installing the Adobe AIR update, you can see the following changes in Flash:

  • In the Publish Settings dialog box (File > Publish Settings), on the Flash tab, a new entry in the Version menu for Adobe AIR 1.0
  • An updated Welcome screen that contains an entry for creating a Flash File (Adobe AIR)
    • (Windows) HD:\Program Files\Adobe\Adobe Flash CS3\en\FirstRun\StartPage
    • (Windows) HD:\Program Files\Adobe\Adobe Flash CS3\en\FirstRun\StartPage\resources
    • Note: On Mac OS, if Flash File (Adobe AIR) does not appear on the Welcome screen, delete the following folder and restart Flash:

      HD:/Users/<username>/Libraries/Application Support/Adobe/Flash CS3/<language>/Configuration/StartPage
  • New playerglobal.swc file that includes all ActionScript 3.0 APIs and Adobe AIR APIs in the ActionScript 3.0/Classes folder

    • (Windows) HD:\Program Files\Adobe\Adobe Flash CS3\en\Configuration\ActionScript 3.0 Classes
    • (Mac OS) HD:/Applications/Adobe Flash CS3/Configuration/ActionScript 3.0/Classes/
  • New jsfl files (AIR - Application and Installer Settings.jsfl, AIR - Publish AIR File.jsfl)

    • (Windows) HD:\Program Files\Adobe\Adobe Flash CS3\en\FirstRun\Commands
    • (Mac OS) HD:/Applications/Adobe Flash CS3/First Run/Commands/
  • Adobe AIR Software Development Kit (AIK)

    • (Windows) HD:\Program Files\Adobe\Adobe Flash CS3\AIK
  • External library

    • (Windows) HD:\Program Files\Adobe\Adobe Flash CS3\en\Configuration\External Libraries
    • (Mac OS) HD:/Applications/Adobe Flash CS3/Configuration/External Libraries/
  • Target configuration file

    • (Windows) HD:\Program Files\Adobe\Adobe Flash CS3\en\Configuration\Players\
    • (Mac OS) HD:/Applications/Adobe Flash CS3/Configuration/Players

Upgrade Flash CS3 Professional authoring tool with Flash Player 9 Security Release (APSB07-20)

Adobe Flash Player 9 Update 3 (v9.0.115.0) addresses various fixes and security-related concerns, and provides support for new features such as H.264.

For more information about the security update, see the Adobe Flash Player security advisory APSB07-20.

For information about new features, see the Adobe Flash Player Product Page.

Flash developers, make sure that you're familiar with the Adobe Developer Connection article "Security changes in Flash Player 9." This article covers specific changes which can affect your content.

Adobe Flash Player Update for Flash CS3 Professional (9.0.2) provides updated versions of the following items to match the Flash Player 9 Update 3 release:

  • New Video Playback component supporting H.264 video.
  • Support for Flash Lite 3 Update for Flash CS3 Professional.
  • All Debug and Release versions of Adobe Flash Player 9.0.115.0 used inside Flash CS3 Professional.
  • Updated authplay.dll for Test Movie and creation of updated projectors.

All Flash CS3 Professional developers, make sure to update to this current version to guarantee secure players and support for new features.

In Flash CS3 Professional (9.0.2) the update can be installed in one of two ways. Both Windows and Mac OS users can use the Adobe Update Manager inside Flash CS3 Professional to install the update. Individual update files are also available for download.

To install the Flash CS3 Professional (9.0.2) Update using Adobe Update Manager, launch the update from Flash CS3 Professional:

  1. Launch Flash CS3 Professional.
  2. Choose Help > Updates.

    The Adobe Update Manager application launches and determine what updates need to be installed. This process checks for all CS3 updates, and may take a few minutes.
  3. To install CS3 updates available for your system, choose Download And Install Updates.

For users preferring a different option to Adobe Update Manager, downloadable updaters are available for Adobe Flash CS3 Professional (9.0.2).

To install the Flash CS3 Professional (9.0.2) Update manually, see the information below for your operating system:

Adobe Flash CS3 Professional on Windows

  1. Download the update EXE file for your language from the Flash Player Downloads page: Flash Player Downloads.
  2. Locate the downloaded updater file. For example, the English Windows update file is named:

    flash9_en_us_9_0_2_update.exe.
  3. Close all Adobe CS3 applications, Instant Messengers, and web browsers.
  4. Run flash9_en_us_9_0_2_update.exe.
  5. Follow the onscreen instructions to complete the update.

Adobe Flash CS3 Professional on Mac OS

  1. Download the update DMG file for your language from the Flash Player Downloads page: Flash Player Downloads.
  2. Locate the downloaded DMG file. For example, the English Mac OS updater file is named:

    Install Flash Player 9 UB.dmg
  3. Close all Adobe CS3 applications, Instant Messengers and web browsers.
  4. Double-click the DMG to expand. Inside the DMG is the updater file. The English Mac OS update file is named "Install Flash Player 9 UB."
  5. Double-click the updater file.
  6. Follow the onscreen instructions to complete the update.

In the Flash Player 9 Security Release (APSB06-11)

December 10 2007: The Adobe Flash Player 9 Security Release is an update of Flash Player that addresses various security-related concerns of the player. For more information about the update, see the Adobe Flash Player security advisory APSB06-11. Updated versions of the player are being provided for the Flash authoring tool to replace the following:

  • Release Flash Player Browser Plug-in Installer (both Netscape-compatible browsers and ActiveX) Release Stand-alone Flash Player Release Stand-alone Flash Player (Projectors) Debug Flash Player Browser Plug-in Installer (both Netscape-compatible browsers and ActiveX) Debug Stand-alone Flash Player
  • Debug Stand-alone Flash Player (Projectors)

Installers for the release and debug versions of Flash Player are provided with the Flash authoring tool installation for testing purposes. The release version is the same version that is freely available to users on the Adobe website. Flash content authors use the debug version to help debug their applications. The stand-alone players are used when a SWF file is played from the user's hard drive. Update these files. The current versions supplied with Flash are insecure.ZIP files containing the updated players and installers are provided for Windows and Mac for Flash 8 . To update your installation of Flash with the new players and installers, download these files and manually copy them into the appropriate directories. If Flash is open, close it before continuing.

If you need language versions of the player besides the English version, see the Flash Player Downloads page to download these items individually. It's necessary to replace all of the items in the Players folder in the Flash installation folder (except Readme.htm).

Flash 8 on Windows:

  1. Download the new and secure player files from:http://www.adobe.com/support/flashplayer/downloads.html#fp8.
  2. Locate the Players folder in your Flash installation directory. Typically, it is in: C:\Program Files\Macromedia\Flash 8\
  3. Delete the Players folder.
  4. Unzip the Players folder within the Flash-Player-Update2-Flash8-Win.zip into that location, replacing the Players folder that you deleted.
  5. Run the installers to update your browser plug-ins.
    • For the Internet Explorer ActiveX plug-in run:

      C:\Program Files\Macromedia\Flash 8\Players\Release\Install Flash Player 8 ActiveX.msi
    • For the Netscape-compatible browsers plug-in run:

      C:\Program Files\Macromedia\Flash 8\Players\Release\Install Flash Player 8 Plugin.msi

Flash 8 on Mac:

  1. Download the new and secure player files from:http://www.adobe.com/support/flashplayer/downloads.html#fp8.
  2. Locate the Players folder in your Flash installation directory. Typically, it is in: Applications:Macromedia Flash 8
  3. Delete the Players folder.
  4. Unzip the Players folder within the Flash-Player-Update2-Flash8-Mac.zip into that location, replacing the Players folder that you deleted.
  5. Update your browser plug-in by running Applications:Macromedia Flash 8:Players:Release:Install Flash Player 8 OSX.dmg
  6. (Optional) Download the Stand-alone Players (Projectors) for Macintosh if you want to publish projectors on the Macintosh. Extract the files and copy them into the new Players folder.

 

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy