Adobe After Effects CC

Stabilisation d'un métrage

Apprenez à corriger les métrages filmés avec une caméra portable, à choisir les objets à stabiliser dans une scène, et même à inverser une stabilisation pour suivre un objet dans une scène non stabilisée à l'aide de l'outil Stabilisation de déformation VFX. (Lecture : 25 min)

Stabilisation d'un métrage

25 min

La qualité des métrages filmés avec une caméra portable est généralement médiocre. Excepté si l'effet est voulu, il est nécessaire de stabiliser les plans pour éliminer les mouvements indésirables.

De quoi ai-je besoin ?

Télécharger les fichiers Fichiers d'exemple pour s'entraîner (ZIP, 37 Mo)

Télécharger le PDF Feuille de référence After Effects

Dans Adobe After Effects CC, l'outil de stabilisation de déformation VFX corrige automatiquement les effets de bougé. La mise à l'échelle et le déplacement incrémentiel du calque compensent le mouvement indésirable et garantissent une lecture fluide (l'effet Stabilisation de déformation VFX remplace l'effet Stabilisation de déformation disponible dans les versions précédentes d'After Effects).

Dans cet extrait de l'ouvrage Adobe After Effects CC Classroom in a Book publié par Adobe Press, vous allez appliquer l'effet Stabilisation de déformation VFX à un élément instable et découvrir son fonctionnement.

À propose de la mise à l'échelle bicubique

Dans ce tutoriel, vous allez mettre à l'échelle l'échantillon vidéo. Pour agrandir un métrage ou une image, After Effects doit échantillonner des données pour ajouter des informations jusqu'ici inexistantes. Vous pouvez choisir la méthode d'échantillonnage à utiliser lors de la mise à l'échelle d'un calque. Pour plus de détails, visionnez la vidéo intitulée Set scaling quality using bicubic sampling (Définition de la qualité de la mise à l'échelle via la méthode d'échantillonnage bicubique).

Les précédentes versions d'After Effects n'utilisaient qu'une méthode d'échantillonnage bilinéaire. Nouveauté d'After Effects CC, l'échantillonnage bicubique repose sur un algorithme plus complexe qui donne de meilleurs résultats lorsque les transitions de couleurs sont progressives, comme dans presque toutes les images photographiques réalistes. La mise à l'échelle bilinéaire convient mieux aux images d'une grande netteté.

Pour adopter une méthode d'échantillonnage, sélectionnez le calque, puis choisissez Calque > Qualité > Bicubique ou Bilinéaire. Les méthodes d'échantillonnage bicubique et bilinéaire sont uniquement disponibles pour les calques de qualité Optimale. Pour appliquer la qualité Optimale à un calque, sélectionnez Calque > Qualité > Optimale.

Définition du projet

Lorsque vous démarrez After Effects, rétablissez les paramètres par défaut du logiciel :

  1. Lancez After Effects, puis appuyez immédiatement sur Ctrl+Alt+Maj (Windows) ou Cmd+Option+Maj (Mac OS) pour rétablir les paramètres de préférence par défaut. À l'invite, cliquez sur OK pour supprimer vos préférences.
  2. Cliquez sur Fermer pour fermer l'écran de bienvenue.
  3. After Effects affiche un nouveau projet sans titre.
  4. Choisissez Fichier > Enregistrer sous > Enregistrer sous.
  5. Nommez le projet Stabilize.aep, puis cliquez sur Enregistrer.

Importation du métrage

Pour démarrer ce projet, vous devez importer un élément de métrage. Téléchargez les fichiers d'exemple pour suivre ce tutoriel.

  1. Double-cliquez dans une zone vide du panneau Projet pour ouvrir la boîte de dialogue Importer fichier.
  2. Sélectionnez le fichier flowers.mov dans les ressources du tutoriel, puis cliquez sur Importer ou Ouvrir pour importer le métrage dans votre projet (voir Figure 1).
Figure 1. Importation du fichier d'exemple flowers.mov dans le projet

Création de la composition

Vous allez commencer par créer la composition.

  1. Faites glisser l'élément flowers.mov sur le bouton Créer une nouvelle composition situé au bas du panneau Projet.
    After Effects crée une composition nommée Flowers de la même taille (en pixels), du même rapport L/H et de la même durée que l'élément source.
  2. Cliquez sur le bouton Prévisualisation RAM dans le panneau Prévisualisation pour prévisualiser le métrage. Appuyez sur la barre d'espace pour quitter le mode de prévisualisation. Cet élément a été filmé avec une caméra portable en fin d'après-midi. Une petite brise souffle sur la végétation, et le mouvement de la caméra est instable.

Application de l'effet Stabilisation de déformation VFX

L'outil Stabilisation de déformation VFX commence par analyser le métrage appliqué. La stabilisation s'exécutant à l'arrière-plan, vous pouvez manipuler d'autres compositions en attendant la fin du processus. Le temps d'exécution dépend de votre système. Une bannière bleue apparaît lors de l'analyse du métrage, et une bannière orange lors de sa stabilisation (voir Figure 2).

Figure 2. Analyse et stabilisation du métrage
  1. Sélectionnez le calque flowers.mov dans le panneau Montage, puis choisissez Animation > Stabilisation de déformation VFX. La bannière bleue apparaît immédiatement.
  2. À la fin du processus de stabilisation, lorsque la bannière orange disparaît, générez une autre prévisualisation RAM pour voir la différence.
  3. Appuyez sur la barre d'espace pour quitter le mode de prévisualisation.

L'élément est encore instable mais la lecture est plus fluide. L'outil Stabilisation de déformation VFX a déplacé et repositionné le métrage. Pour voir comment les changements ont été appliqués, ouvrez le panneau Options d'effet. Les bordures du clip ont été mises à l'échelle (à environ 103 %) pour masquer les espaces noirs qui se forment lors du repositionnement de l'image en cours de stabilisation. À présent, vous allez ajuster les paramètres de l'outil Stabilisation de déformation VFX.

Ajustement des paramètres de stabilisation de déformation VFX

Vous allez modifier les paramètres du panneau Options d'effet pour fluidifier le plan.

  1. Dans le panneau Options d'effet, faites passer le pourcentage de lissage à 75 %.
    L'outil Stabilisation de déformation VFX relance automatiquement le processus de stabilisation (voir Figure 3). Il n'a pas besoin d'effectuer une nouvelle analyse, les données de la précédente étant stockées en mémoire.
Figure 3. Ajustement des paramètres de stabilisation et visualisation des résultats
  1. À la fin du processus de stabilisation, générez une nouvelle prévisualisation RAM pour voir les changements.
  2. Appuyez sur la barre d'espace pour arrêter la lecture.
    Le résultat est meilleur mais pas encore parfait. Le paramètre Échelle auto du panneau Options d'effet indique une valeur de 103,7 % ; une mise à l'échelle plus importante est nécessaire pour éliminer les espaces noirs autour des images.
    Au lieu d'augmenter le pourcentage de lissage du métrage, vous allez modifier le résultat.
  3. Dans le panneau Options d'effet, sélectionnez Aucune animation dans le menu Résultat (voir Figure 4).
Figure 4. Sélection de l'option Aucune animation dans le menu Résultat du panneau Options d'effet

    L'outil Stabilisation de déformation VFX tente alors d'immobiliser la caméra. Il faut augmenter la mise à l'échelle. Lorsque l'option Aucune animation est sélectionnée, l'option Lissage est grisée.

  1. Dès que la bannière orange disparaît, générez une nouvelle prévisualisation RAM. Appuyez sur la barre d'espace pour arrêter la lecture.

Maintenant que la caméra demeure immobile, le mouvement se limite au frémissement des fleurs. Pour finaliser le tout, l'outil Stabilisation de déformation VFX a dû mettre le clip à une échelle de 112,4 % par rapport à la taille d'origine.

Optimisation des résultats

La plupart du temps, l'analyse par défaut fonctionne parfaitement bien. Il est cependant parfois nécessaire d'affiner le résultat. Dans ce projet, l'élément s'incline légèrement par endroits, surtout autour de la cinquième seconde, ce qu'un œil non exercé ne remarquera sans doute pas. Pour corriger l'inclinaison, vous allez opter pour une autre méthode de stabilisation de déformation VFX.

  1. Dans le panneau Options d'effet, choisissez Position, Échelle, Rotation dans le menu Méthode.
  2. Choisissez Stabiliser uniquement dans le menu Cadrage.
  3. Attribuez la valeur 114 % à l'option Échelle supplémentaire (voir Figure 5).

Remarque : l'agrandissement d'un calque vidéo altère la qualité de l'image. En règle générale, il convient de ne pas dépasser 115 % pour l'échelle supplémentaire.

Figure 5. Augmentation de l'échelle dans le panneau Options d'effet
  1. Générez une nouvelle prévisualisation RAM.
    Le plan est à présent parfaitement stable. Le seul mouvement perceptible est celui des fleurs caressées par le vent.
  2. Appuyez sur la barre d'espace pour arrêter la lecture.
  3. Choisissez Fichier > Enregistrer pour enregistrer le projet.
  4. Choisissez Fichier > Fermer le projet.

Ouvrez le fichier Stabilize.mov inclus dans les ressources du tutoriel pour visualiser le métrage stabilisé.

Comme vous avez pu le constater, la stabilisation d'un plan présente toutefois quelques inconvénients. Pour compenser les données de mouvement ou de rotation appliquées au calque, les images doivent être mises à l'échelle, ce qui peut altérer la qualité du métrage. Si vous devez impérativement inclure le plan dans votre production, c'est en procédant ainsi que vous obtiendrez le meilleur compromis.

Paramètres de stabilisation de déformation VFX

Ce n'est là qu'un aperçu des paramètres de stabilisation de déformation VFX. Pour en savoir plus ou obtenir des conseils supplémentaires sur l'utilisation de cet effet, consultez l'aide d'After Effects.

  • Les options du menu Résultat permettent d'obtenir le résultat souhaité. L'option Lissage permet d'atténuer le mouvement de la caméra mais ne l'élimine pas complètement ; utilisez le paramètre Lissage pour définir plus précisément la fluidité du mouvement. L'option Aucune animation tente de supprimer tous les mouvements de caméra.
  • La méthode indique l'opération que l'outil de stabilisation de déformation VFX va exécuter pour stabiliser le métrage : l'option Position repose sur les données de position. L'option Position, Échelle, Rotation combine ces trois types de données. L'option Perspective va modifier la perspective des quatre coins de l'image. L'option Déformation de sous-espace (option par défaut) tentera de déformer certaines parties de l'image différemment pour la stabiliser.
  • Ces paramètres permettent de déterminer le traitement des bordures (bords mobiles) pour un métrage stabilisé. Les options de cadrage permettent de définir l'apparence des contours et déterminent si un recadrage, une mise à l'échelle ou une synthétisation des contours est nécessaire à partir du contenu d'autres images.
  • La mise à l'échelle automatique affiche le niveau de mise à l'échelle automatique appliqué, tout en vous permettant de fixer des limites.
  • Les paramètres avancés permettent de contrôler plus étroitement les actions de l'effet Stabilisation de déformation VFX.

Remarque : vous pouvez également utiliser les paramètres avancés de la stabilisation de déformation VFX pour obtenir des effets plus complexes. Pour en savoir plus, consultez l'ouvrage Adobe After Effects CC Visual Effects and Compositing Studio Techniques, disponible sur le site d'Adobe Press.

Donnez-nous votre avis.

Et voilà, vous avez terminé !

ae-cib-cover-83x83

Extrait de l'ouvrage Adobe After Effects CC Classroom in a Book publié par Adobe Press.