Question

Avant d'installer un nouveau Featurepack, je souhaite vérifier que mes recouvrements sous / apps ne soient pas en conflit avec le code produit mis à jour créé par FeaturePack.

Réponse, Résolution
 
 

Une demande d’amélioration du Gestionnaire de modules existe à propos de ce problème :

Dans une prochaine version du produit, le gestionnaire de modules est capable d’émettre des avertissements lors de l’installation lorsqu’il détecte que les fichiers d’un module sont déjà superposés.

En attendant, la solution suivante est possible :

À l'aide du Gestionnaire de modules CQ, ouvrez la page du module, puis utilisez le bouton « Contenu » pour afficher le contenu du module.

Copiez le contenu dans un fichier texte dans votre système de fichiers.

Exécutez le script shell joint avec les arguments suivants :

1) Chemin du fichier texte

2) Nom d’utilisateur administrateur de votre instance CQ

3) Mot de passe de votre utilisateur administrateur

4) URL de votre instance CQ (« http://localhost:5401 ») sans barre oblique à la fin.

Le script vérifie tous les fichiers pouvant être superposés sous / libs dans le contenu, s’il existe un fichier équivalent sous / apps via une requête d’état, et affiche la liste de ces fichiers.

La fusion des fichiers doit ensuite être effectuée manuellement à l’aide des outils de comparaison et de texte standard, afin d’adapter le code personnalisé au code de produit mis à jour.

Une autre solution de contournement peut être ajoutée ultérieurement, sous la forme d’une JSP intégrée dans le produit qui effectue le test.

S’applique à

CQ5.x.

Telechargement

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne