Problème

Avec un 1.8 JDK plus ancien, le message qui suit s'affiche lorsque les flux traités [1] contiennent des PDF :  

capture

Environnement

AEM6.2 CFP4

Résolution

  1. Mettre à niveau vers la dernière version de JDK1.8.

    Pour remédier à ce problème, ajoutez ce paramètre JVM :

    -Dsun.java2d.cmm=sun.java2d.cmm.kcms.KcmsServiceProvider

    Les paramètres ci-dessus forcent Java à utiliser la couleur d'un ancien API au lieu d'utiliser sun.java2d.cmm.lcms.LCMS.