Après avoir installé la synchro Oak 1.4.10 LDAP ne fonctionne plus | AEM 6.2, Oak.

Problème

Si vous utilisez l'intégration LDAP avec AEM puis après l'application de la synchronisation Oak 1.4.10 ou l'utilisateur LDAP 1.4.11 et la synchronisation du groupe ne fonctionne plus. L’utilisateur peut se connecter à AEM, mais les propriétés synchronisées sont supprimées du profil.

Environnement

AEM 6.2

Cause

Il s'agit d'un bogue de régression OAK-4344.

Résolution

Pour résoudre ce problème, procédez comme suit :

  1. Allez à http://host:port/system/console/configMgr et connectez-vous en tant qu'administrateur.

  2. Recherchez LdapIdentityProvider.

  3. Cliquez sur Éditer (icône de crayon) à droite de l'élément de configuration.

  4. Dans la partie inférieure de la boîte de dialogue liée à la configuration, se trouve Attributs personnalisés.

  5. Dans ce champ ajoutez (à l'aide du bouton +) tous les attributs LDAP en cours de synchronisation vers les utilisateurs et les groupes. Par exemple, ces propriétés peuvent être : cn, sn, givenName, mail.

  6. Cliquez sur Enregistrer.

Remarque :

Si vous ne connaissez pas les propriétés LDAP que vous utilisez, vous pouvez faire référence à la configuration du gestionnaire de synchronisation par défaut.  Recherchez DefaultSyncHandler dans http://host:port/system/console/configMgr l'interface utilisateur. Les attributs de synchronisation sont répertoriés = dans chaque entrée de Mise en correspondance de propriétés des utilisateurs et Mise en correspondance de propriété du groupe. Seuls les attributs qui ne sont pas entre guillemets (« ») sont les attributs LDAP.

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne