Les utilisateurs du système d’exploitation Ubuntu 10.x et 11.x Linux voient parfois un écran vide ou noir dans Flash Player 11 lors de la lecture de contenu vidéo protégé. (Par exemple, ce problème se produit avec les services tels que Amazon Instant Video). Un module Ubuntu HAL (Hardware Abstraction Layer) manquant, non installé par défaut, provoque ce comportement. Si le fournisseur affiche les messages d’erreur, les utilisateurs voient une erreur DRM 3323 ou 3322.

Conditions préalables à la lecture de contenu protégé

Pour Ubuntu 10.04 ou versions ultérieures, assurez-vous que le module HAL (Hardware Abstraction Layer) est d’abord installé à l’aide d’apt-get.
(Examinez soigneusement les erreurs d’installation « hal », car l’installation d’un package endommagé peut continuer à affecter la lecture vidéo.)

sudo apt-get install hal

Une fois l’installation de la bibliothèque « libhal » (HAL) terminée, fermez le navigateur et effacez les répertoires Adobe Access en exécutant les commandes shell suivantes :

cd ~/.adobe/Flash_Player
rm -rf NativeCache AssetCache APSPrivateData2

Remarque :

Si le module Hardware Abstraction Layer est absent, Flash Player fonctionne toujours. Cependant, il ne peut pas lire le contenu protégé qui requiert le module DRM (Digital Rights Management) Adobe Flash Access.

Prise en charge des versions 64 bits ciblées de Linux

Adobe publie un support de plate-forme pour Linux 32 bits et 64 bits dans la section configuration requise du site de Flash Player 11. Les distributions actuellement prises en charge (32 bits et 64 bits) sont Redhat Enterprise Linux 5.6 ou versions ultérieures et Ubuntu 10.04 ou version ultérieure.

openSuse est également pris en charge.

Installation du module externe 32 bits ou 64 bits correct de Flash Player

Accédez à http://www.adobe.com/fr/go/flashplayer afin d’installer la dernière version de Flash Player pour votre plate-forme et votre architecture.

Si vous n’êtes pas sûr du package Linux à installer, cliquez sur Disposez-vous d’un système d’exploitation ou d’un navigateur différent ? pour faire votre choix parmi plus de systèmes d’exploitation.

openSuse et autres versions Linux

Certaines distributions Linux ont leur propre façon de gérer les packages, notamment openSUSE. openSUSE utilise RPM comme format de package natif. Cependant, il possède son propre outil de niveau élevé pour gérer l’installation du logiciel système. 
Les installations .rpm sur openSUSE (32 et 64 bits) sont capricieuses. Elles génèrent parfois l’erreur générique « Le message n’a pas reçu de réponse (délai d’expiration par bus de message) ».

Dans ces cas, téléchargez l’archive .tar.gz à la place et placez Flash Player (libflashplayer.so) dans ce répertoire :

/usr/lib/adobe-flashplugin/libflashplayer.so

Test de la lecture de contenu vidéo protégé à l’aide du lecteur de démonstration

  1. Lancez le conteneur de lecteur vidéo de démonstration : http://drmtest2.adobe.com:8080/SVP/SampleVideoPlayer_FP.html
     
      Notez la version d’Adobe Flash Player dans la partie inférieure gauche du shell vidéo de démonstration. Assurez-vous que 11.2 ou version ultérieure est indiqué.
       
  2. Lisez le contenu protégé échantillon.
     
      Entrez l’adresse URL suivante dans le champ « Entrer l’URL vidéo : » (sensible à la casse)
      http://drmtest2.adobe.com:8080/Content/anonymous.f4v
       
  3. Cliquez sur le bouton [Lecture] situé au bas du conteneur vidéo.

Le contenu protégé anonymous.f4v est lu. (Cette vidéo s’appelle la vidéo de « train » Getty.)

 

Produits concernés

Adobe Flash Player 11, Flash Access (FAXS), Ubuntu 10.x & 11.x Linux

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne