Ce document explique comment installer et utiliser le module externe OpenEXR Alpha supplémentaire.

Le module externe OpenEXR Alpha supplémentaire offre une autre méthode pour traiter les données de couche « A » lors de l’ouverture d’un fichier OpenEXR. Plutôt que de convertir directement les données de couche « A » en transparence (comme le fait l’ancien module externe OpenEXR), OpenEXR Alpha ouvre les données de couche « A » sous la forme d’une couche alpha.

Arrière-plan

Photoshop CS2 ne prend généralement pas en charge la transparence en mode 32 bits. Cette version intégrait une solution qui vous permettait de lire les données de transparence sur une couche alpha. Dans Photoshop CS3, la prise en charge de la transparence a été intégrée pour le mode 32 bits afin d’assurer la conformité à la spécification OpenEXR. La transparence n’était donc plus lue dans une couche alpha lors de la composition de couche directe.

Avant de commencer

L’installation du module externe OpenEXR Alpha requiert des droits d’administrateur local. Si vous utilisez Mac OS, Windows Vista ou Windows 7, le système d’exploitation vous invite à entrer le nom et le mot de passe d’un compte utilisateur administrateur. Si vous utilisez Windows XP, connectez-vous à votre ordinateur à l’aide d’un compte administrateur local avant de commencer.

Utilisateurs Windows : plusieurs étapes de cette note technique répertorient les fichiers par leur nom complet, qui inclut les extensions de nom de fichier (par exemple, OpenEXR Alpha.8bi). Sous Windows, les extensions de nom de fichier des types de fichier connus sont invisibles par défaut. Pour rendre les extensions de nom de fichier visibles, procédez comme suit :

  1. Dans l’Explorateur Windows, sélectionnez Outils > Options des dossiers (Windows XP) ou Organiser > Options des dossiers et de recherche (Windows 7 et Vista).
  2. Sélectionnez l’onglet Affichage en haut de la fenêtre Options des dossiers.
  3. Dans la zone Paramètres avancés du panneau Affichage, désélectionnez Masquer les extensions des fichiers dont le type est connu.
  4. Cliquez sur OK.

Utilisateurs Windows : plusieurs étapes décrites dans ce document nécessitent que vous déterminiez si vous utilisez une édition 32 bits ou 64 bits de Windows. Pour déterminer le type de système dont vous disposez, voir Déterminez si votre ordinateur exécute une édition 32 bits ou 64 bits de Windows.

Compatibilité

Sous Windows, le module externe OpenEXR Alpha n’est pas compatible avec les versions de Photoshop antérieures à Photoshop CS5. Il ne se charge pas dans Photoshop CS3 ou CS4.

Sous Mac OS, le module externe OpenEXR Alpha ne se charge pas sur les machines PPC.

Installez le module externe OpenEXR Alpha pour Photoshop CS5 sous Mac ou Windows (télécharger la mise à jour à partir du site Web Adobe)

Pour installer le module externe OpenEXR Alpha lors du téléchargement d’une mise à jour depuis le site Web d’Adobe :

  1. Téléchargez le module externe compressé :

  2. Quittez Photoshop CS5.
  3. Décompressez le fichier téléchargé.
  4. Faites glisser le module externe dans le dossier des modules externes de Photoshop.
    • Windows 32 bits : faites glisser OpenEXR Alpha.8bi du dossier Win32 vers le dossier /Program Files/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats.
    • Windows 64 bits/Photoshop 64 bits : faites glisser OpenEXR Alpha.8bi du dossier Win64 vers le dossier /Program Files/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats.
    • Windows 64 bits/Photoshop 32 bits : faites glisser OpenEXR Alpha.8bi du dossier Win32 vers le dossier /Program Files (x86)/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats.
    • Mac OS : faites glisser OpenEXR.plugin dans le dossier /Applications/Adobe Photoshop CS5/Plug-ins/File Formats.
  5. Lancez Photoshop CS5.

Utilisation du module externe OpenEXR Alpha

Pour ouvrir un fichier EXR :

  1. Lancez Photoshop CS5.
  2. Choisissez Fichier > Ouvrir.
  3. Accédez au fichier EXR que vous souhaitez ouvrir. Dans la liste des formats de fichier, sélectionnez OpenEXR Alpha. Photoshop traite les données de couche « A » en tant que couche alpha et non en tant que transparence.

Pour exporter un fichier EXR :

  1. Choisissez Fichier > Enregistrer sous.
  2. Dans la liste des formats de fichier, sélectionnez OpenEXR Alpha.

  3. Sélectionnez l’option Enregistrer : Couches alpha. Ce paramètre permet de conserver les données de couche alpha.

Remarque : la transparence ajoutée après l’ouverture du fichier a été aplatie.

Remarque : même après l’installation du module externe OpenEXR Alpha, vous avez toujours la possibilité de sélectionner l’ancienne version d’OpenEXR dans la liste des formats de fichier. Ce module externe traite toujours les données dans la couche « A » en tant que transparence. Ce comportement est le comportement par défaut dans Photoshop depuis Photoshop CS3 (version 10.0).

Remarques supplémentaires

Autre comportement à prendre en compte lors de l’utilisation du module externe supplémentaire :

  • La composition prémultipliée n’est pas prise en charge.
  • Si vous double-cliquez sur un fichier pour l’ouvrir, Photoshop CS5 utilise toujours OpenEXR Alpha plutôt qu’OpenEXR.
  • Si vous ouvrez un fichier contenant deux couches alpha ou plus, OpenEXR Alpha ne conserve aucune couche alpha. Elles sont entièrement supprimées.
  • (Mac OS) : dans la boîte de dialogue Enregistrer, OpenEXR Alpha est l’élément de niveau supérieur. Il ne s’affiche pas par ordre alphabétique en regard d’Open EXR.
  • (Windows) : pour obtenir l’ancien comportement d’OpenEXR, choisissez Fichier > Ouvrir sous, puis sélectionnez OpenEXR.
     

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne