Cet article contient les étapes à suivre en cas de rencontre de DRMError 3324 avec le sous-code d’erreur 111 - Jeton d’ordinateur non valide.

Problème

Lorsque vous essayez de lire un flux DRM protégé par AAXS (Adobe Access), vous rencontrez l’erreur suivante :

DrmErrorCode 3324:111

Environnement

  • Ordinateur de bureau
  • Android
  • iOS
  • Toute autre plate-forme

Cause

Une erreur 3324 est envoyée si le serveur de licences ne reconnaît pas le "MachineToken" du client.  Ce jeton est provisionné par le service Individualization et, si le service Individualization utilise un certificat non approuvé par le serveur de licences Access DRM, le jeton est évidemment "non valide".  

Sous-erreur-ID 111 est le code d’erreur côté serveur et correspond à "REQ_MACHINE_TOKEN_INVALID_EXPIRED", ce qui se produit si le jeton machine du client a expiré ou est invalide. 

Résolution

  1. Veuillez vérifier si vous avez mis à jour tous vos serveurs de licences Access DRM pour vous fier au nouveau point de terminaison du service de personnalisation que nous avons récemment créé.  Veuillez suivre les instructions décrites dans cet article : https://forums.adobe.com/message/8548395#8548395
  2. Si vous avez fait ce qui précède, alors peut-être que le serveur de licence DRM (1 ou plusieurs d’entre eux) n’a pas été mis à jour correctement et / ou n’a pas été redémarré après la mise à jour décrite ci-dessus.
  3. Si les deux éléments ci-dessus ne fonctionnent pas, il existe peut-être un problème de pare-feu / accès pour le serveur de licences Access DRM qui empêche de toucher l’URL suivante (où le serveur de licences doit obtenir le fichier CRL - Liste de révocation de certificats).  Veuillez vérifier que votre serveur peut atteindre le point de terminaison CRL. Un nouveau point d’extrémité de la liste de révocation de certificats a été créé pour servir le nouveau serveur d’individualisation. Votre serveur de licences a peut-être des problèmes d’accès à ce nouveau point de terminaison : http://individualization-crl.primetime.adobe.com/FlashAccessIndividualizationCA.crl

Si vous rencontrez effectivement des problèmes d’accès à ce fichier, pour contourner l’obstacle actuel, vous pouvez copier manuellement ce fichier sur votre serveur de licences et (si vous utilisez Tomcat), le placer dans le dossier tomcat / temp / où vont les fichiers .crl téléchargés.

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