Learn how to export Avid Sequences and Bins and bring your edit into Adobe Premiere Pro CC.

Export an AAF of the Avid Sequence

An Advanced Authoring Format file (AAF) contains complex media data, as well as metadata pertaining to that media content and project. Put simply, an AAF contains links to audio and video files as well as editing decisions that are to be applied to the audio and video data. It facilitates cross-platform interchange of metadata and program content. It catalogs an extensive list of audio and video effects, and provides a way to "wrap" elements of a project together for passing or archiving.


What you learned:
How to Export an Avid Sequence AAF, for Import into Premiere Pro.

  • Clean up Sequence tracks prior to exporting an AAF file. Give each asset type a unique track.
  • Export a Reference Movie to later use for identification and recreation of effects that do not migrate.
  • Select Sequence in Bin, right-click and choose Output > Export to File.
  • Create an AAF exports folder for saving AAF files.
  • Start with an Untitled Export Setting and click the Options button to customize your export.
  • Export the Sequence as AAF and select All Video Tracks and All Audio Tracks.
  • For Export Method: Use the “Link-To (Don’t Export) Media” option.
  • Choosing Mixdown Video Effects will “bake” effects into clips (render a movie) and result in the effect being un-editable in Premiere Pro.
  • Save the file to your AAF Exports folder.

Export Avid Bins as ALE Files

An Avid Log Exchange (ALE) file is a text-based metadata exchange format, and is used for transferring film, video, and audio data between systems. It contains important information about the media, such as Name, Filepath, Video Format, Duration, Timecode, Scene, Take, Notes, Comments, LUT information, and more.


What you learned:
How to Export Avid Bins as ALE files, for Import into Premiere Pro.

  • Check each Bin to ensure all needed information is entered in Metadata Columns before exporting the ALE file for migration into Premiere Pro.
  • Make sure all Bin Clips are not selected, then go File Menu and choose Output > Export Bin.
  • Create an ALE Exports Folder.
  • For Export Setting, choose Avid Log Exchange.
  • Save the file to your ALE Exports Folder.
  • Repeat for each Bin.

Export an Avid Sequence as an Edit Decision List (EDL)

An EDL contains an ordered list of reel/tape/disk names and timecode data representing where each film/video/audio clip can be obtained and correctly placed in order to conform the final cut. An Edit Decision List is a log of every piece of footage used in a Sequence, and it includes detailed effects information. Adobe Premiere Pro supports CMX3600 EDL files.


What you learned: How to export an EDL from an Avid Sequence to use as a printed shot list and reference file for rebuilding effects that don’t migrate into Premiere Pro.

  • Select the Sequence, go the Tools Menu and use the List Tool to generate an EDL.
  • Put check marks next to the data you want included in the list, such as color effects, transitions, 3rd party transitions, and EQ effects.
  • Preview the list, make changes to data choices as needed, and update before clicking Save List.
  • Create an EDL Exports folder and Save the file.

Import Avid Sequence AAF into Adobe Premiere Pro

What you learned: How to import an Avid Sequence as an AAF File into Adobe Premiere Pro.

  • Create a new project in Adobe Premiere Pro. In the Project Panel, right-click and choose Import. Navigate to the exported Avid .aaf file, select it and click Import.
  • A text file called a Translation Report will alert you about unsupported media or effects.
  • A bin containing the Sequence and all associated clips will appear in the Project. Move the Sequence into it’s own bin. Go to the File Menu and select Save.
  • Some Sequence clips may appear altered after import. For example, a Stereo Audio File may appear in the Sequence as Left and Right Mono Channels. If this occurs, those specific clips will be automatically placed in a Recovered Clips Bin.

Import Avid Log Exchange (ALE) Files into Adobe Premiere Pro

Note: Requires Premiere Pro CC 2018 or higher

What you learned: How to import Avid Bins as ALE Files into Adobe Premiere Pro.

  • In the Project Panel, right-click and choose Import. Navigate to an exported .ALE file. Select the ALE file and click Import.
  • Multiple .ALE files can be imported all at once, to bring in all Bins exported from the Avid Project.
  • Right-Click on Metadata Column headers to reveal the Metadata Display Panel.  Select and reveal migrated information for each Bin.   
  • Relink all Media Files.
  • In the Link Media Panel, improve relinking to Avid Sequence and Bin information by unchecking Tape Name, checking Use Media Brower, and Saving Favorite Locations in the Media Directory.

Migration Results

What you learned: Sequence Effects and Metadata Migration

  • Custom information entered in Avid Metadata columns, such as the Comments field, will migrate.
  • Markers will be placed in the Sequence to identify unsupported effects.
  • Effects such as dissolves and speed variations will migrate from Avid.
  • Audio Levels and Keyframes will migrate from Avid.
  • Some Motion parameter settings migrate, but complex animation might not.
  • LUT information baked into master clips will migrate, along with LUT information in Metadata Display columns.
  • LUT Filter Effects and Color Filters applied to clips in Avid Sequence do not migrate.
  • Matte Keys can lose Alpha Channel after migration.
  • Multi-Cam Clips will be broken into discreet camera angles and only the Active Camera Angle from an Avid Sequence will be placed in the Sequence.
  • All Camera angles will be available if Avid Clip Bins are Exported as ALE Files and Imported as Bins into Premiere Pro.

See Importing AAF project files from Avid Media Composer for more information about supported Metadata and Effects when importing ALE, AAF, and EDL files in Premiere Pro.

Avid Bin Export: AAF vs. ALE

  • An AAF sends either Metadata that can “Link-To” MXF Media, or you can embed the media (Copy or Consolidate) into the AAF file.
  • ALE files link to media, they do not contain media.
  • An Avid Sequence imported as an AAF file into Premiere Pro will contain clips that link to the MXF files.
  • An Avid Bin Exported as an AAF file will import into Premiere Pro and link to the MXF files.
  • An Avid Bin Exported as an ALE file will link to the original media (not to the Avid MXF files).
04/18/2018

Contributor: Christine Steele

Was this page helpful?