User Guide Cancel

Creating and recording actions

  1. Photoshop User Guide
  2. Introduction to Photoshop
    1. Dream it. Make it.
    2. What's new in Photoshop
    3. Edit your first photo
    4. Create documents
    5. Photoshop | Common Questions
    6. Photoshop system requirements
    7. Get to know Photoshop
  3. Photoshop and other Adobe products and services
    1. Work with Illustrator artwork in Photoshop
    2. Work with Photoshop files in InDesign
    3. Substance 3D Materials for Photoshop
    4. Use the Capture in-app extension in Photoshop
  4. Photoshop on the iPad (not available in mainland China)
    1. Photoshop on the iPad | Common questions
    2. Get to know the workspace
    3. System requirements | Photoshop on the iPad
    4. Create, open, and export documents
    5. Add photos
    6. Work with layers
    7. Draw and paint with brushes
    8. Make selections and add masks
    9. Retouch your composites
    10. Work with adjustment layers
    11. Adjust the tonality of your composite with Curves
    12. Apply transform operations
    13. Crop and rotate your composites
    14. Rotate, pan, zoom, and reset the canvas
    15. Work with Type layers
    16. Work with Photoshop and Lightroom
    17. Get missing fonts in Photoshop on the iPad
    18. Japanese Text in Photoshop on the iPad
    19. Manage app settings
    20. Touch shortcuts and gestures
    21. Keyboard shortcuts
    22. Edit your image size
    23. Livestream as you create in Photoshop on the iPad
    24. Correct imperfections with the Healing Brush
    25. Create brushes in Capture and use them in Photoshop
    26. Work with Camera Raw files
    27. Create and work with Smart Objects
    28. Adjust exposure in your images with Dodge and Burn
  5. Photoshop on the web (not available in mainland China)
    1. Common questions
    2. System requirements
    3. Keyboard shortcuts
    4. Supported file types
    5. Introduction to the workspace
    6. Open and work with cloud documents
    7. Generative AI features
    8. Basic concepts of editing
    9. Quick Actions
    10. Work with layers
    11. Retouch images and remove imperfections
    12. Make quick selections
    13. Image improvements with Adjustment Layers
    14. Move, transform, and crop images
    15. Draw and paint
    16. Work with Type layers
    17. Work with anyone on the web
    18. Manage app settings
  6. Photoshop (beta) (not available in mainland China)
    1. Get started with Creative Cloud Beta apps
    2. Photoshop (beta) on the desktop
  7. Generative AI (not available in mainland China) 
    1. Common questions on generative AI in Photoshop
    2. Generative Fill in Photoshop on the desktop
    3. Generative Expand in Photoshop on the desktop
    4. Generative Fill in Photoshop on the iPad
    5. Generative Expand in Photoshop on the iPad
    6. Generative variations in Photoshop on the iPad
    7. Generative AI features in Photoshop on the web
  8. Content authenticity (not available in mainland China)
    1. Content credentials in Photoshop
    2. Identity and provenance for NFTs
    3. Connect accounts for creative attribution
  9. Cloud documents (not available in mainland China)
    1. Photoshop cloud documents | Common questions
    2. Photoshop cloud documents | Workflow questions
    3. Manage and work with cloud documents in Photoshop
    4. Upgrade cloud storage for Photoshop
    5. Unable to create or save a cloud document
    6. Solve Photoshop cloud document errors
    7. Collect cloud document sync logs
    8. Invite others to edit your cloud documents
    9. Share files and comment in-app
  10. Workspace
    1. Workspace basics
    2. Preferences
    3. Learn faster with the Photoshop Discover Panel
    4. Create documents
    5. Place files
    6. Default keyboard shortcuts
    7. Customize keyboard shortcuts
    8. Tool galleries
    9. Performance preferences
    10. Use tools
    11. Presets
    12. Grid and guides
    13. Touch gestures
    14. Use the Touch Bar with Photoshop
    15. Touch capabilities and customizable workspaces
    16. Technology previews
    17. Metadata and notes
    18. Touch capabilities and customizable workspaces
    19. Place Photoshop images in other applications
    20. Rulers
    21. Show or hide non-printing Extras
    22. Specify columns for an image
    23. Undo and history
    24. Panels and menus
    25. Position elements with snapping
    26. Position with the Ruler tool
  11. Web, screen, and app design
    1. Photoshop for design
    2. Artboards
    3. Device Preview
    4. Copy CSS from layers
    5. Slice web pages
    6. HTML options for slices
    7. Modify slice layout
    8. Work with web graphics
    9. Create web photo galleries
  12. Image and color basics
    1. How to resize images
    2. Work with raster and vector images
    3. Image size and resolution
    4. Acquire images from cameras and scanners
    5. Create, open, and import images
    6. View images
    7. Invalid JPEG Marker error | Opening images
    8. Viewing multiple images
    9. Customize color pickers and swatches
    10. High dynamic range images
    11. Match colors in your image
    12. Convert between color modes
    13. Color modes
    14. Erase parts of an image
    15. Blending modes
    16. Choose colors
    17. Customize indexed color tables
    18. Image information
    19. Distort filters are unavailable
    20. About color
    21. Color and monochrome adjustments using channels
    22. Choose colors in the Color and Swatches panels
    23. Sample
    24. Color mode or Image mode
    25. Color cast
    26. Add a conditional mode change to an action
    27. Add swatches from HTML CSS and SVG
    28. Bit depth and preferences
  13. Layers
    1. Layer basics
    2. Nondestructive editing
    3. Create and manage layers and groups
    4. Select, group, and link layers
    5. Place images into frames
    6. Layer opacity and blending
    7. Mask layers
    8. Apply Smart Filters
    9. Layer comps
    10. Move, stack, and lock layers
    11. Mask layers with vector masks
    12. Manage layers and groups
    13. Layer effects and styles
    14. Edit layer masks
    15. Extract assets
    16. Reveal layers with clipping masks
    17. Generate image assets from layers
    18. Work with Smart Objects
    19. Blending modes
    20. Combine multiple images into a group portrait
    21. Combine images with Auto-Blend Layers
    22. Align and distribute layers
    23. Copy CSS from layers
    24. Load selections from a layer or layer mask's boundaries
    25. Knockout to reveal content from other layers
  14. Selections
    1. Get started with selections
    2. Make selections in your composite
    3. Select and Mask workspace
    4. Select with the marquee tools
    5. Select with the lasso tools
    6. Adjust pixel selections
    7. Move, copy, and delete selected pixels
    8. Create a temporary quick mask
    9. Select a color range in an image
    10. Convert between paths and selection borders
    11. Channel basics
    12. Save selections and alpha channel masks
    13. Select the image areas in focus
    14. Duplicate, split, and merge channels
    15. Channel calculations
  15. Image adjustments
    1. Replace object colors
    2. Perspective warp
    3. Reduce camera shake blurring
    4. Healing brush examples
    5. Export color lookup tables
    6. Adjust image sharpness and blur
    7. Understand color adjustments
    8. Apply a Brightness/Contrast adjustment
    9. Adjust shadow and highlight detail
    10. Levels adjustment
    11. Adjust hue and saturation
    12. Adjust vibrance
    13. Adjust color saturation in image areas
    14. Make quick tonal adjustments
    15. Apply special color effects to images
    16. Enhance your image with color balance adjustments
    17. High dynamic range images
    18. View histograms and pixel values
    19. Match colors in your image
    20. Crop and straighten photos
    21. Convert a color image to black and white
    22. Adjustment and fill layers
    23. Curves adjustment
    24. Blending modes
    25. Target images for press
    26. Adjust color and tone with Levels and Curves eyedroppers
    27. Adjust HDR exposure and toning
    28. Dodge or burn image areas
    29. Make selective color adjustments
  16. Adobe Camera Raw
    1. Camera Raw system requirements
    2. What's new in Camera Raw
    3. Introduction to Camera Raw
    4. Create panoramas
    5. Supported lenses
    6. Vignette, grain, and dehaze effects in Camera Raw
    7. Default keyboard shortcuts
    8. Automatic perspective correction in Camera Raw
    9. Radial Filter in Camera Raw
    10. Manage Camera Raw settings
    11. Open, process, and save images in Camera Raw
    12. Repair images with the Enhanced Spot Removal tool in Camera Raw
    13. Rotate, crop, and adjust images
    14. Adjust color rendering in Camera Raw
    15. Process versions in Camera Raw
    16. Make local adjustments in Camera Raw
  17. Image repair and restoration
    1. Remove objects from your photos with Content-Aware Fill
    2. Content-Aware Patch and Move
    3. Retouch and repair photos
    4. Correct image distortion and noise
    5. Basic troubleshooting steps to fix most issues
  18. Image enhancement and transformation
    1. Replace sky in your images
    2. Transform objects
    3. Adjust crop, rotation, and canvas size
    4. How to crop and straighten photos
    5. Create and edit panoramic images
    6. Warp images, shapes, and paths
    7. Vanishing Point
    8. Content-aware scaling
    9. Transform images, shapes, and paths
  19. Drawing and painting
    1. Paint symmetrical patterns
    2. Draw rectangles and modify stroke options
    3. About drawing
    4. Draw and edit shapes
    5. Painting tools
    6. Create and modify brushes
    7. Blending modes
    8. Add color to paths
    9. Edit paths
    10. Paint with the Mixer Brush
    11. Brush presets
    12. Gradients
    13. Gradient interpolation
    14. Fill and stroke selections, layers, and paths
    15. Draw with the Pen tools
    16. Create patterns
    17. Generate a pattern using the Pattern Maker
    18. Manage paths
    19. Manage pattern libraries and presets
    20. Draw or paint with a graphics tablet
    21. Create textured brushes
    22. Add dynamic elements to brushes
    23. Gradient
    24. Paint stylized strokes with the Art History Brush
    25. Paint with a pattern
    26. Sync presets on multiple devices
    27. Migrate presets, actions, and settings
  20. Text
    1. Add and edit the text
    2. Unified Text Engine
    3. Work with OpenType SVG fonts
    4. Format characters
    5. Format paragraphs
    6. How to create type effects
    7. Edit text
    8. Line and character spacing
    9. Arabic and Hebrew type
    10. Fonts
    11. Troubleshoot fonts
    12. Asian type
    13. Create type
  21. Filters and effects
    1. Use the Liquify filter
    2. Use the Blur Gallery
    3. Filter basics
    4. Filter effects reference
    5. Add Lighting Effects
    6. Use the Adaptive Wide Angle filter
    7. Use the Oil Paint filter
    8. Use the Liquify filter
    9. Layer effects and styles
    10. Apply specific filters
    11. Smudge image areas
  22. Saving and exporting
    1. Save your files in Photoshop
    2. Export your files in Photoshop
    3. Supported file formats
    4. Save files in graphics formats
    5. Move designs between Photoshop and Illustrator
    6. Save and export video and animations
    7. Save PDF files
    8. Digimarc copyright protection
  23. Color Management
    1. Understanding color management
    2. Keeping colors consistent
    3. Color settings
    4. Duotones
    5. Work with color profiles
    6. Color-managing documents for online viewing
    7. Color-managing documents when printing
    8. Color-managing imported images
    9. Proofing colors
  24. Web, screen, and app design
    1. Photoshop for design
    2. Artboards
    3. Device Preview
    4. Copy CSS from layers
    5. Slice web pages
    6. HTML options for slices
    7. Modify slice layout
    8. Work with web graphics
    9. Create web photo galleries
  25. Video and animation
    1. Video editing in Photoshop
    2. Edit video and animation layers
    3. Video and animation overview
    4. Preview video and animations
    5. Paint frames in video layers
    6. Import video files and image sequences
    7. Create frame animations
    8. Creative Cloud 3D Animation (Preview)
    9. Create timeline animations
    10. Create images for video
  26. Printing
    1. Print 3D objects
    2. Print from Photoshop
    3. Print with color management
    4. Contact Sheets and PDF Presentations
    5. Print photos in a picture package layout
    6. Print spot colors
    7. Print images to a commercial printing press
    8. Improve color prints from Photoshop
    9. Troubleshoot printing problems | Photoshop
  27. Automation
    1. Creating actions
    2. Create data-driven graphics
    3. Scripting
    4. Process a batch of files
    5. Play and manage actions
    6. Add conditional actions
    7. About actions and the Actions panel
    8. Record tools in actions
    9. Add a conditional mode change to an action
    10. Photoshop UI toolkit for plug-ins and scripts
  28. Troubleshooting
    1. Fixed issues 
    2. Known issues
    3. Optimize Photoshop performance
    4. Basic troubleshooting
    5. Troubleshoot crash or freeze
    6. Troubleshoot program errors
    7. Troubleshoot scratch disk full errors
    8. Troubleshoot GPU and graphics driver issues
    9. Find missing tools
    10. Photoshop 3D | Common questions around discontinued features

Work efficiently by easily recording actions for frequently performed tasks.

Topics in this article:

Guidelines for recording actions

Keep in mind the following guidelines when recording actions:

  • You can record most—but not all—commands in an action.

  • You can record operations that you perform with the Marquee, Move, Polygon, Lasso, Magic Wand, Crop, Slice, Magic Eraser, Gradient, Paint Bucket, Type, Shape, Notes, Eyedropper, and Color Sampler tools—as well as those that you perform in the History, Swatches, Color, Paths, Channels, Layers, Styles, and Actions panels.

  • Results depend on file and program setting variables, such as the active layer and the foreground color. For example, a 3‑pixel Gaussian blur won’t create the same effect on a 72‑ppi file as on a 144‑ppi file. Nor will Color Balance work on a grayscale file.

  • When you record actions that include specifying settings in dialog boxes and panels, the action will reflect the settings in effect at the time of the recording. If you change a setting in a dialog box or panel while recording an action, the changed value is recorded.

Note:

Most dialog boxes retain the settings specified at the previous use. Check carefully that those are the values you want to record.

  • Modal operations and tools—as well as tools that record position—use the units currently specified for the ruler. A modal operation or tool is one that requires you to press Enter or Return to apply its effect, such as transforming or cropping. Tools that record position include the Marquee, Slice, Gradient, Magic Wand, Lasso, Shape, Path, Eyedropper, and Notes tools.
Note:

If you record an action that will be played on files of different sizes, set the ruler units to percentages. As a result, the action will always play back in the same relative position in the image.

  • You can record the Play command listed on the Actions panel menu to cause one action to play another.

Steps to record an action

When you create a new action, the commands and tools you use are added to the action until you stop recording.

Note:

To guard against mistakes, work in a copy: At the beginning of the action before applying other commands, record the File > Save As command and select As A Copy. Alternatively, you can click the New Snapshot button on the History panel to make a snapshot of the image before recording the action.  

  1. Open a file.
  2. In the Actions panel, click the Create New Action button  , or choose New Action from the Actions panel menu.
  3. Enter an action name, select an action set, and set additional options:

    Function Key

    Assigns a keyboard shortcut to the action. You can choose any combination of a function key, the Ctrl key (Windows) or Command key (Mac OS), and the Shift key (for example, Ctrl+Shift+F3), with these exceptions: In Windows, you cannot use the F1 key, nor can you use F4 or F6 with the Ctrl key.

    Note:

    If you assign an action the same shortcut that is used for a command, the shortcut will apply the action rather than the command.

    Use the Color field to assign color for display in Button mode.

    Use the Color field to assign color for display in Button mode.

  4. Click Begin Recording. The Begin Recording button in the Actions panel turns red  .
    Note:

    When recording the Save As command, do not change the filename. If you enter a new filename, that new name is recorded and used each time you run the action. Before saving, if you navigate to a different folder, you can specify a different location without having to specify a filename.

  5. Perform the operations and commands you want to record.

    Not all tasks in actions can be recorded directly; however, you can insert most nonrecordable tasks using commands in the Actions panel menu.

  6. To stop recording, either click the Stop Playing/Recording button, or choose Stop Recording from the Actions panel menu, or press the Esc key.

Note:

To resume recording in the same action, choose Start Recording from the Actions panel menu.

Record tools in actions

Photoshop lets you record tools such as the brush tool in your action. To enable this feature, choose Allow Tool Recording from the Actions panel menu.

A couple of items to keep in mind:

  • When recording a tool, choose your brush as part of the action or Photoshop uses the currently selected brush.
  • If you are recording the action to play back at a different size, set Photoshop's measurement units to percentage and don’t define the brush size as part of a brush preset.

From an expert: Tool recording

Photoshop educator Howard Pinsky demonstrates how to use the Allow Tool Recording command when creating actions.

Record a path

The Insert Path command lets you include a complex path (a path created with a pen tool or pasted from Adobe Illustrator) as part of an action. When the action is played back, the work path is set to the recorded path. You can insert a path when recording an action or after it has been recorded.

  1. Do one of the following:
    • Start recording an action.

    • Select an action’s name to record a path at the end of the action.

    • Select a command to record a path after the command.

  2. Select an existing path from the Paths panel.
  3. Choose Insert Path from the Actions panel menu.

If you record multiple Insert Path commands in a single action, each path replaces the previous one in the target file. To add multiple paths, record a Save Path command using the Paths panel after recording each Insert Path command.

Note:

Playing actions that insert complex paths may require significant amounts of memory. If you encounter problems, increase the amount of memory available to Photoshop.

Insert a stop

You can include stops in an action that let you perform a task that cannot be recorded (for example, using a painting tool). After you complete the task, click the Play button in the Actions panel to complete the action.

You can also display a short message when the action reaches the stop as a reminder of what needs to be done before continuing with the action. You can include a Continue button in the message box in case no other task needs to be done.

  1. Choose where to insert the stop by doing one of the following:
    • Select an action’s name to insert a stop at the end of the action.

    • Select a command to insert a stop after the command.

  2. Choose Insert Stop from the Actions panel menu.
  3. Type the message you want to appear.
  4. If you want the option to continue the action without stopping, select Allow Continue.
  5. Click OK.
Note:

You can insert a stop when recording an action or after it has been recorded.

Change settings when playing an action

By default, actions are completed using the values specified when they were originally recorded. If you want to change the settings for a command within an action, you can insert a modal control. A modal control pauses an action so that you can specify values in a dialog box or use a modal tool. (A modal tool requires pressing Enter or Return to apply its effect—once you press Enter or Return, the action resumes its tasks.)

A modal control is indicated by a dialog box icon  to the left of a command, action, or set in the Actions panel. A red dialog box icon  indicates an action or set in which some, but not all, commands are modal. You can’t set a modal control in Button mode.

  1. Do one of the following:
    • To enable a modal control for a command within an action, click the box to the left of the command name. Click again to disable the modal control.

    • To enable or disable modal controls for all commands in an action, click the box to the left of the action name.

    • To enable or disable modal controls for all actions in a set, click the box to the left of the set name.

Exclude commands from an action

You can exclude commands that you don’t want to play as part of a recorded action. You can’t exclude commands in Button mode.

  1. If necessary, expand the listing of commands in the action by clicking the triangle to the left of the action name in the Actions panel.
  2. Do one of the following:
    • To exclude a single command, click to clear the check mark to the left of the command name. Click again to include the command.

    • To exclude or include all commands or actions in an action or set, click the check mark to the left of the action or set name.

    • To exclude or include all commands except the selected command, Alt-click (Windows) or Option-click (Mac OS) its check mark.

      To indicate that some of the commands within the action are excluded, the check mark of the parent action turns red.

Insert a non-recordable menu command

You can insert many non-recordable commands into an action using the Insert Menu Item command.

You can insert a command when recording an action, or after it has been recorded. An inserted command doesn’t execute until the action is played, so the file remains unchanged when the command is inserted. No values for the command are recorded in the action. If the command opens a dialog box, the dialog box appears during playback, and the action pauses until you click OK or Cancel.

Note:

When you use the Insert Menu Item command to insert a command that opens a dialog box, you cannot disable the modal control in the Actions panel.

  1. Choose where to insert the menu item:
    • Select an action’s name to insert the item at the end of the action.

    • Select a command to insert the item at the end of the command.

  2. Choose Insert Menu Item from the Actions panel menu.
  3. With the Insert Menu Item dialog box open, choose a command from its menu.
  4. Click OK.

Edit and re-record actions

You can tweak the settings of any specific command within an action, add commands to an existing action, or step through an entire action and change any or all settings.

Overwrite a single command

  1. In the Actions panel, double-click the command.
  2. Enter the new values, and click OK.

Add commands to an action

  1. Do one of the following:
    • Select the action name to insert a new command at the end of the action.

    • Select a command in the action to insert a command after it.

  2. Click the Begin Recording button, or choose Start Recording from the Actions panel menu.
  3. Record the additional commands.
  4. When finished, click the Stop Playing/Recording button in the Actions panel or choose Stop Recording from the panel menu.

Rearrange commands within an action

  1. In the Actions panel, drag a command to its new location within the same or another action. When the highlighted line appears in the desired position, release the mouse button.

Record an action again

  1. Select an action, and choose Record Again from the Actions panel menu.
  2. If a modal tool appears, use the tool to create a different result, and press Enter or Return, or just press Enter or Return to retain the same settings.
  3. If a dialog box appears, change the settings, and click OK to record them, or click Cancel to retain the same values.

 Adobe

Get help faster and easier

New user?