User Guide Cancel

Applying transitions in Premiere Pro

  1. Adobe Premiere Pro User Guide
  2. Beta releases
    1. Beta Program Overview
    2. Premiere Pro Beta Home
  3. Getting started
    1. Get started with Adobe Premiere Pro
    2. What's new in Premiere Pro
    3. Release Notes | Premiere Pro
    4. Keyboard shortcuts in Premiere Pro
    5. Accessibility in Premiere Pro
  4. Hardware and operating system requirements
    1. Hardware recommendations
    2. System requirements
    3. GPU and GPU Driver requirements
    4. GPU Accelerated Rendering & Hardware Encoding/Decoding
  5. Creating projects
    1. Start a new project
    2. Open projects
    3. Move and delete projects
    4. Work with multiple open projects
    5. Work with Project Shortcuts
    6. Backward compatibility of Premiere Pro projects
    7. Open and edit Premiere Rush projects in Premiere Pro
    8. Best Practices: Create your own project templates
  6. Workspaces and workflows
    1. Workspaces
    2. FAQ | Import and export in Premiere Pro
    3. Working with Panels
    4. Windows touch and gesture controls
    5. Use Premiere Pro in a dual-monitor setup
  7. Capturing and importing
    1. Capturing
      1. Capturing and digitizing footage
      2. Capturing HD, DV, or HDV video
      3. Batch capturing and recapturing
      4. Setting up your system for HD, DV, or HDV capture
    2. Importing
      1. Transfer files
      2. Importing still images
      3. Importing digital audio
    3. Importing from Avid or Final Cut
      1. Importing AAF project files from Avid Media Composer
      2. Importing XML project files from Final Cut Pro 7 and Final Cut Pro X
    4. Supported file formats
    5. Digitizing analog video
    6. Working with timecode
  8. Editing
    1. Sequences
      1. Create and change sequences
      2. Add clips to sequences
      3. Rearrange clips in a sequence
      4. Find, select, and group clips in a sequence
      5. Edit from sequences loaded into the Source Monitor
      6. Simplify sequences
      7. Rendering and previewing sequences
      8. Working with markers
      9. Scene edit detection
    2. Video
      1. Create and play clips
      2. Trimming clips
      3. Synchronizing audio and video with Merge Clips
      4. Render and replace media
      5. Undo, history, and events
      6. Freeze and hold frames
      7. Working with aspect ratios
    3. Audio
      1. Overview of audio in Premiere Pro
      2. Audio Track Mixer
      3. Adjusting volume levels
      4. Edit, repair, and improve audio using Essential Sound panel
      5. Automatically duck audio
      6. Remix audio
      7. Monitor clip volume and pan using Audio Clip Mixer
      8. Audio balancing and panning
      9. Advanced Audio - Submixes, downmixing, and routing
      10. Audio effects and transitions
      11. Working with audio transitions
      12. Apply effects to audio
      13. Measure audio using the Loudness Radar effect
      14. Recording audio mixes
      15. Editing audio in the timeline
      16. Audio channel mapping in Premiere Pro
      17. Use Adobe Stock audio in Premiere Pro
    4. Advanced editing
      1. Multi-camera editing workflow
      2. Editing workflows for feature films
      3. Set up and use Head Mounted Display for immersive video in Premiere Pro
      4. Editing VR
    5. Best Practices
      1. Best Practices: Mix audio faster
      2. Best Practices: Editing efficiently
  9. Video Effects and Transitions
    1. Overview of video effects and transitions
    2. Effects
      1. Types of effects in Premiere Pro
      2. Apply and remove effects
      3. Effect presets
      4. Automatically reframe video for different social media channels
      5. Color correction effects
      6. Change duration and speed of clips
      7. Adjustment Layers
      8. Stabilize footage
    3. Transitions
      1. Applying transitions in Premiere Pro
      2. Modifying and customizing transitions
      3. Morph Cut
  10. Graphics, Titles, and Animation
    1. Graphics and titles
      1. Overview of the Essential Graphics panel
      2. Create a title
      3. Create a shape
      4. Align and distribute text and shapes
      5. Check spelling and Find and Replace
      6. Apply text gradients in Premiere Pro
      7. Add Responsive Design features to your graphics
      8. Use Motion Graphics templates for titles
      9. Replace images or videos in Motion Graphics templates
      10. Use data-driven Motion Graphics templates
      11. Best Practices: Faster graphics workflows
      12. Working with captions
      13. Speech to Text
      14. Speech to Text in Premiere Pro | FAQ
      15. Upgrade Legacy titles to Source Graphics
    2. Animation and Keyframing
      1. Adding, navigating, and setting keyframes
      2. Animating effects
      3. Use Motion effect to edit and animate clips
      4. Optimize keyframe automation
      5. Moving and copying keyframes
      6. Viewing and adjusting effects and keyframes
  11. Compositing
    1. Compositing, alpha channels, and adjusting clip opacity
    2. Masking and tracking
    3. Blending modes
  12. Color Correction and Grading
    1. Overview: Color workflows in Premiere Pro
    2. Auto Color
    3. Get creative with color using Lumetri looks
    4. Adjust color using RGB and Hue Saturation Curves
    5. Correct and match colors between shots
    6. Using HSL Secondary controls in the Lumetri Color panel
    7. Create vignettes
    8. Looks and LUTs
    9. Lumetri scopes
    10. Display Color Management
    11. HDR for broadcasters
    12. Enable DirectX HDR support
  13. Exporting media
    1. Export video
    2. Export Preset Manager
    3. Workflow and overview for exporting
    4. Quick export
    5. Exporting for the Web and mobile devices
    6. Export a still image
    7. Exporting projects for other applications
    8. Exporting OMF files for Pro Tools
    9. Export to Panasonic P2 format
    10. Export settings reference
    11. Best Practices: Export faster
  14. Collaboration: Frame.io, Productions, and Team Projects
    1. Collaboration in Premiere Pro
    2. Frame.io
      1. Install and activate Frame.io
      2. Use Frame.io with Premiere Pro and After Effects
      3. Frequently asked questions
    3. Productions
      1. Using Productions
      2. How clips work across projects in a Production
      3. Best Practices: Working with Productions
    4. Team Projects
      1. What's New in Team Projects
      2. Get started with Team Projects
      3. Create a Team Project
      4. Add and manage media in Team Projects
      5. Collaborate with Team Projects
      6. Share and manage changes with Team Project collaborators
      7. Archive, restore, or delete Team Projects
  15. Working with other Adobe applications
    1. After Effects and Photoshop
    2. Dynamic Link
    3. Audition
    4. Prelude
  16. Organizing and Managing Assets
    1. Working in the Project panel
    2. Organize assets in the Project panel
    3. Playing assets
    4. Search assets
    5. Creative Cloud Libraries
    6. Sync Settings in Premiere Pro
    7. Consolidate, transcode, and archive projects
    8. Managing metadata
    9. Best Practices
      1. Best Practices: Learning from broadcast production
      2. Best Practices: Working with native formats
  17. Improving Performance and Troubleshooting
    1. Set preferences
    2. Reset preferences
    3. Working with Proxies
      1. Proxy overview
      2. Ingest and Proxy Workflow
    4. Check if your system is compatible with Premiere Pro
    5. Premiere Pro for Apple silicon
    6. Eliminate flicker
    7. Interlacing and field order
    8. Smart rendering
    9. Control surface support
    10. Best Practices: Working with native formats
    11. Knowledge Base
      1. Known issues
      2. Fixed issues
      3. Green and pink video in Premiere Pro or Premiere Rush
      4. How do I manage the Media Cache in Premiere Pro?
      5. Fix errors when rendering or exporting
      6. Troubleshoot issues related to playback and performance in Premiere Pro
  18. Monitoring Assets and Offline Media
    1. Monitoring assets
      1. Using the Source Monitor and Program Monitor
      2. Using the Reference Monitor
    2. Offline media
      1. Working with offline clips
      2. Creating clips for offline editing
      3. Relinking offline medInstia

What are transitions?

A transition is an effect added between pieces of media to create an animated link between them. Transitions are used to move a scene from one shot to the next. Premiere Pro provides a list of transitions that you can apply to a sequence. A transition can be a subtle crossfade or a stylized effect.

Different transitions available in Premiere Pro are:

By default, placing one clip next to another in a Timeline panel results in a cut, where the last frame of one clip is followed by the first frame of the next. Transitions are usually placed on a cut line between shots. You can also apply a transition only to the beginning or end of a clip.

Before you apply a transition, trim the clips. Then, apply the transition. The more you trim, the more availability of frames you can use in the transition.

TIP: Trim at least 15 frames off of each clip for a centered 1:00 transition.

Using clip handles

Clip handles are extra footage before the clip's in-point and after the clip's out-point that you can use to manipulate a transition.

 If the source media does not contain enough frames, clip handles may not be present as there is no extra footage to add the transition. When you add the transition, Premiere Pro warns you that there is ‘Insufficient Media’ and that the transition will contain repeated frames. Premiere Pro automatically creates its Clip Handles by repeating the end frames to form a freeze frame of the clip. The transition appears in the Timeline panel with diagonal warning bars through it.

clip handle
Clip handles

When you add a transition, a colored overlay appears over the clips in the timeline. The transition does not shorten the clip. It continues the clip from the In/Out point.

Illustration

Description

Result


Sufficient outgoing (blue) and incoming handles (pink)

You can add a transition. Here you could add a standard 1:00 transition.

Insufficient outgoing and incoming handles

You can add a short transition. Here you could add a centered transition with a duration of :15.

No handles

You cannot add a transition. You'll see an "Insufficient content" error message or an "X" next to the Selection tool. Ripple trim both sides of the edit point to fix this.

Insufficient outgoing handle

You can add a short transition. Roll the edit point  to the left to restore handle.

No outgoing handle

Your best choice here would be a transition that begins at the cut. For a centered transition, you'd need to ripple trim the outgoing clip.

Insufficient incoming handle

You can add a short transition. Roll the edit point to the right to restore handle.

No incoming handle

Your best choice here would be a transition that ends at the cut. For 1:00, centered transition, roll the edit point to the right. 

Note:

While adding a transition between clips, make sure you have a clip handle at the end of the first clip and at the beginning of the next clip.

 When you don’t have enough clip handles for the transition, the easiest solution is to re-edit the clip. Select the clip in the timeline. Use the Ripple edit tool to trim back the clip. Now you can add the transition. 

For more information, see Trimming clips.

Apply transitions between two clips

To place a transition between two clips (centered on the cut line), the clips must be on the same track, with no space between them.

Apply transitions between 2 clips
Apply transitions between 2 clips

To apply a transition between two clips, do the following:

  1. Choose Window > Effects.

  2. Expand the Video Transitions or Audio Transitions bin.

  3. Expand the bin containing the transition you want to use.

  4. To place a transition between two clips, drag the transition to the cut line between two clips, and release the mouse when you see the Center At Cut icon.

    Note:

    As you drag over heads or tails of clips in the Timeline panel, you can see the area covered by the transition outlined.

To preview the transition, play the sequence or drag the current-time indicator through the transition.

Apply a single-sided transition

Transitions are typically double-sided as they get applied to both clips. Single sided transitions are only applied on a single clip. This is useful when you don’t have a clip handle.

     

Using single-sided transitions, you have more control over how clips transition.

For example, you can create the effect of one clip departing using the Venetian Blinds transition, and the next clip fading in using Cross Dissolve.

In a Timeline panel or the Effect Controls panel, a double-sided transition has a dark diagonal line through it, while a single-sided transition is split diagonally with one half dark and one half light.

Types of transitions
Difference between a single-sided and double-sided transition

A. Double-sided transition B. Single-sided transitions 

To apply a single-sided transition, do the following:

  1. In the Effects panel, find the transition you want to apply.  Expand the Video Transitions or Audio Transitions bin. Then, expand the bin containing the transition you want to use.

  2. To place a transition on a single cut, Ctrl+drag (Win) or Cmd+drag (macOS) the transition into a Timeline panel. Release the mouse when you see either the End At Cut or Start At Cut icon.

    • End At Cut icon: Aligns the end of the transition to the end of the first clip.
    • Start At Cut icon: Aligns the beginning of the transition to the beginning of the second clip.
    Apply a single-sided transition
    Applying a single-sided transition

    Note:

    To place a transition at the end of a clip that is not next to another clip, drag-and-drop the transition. Don’t Ctrl+drag (Win) or Cmd+drag (macOS). The transition automatically becomes single-sided.

To preview the transition, play the sequence or drag the current-time indicator through the transition.

Set and apply default transitions

You can set a video transition and an audio transition as default transitions.  Cross Dissolve and Constant Power Crossfade are preset as the video and audio default transitions. A blue outline marks default transition icon in the Effects panel.

If you use another transition more frequently, you can set it as the default. When you change the default transition setting, you change the default for all projects. Changing the default transition doesn’t affect transitions already applied to sequences.

Note:

If you want to apply the default transition to most or all the clips in a sequence, consider using the Automate To Sequence command. Automate To Sequence places the default video and audio transition between all the clips it adds. For more information, see Add clips to a sequence automatically.

Set a default transition

  1. Choose Window > Effects and expand the Video Transitions or Audio Transitions bin.

  2. Select the transition that you want to make the default.
  3. Click the Menu button for the Effects panel, or right-click the transition.
  4. Choose Set Selected As Default Transition.

Set the duration of the default transition

  1. Do one of the following:
    • Choose Edit > Preferences > Timeline (Win), or Premiere Pro > Preferences > Timeline (macOS).

    • Click the Effects panel menu button. Choose Set Default Transition Duration.

  2. Change the value for the Video Transition Default Duration or Audio Transition Default Duration, and then click OK.

Apply default transitions between selected clips

You can apply the default video and audio transitions to any selection of two or more clips. The default transitions are applied to every edit point where two selected clips touch. The placement does not depend upon the position of the current-time indicator or on whether the clips lie on targeted tracks. The default transitions are not applied where a selected clip touches a non-selected clip or no clip at all.

  1. In the Timeline, select two or more clips. Shift-click clips, or draw a marquee over them, to select them.
  2. Select Sequence > Apply Default Transitions To Selection.

Copy and paste transitions

You can copy any transition in a sequence and paste it to any other cut line on a track of the same type: video transitions to video tracks, and audio transitions to audio tracks.

  1. Select a transition in a sequence.
  2. Select Edit > Copy, or use the keyboard shortcut Ctrl+C (Win) or Cmd+C (macOS).

  3. Do one of the following:

    • To copy a transition to a single clip: Move the current-time indicator to the cut line where you want to paste the transition.
    • To copy a transition to multiple clips: Select multiple edit points in the sequence by dragging a marquee around the edit points, or by using the Shift key with any trim tool.
    Note:

    If you paste a transition without selecting edit points, the transitions are pasted to edit points at or near the playhead, without overriding track targeting.

  4. Select Edit > Paste, or use the keyboard shortcut Ctrl+V (Win) or Cmd+V (macOS).

Replace a transition

To replace a transition, drag the new video or audio transition from the Effects panel onto the existing transition in the sequence.

When you replace a transition, the alignment and duration are preserved. However, this discards the settings for the old transition and replaces it with the default settings for the new transition.

Adobe logo

Sign in to your account