InDesign 的 Adobe Print Engine 失敗問題

問題

嘗試列印時,InDesign 傳回以下錯誤:

「列印錯誤:由於發生不明問題,Adobe Print Engine 無法輸出您的資料。」

解決方案

執行下列任一操作:

解決方法 1:重新建立 InDesign 偏好設定檔案。

  1. 結束 InDesign。
  2. 重新命名下列位置中的 InDesign SavedData 檔案和 InDesign Defaults 檔案 (例如重新命名為 InDesign SavedData.old、InDesign Defaults.old):
    • Windows XP:C:/Documents and Settings/[使用者名稱]/Application Data/Adobe/InDesign/[版本]
    • Windows 7/Vista:C:/Users/[使用者名稱]/AppData/Roaming/Adobe/InDesign/[版本]
    • Mac OS:/Users/[使用者名稱]/Library/Preferences/Adobe InDesign/[版本]
  3. 啟動 InDesign。InDesign 會建立偏好設定檔案。
  4. 如果問題持續發生,您可以還原原始偏好設定,方法是刪除新檔案,然後將舊的偏好設定檔案重新命名為其原始名稱。

解決方法 2:重新建立漸層,讓特別色來自相同的色域。

如果您列印的 EPS 檔案是從具有漸層的 InDesign 文件進行轉存,請確認漸層中的特別色來自相同色域,然後重新轉存 EPS。(例如,請確認漸層並未包含一個 RGB 特別色和一個 LAB 特別色。)

解決方法 3:在「列印」對話框中變更列印選項。

依照以下步驟變更「列印」對話框中的設定:

  • 如果您列印的區段只包含一頁奇數頁,請取消選取「僅偶數頁」。
  • 如果您列印的區段只包含一頁偶數頁,請取消選取「僅奇數頁」。

解決方法 4:以範圍內的顏色取代超出範圍的顏色。

如果您列印的 InDesign 文件含有匯入的已標記文字,請檢查以確認已標記文字檔案是否包含超出範圍的顏色。在「色票」調色盤中顯示的超出範圍顏色會具有附加值,例如「+5」,表示最接近的範圍內值。

若要以範圍內的顏色取代超出範圍的顏色,請執行以下操作:

  • 在 InDesign 中定義新的色票,然後使用「尋找/變更」功能,以新顏色取代已標記文字檔案中的顏色。
  • 重新定義已標記文字檔案中的顏色值,然後將檔案重新匯入 InDesign。顏色值是以顏色表標記 (<Color Table>) 定義。如需進一步瞭解已標記文字顏色的定義以及標記,請參閱 InDesign CD-ROM 上的「已標記文字 PDF 檔案」。

解決方法 5:將檔案轉存為 PDF,然後從 Adobe Acrobat 5 或更新版本中列印。

將檔案轉存為 PDF,然後從 Adobe Acrobat 5 以上或 Adobe Acrobat Reader 5.0 以上版本列印該 PDF 檔案。

解決方法 6:移除 PDF 檔案中的 OPI 2.0 注釋。

移除 PDF 檔案中的 OPI 2.0 注釋,並將 PDF 檔案置入 InDesign,然後列印文件。

若要移除 OPI 2.0 注釋,請執行下列任一項作業:

  • 在 Adobe Acrobat 中,手動移除 OPI 2.0 注釋,然後重新建立 PDF 檔案。
  • 在 Acrobat 中,使用 Enfocus Pitstop 移除 OPI 2.0 注釋。
  • 使用 OPI 1.3 注釋。
  • 在 Acrobat Distiller 中,選擇「設定 > 編輯 Adobe PDF 設定」,按一下「進階」標籤,並取消選取「保留 OPI 注釋」,然後製作 PDF 檔案。
  • 使用代理程式 OPI 工作流程,並在 PDF 中嵌入代理程式 (不忽略)。
  • 在 InDesign 中,選取 PDF 並套用透明度選項。如需指示,請參閱 InDesign 說明中的「指定透明度」。

解決方法 7:以 EPS 影像取代 PDF 檔案。

使用影像編輯應用程式,例如 Adobe Photoshop,以將 PDF 檔案另存為 EPS 影像。然後將 EPS 影像置入 InDesign 文件中。

解決方法 8:使用「油墨管理員」將所有特別色轉換為印刷色。

若要確認您使用的特別色數量,請開啟「色票」調色盤。色票名稱後接方塊中若有灰色圓形,就是特別色。

若要透過「油墨管理員」將所有顏色轉換為印刷色,請執行以下操作:

  1. 開啟「色票」調色盤。
  2. 從選單中選取「油墨管理」。
  3. 選取對話框左下角的「將所有特別色轉換為印刷色」,然後按一下「確定」。

如果您在「列印」對話框中選取「輸出」頁面,則「油墨」區段只會列出「青色」、「洋紅色」、「黃色」和「黑色」油墨。

注意:此問題只會在列印至 PostScript 印表機時出現。如果您可以存取非 PostScript 印表機,則可以用其列印複合檔案。

解決方法 9:將來源檔案另存為不同的檔案格式。

在建立檔案的應用程式中開啟來源檔案,並儲存為 PDF 以外的格式。如需更多資訊,請參閱該應用程式隨附的文件。

解決方法 10:將文件轉存為 InDesign Interchange (.inx) 格式,然後檢查字型資訊。

  1. 在 InDesign CS 中,選擇「檔案 > 轉存」,然後從「另存新檔類型」選單中選擇「InDesign Interchange」。
  2. 按一下「儲存」。

解決方法 11:從 InDesignas 將 PDF 檔案轉存為 JPEG 檔案。

將 PDF 檔案置入新的 InDesign 文件中。將 PDF 檔案轉存為 JPEG 檔案,然後將該 JPEG 檔案置入原始 InDesign 文件中。

  1. 建立 InDesign 文件。
  2. 選擇「檔案 > 置入」,選取所需的 PDF 檔案,然後按一下「開啟」。
  3. 按一下要置入 PDF 檔案的頁面。
  4. 選取 PDF 檔案後,選擇「檔案 > 轉存」。
  5. 從「格式」選單中選擇「JPEG」,並為檔案命名,然後按一下「儲存」。
  6. 選取您要的轉存選項,然後按一下「轉存」。
  7. 開啟無法列印的原始 InDesign 文件。
  8. 選擇「檔案 > 置入」,並選取您在步驟 5 中儲存的 JPEG 檔案,然後按一下「開啟」。
  9. 按一下要置入 JPEG 檔案的頁面。

解決方法 12:使用 Microsoft Office 中的「轉換為 PDF」工具來建立 PDF 檔案。

  1. 在 Microsoft Excel、Microsoft PowerPoint 或 Microsoft Word 中開啟文件。
  2. 按一下工具列中的「轉換為 Adobe PDF」。
  3. 命名並儲存 PDF 檔案。

解決方法 13:使用 Adobe Acrobat Distiller 建立 PostScript 檔案並轉換為 PDF。

若要在來源應用程式中建立 PostScript 檔案,請參閱該應用程式隨附的文件。

若要將 PostScript 檔案轉換為 PDF 檔案,請執行以下操作:

  1. 啟動 Acrobat Distiller。
  2. 從「預設設定」選單中選擇設定。
  3. 選擇「檔案 > 開啟」。
  4. 選取 PostScript 檔案,然後選擇「開啟」。PDF 檔案會出現在與 PostScript 檔案相同的位置。

解決方法 14:檢查字型是否損毀。

若要判斷問題是否與損毀的字體有關,請嘗試將文件中使用的所有字體切換為標準字體。(例如變更為 Arial 或 Times New Roman。)

如果切換字體後問題重複發生,則該問題與字體無關。如果問題未再次發生,表示原始字體可能已損壞或過期 (即在 1992 年前建立)。請嘗試重新安裝字體,或從字體製造商取得更新版本。

解決方法 15:重新建立 Adobe 字體清單檔案

Windows:

  1. 結束所有 Adobe 應用程式。
  2. 選擇「開始> 搜尋 >檔案或資料夾」。
  3. 搜尋字體清單檔案:
  • 在 Windows XP 和 Windows Vista 中,在「全部或部分檔名」方塊中輸入「"Adobefnt*.lst"」(包括英文引號),然後按一下「搜尋」。
  • 在 Windows 2000 中,於「指定名稱」方塊中輸入「"Adobefnt*.lst"」(包括英文引號),然後按一下「立即尋找」。
  1. 選取列出的所有檔案,然後選擇「檔案 > 刪除」。(如果您刪除其他 Adobe 應用程式的字體清單檔案,該檔案會在下次啟動 Adobe 應用程式時重新建立。)
  2. 重新啟動 InCopy 或 InDesign。字體清單檔案會在啟動期間重新建立。

在 Mac OS X 上:

  1. 結束所有 Adobe 應用程式。
  2. 選擇「檔案 > 搜尋」,然後執行下列其中一個動作:
  • 在 Mac OS X v10.4.x 中,按一下「電腦」按鈕,並在「檔案名稱」旁的文字欄位中輸入「Adobefnt」,然後按一下 Enter。
  • 在 Mac OS X v10.2.x-v10.3.x 中,從「搜尋範圍」選單中選擇「本機磁碟」,並在「檔案名稱」旁的方塊中輸入「Adobefnt」,然後按一下「搜尋」。
  1. 選取檔案,然後選擇「檔案 > 移至垃圾桶」。
  2. Adobefnt05.lstAdobefnt06.lst 檔案重複步驟 2 至 3。
  3. 重新啟動 InCopy 或 InDesign。字體清單檔案會在啟動期間重新建立。

注意:在 Mac OS 10.5x 中,若找不到 adobefnt.lst 檔案,請在「檔案 > 搜尋」對話框的搜尋條件中加入系統檔案。

  1. 在「種類」快顯視窗選單中選取「其他」,然後等待「選取搜尋屬性」對話框顯示。
  2. 輸入系統。
  3. 從清單中選取「系統檔案」,然後按一下「確定」。
  4. 如果您希望「系統檔案」日後出現在條件中,請亦勾選「在選單中」核取方塊。
  1. 一次列印一頁。

  2. 找出文件中損毀的頁面或連結。

解決方法 17:重新安裝印表機驅動程式

聯絡您的印表機製造商以取得最新版本的印表機驅動程式。如果您使用最新版本的印表機驅動程式,但問題持續發生,請移除驅動程式,然後從原始安裝磁碟或 CD-ROM 重新安裝。

解決方法 18:將文件移至新檔案中

  1. 使用「移動頁面」命令移動頁面
    選擇「版面 > 頁面 > 移動頁面」,或從「頁面」面板選單中選擇「移動頁面」

  2. 指定要移動的一或多頁。

  3. 在「目的地」中,選取移動頁面的目的地,然後視需要指定頁面。 

  4. 按一下「確定」。

其他資訊

此錯誤有幾種可能的原因。重新建立偏好設定檔案可修正最常見的原因,包含以下幾個:

  • 在選取「縮放以符合」的狀態下,於列印至 PostScript 印表機後立即列印至非 PostScript 印表機。
  • 在列印或多工緩衝列印流程期間取消列印工作。
  • 使用損毀的偏好設定檔案進行列印。

其他可能原因包含:

  • 列印包含 OPI 2.0 注釋的 PDF 檔案。
  • 列印的漸層包含來自不同色域的特別色。
  • 列印的已標記文字檔案使用超出範圍的顏色。
  • 未在「選擇器」中選取印表機即進行列印。
  • 選取印表機後,在「選擇器」開啟的情況下進行列印。

在某些情況下,列印檔案的 PDF 版本是一種因應措施。InDesign 1.5 或更新版本不一定會發生此錯誤,因為這些版本包含許多列印強化功能。

嘗試列印 OPI 2.0 注釋時,InDesign 傳回錯誤。當您將在 QuarkXPress 5.x 中建立的 PDF 檔案置入 InDesign 文件時,可能會發生此錯誤。OPI 1.3 注釋不會發生此問題。大多數代理程式不包含 OPI 2.0 注釋。

 Adobe

更快、更輕鬆地獲得協助

新的使用者?

Adobe MAX 2024

Adobe MAX
創意大會

10 月 14 至 16 日邁阿密海灘和線上

Adobe MAX

創意大會

10 月 14 至 16 日邁阿密海灘和線上

Adobe MAX 2024

Adobe MAX
創意大會

10 月 14 至 16 日邁阿密海灘和線上

Adobe MAX

創意大會

10 月 14 至 16 日邁阿密海灘和線上