儘管改善效能一直是 Lightroom 團隊的目標,但新功能與改善功能仍需耗費系統資源。 

已在網路上浮現的效能問題收到諸多不同的建議。Lightroom 團隊想為客戶提供有效的解決方法。此團隊也想要確認您了解任何涉及任一支援解決方法的風險。 

此 TechNote 為針對客戶在社交媒體網站上所述之效能問題,所提出較不傳統的建議清單。此清單將隨著發現解決方法,或解決方法過時而更新。如需更多傳統的解決方法與建議,請參閱此篇 TechNote

重新啟動 Lightroom

重新啟動 Lightroom 以重新整理電腦記憶體,是第一件要嘗試的動作,可緩和許多速度緩慢的操作。

更新至 Lightroom 的最新版本

若要更新 Lightroom,請選擇 Lightroom 中的「說明 > 檢查更新」

在 Lightroom 5.6 中,請減少 Develop 預置數

在 Lightroom 5.6 中,若您已載入無數的 Develop 預置,效能可能會降低。確切的預置數將取決於您的電腦。 Lightroom 以 1000 個預置測試,因此請嘗試將數目減少至約 1000 個,然後查看效能是否因而提高。若此方法有效,請嘗試增加預置數,直至找到適合您電腦的數目為止。

硬體

RAM: 最低需求為 2 GB。但 16 GB 可大幅提升效能,尤其時您同時使用如 Photoshop 等其它應用程式。

SSD 磁碟機: 若您擁有固態硬碟,並將編目 (.lrcat 檔案) 及影像預視 (.lrdata 檔案) 放在 SSD 磁碟機上,Lightroom 會變得更快。

更新視訊驅動程式

更新的顯示驅動程式可修正許多問題,例如當掉、不正確呈現的物件,以及效能問題。

如要在 Windows 7 或 Vista 更新顯示驅動程式,請參閱此 TechNote

在 Mac OS 上,大多數視訊驅動程式更新皆隨著 OS 更新安裝。然而,Nvidia 確實有提供一些驅動程式。有關 Nvidia 視訊卡的資訊,請前往 Nvidia 網站

編目位置

您編目的預設位置為「我的圖片 > Lightroom 資料夾」(Windows) 或「圖片 > Lightroom 資料夾」(Mac OS)。您的影像預視檔案 ([編目名稱 Previews.lrdata]) 與您的編目位於相同位置。您可將編目與預視檔案移至任何位置。然而,若您移動,請確認您會記得編目與預視檔案的名稱及位置。

移動您的編目後,請將 Lightroom 指向其新位置。重新開啟 Lightroom 時,系統會要求您尋找您的編目。請選取「選擇其它編目」:

Lightroom 編目位置

接著會出現「選取編目」對話框。選取編目。若未列出您移動的編目,請選取「選擇其它編目」。然後導覽至所開啟之「Finder」視窗中的新位置。

Lightroom 選擇其它對話框

若下列對話框開啟,請選取「選擇其它編目」,直至 「Finder」視窗開啟。導覽至您目前編目的新位置。

Lightroom 選擇其它對話框

若您一起使用 Photoshop 與 Lightroom,請檢查 Photoshop 的 RAM 設定

請參閱此 TechNote 中的發揮 RAM 與記憶體使用量最大效能章節,來判斷您電腦的最佳 RAM 設定。 若要變更 Photoshop 中的記憶體設定,請選擇「Apple > 偏好設定 > 效能」(Mac OS) 或 「編輯 > 偏好設定 > 效能」(Windows)。

高解析度顯示器

Lightroom 使用整個高解析度顯示器的全部畫面時,在畫面上繪圖會顯得較為緩慢。高解析度顯示器的原生解析度接近 2560 x 1600,可見於 30 吋螢幕和 Retina MacBooks。若要提高此類顯示器的效能,請減少 Lightroom 視窗的尺寸,或使用「導覽器」面板中的 1:2 或 1:3 檢視。

Develop 模組

「污點移除」工具、局部校正及「步驟記錄」面板

「污點移除」工具及「局部校正」筆刷並非針對數百到數千次校正所設計。若您的影像包含許多 (數百次) 局部調整,請考慮使用以像素為基礎的編輯方法 (如 Photoshop) 進行此層級的校正。

若您校正許多次,請查看您的「步驟記錄」面板。 「步驟記錄」面板並無限制,且除非另有規定,否則不會遭到刪除。若您已建立許多局部或污點校正,您的步驟記錄可能會相當冗長,因而拖慢整體 Lightroom 的效能。

請按一下「步驟記錄」面板標題右方的 X,清除「步驟記錄」面板。

Develop 作業順序

提高效能的最佳 Develop 作業順序如下所述:

  1. 污點修復。
  2. 如「鏡頭校正」設定檔及「手動」校正等幾何校正,包括使用「垂直」滑桿的梯形校正。
  3. 非細節的整體校正,如「曝光度」及「白平衡」。必要時,也可先行完成這些校正。
  4. 局部校正,如「漸層濾鏡」及「調整筆刷」筆畫。
  5. 細節校正,如「雜訊消除」及「銳化」。

備註: 先執行污點修復可提高污點修復的準確性,並確保修復的區域邊界符合污點位置。

避免進行非必要的校正

此建議尤其適用於局部校正。您在套用局部校正或漸層濾鏡時變更的每個滑桿,皆會套用至整體校正。而且,每個選項都會耗用資源,影響效能。

套用局部校正及漸層時,請確認您需要已選取的所有校正。

若您無須使用筆刷筆畫或漸層來執行某類型的校正,請將其滑桿設為零。

另請避免運用不必要的整體校正,尤其是耗費資源的選項,如「雜訊消除」、「銳化」及「鏡頭校正」。

某些滑桿的預設值是開啟。若是資源更密集的選項,設為零會停用滑桿。

縮放顯示選項

若「符合」與「填滿」縮放顯示選項變慢,請嘗試使用「導覽器」面板中的「1:2」、「1:3」 或「1:4」選項。

要使用哪個處理版本

處理版本 2012 耗費的資源確實高於處理版本 2010,因此在某些情況下可能會變慢。然而,需在效能增益與處理版本 2012 提供的編輯與影像品質之間求取平衡。

增加 Camera Raw 快取

若您重複在同一組影像上作業,在 Lightroom 的偏好設定中增加 Camera Raw 快取,有助於提高 Develop 模組中的效能。

若要重設 Camera Raw 快取:

  1. 在 Lightroom 中,選取「編輯 > 偏好設定 > 檔案處理」(Windows) 或「Lightroom > 偏好設定 > 檔案處理」(Mac OS)。
  2. 增加 Camera Raw 快取。若您不確定要增加多少,視硬碟空間與您如何使用 Lightroom 而定,請先從 2-3 GB 開始。
  3. 若需要,您也可變更快取位置。

刪除 Lightroom 預置快取。

儘管下列問題鮮少發生,但下列其中一個或多個問題有時會發生,且若真的發生,您可能需要刪除預視快取檔案:

  • 您的硬碟突然滿了。
  • 您在 Lightroom 中出現快取錯誤。
  • 您的影像中出現不自然感—如線條、圓點或非預期的彩色區域。

包含您的縮圖與預視資料的檔案稱為 [編目名稱] Previews.lrdata,與編目一樣位於相同資料夾中。

您的縮圖、小預視及 1:1 (完整尺寸) 預視均保留在此 Previews.lrdata 檔案中。Lightroom 的偏好設定具有何時要刪除最大預視 (1:1 預視) 的選項。刪除 1:1 預視時,Previews.lrdata 檔案大小將會隨之減少。若您未刪除 1:1 預視,預視檔案可以變很大。 

1:1 預視刪除時間的預設設定為 1 週。刪除這些大預視時,雖然預視檔案大小會減少,但除非手動刪除整個檔案,否則不會刪除整個檔案。除非您鮮少或從未刪除 1:1 預視,否則檔案不會變得很巨大,但是否會影響硬碟,則取決於您的可用硬碟空間。您可選擇「編輯 > 編目設定 > 檔案處理」(Windows) 或 「Lightroom > 編目設定 > 檔案處理」(Mac OS),變更刪除 1:1 預視的頻率。

備註: 請勿將在此 TechNote 討論的 Previews.lrdata 檔案與 [編目名稱] Smart Previews.lrdata 檔案 (內含您所有智慧型預視) 搞混。若硬碟空間非常有限,您可能需要刪除此檔案,但若您的硬碟空間不足,而出現硬碟錯誤,您應清空資源回收筒、封存某些檔案,及/或辨識您的資料,以便有更多的硬碟空間可用。

若您刪除 Previews.lrdata 檔案,您在 Lightroom 中開啟的每個資料夾或集合都會重新建立預視,因此首次在資料夾中工作時,您會在重新建立預視時感到些許延遲。

若「自動捨棄 1:1 預視」選項設為「從不」或「30 天後」,您的預視檔案會變得非常大。這會佔用好幾 GB 的空間。若您的硬碟突然滿了,請檢查此檔案的大小。您之後可以刪除檔案。 

您可能會在 Lightroom 中遇到指出快取問題的錯誤;此時是您會想要刪除 previews.lrdata 檔案的時候。

若您的影像有不自然感 (如彩色線條、圓點或非預期的彩色區域),您的預視檔案可能損毀,而唯一修正的方法即是刪除 previews.lrdata 檔案。 

請注意,若您從已封存的影像將影像預視納入編目中,您也會失去這些預視。 

若刪除 Previews.lrdata 檔案無法解決您的問題,請嘗試清除您的 Camera Raw 快取檔案。 

  1. 在 Lightroom 中,選擇「編輯 > 偏好設定 > 檔案處理」(Windows) 或「Lightroom > 偏好設定 > 檔案處理」(Mac OS)。
  2. 按一下「Camera Raw 快取設定」下的「清除快取」

您也可以按一下「選擇」,變更此快取的位置。請注意,此快取僅供 Develop 模組之用。

減少預置數

增加 Lightroom 的預置數 (無論是您或協力廠商建立) 會因 Develop 模組在「導覽器」面板中產生各預置的縮圖,而降低效能。您擁有 2,000 或以上的預置數後,最能感受到此現象。請將載入 Lightroom 預置數減少至您最常用的幾個預置數,以免出現此類型的拖慢現象。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策