本文件描述如何安裝及使用補充的 OpenEXR Alpha 增效模組。

補充的 OpenEXR Alpha 增效模組可在開啟 OpenEXR 檔案時,提供處理「A」色版資料的替代方法。OpenEXR 會將「A」色版資料開啟為 Alpha 色版,而非直接將「A」色版資料轉換成透明度 (如舊版 OpenEXR 增效模組)。

「背景」

Photoshop CS2 通常在 32 位元模式中不支援透明度。在該版本中實施的因應措施讓您可將透明度資料讀取至 Alpha 色版內。在 Photoshop CS3 中,32 位元模式實施透明度支援以確保遵循 OpenEXR 的規格。因此,直接合成色版時,透明度不再讀取至 Alpha 色版中。

開始之前

安裝 OpenEXR Alpha 增效模組需要擁有本機管理權限。如果您使用 Mac OS、Windows Vista 或 Windows 7,作業系統會提示您輸入管理員使用者帳戶的名稱與密碼。如果您使用 Windows XP,請在開始之前使用本機管理員帳戶登入電腦。

Windows 使用者: 此技術文件中的某些步驟會以完整檔名列出檔案,即包含副檔名 (例如 OpenEXR Alpha.8bi)。在 Windows 上,已知檔案類型的副檔名預設為不可見。如要顯示副檔名,請採取以下步驟:

  1. 在 Windows 檔案總管中,選擇「工具 > 資料夾選項 (Windows XP)」或「組合管理 > 資料夾和搜尋選項 (Windows 7 和 Vista)」。
  2. 選取「資料夾選項」視窗上方的「檢視」索引標籤。
  3. 在「檢視」索引標籤的「進階設定」部分中,取消選取「隱藏已知檔案類型的副檔名」。
  4. 按一下「確定」。

Windows 使用者: 此文件中的某些步驟需要您確認使用的 Windows 為 32 位元或 64 位元版本。如要判斷您使用的系統類型,請查看 判斷電腦是否運作 32 位元或 64 位元版本 Windows

相容性

在 Windows 上,OpenEXR Alpha 增效模組不相容於比 Photoshop CS5 更早的 Photoshop 版本。Photoshop CS3 或 CS4 無法載入該增效模組。

在 Mac OS 上,OpenEXR Alpha 增效模組無法在 PPC 電腦上載入。

在 Mac 或 Windows 上安裝 Photoshop CS5 的 OpenEXR Alpha 增效模組 (從 Adobe 網站下載更新)

若要從 Adobe 網站下載更新以安裝 OpenEXR Alpha 增效模組:

  1. 下載壓縮的增效模組:

  2. 結束 Photoshop CS5。
  3. 解壓縮已下載的檔案。
  4. 將增效模組拖曳到 Photoshop 的 Plug-ins 資料夾中。
    • Windows 32 位元: 將 OpenEXR Alpha.8bi 從 Win32 資料夾拖曳到 /Program Files/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats 資料夾中。
    • Windows 64 位元/Photoshop 64 位元: 將 OpenEXR Alpha.8bi 從 Win64 資料夾拖曳到 /Program Files/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats 資料夾中。
    • Windows 64 位元/Photoshop 32 位元: 將 OpenEXR Alpha.8bi 從 Win32 資料夾拖曳到 /Program Files/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats 資料夾中。
    • Mac OS: 將 OpenEXR 增效模組拖曳到 /Applications/Adobe Photoshop CS5/Plug-ins/File Formats 資料夾中。
  5. 啟動 Photoshop CS5。

使用 OpenEXR Alpha 增效模組

若要開啟 EXR 檔案:

  1. 啟動 Photoshop CS5。
  2. 選擇「檔案 > 開啟」。
  3. 瀏覽至欲開啟的 EXR 檔案。在檔案格式清單中,選擇 OpenEXR Alpha。Photoshop 會將「A」色版資料當作 Alpha 色版處理,而非透明度。

若要轉存 EXR 檔案:

  1. 選擇「檔案 > 另存新檔」。
  2. 在檔案格式清單中,選擇 OpenEXR Alpha。

  3. 選取「儲存: Alpha 色版」選項。此設定將會儲存 Alpha 色版資料。

注意: 開啟檔案後新增的透明度將會平面化。

注意: 安裝 OpenEXR Alpha 增效模組後,您仍會有在檔案格式清單中選擇舊版 OpenEXR 的選項。此增效模組仍會將「A」色版的資料當作透明度處理。這從 Photoshop CS3 (版本 10.0) 起即是預設行為。

其他注意事項

使用補充增效模組應注意的其它行為:

  • 不支援預乘組合。
  • 如果您按兩次以開啟檔案,Photoshop CS5 總是使用 OpenEXR Alpha 而非 OpenEXR。
  • 如果您開啟包含兩個或更多 Alpha 色版的檔案,OpenEXR Alpha 將不會保存任何 Alpha 色版。這些 Alpha 色版都會被完全捨棄。
  • (Mac OS): 在「儲存」對話框中,OpenEXR Alpha 是最上方的項目。它不會按照字母顯示於 Open EXR 旁邊。
  • (Windows): 若要取得舊版 OpenEXR 的行為,選擇「檔案 > 開啟為」,然後選取 OpenEXR。
     

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策