Az Ubuntu 10.x és 11.x Linux OS felhasználók néha üres vagy fekete képernyőt láthatnak, ha Flash Player 11 alkalmazással védett videotartalmat játszanak le. (például ez a probléma olyan szolgáltatásoknál jelentkezik, mint az Amazon Instant Video.) Ezt a viselkedést a hiányzó Ubuntu HAL (Hardware Abstraction Layer, hardverabsztrakciós réteg) modul okozza, amely alapértelmezésként nincs telepítve. Ha a szállító hibaüzeneteknek tesz ki, a felhasználók 3323-as vagy 3322-es DRM hibát láthatnak.

Előfeltételek védett tartalom lejátszásához

Az Ubuntu 10.04 vagy újabb verziói esetében előbb telepítse a Hardware Abstraction Layer modult apt-get használatával.
(gondosan ügyeljen a “hal” telepítési hibákra, mivel sérült csomag telepítése továbbra is befolyásolhatja a videolejátszást.)

hal sudo apt-get telepítése

Miután a "libhal" (HAL) könyvtár telepítése befejeződött, zárja be a böngészőt és törölje az Adobe Access könyvtárakat a következő felületparancsok végrehajtásával:

cd ~/.adobe/Flash_Player
rm -rf NativeCache AssetCache APSPrivateData2

Megjegyzés:

Ha a Hardverabsztrakciós réteg modul hiányzik, a Flash Player még mindig működik. Azonban ez nem játszhat le védett tartalmat, amelyhez az Adobe Flash Access DRM (Digital Rights Management, digitális jogkezelés) modul szükséges.

Támogatja a Linux használni kívánt 64-bites verzióit

Az Adobe a platform támogatást a 32-bites és 64-bites Linux verzióhoz a Flash Player 11 weboldalának rendszerkövetelmények részén teszi közzé. A jelenleg támogatott forgalmazott verziók (32 bites és 64 bites verzió) a Redhat Enterprise Linux 5.6 vagy újabb verzió és az Ubuntu 10.04 vagy újabb verzió.

Az openSuse is támogatott.

Telepítse a helyes 32-bites vagy 64-bites Flash Player bővítményt

Látogasson ide: http://www.adobe.com/go/flashplayer a legújabb Flash Player telepítésére az Ön platformjára és architektúrájára.

Ha nem biztos benne, hogy melyik Linux csomagot telepítse, kattintson ide: Más operációs rendszere vagy böngészője van?  további operációs rendszer lehetőségekért.

openSuse és egyéb Linux verziók

Néhány forgalmazott Linux verzió saját kezelőcsomaggal rendelkezik, főleg az openSUSE. Az openSUSE natív csomagformátuma az RPM. Azonban megvan a saját magas szintű eszköze a rendszer szoftver telepítésének kezeléséhez. 
Az .rpm telepítések az openSuse (32 bites és 64 bites verzió) rendszerre szeszélyesek. Ezek néha a következő általános hibát idézik elő "Az üzenetre nem érkezett válasz (üzenetsín időtúllépése)".

Ezekben az esetekben töltse le helyette a .tar.gz archívumot és helyezze erre a helyre a Flash Player (libflashplayer.so) alkalmazást:

/usr/lib/adobe-flashplugin/libflashplayer.so

Próbálja meg lejátszani a védett videotartalmat a demo lejátszóval

  1. Indítsa el az Adobe demo videolejátszó tárolót: http://drmtest2.adobe.com:8080/SVP/SampleVideoPlayer_FP.html
     
      Jegyezze fel az Adobe Flash Player verziót demo videofelület bal alsó részébe. Győződjön meg, hogy 11.2-t vagy újabb verziót mutat
       
  2. Játssza le a védett mintatartalmat.
     
      Gépelje be a következő URL-t a „Videó URL megadása: (kis- és nagybetű megkülönböztetése) mezőbe
      http://drmtest2.adobe.com:8080/Content/anonymous.f4v
       
  3. Kattintson a videotároló alján lévő [Lejátszás] gombra.

Az anonymous.f4v védett tartalmat játssza le. (a videó címe Getty "train" videó.)

 

Érintett termékek

Adobe Flash Player 11, Flash Access (FAXS), Ubuntu 10.x & 11.x Linux

Ez a munka a Creative Commons Nevezd meg!-Ne add el!-Így add tovább! 3.0 Unported licenc alatt lett közzétéve.  A Twitter™ és Facebook közzétételeket a Creative Commons jogi feltételei nem szabályozzák.

Jogi közlemények   |   Online adatvédelmi nyilatkozat