A Struktúramező – áttekintés

A Struktúramezőben hierarchikus alakban jelennek meg a dokumentum XML-címkékkel megjelölt egyes részei. Ezeket a részeket elemeknek nevezzük. Az elemek át is helyezhetők a Struktúramezőben, így meghatározható az említett részek szükséges sorrendje és hierarchiája. Az elemek az elemtípust jelölő ikonból és egy címkenévből állnak.

vb_30
Structure pane

A. Triangle to expand or collapse elements B. Element C. Text snippet D. Attribute 
vb_30_IC
Structure pane

A. Triangle to expand or collapse elements B. Element C. Text snippet D. Attribute 

Az elemek továbbá az alábbi információt is hordozhatják:

Kék rombusz

Az elemikonon megjelenő kék rombusz azt jelzi, hogy az elem az oldalon lévő valamely részhez kapcsolódik; ha nem látható a kék rombusz, az elemet nem rendelték oldalrészhez.

Aláhúzott

A címke neve akkor van aláhúzva, ha az elem oldalrésze ki van jelölve. Ha kijelöli például a Cím címkével megjelölt szöveget, a szöveg elemének Cím szava lesz aláhúzva a Struktúramezőben. Az aláhúzással jól azonosítható, hogy az oldal kijelölt részei és a Struktúramezőben felsorolt elemek megfelelnek-e egymásnak.

Szövegrész

A címkézett szöveg első 32 karaktere (a szövegrész) megjeleníthető az elem jobb oldalán. Ezek a szövegrészek segítenek azonosítani azt az oldalrészt, amelyhez az adott elem tartozik.

Pont és attribútum

Az attribútumok metaadatokat szolgáltatnak a szóban forgó elemről. Ha egy elemhez attribútumokat rendeltek, az elem fölött egy fekete pont, valamint az ahhoz tartozó attribútumnevek és értékek jelennek meg.

A Struktúramező használata

  • A Struktúramező megnyitásához válassza a Nézet menü Struktúra almenüjének Struktúra megjelenítése parancsát.
  • A mező bezárásához válassza a Nézet menü Struktúra almenüjének Struktúra elrejtése parancsát, vagy kattintson a Struktúra elrejtése gombra.
  • Az elemek kibontásához vagy összecsukásához (és gyermekelemeik megjelenítéséhez vagy elrejtéséhez) kattintson a mellettük lévő háromszögikonra.
  • A Struktúramező méretét az osztóvonal húzásával változtathatja meg.
  • Egy adott elem és az abban lévő összes gyermekelem kibontásához vagy összecsukásához a háromszögikonra kattintás közben tartsa lenyomva a CTRL (Windows) vagy a COMMAND (Macintosh) billentyűt.
  • A szövegrészek megjelenítéséhez vagy elrejtéséhez kattintson a Struktúramező menüjének Szövegrészek megjelenítése vagy Szövegrészek elrejtése parancsára.

A Struktúramező ikonjai

A Struktúramezőben látható ikonokat az alábbi táblázat foglalja össze.

Ikon

Név

Használat

 

Gyökérelem

Valamennyi dokumentum rendelkezik egy gyökérelemmel a struktúra tetején; a gyökérelem átnevezhető, de nem helyezhető át és nem törölhető.

 

Szövegegységelem

A címkézett szövegegységeket (legalább egy csatolt keretet) jelöli.

 

Szövegelem

Az adott keretben lévő címkézett szöveget jelöli.

 

Grafikaelem

Elhelyezett képet tartalmazó címkézett keretet jelöl. Minden egyes grafikaelem rendelkezik egy href attribútummal, amely definiálja a csatolt fájl elérési útvonalát vagy URL-címét.

 

El nem helyezett szövegelem

Oldalrészhez még hozzá nem rendelt, el nem helyezett szövegelem.

 

El nem helyezett grafikaelem

Oldalrészhez még hozzá nem rendelt, el nem helyezett grafikaelem.

 

Táblázatelem

Táblázatot jelölő elem.

 

Fejléccellaelem

A táblázat fejlécsorában lévő valamely cellát jelöli.

 

Törzscellaelem

A táblázat törzsében található valamely cellát jelöli.

 

Lábléccellaelem

A táblázat láblécsorában elhelyezkedő valamely cellát jelöli.

 

Üres elem

Ehhez az elemhez üres keret van hozzárendelve.

 

Jellemző

Metaadatokat tartalmaz, például kulcsszavakat vagy egy csatolt kép helyét (HREF attribútum).

 

Megjegyzés

Az XML-fájlban megjelenő megjegyzéseket tartalmazza, az InDesign-dokumentumbeli megjegyzéseket azonban nem.

 

Feldolgozási utasítás

Az ilyen utasításokat olvasni képes alkalmazásokban felhasználható műveletet kiváltó utasítást tartalmaz.

 

DOCTYPE elem

Azt közli az InDesign programmal, hogy melyik DTD-fájlt kell használni az XML-fájl érvényesítésekor.

Strukturált elemek átrendezése

A Struktúramezőben megváltoztatható az elemek sorrendje és hierarchiai besorolása. Mindamellett a következő szabályokat szem előtt kell tartani:

  • Minden egyes XML-dokumentum a struktúra tetején elhelyezkedő gyökérelemmel kell, hogy rendelkezzen. Ez a gyökérelem a szülőeleme az összes többi elemnek, tehát alatta helyezkedik el valamennyi alárendelt elem. A Struktúramezőben a gyökérelem fölött csak a DTD-fájl (DOCTYPE elemként), a megjegyzések és a feldolgozási utasítások helyezkedhetnek el.

  • Az XML hierarchiai felépítésének módosítása befolyásolhatja a címkézett elemek megjelenését az InCopy oldalain. Ha egy szövegelemet például a struktúra egy másik helyén lévő elem gyermekelemévé tesz, a szöveg az elrendezésben is máshová kerül.

  • Táblázatcella-elem nem húzható táblázatelembe, és ez utóbbiba egyéb elemek sem helyezhetők.

  1. Hajtsa végre az alábbi műveletek egyikét a Struktúramezőben:
    • Elem áthelyezéséhez húzza azt új helyére a struktúrán belül. Húzás közben egy vonal jelzi, hogy hova kerül az elem. A vonal vastagsága a hierarchián belüli szintet is szemlélteti.

    • Ha egy elemet egy másik elem gyermekelemévé szeretne tenni, vigye a szülőelem fölé annak kiemeléséhez, vagy helyezze a szülőelem többi gyermekeleme közé, és engedje fel az egérgombot.

    • Ha egy szinttel lejjebb szeretne sorolni egy elemet a hierarchiában, húzza egy másik szülőelem fölé, majd egy kissé balra, amíg a helyét jelző vonal vastagsága meg nem egyezik a szülőelemével.

    • Elem másolásához vagy kivágásához jelölje ki az eleme(ke)t a Struktúramezőben, és kattintson a Szerkesztés menü Másolás vagy Kivágás parancsára. Jelölje ki az elem célhelye fölötti elemet, és válassza a Szerkesztés menü Beillesztés parancsát.

Megjegyzés:

Elem kivágásakor az elem és annak tartalma a vágólapra kerül, a keret azonban a helyén marad.

Szülőelem beszúrása

A Struktúramező használatával beszúrt szülőelem révén megőrizhető a helyes XML-struktúra és hatékonyabban rendezhető a tartalom. Új szülőelem beszúrása előtt ki kell jelölnie azokat az elemeket, amelyek az új szülőelem gyermekelemei lesznek. Az új szülőelem beszúrásakor a kijelölt gyermekelemek egy szinttel lejjebb kerülnek a struktúrahierarchiában.

vp_structure_ID
With child elements selected (left); a newly inserted parent element includes the child elements (right).
vb_structure_IC
With child elements selected (left); a newly inserted parent element includes the child elements (right).
  1. Jelölje ki a Struktúramezőben azokat az elemeket, amelyek az újonnan beszúrandó szülőelem gyermekelemei lesznek. Ne feledkezzen el a következőkről:

    • A gyökérelemet és a gyökérszinten lévő elemeket nem lehet kijelölni.

    • A szövegegységelem és az annak szintjén lévő elemek nem jelölhetők ki.

    • Az elemeknek a struktúrahierarchia ugyanazon szintjén kell elhelyezkedniük.

    • Az elemek csak egymással szomszédosak lehetnek.

    • A kijelölt rész nem tartalmazhat táblázatcellákat és attribútumokat.

  2. Kattintson a Struktúramező menüjének Új szülőelem parancsára. Ugyanezt érheti el, ha a jobb gombbal (Windows) vagy a Control (Mac OS) billentyűt lenyomva tartva kattint, és az Új szülőelem lehetőséget választja.

  3. Válasszon címkét az új szülőelemhez, majd kattintson az OK gombra.

Megjegyzés:

Új szülőelemet úgy szúrhat be gyorsan, hogy a Címkék panelen bejelöli a Címke hozzáadása választógombot, és a panelen látható valamelyik címkére kattint. Ugyanez az eredmény, ha a jobb gombbal (Windows) vagy a Control billentyűt lenyomva tartva (Mac OS) kattint a Struktúramezőben kijelölt valamely elemre, a helyi menü Új szülőelem lehetőségét választja, majd megadja a használandó elemet.

Műveletek attribútumokkal

Az attribútumok további információt nyújtanak az XML-elemekről. Minden egyes attribútum egy névből és egy értékből tevődik össze. A Struktúramező az attribútumokat is megjeleníti, noha a dokumentumban nem lesznek láthatók, és dokumentumtartalom sem lesz belőlük. Mellékeljen attribútumokat az elemekhez, hogy az InCopy szoftverrel létrehozott XML-fájlokat később feldolgozó alkalmazások és fájlok használhassák azokat.

Kép címkézésekor az InDesign automatikusan egy href attribútumot hoz létre egy olyan értékkel, amely meghatározza a képfájl merevlemezen elfoglalt helyét. Ez a href attribútum lehetővé teszi az egyéb fájloknak és alkalmazásoknak, hogy megkeressék a képet a lemezen, majd megjelenítsék.

vb_31
An attribute includes a name (href, in this case) and a value.

Attribútumok a DOCTYPE elem (azaz egy DTD-fájl), a megjegyzések és a feldolgozási utasítások kivételével bármely elemhez hozzáadhatók. Ha például egy korábbi alkalmazásban végzett kereséshez szeretne kulcsszavakat felvenni, létrehozhat egy kulcsszavak nevű attribútumot. Attribútumok létrehozhatók a helyettesített szöveg jelzéséhez, a cikkcímek nyomon követéséhez, de akár a tartalomhoz kapcsolódó egyéb információ rögzítéséhez is.

Megjegyzés:

DTD-fájl használata esetén tanulmányozza annak tartalmát, és látni fogja, hogy mely attribútumok használatát teszi lehetővé. Az attribútumneveknek a címkenevekhez hasonlóan meg kell felelniük a DTD-nevezéktanra vonatkozó előírásoknak.

Megjegyzés:

Az InCopy felismeri a speciális névtérattribútumokat, amelyek bekezdés- vagy karakterstílusokat, táblázatokat és cellastílusokat, valamint szóközöket határozhatnak meg. További információkért tekintse át az XML technikai referenciainformációkat és a további anyagokat: www.adobe.com/go/learn_id_XMLscript_hu.

Jellemző hozzáadása

  1. Jelöljön ki egy elemet.
  2. Tegye a következők egyikét:
    • Kattintson az Attribútum hozzáadása gombra .

    • Kattintson a Struktúramező menüjének Új attribútum parancsára.

    • Kattintson a jobb gombbal (Windows) vagy a Control billentyűt lenyomva tartva (Mac OS) a kijelölt elemre, és válassza az Új attribútum parancsot.

  3. Írja be az attribútum nevét és értékét, majd kattintson az OK gombra.

Attribútumok megjelenítése vagy elrejtése a Struktúramezőben

  1. Kattintson a Struktúramező menüjének Attribútumok megjelenítése vagy Attribútumok elrejtése parancsára.

    Előfordulhat, hogy a szóban forgó elem attribútumainak megjelenítéséhez a háromszögikonra kell kattintania.

Attribútum szerkesztése vagy törlése

  1. Jelöljön ki egy attribútumot a Struktúramezőben.
  2. Tegye a következők egyikét:
    • Az attribútum szerkesztéséhez kattintson duplán rá, vagy kattintson a Struktúramező menüjének Szerkesztés parancsára.

    • Az attribútum törléséhez kattintson a szemeteskukát ábrázoló gombra, vagy válassza a Struktúramező menüjének Törlés parancsát.

href attribútumok szerkesztése

Az InCopy a képfájlok kezeléséhez automatikusan href attribútumokat hoz létre. A href attribútum meghatározza a képfájl merevlemezen elfoglalt helyét, így a kép könnyen megjeleníthető. Ha elhelyezett képet címkéz meg, az InCopy egy href attribútumértéket hoz létre, amely tartalmazza a kép útvonalát és fájlnevét.

Az elérési út lehet abszolút hivatkozás, az XML-fájlt tartalmazó mappával megegyező mappára mutató relatív hivatkozás, de az XML-fájlt tároló mappa Images almappájára mutató relatív hivatkozás is. A relatív elérési utak arra az elérési útra vonatkoznak, amely a dokumentum mentési helyét adja meg.

  • Az abszolút hivatkozással ellátott href attribútumok a következőképpen jelennek meg (Windows és Macintosh rendszerben egyaránt):

    href=file:///C:/Tervek/Marketing.psd

    href=file:///Adatok/hazai//Asztal/abc.jpg

  • Az XML-fájlt is tároló mappában lévő képfájlra mutató href attribútum így jelenik meg:

    href=file:Marketing.psd

  • Az Images almappában található képfájlra mutató href attribútum így néz ki:

    href=file:///Tervek/Marketing.psd

A href attribútum szerkesztésével a képre mutató új hivatkozás határozható meg. Egy abszolút hivatkozás például szerkesztéssel relatívvá tehető, ezáltal a képfájl elérhetővé válik a fájl exportálásakor.

  1. Kattintson a Struktúramezőben duplán a href attribútumra. (Elképzelhető, hogy az attribútum megjelenítéséhez a képelem melletti háromszögikonra kell kattintania.)
  2. Az Érték mezőben adja meg a kép új elérési útvonalát, majd kattintson az OK gombra.

Megjegyzések és feldolgozási utasítások hozzáadása

Az InCopy segítségével megjegyzéseket és feldolgozási utasításokat illeszthet az XML-fájlokba. A szóban forgó elem leírásának megadásához írjon be egy megjegyzést. A megjegyzések webböngészővel és szövegszerkesztő alkalmazásokkal egyaránt megtekinthetők: alkalmazásukkal mások is megérthetik az XML-struktúrát és az XML-címkék használatát. A feldolgozási utasítás tulajdonképpen egy különleges alkalmazásspecifikus parancs. Beírhat például egy oldaltörést elvégző feldolgozási utasítást, hogy az XML-fájl exportálásának célalkalmazása felismerje, hogy hol kell elhelyezni az oldaltörést. Az InCopy felhasználó által létrehozott feldolgozási utasításai más programok általi felhasználásra szolgálnak, maga az InCopy nem veszi figyelembe őket.

A megjegyzések és a feldolgozási utasítások a Struktúramezőben jelennek meg, és a mezőben lévő többi elemhez hasonlóan ugyanúgy áthelyezhetők, szerkeszthetők és törölhetők. Gyermekelemeket és attribútumokat azonban nem tartalmazhatnak.

vb_36
InDesign Structure pane with text snippets showing

A. Processing instruction B. Comment 

Megjegyzés hozzáadása

  1. Jelölje ki a megjegyzéssel ellátni kívánt elemet.

    Megjegyzés:

    Ha táblázathoz szeretne megjegyzést adni, jelöljön ki egy táblázatcella-elemet. Megjegyzéseket nem adhat táblázathoz, csak táblázatcellákhoz.

  2. Kattintson a Struktúramező menüjének Új megjegyzés parancsára.
  3. Írja be a megjegyzést a megjelenő párbeszédpanelen.

Feldolgozási utasítás hozzáadása

  1. Jelöljön ki egy elemet a feldolgozási utasításhoz.

    Megjegyzés:

    Ha táblázathoz szeretne feldolgozási utasítást adni, jelöljön ki egy táblázatcella-elemet. Feldolgozási utasításokat nem adhat táblázathoz, csak táblázatcellákhoz.

  2. Kattintson a Struktúramező menüjének Új feldolgozási utasítás parancsára.
  3. A Cél mezőbe írja be az utasítást azonosító nevet, amelyet majd az XML-fájlokat olvasó másik alkalmazás értelmezhet.
  4. Az Adatok mezőbe írja be azt az értéket, amely közli az alkalmazással, hogy mi a teendője a feldolgozási utasítással kapcsolatban.

Megjegyzések és feldolgozási utasítások megtekintése

  1. Kattintson a Struktúramező menüjének Megjegyzések megjelenítése vagy Feldolgozási utasítások megjelenítése parancsára.

Megjegyzések és feldolgozási utasítások szerkesztése

  1. Jelölje ki a megjegyzést vagy a feldolgozási utasítást.
  2. Végezze el a következő műveletek valamelyikét:
    • Kattintson duplán a megjegyzésre vagy a feldolgozási utasításra.

    • Kattintson a Struktúramező menüjének Szerkesztés parancsára.

  3. Módosítsa a megjegyzést vagy a feldolgozási utasítást, és kattintson az OK gombra.

XML érvényesítése DTD-fájlokkal

A dokumentumban található XML érvényesítése azt jelenti, hogy a program összeveti a struktúrát, az elemek címkenevét és az attribútumokat a DTD-fájlban meghatározott jellemzőkkel. A DTD-fájllal végrehajtandó érvényesítéshez először be kell tölteni a fájlt az InDesign-dokumentumba.

Megjegyzés:

A DTD-fájl betöltésével együtt a címkenevek is betöltődnek a Címkék panelre. Az importált címkenevek zároltak, tehát nem törölhetők és nem nevezhetők át, csak úgy, ha a DTD-fájlt is törli a dokumentumból.

Ha a dokumentum betöltött DTD-fájlt tartalmaz, a DOCTYPE elem a Struktúramező tetején jelenik meg. (XML-fájl importálásakor a DTD-fájlok néha automatikusan betöltődnek.) A dokumentumban lévő DTD-fájl felülírásához törölje a már meglévő DTD-fájlt, és töltsön be egy újat.

vb_05
Working with DTD files in InDesign

A. DOCTYPE element from the DTD file (Structure pane) B. Locked tag from the DTD file (Tags panel) 

DTD-fájl betöltése

DTD-fájl betöltésekor az InDesign beágyazza azt a dokumentumba.

  1. Tegye a következők egyikét:
    • Kattintson a Struktúramező panelmenüjének DTD betöltése parancsára.

    • Kattintson a Címkék panelen a panelmenü DTD betöltése parancsára.

  2. Jelölje ki az importálandó DTD-fájlt, és kattintson a Megnyitás gombra.

    Megjegyzés:

    A DTD fájlban meghatározott címkék megtekintéséhez nyissa meg a Címkék panelt az Ablak > Segédeszközök > Címkék menüelemmel.

DTD-fájl megtekintése

A DTD-fájlok ASCII formátumú szövegfájlok, amelyek a címkék alkalmazását és az elemek helyes rendezését ismertető beágyazott utasításokat és magyarázatokat tartalmazhatnak. Az InDesign csak a dokumentumba betöltött DTD-fájl megtekintését teszi lehetővé.

vb_14
DTD file opened for viewing
  1. Tegye a következők egyikét:
    • Kattintson a Struktúramező menüjének DTD megtekintése parancsára.

    • Kattintson duplán a Struktúramezőben látható DOCTYPE elemre.

    Megjegyzés:

    DTD-fájl kinyomtatásához másolja a kódot a vágólapra a DTD megtekintése ablakból, és illessze be egy szövegszerkesztőben megnyitott fájlba.

DTD-fájl törlése

  1. Kattintson a Struktúramező menüjének DTD törlése parancsára.

    Az InDesign törli a DTD-fájl InDesign-dokumentumban tárolt példányát, ez eredeti DTD-fájlt azonban érintetlenül hagyja. A DTD-fájllal együtt importált címkék továbbra is elérhetőek maradnak a Címkék panelen, de a program feloldja a zárolásukat.

XML-struktúra érvényesítése

Mikor dokumentumot érvényesít, az InCopy figyelmezteti, ha az XML eltér a DTD-fájlban szereplő szabályoktól, és módszereket javasol az XML-tartalom DTD-fájlban foglaltaknak megfelelő állapotba hozásához. A hibák javíthatók egyesével, de egy külön ablakban megjeleníthető az összes hiba egyszerre is.

vb_06
Structure pane with Suggestions pane

A. Loaded DTD B. Error or invalidating condition C. Description of error with suggested fix D. Error count E. Validate button F. View all errors in a separate window 
ch_08
Structure pane with Suggestions section

A. DOCTYPE element from assigned DTD file B. Error or invalidating condition C. Description of error with suggested fixes D. Error count E. Validate button F. View all errors at once in a separate window 
  1. Kattintson a Nézet menü Struktúra almenüjének Struktúra megjelenítése parancsára.
  2. Kattintson a Struktúramező Érvényesítés gombjára .

    Megjegyzés:

    Ha másik gyökérelemet szeretne megadni az érvényesítés forrásául, kattintson a Struktúramező menüjének DTD-beállítások parancsára.

  3. A javaslatokat tartalmazó panelen látható hibák javításához kattintson valamelyik javasolt javításra, vagy módosítsa az XML-struktúrát és a címkéket közvetlenül a Struktúramezőben vagy a Címkék panelen.
  4. Az egyéb hibák megtekintéséhez a következőket teheti:
    • Kattintson a balra mutató nyílra  vagy a jobbra mutató nyílra .

    • Az összes hiba külön ablakban történő megjelenítéséhez kattintson a hibákat összegző ablakot megnyitó gombra .

    • Kattintson a Struktúramező menüjének Hibalista megtekintése parancsára.

Megjegyzés:

Az InCopy leállítja az érvényesítést, ha 250 hibát észlel. Ha a hibák száma eléri ezt az értéket, egy pluszjel jelenik meg a hibák számát mutató mezőben.

Ez a munka a Creative Commons Nevezd meg!-Ne add el!-Így add tovább! 3.0 Unported licenc alatt lett közzétéve.  A Twitter™ és Facebook közzétételeket a Creative Commons jogi feltételei nem szabályozzák.

Jogi közlemények   |   Online adatvédelmi nyilatkozat