Issue
When configuring Adobe Target within AEM and entering the email ID & password associated with the Target account, an error is observed "Connection failed for following reasons".
Environment
- Target Classic
- Target Standard/Premium
Cause
For the Target and AEM integration, the credentials of a user provided from Target Standard/Premium do not work.
Resolution
A user name and password of the user that exists in the Target classic back end is required. Contact Target support at customercare@adobe.com if no user exists.
Additional information
The way the integration works requires the Target classic back-end credentials. Even though you are on Target premium, it still connects to Classic. The engineering/product teams are working on updating to the new APIs - but there is no date for it. Until this fix, the integration works as usual.