UTF-8 characters returned from Search and Promote show garbled characters

When using Search and Promote integration with AEM, certain UTF-8 characters are returned in results (superscript, subscript, etc) as garbled characters.

Cause

The cause could be that the template for the Search and Promote results isn't configured properly to support UTF-8 encoding.

Resolution

  1. In your browser, go to https://searchandpromote.omniture.com and log in.

  2. Go to Design => Templates

  3. Edit author.tmpl (Staged) file in Search and Promote 

    <guided-content-type-header content="text/xml; charset=utf-8" />

    Note:

    You can make this same change to other used templates.

  4. Push the changes live by following this documentation.

 Adobe

Get help faster and easier

New user?

Adobe MAX 2024

Adobe MAX
The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX

The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX 2024

Adobe MAX
The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX

The Creativity Conference

Oct 14–16 Miami Beach and online