After installing Oak 1.4.10 LDAP sync no longer works | AEM 6.2, Oak

Issue

If you are using LDAP integration with AEM then after applying Oak 1.4.10 or 1.4.11 LDAP user and group synchronization no longer works. The user can log in to AEM, but when they do all the synchronized properties are removed from the profile.

Environment

AEM 6.2

Cause

This is a regression bug of OAK-4344.

Resolution

To fix the issue, do the following:

  1. Go to http://host:port/system/console/configMgr and log in as admin.

  2. Search for LdapIdentityProvider.

  3. Click Edit (pencil icon) to the right of the configuration item.

  4. In the bottom of the configuration dialog, you will see Custom Attributes.

  5. In that field add (using the + button) all LDAP attributes being synchronized to the users and groups. For example, these properties might be: cn, sn, givenName, mail.

  6. Click Save.

Note:

If you don't know which LDAP properties you are using then you can refer to your Default Sync Handler configuration.  Search for DefaultSyncHandler in the http://host:port/system/console/configMgr UI. The sync'ed attributes would be listed after the = in each entry of User property mapping and Group property mapping. Only the attributes that are not wrapped with quotation marks (") are the LDAP attributes.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy