אודות לחצנים

לחצנים משויכים בדרך כלל לטפסים, אך ניתן להוסיפם לכל מסמך. לחצנים יכולים לפתוח קובץ, להשמיע קובץ קול או להקרין סרטון, למסור נתונים לשרת אינטרנט ועוד. כשמחליטים כיצד ליזום פעולה, יש לזכור כי לחצנים מציעים את היכולות הבאות, שסימניות וקישורים אינם יכולים להציע:

  • לחצן יכול להפעיל פעולה בודדת או סדרה של פעולות.

  • לחצן יכול לשנות מראה בתגובה לפעולות עכבר.

  • ניתן להעתיק לחצן בקלות לעמודים רבים.

  • פעולות עכבר יכולות להפעיל לחצנים שונים. לדוגמה, Mouse Down (לחיצה), Mouse Up (שחרור לאחר לחיצה), Mouse Enter (הזזת המצביע מעל הלחצן) ו- Mouse Exit (הזזת המצביע הרחק מהלחצן) יכולות להפעיל פעולה שונה עבור אותו לחצן.

    לחצנים מאפשרים למשתמשים ליזום פעולה במסמכי PDF בצורה קלה ואינטואיטיבית. ניתן ליצור שילוב של תוויות וסמלים בלחצנים שינחו את המשתמש במהלך סדרת פעולות או אירועים, וישתנו בהתאם לתנועת העכבר. לדוגמה, ניתן ליצור לחצנים עם התוויות והסמלים "הפעלה", "השהיה" ו"עצירה". לאחר מכן, ניתן להגדיר ללחצנים אלה פעולות כך שהם יפעילו , ישהו ויעצרו הפעלה של קובץ מולטימדיה.. ניתן לבחור כל שילוב של התנהגויות עכבר ללחצן, ולציין כל שילוב של פעולות להתנהגות של העכבר.

הוספת לחצן לטופס PDF של Acrobat

  1. ודאו שאתם במצב עריכה על-ידי בחירת Tools‏ > Forms‏ > Edit ולאחר מכן בחרו Button מהרשימה Add New Field. הסמן משנה את צורתו לצורת צלב דק.
  2. לחצו בעמוד במקום שברצונכם להוסיף בו את הלחצן כדי ליצור לחצן בגודל ברירת המחדל. ללחצן בגודל מותאם אישית, גררו מלבן לסימון גודל הלחצן.
  3. לחצו פעמיים על שדה הלחצן וציינו שם, מלל לעצת הכלי ומאפיינים נפוצים אחרים.
  4. לחצו על הכרטיסייה Appearance וציינו אפשרויות כדי לקבוע את מראה הלחצן בעמוד. זכרו: אם תבחרו צבע רקע, לא תוכלו לראות את התמונות שמאחורי הלחצן. אפשרויות המלל משפיעות על התווית שתציינו בכרטיסייה Options, ולא על שם הלחצן בכרטיסייה General.

    הערה:

    אם בוחרים באפשרות Enable Right-To-Left Language Options בחלונית International בתיבת הדו-שיח Preferences, הכרטיסייה Appearance תכלול אפשרויות לשינוי סגנון הספרות וכיוון המלל בלחצנים.

  5. לחצו על הכרטיסייה Options, ובחרו באפשרויות שיקבעו את אופן הצגת הסמלים והתוויות בלחצן.
  6. לחצו על הכרטיסייה Actions, וציינו אפשרויות שיקבעו מה יתבצע בלחיצה על הלחצן, כגון מעבר לעמוד אחר או הפעלת קובץ מולטימדיה.
  7. לחצו על Close.

    הערה:

    בשעת יצירת סדרת לחצנים, ניתן להצמיד את העצם לקווי רשת או לקווי עזר.

הוספת לחצן מסירה

כשמפיצים טופס, Acrobat בודקת אוטומטית את הטופס. אם היא אינה מוצאת לחצן מסירה, היא מוסיפה את הלחצן Submit Form לשרות ההודעות של המסמך. המשתמשים יכולים ללחוץ על לחצן זה כדי לשלוח את הטפסים לאחר המילוי בחזרה אליכם. אם אין בכוונתכם להשתמש בלחצן Submit Form שנוצר על-ידי Acrobat, באפשרותכם להוסיף לחצן שליחה מותאם אישית לטופס.

  1. אם אינכם במצב עריכת טופס, בחרו Tools‏ > Forms‏ > Edit. חלונית המשימות Forms נפתחת.
  2. באמצעות הכלי לחצן , גררו לאורך האזור הרצוי להצגת הלחצן. לחצו פעמיים על הלחצן וקבעו אפשרויות בכרטיסיות General וOptions.
  3. בכרטיסייה Options, בחרו אפשרות מתפריט Layout לתווית הלחצן, לתמונת הסמל או לשתיהן. בצעו אחד מהצעדים הבאים או את שניהם:
    • הקלידו מלל בתיבה Label לזיהוי הלחצן כלחצן מסירה.

    • לחצו על Choose Icon והקלידו את הנתיב לקובץ תמונה, או לחצו על Browse ואתרו את קובץ התמונה שברצונכם להשתמש בו.

  4. בכרטיסייה Actions, בחרו Submit A Form בתפריט Select Action ולחצו על Add.
  5. בתיבת הדו-שיח Submit Form Selections, בצעו אחת מהפעולות הבאות:
    • כדי לאסוף נתוני טופס בשרת, הקלידו את המיקום באפשרות Enter a URL עבור קישור זה. לדוגמה, http://www.[דומיין]/[תיקייה]/[תת-תיקייה]/ לכתובת אינטרנט או \\[שרת]\[תיקייה]\[תת-תיקייה]\ למיקום ברשת מקומית.

    • לאיסוף הנתונים כקבצים מצורפים מהודעות דוא"ל, הקלידו mailto:‎ וכתובת דוא"ל. לדוגמה, mailto:nobody@adobe.com.

  6. בחרו אפשרויות עבור Export Format‏, Field Selection ו-Date Options ולחצו על OK.

הערה:

אם הנתונים יוחזרו בתבנית FDF או XFDF, כתובת URL של השרת חייבת להסתיים בסיומת ‎#FDF; לדוגמה, http://myserver/cgi-bin/myscript#FDF.

אפשרויות בחירה למסירת טופס

האפשרויות הבאות זמינות בתיבת הדו-שיח Submit Forms Selections:

Enter a URL for this link

ציון כתובת ה- URL לאיסוף נתוני הטופס.

FDF

מחזיר את הקלט של המשתמש ללא קובץ PDF שנשלח במקור למשתמש. באפשרותכם לבחור אפשרויות כדי לכלול את Field Data‏, Comments ו- Incremental Changes To The PDF.

 

הערה:

בחירה באפשרות של שינויים הדרגתיים היא שימושית לקבלת חתימות דיגיטליות באופן קל לקריאה ולשחזור בשרת.

HTML

מחזיר את הטופס ב- Hypertext Markup Language.

XFDF

מחזיר את הקלט של המשתמש כקובץ XML. ניתן לכלול הערות בנתוני השדה או רק את נתוני השדה.

PDF

מחזיר את כל קובץ PDF עם הקלט של המשתמש.

Field Selection

מציין אילו שדות יוחזרו. כדי לקבל רק חלק מנתוני השדה שהושלמו, בחרו Only These, לחצו על Select Fields ובחרו את השדות שיש לכלול או לא לכלול בתיבת הדו-שיח Field Selection.

לדוגמה, תוכלו להשתמש באפשרות זו כדי שלא לכלול חלק מהשדות המחושבים או הכפולים המופיעים בטופס לנוחיותו של המשתמש אך אינם כוללים נתונים חדשים.

Date Options

קביעת תבנית התאריכים שיזין המשתמש.

שינוי מראה של לחצנים

לחצן יכול לכלול תווית, סמל או את שניהם. ניתן לשנות את המראה של לחצן בכל אחד ממצבי העכבר (Up‏, Down‏, ו- Rollover). לדוגמה, באפשרותכם ליצור תווית “Home” עד שהמצביע יזוז מעל הלחצן והיא עשויה להשתנות לתווית “Click to return to home page”.

ניתן ליצור סמלי לחצנים מכל תבנית קובץ שתוכנת Acrobat יכולה להציג, כולל PDF, ‏JPEG, ‏GIF ותבניות תמונה אחרות. לכל תבנית שתבחרו ישמש העמוד כולו, כך שאם ברצונכם להשתמש רק בחלק מהעמוד כסמל, יש לחתוך את העמוד או את התמונה לפני שתמשיכו בביצוע הליך זה. גודל עמוד PDF הקטן ביותר המותר הוא 1 על 1 אינץ' (2.54 על 2.54 ס"מ). אם ברצונכם שהסמל ייראה קטן מ- 1 על 1 אינץ', הקטינו אותו כך שיתאים לגודל התיבה שצוירה בעזרת הכלי Button. לחיצה על Advanced בכרטיסייה Options של תיבת הדו-שיח Button Properties מאפשרת לכם לקבוע כיצד קנה המידה של סמל לחצן משתנה כדי להתאים ללחצן.

פריסות לחצנים
פריסות לחצנים

A. תווית בלבד B. סמל בלבד C. סמל למעלה, תווית למטה D. תווית למעלה, סמל למטה E. סמל משמאל, תווית מימין F. תווית משמאל, סמל מימין G. תווית על גבי סמל 

עריכת לחצן

  1. אם אינכם במצב עריכת טופס, בחרו Tools‏ > Forms‏ > Edit. חלונית המשימות Forms נפתחת.
  2. בחרו בשדה Button ובצעו אחת מהפעולות הבאות:
    • כדי לערוך את מאפייני שדה הלחצן, לחצו פעמיים על הלחצן.

    • כדי לשנות את מראה הלחצנים, השתמשו באפשרויות המראה בכרטיסייה Appearance של תיבת הדו-שיח Button Properties.

    • כדי ליישר, למרכז או לפזר את הלחצן בין שדות טופס אחרים, או כדי לשנות את גודלו או לשכפל אותו, לחצו עליו לחיצה ימנית ובחרו אפשרות מהתפריט תלוי-ההקשר.

קביעת מאפייני תצוגה של לחצן ב- Acrobat

  1. אם אינכם במצב עריכת טופס, בחרו Tools‏ > Forms‏ > Edit. חלונית המשימות Forms נפתחת.
  2. לחצו לחיצה כפולה על לחצן קיים ולחצו על הכרטיסייה Options בתיבת הדו-שיח Button Properties.
  3. באפשרות Layout, בחרו בסוג תצוגת התווית הרצוי. (לקבלת מידע על שינוי גודל של סמלי לחצן, ראו ההליך הבא).
  4. באפשרות Behavior, ציינו את מראה הלחצן בזמן שלוחצים עליו:
  5. כדי להגדיר את התווית או הסמל שמופיעים על הלחצן, בצעו את הפעולות הבאות:
    • אם נבחרה אפשרות תווית מתפריט Layout, הקלידו את המלל בתיבה Label.

    • אם אפשרות סמל נבחרת מהתפריט Layout, לחצו על Choose Icon, לחצו על Browse ובחרו את הקובץ. ‏(לחצו על Clear כדי להסיר את הסמל שנבחר).

אפשרויות Button Behavior

None

משאיר את מראה הלחצן ללא שינוי.

Push

מציין מראה במצבי העכבר ‏Up‏, Down או Rollover. בחרו אפשרות תחת State וציינו אפשרות תווית או סמל:

Up

קובע את מראה הלחצן כשלא לוחצים על לחצן העכבר.

Down

קובע את מראה הלחצן כשלוחצים על לחצן העכבר, לפני שמשחררים אותו.

Rollover

קובע את מראה העכבר כשמחזיקים את המצביע על לחצן.

Outline

מסמן את גבולות הלחצן.

Invert

מחליף בין הגוונים הכהים והבהירים של הלחצן.

שינוי גודל ומיקום של לחצנים

  1. אם אינכם נמצאים במצב עריכת טופס, בחרו Tools‏ > Forms‏ > Edit.
  2. לחצו לחיצה כפולה על לחצן קיים כדי לפתוח את תיבת הדו-שיחButton Properties.
  3. לחצו על הכרטיסייה Options, בחרו אחת מאפשרויות הסמלים מהתפריט Layout ולחצו על Advanced.

    הערה:

    הלחצן Advanced אינו זמין אם אתם בוחרים Label Only מהתפריט Layout.

  4. בחרו אפשרות מתפריט When To Scale:

    Always

    משנה את גודל הסמל כפי שמוגדר, ללא קשר לגודלו ביחס לגודל הלחצן.

    Never

    שומר על גודלו המקורי של הסמל; גבולות הלחצן חותכים את הסמל אם הוא אינו מתאים לשטח הלחצן. אם נבחרה האפשרות Never, אפשרויות שינוי הגודל אינן זמינות.

    Icon Is Too Big

    משנה את גודל הסמל כפי שהוגדר, רק אם הסמל גדול מהלחצן.

    Icon Is Too Small

    משנה את גודל הסמל כפי שהוגדר, רק אם הסמל קטן מהלחצן.

  5. מתפריט Scale, בחרו אם לשנות או לא לשנות את גודל הסמל באופן פרופורציונלי. אם גודל הסמל משתנה בצורה לא פרופורציונלית, הסמל עלול להופיע נטוי.
  6. כדי לוודא שהשוליים העליונים, התחתונים, הימניים והשמאליים מוצמדים לקצות הלחצן, בחרו באפשרות Fit To Bounds‏.
  7. כדי להגדיר היכן הסמל ימוקם בתוך הלחצן, גררו את חיצי המחוון. מיקום סמל מוגדר בהתאם לאחוזי הרווח שנשמרים בין הסמל והגבול השמאלי של השדה ובין הסמל והגבול התחתון של השדה. הגדרת ברירת המחדל (50, 50) ממקמת את הסמל במרכז השדה. ניתן ללחוץ על Reset בכל עת כדי לחזור להגדרת המיקום של ברירת המחדל.
  8. לחצו על OK ולאחר מכן על Close.

הסתרת לחצן של Acrobat, פרט למצב הצבעה על הלחצן

במקרים מסוימים, ייתכן שתרצו שאזור הלחצן לא יהיה גלוי, עד שמזיזים אליו את המצביע. באמצעות הצגה והסתרה של לחצן לחלופין, ניתן ליצור אפקטים חזותיים מעניינים במסמך. לדוגמה, כשמזיזים את המצביע לעיר במפה, ניתן להציג מפה מפורטת של העיר, והמפה המפורטת יכולה להיעלם כשמזיזים את המצביע מהעיר.

הצגה והסתרה של סמלים
הצגה והסתרה של סמלים

A. המצביע אינו נמצא על לחצן B. המצביע נכנס לאזור הלחצן C. המצביע יוצא מאזור הלחצן 
  1. אם אינכם במצב עריכת טופס, בחרו Tools‏ > Forms‏ > Edit. חלונית המשימות Forms נפתחת.
  2. באמצעות הכלי לחצן , גררו לאזור הרצוי לתצוגת הלחצן הנפתח. לדוגמה, אם מסמך PDF כולל מפה של צרפת, גררו לאזור שברצונכם לפתוח בו מפה מפורטת של פריס.
  3. לחצו פעמיים על הלחצן.
  4. לחצו על הכרטיסייה Options, ובחרו באפשרות Icon Only מתפריט Layout.
  5. בחרו באפשרות Push מתפריט Behavior, ולאחר מכן בחרו באפשרות Rollover מרשימת מצבי העכבר.
  6. לחצו על Choose Icon ולאחר מכן לחצו על Browse. בחרו בסוג הקובץ מהתפריט הנפתח File Of Type, נווטו למיקום של קובץ התמונה, ולחצו פעמיים על הקובץ. בדוגמה זו, תבחרו מפה של פריס. לחצו על OK כדי לקבל את התצוגה המקדימה של התמונה כתמונת הלחצן.
  7. לחצו על הכרטיסייה Appearance. במידת הצורך, בטלו את הסימון באפשרות Border Color and Fill Color, ולחצו על Close.
  8. אם אתם נמצאים במצב עריכה, לחצו על Preview. שדה התמונה שהגדרתם מופיע כשהמצביע נכנס לאזור הלחצן, ונעלם כשהמצביע יוצא מאזור הלחצן.

    הערה:

    אם ברצונכם שהתמונה תהיה גדולה יותר מאזור הלחצן במצב הצבעה, או אם ברצונכם שהתמונה תופיע במיקום שונה ממיקום הלחצן הנפתח, השתמשו בפעולה Show/Hide A Field. ראשית, יש לציין סמל ללחצן שיוצג ויוסתר. לאחר מכן יש ליצור לחצן שני שיפעל כנקודה חמה כשהמצביע יזוז אליו. אל תשייכו סמל ללחצן השני. במקום זאת, השתמשו בכרטיסייה Actions כדי להציג את הלחצן הראשון כשמצביע העכבר נכנס לאזור הלחצן השני, וכדי להסתיר את הלחצן הראשון כשמצביע העכבר יוצא מאזור זה

עבודה זו בוצעה ברישיון של Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  הודעות המתפרסמות ב- Twitter™‎ ו- Facebook אינן מכוסות בתנאי Creative Commons.

הצהרות משפטיות   |   מדיניות פרטיות מקוונת