אתה מציג תוכן עזרה עבור גרסה:

AEM Forms includes several new features and enhancements that streamline and enhance designing, management, publishing, and processing of forms, documents, and correspondences. To learn about all the new capabilities of AEM Forms, see What's new in AEM 6.2 Forms.

You can upgrade from AEM 6.0 Forms, AEM 6.1 Forms, various versions of LiveCycle and corresponding Feature Packs of AEM 6.0 Forms and AEM 6.1 Forms to AEM 6.2 Forms.     

For steps-by-step instructions to upgrade, choose an appropriate upgrade path:  

LiveCycle > AEM 6.2 Forms on JEE

  1. Download the AEM 6.2 Forms on JEE  installer from the Adobe Licensing Website (LWS). You require a valid Maintenance & Support contract to download the installer.

  2. Read the Upgrade checklist and planning document to learn about the versions of Adobe LiveCycle supported for upgrade and the checks to perform to ensure a successful upgrade.

    הערה:

    Direct upgrade from LiveCycle to AEM 6.2 Forms is not available. You have to perform intermediate upgrade to one or more versions of LiveCycle or AEM Forms. For the complete list of intermediate versions, see the Supporting software infrastructure compatibilities section of the Upgrade checklist and planning document.

  3. Use the Prepare to upgrade to AEM Forms to learn and perform the tasks that ensure the upgrade runs correctly with minimal server downtime.

  4. Depending on your application server, choose one of the following documents and follow the instructions:

  5. (If you are using forms portal) To keep your existing pages with Forms Portal component up and running, Install forms portal upgrade package.

AEM 6.0 Forms on OSGi > AEM 6.2 Forms on OSGi

  1. Install the latest service pack and patches for AEM 6.0 Forms.

  2. Prepare the source instance for upgrade. For detailed steps, see the Upgrading to AEM 6.2 article.

  3. Download the AEM 6.2 QuickStart.

  4. (Unix/Linux-based installations only) If you are using UNIX or Linux as the underlying operating system, open the terminal window, navigate to the folder containing crx-quickstart, and run the following command:

    chmod -R 755 ../crx-quickstart

  5. Replace the AEM 6.0 QuickStart with AEM 6.2 QuickStart and start the author instance.

    Starting the AEM 6.2 QuickStart, upgrades the existing crx-repository to AEM 6.2, automatically migrates the content from older version to newer version, and creates a folder named archived-versions.  

  6. Before continuing with the next steps, wait until the ServiceEvent REGISTERED and ServiceEvent UNREGISTERED messages stop appearing in the <crx-repository>/error.log file.  

    הערה:

    After the server is up and running, a few AEM Forms bundles remain in install state. The number of bundles can vary for every installation. You can safely ignore the state these bundles. The bundles are listed at http://[server]:[port]/system/console/.

  7. Open the archived-versions folder and copy all the folders inside archived-versions folder to the [AEM_root]\crx-repository folder. Restart the AEM 6.2 instance. Before restarting the AEM instance, ensure that all the bundles are in active state. The bundles are listed at http://[server]:[port]/system/console/. If all the bundles are not active, wait, and check the status of the bundles after for a few minutes. After all the bundles are in active state, restart the AEM server.  

  8. Log in to AEM as an administrator and open the package share. Log in to the package share with an Adobe ID. A list of folders and packages appears.   

    הערה:

    The default URL of package share is http:[server]/host/crx/packageshare/login.html.

    הערה:

    Before installing the AEM Forms add-on package, ensure that the installation path of the AEM Quickstart does not contain any spaces.

  9. In package share, search AEM Forms add-on packages, click the package applicable to your operating system, and click Download. Read and accept the license agreement and click OK. Once downloaded, the word Downloaded appears next to the package.

    You can also use the direct download links listed in the AEM Forms releases article to manually download a package.

  10. Open the package manager, locate the downloaded package, and click Install. The default URL is http://[server]:[port]/crx/packmgr/index.jsp. After the package is installed on your environment, the word Share appears next to the package in the Package Manager. 

  11. (Optional) Configure the Doc Assurance Service

    The DocAssurance service is not available out of the box. It requires RSA and BouncyCastle libraries installed with AEM Forms package. Perform the following steps to bootdelegate these libraries:   

    1. Stop the AEM server.

    2. Open the sling.properties at [AEM installation]\crx-quickstart\conf\ for editing.

      הערה:

      If you use [AEM_root]\crx-quickstart\bin\start.bat to start AEM, then edit the sling.properties at [AEM_root]\crx-quickstart\

    3. Add the following properties to the sling.properties file:

      sling.bootdelegation.class.com.rsa.jsafe.provider.JsafeJCE=com.rsa.*
      sling.bootdelegation.class.org.bouncycastle.jce.provider.BouncyCastleProvider=org.bouncycastle.* 
    4. Save and close the file. Restart the AEM server.

  12. After the package is installed, do not immediately restart the server. Before restarting the AEM server, ensure that all the bundles are in active state. The bundles are listed at http://[server]:[port]/system/console/. If all the bundles are not active, wait, and check the status of the bundles after for a few minutes.

    After all the bundles are in active state, restart the AEM server.  

AEM 6.0 Forms on JEE > AEM 6.2 Forms on JEE

  1. Download the AEM 6.2 Forms on JEE  installer from the Adobe Licensing Website (LWS). You require a valid Maintenance & Support contract to download the installer.

  2. Read the Upgrade checklist and planning document to learn about the checks to perform to ensure a successful upgrade.

  3. Use the Prepare to upgrade to AEM Forms to learn and perform the tasks that ensure the upgrade runs correctly with minimal server downtime.

  4. Depending on your application server, choose one of the following documents and follow the instructions:

  5. (If you are using forms portal) To keep your existing pages with Forms Portal component up and running, Install forms portal upgrade package.

AEM 6.1 Forms on OSGi > AEM 6.2 Forms on OSGi

  1. Install the latest service pack and patches for AEM 6.1 Forms.

  2. Prepare the source instance for upgrade. For detailed steps, see the Upgrading to AEM 6.2 article.

  3. Download the AEM 6.2 QuickStart.

  4. (Unix/Linux-based installations only) If you are using UNIX or Linux as the underlying operating system, open the terminal window, navigate to the folder containing crx-quickstart, and run the following command:

    chmod -R 755 ../crx-quickstart

  5. Replace the AEM 6.1 QuickStart with AEM 6.2 QuickStart and start the author instance.

    Starting the AEM 6.2 QuickStart, upgrades the existing crx-repository to AEM 6.2, automatically migrates the content from older version to newer version, and creates a folder named archived-versions.  

  6. Before continuing with the next steps, wait until the ServiceEvent REGISTERED and ServiceEvent UNREGISTERED messages stop appearing in the <crx-repository>/error.log file.  

    הערה:

    After the server is up and running, a few AEM Forms bundles remain in install state. The number of bundles can vary for every installation. You can safely ignore the state these bundles. The bundles are listed at http://[server]:[port]/system/console/.

  7. Open the archived-versions folder and copy all the folders inside archived-versions folder to the [AEM_root]\crx-repository folder. Restart the AEM 6.2 instance. Before restarting the AEM instance, ensure that all the bundles are in active state. The bundles are listed at http://[server]:[port]/system/console/. If all the bundles are not active, wait, and check the status of the bundles after for a few minutes. After all the bundles are in active state, restart the AEM server.  

  8. Log in to AEM as an administrator and open the package share. Log in to the package share with an Adobe ID. A list of folders and packages appears.   

    הערה:

    The default URL of package share is http:[server]/host/crx/packageshare/login.html.

    הערה:

    Before installing the AEM Forms add-on package, ensure that the installation path of the AEM Quickstart does not contain any spaces.

  9. In package share, search AEM Forms add-on packages, click the package applicable to your operating system, and click Download. Read and accept the license agreement and click OK. Once downloaded, the word Downloaded appears next to the package.

    You can also use the direct download links listed in the AEM Forms releases article to manually download a package.

  10. Open the package manager, locate the downloaded package, and click Install. The default URL is http://[server]:[port]/crx/packmgr/index.jsp. After the package is installed on your environment, the word Share appears next to the package in the Package Manager. 

  11. (Optional) Configure the Doc Assurance Service

    The DocAssurance service is not available out of the box. It requires RSA and BouncyCastle libraries installed with AEM Forms package. Perform the following steps to bootdelegate these libraries:   

    1. Stop the AEM server.

    2. Open the sling.properties at [AEM installation]\crx-quickstart\conf\ for editing.

      הערה:

      If you use [AEM_root]\crx-quickstart\bin\start.bat to start AEM, then edit the sling.properties at [AEM_root]\crx-quickstart\

    3. Add the following properties to the sling.properties file:

      sling.bootdelegation.class.com.rsa.jsafe.provider.JsafeJCE=com.rsa.*
      sling.bootdelegation.class.org.bouncycastle.jce.provider.BouncyCastleProvider=org.bouncycastle.* 
    4. Save and close the file. Restart the AEM server.

  12. After the package is installed, do not immediately restart the server. Before restarting the AEM server, ensure that all the bundles, but the Signatures bundle, are in active state. The bundles are listed at http://[server]:[port]/system/console/. If all the bundles are not active, wait, and check the status of the bundles after for a few minutes.

    After all the bundles are in active state, restart the AEM server.  

AEM 6.1 Forms on JEE > AEM 6.2 Forms on JEE

  1. Download the AEM 6.2 Forms on JEE  installer from the Adobe Licensing Website (LWS). You require a valid Maintenance & Support contract to download the installer.

  2. Read the Upgrade checklist and planning document to learn about the checks to perform to ensure a successful upgrade.

  3. Use the Prepare to upgrade to AEM forms to learn and perform the tasks that ensure the upgrade runs correctly with minimal server downtime.

  4. Depending on your application server, choose one of the following documents and follow the instructions:

  5. (If you are using forms portal) To keep your existing pages with Forms Portal component up and running, Install forms portal upgrade package.

Considerations

  • (AEM Forms on JEE only) The Document Security module does not use Content Repository. It implies, if you are using only Rights Management or Document Security and do not plan to use Workspace, HTML5 forms, and adaptive forms, you need not install Content Repository.
  • Supported repository types for AEM 6.2 Forms:
    • Cluster-based installations: For cluster-based installations, you can use RDBMK and MongoDB. AEM 6.2 Forms RDBMK is supported via a gated program. Contact Adobe support for detailed information on using RDBMK in a production environment.
    • Single-server installations: For single-server installations, you can use TarMK, RDBMK, or MongoDB.

Note: You can install all the modules of AEM Forms on all the supported Storage & Persistence types (TarMK, RDBMK, and MongoDB). 

עבודה זו בוצעה ברישיון של Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  הודעות המתפרסמות ב- Twitter™‎ ו- Facebook אינן מכוסות בתנאי Creative Commons.

הצהרות משפטיות   |   מדיניות פרטיות מקוונת