Move, align, and distribute objects

  1. Illustrator User Guide
  2. Get to know Illustrator
    1. Introduction to Illustrator
      1. What's new in Illustrator
      2. Common questions
      3. Illustrator system requirements
      4. Illustrator for Apple silicon
    2. Workspace
      1. Workspace basics
      2. Create documents
      3. Tools Default keyboard shortcuts | Illustrator
      4. Tool galleries
      5. Customize keyboard shortcuts
      6. Artboards
      7. Customize the workspace
      8. Properties panel
      9. Set preferences
      10. Touch Workspace
      11. Microsoft Surface Dial support in Illustrator
      12. Recovery, undo, and automation
      13. Rotate view
      14. Rulers, grids, and guides
      15. Accessibility in Illustrator
      16. Safe Mode
      17. View artwork
      18. Use the Touch Bar with Illustrator
      19. Files and templates
      20. Synchronize settings using Adobe Creative Cloud
  3. Illustrator on the iPad
    1. Introduction to Illustrator on the iPad
      1. Illustrator on the iPad overview
      2. Illustrator on the iPad FAQs
      3. System requirements | Illustrator on the iPad
      4. What you can or cannot do on Illustrator on the iPad
    2. Workspace
      1. Illustrator on the iPad workspace
      2. Touch shortcuts and gestures
      3. Keyboard shortcuts for Illustrator on the iPad
      4. Manage your app settings
    3. Documents
      1. Work with documents in Illustrator on the iPad
      2. Import Photoshop and Fresco documents
    4. Select and arrange objects
      1. Create repeat objects
      2. Blend objects
    5. Drawing
      1. Draw and edit paths
      2. Draw and edit shapes
    6. Type
      1. Work with type and fonts
      2. Create text designs along a path
      3. Add your own fonts
    7. Work with images
      1. Vectorize raster images
    8. Color
      1. Apply colors and gradients
  4. Cloud documents
    1. Basics
      1. Work with Illustrator cloud documents
      2. Share and collaborate on Illustrator cloud documents
      3. Upgrade cloud storage for Adobe Illustrator
      4. Illustrator cloud documents | Common questions
    2. Troubleshooting
      1. Troubleshoot create or save issues for Illustrator cloud documents
      2. Troubleshoot Illustrator cloud documents issues
  5. Add and edit content
    1. Drawing
      1. Drawing basics
      2. Edit paths
      3. Draw pixel-perfect art
      4. Draw with the Pen, Curvature, or Pencil tool
      5. Draw simple lines and shapes
      6. Image Trace
      7. Simplify a path
      8. Define perspective grids
      9. Symbolism tools and symbol sets
      10. Adjust path segments
      11. Design a flower in 5 easy steps
      12. Perspective drawing
      13. Symbols
      14. Draw pixel-aligned paths for web workflows
    2. 3D effects and Adobe Substance materials
      1. About 3D effects in Illustrator
      2. Create 3D graphics
      3. Create 3D objects
      4. Create 3D Text
    3. Color
      1. About color
      2. Select colors
      3. Use and create swatches
      4. Adjust colors
      5. Use the Adobe Color Themes panel
      6. Color groups (harmonies)
      7. Color Themes panel
      8. Recolor your artwork
    4. Painting
      1. About painting
      2. Paint with fills and strokes
      3. Live Paint groups
      4. Gradients
      5. Brushes
      6. Transparency and blending modes
      7. Apply stroke on an object
      8. Create and edit patterns
      9. Meshes
      10. Patterns
    5. Select and arrange objects
      1. Select objects
      2. Layers
      3. Group and expand objects
      4. Move, align, and distribute objects
      5. Stack objects    
      6. Lock, hide, and delete objects
      7. Duplicate objects
      8. Rotate and reflect objects
    6. Reshape objects
      1. Crop images
      2. Transform objects
      3. Combine objects
      4. Cut, divide, and trim objects
      5. Puppet Warp
      6. Scale, shear, and distort objects
      7. Blend objects
      8. Reshape using envelopes
      9. Reshape objects with effects
      10. Build new shapes with Shaper and Shape Builder tools
      11. Work with Live Corners
      12. Enhanced reshape workflows with touch support
      13. Edit clipping masks
      14. Live shapes
      15. Create shapes using the Shape Builder tool
      16. Global editing
    7. Type
      1. Create text
      2. Fonts and typography
      3. Format type
      4. Import and export text
      5. Format paragraphs
      6. Special characters
      7. Create type on a path
      8. Character and paragraph styles
      9. Tabs
      10. Text and type
      11. Find missing fonts (Typekit workflow)
      12. Update text from Illustrator 10
      13. Arabic and Hebrew type
      14. Fonts | FAQ and troubleshooting tips
      15. Create 3D text effect
      16. Creative typography designs
      17. Scale and rotate type
      18. Line and character spacing
      19. Hyphenation and line breaks
      20. Text enhancements
      21. Spelling and language dictionaries
      22. Format Asian characters
      23. Composers for Asian scripts
      24. Create text designs with blend objects
      25. Create a text poster using Image Trace
    8. Create special effects
      1. Work with effects
      2. Graphic styles
      3. Create a drop shadow
      4. Appearance attributes
      5. Create sketches and mosaics
      6. Drop shadows, glows, and feathering
      7. Summary of effects
    9. Web graphics
      1. Best practices for creating web graphics
      2. Graphs
      3. SVG
      4. Create animations
      5. Slices and image maps
  6. Import, export, and save
    1. Import
      1. Import artwork files
      2. Import bitmap images
      3. Import artwork from Photoshop
      4. Place multiple files | Illustrator CC
      5. Unembed images
      6. Import Adobe PDF files
      7. Import EPS, DCS, and AutoCAD files
      8. Links information
    2. Creative Cloud Libraries in Illustrator 
      1. Creative Cloud Libraries in Illustrator
    3. Save
      1. Save artwork
    4. Export
      1. Use Illustrator artwork in Photoshop
      2. Export artwork
      3. Collect assets and export in batches
      4. Package files
      5. Create Adobe PDF files
      6. Extract CSS | Illustrator CC
      7. Adobe PDF options
      8. File information and metadata
  7. Printing
    1. Prepare for printing
      1. Set up documents for printing
      2. Change the page size and orientation
      3. Specify crop marks for trimming or aligning
      4. Get started with large canvas
    2. Printing
      1. Overprint
      2. Print with color management
      3. PostScript printing
      4. Print presets
      5. Printer's marks and bleeds
      6. Print and save transparent artwork
      7. Trapping
      8. Print color separations
      9. Print gradients, meshes, and color blends
      10. White Overprint
  8. Automate tasks
    1. Data merge using the Variables panel
    2. Automation with scripts
    3. Automation with actions
  9. Troubleshooting 
    1. Crash on launch issues
    2. Recover files after crash
    3. File issues
    4. GPU device driver issues
    5. Wacom device issues
    6. DLL file issues
    7. Memory issues
    8. Preferences file issues
    9. Font issues
    10. Printer issues
    11. Share crash report with Adobe

Move objects

You can move objects by dragging them with specific tools, by using the arrow keys on the keyboard, or by entering precise values in a panel or dialog box.

You can use snapping to help you position objects as you move them. For example, you can snap the pointer to guides and anchor points and snap object boundaries to gridlines. You can also use the Align panel to position objects in relation to each other.

You can then use the Shift key to constrain the movement of one or more objects so that they move in a precise horizontal, vertical, or diagonal direction relative to the current orientation of the x and y axes. You can also use the Shift key to rotate objects in multiples of 45°.

Move objects
Hold down Shift while dragging or drawing to limit movement to the nearest 45° angle.

Move or duplicate an object by pasting

  1. Select one or more objects.

  2. Choose Edit > Cut to move the selection or Edit > Copy to duplicate the selection.

  3. To paste an object into another file, open the file. (To paste between layers, see Pasting objects between layers.)

  4. Choose one of the following commands:

    Edit > Paste

    Pastes the object into the center of the active window.

    Edit > Paste In Front

    Pastes the object directly in front of the selected object.

    Edit > Paste In Back

    Pastes the object directly in back of the selected object.

    Edit > Paste in Place

    Pastes artwork on the active artboard at the same position as the artboard from where the artwork is copied.

    Edit > Paste on All Artboards

    Pastes artwork on all the artboards at the same location where the artwork is on the current artboard.

Move an object by dragging

  1. Select one or more objects.

  2. Drag the object to a new location.

    If a selected object is filled, you can drag from anywhere on the object. If a selected object is unfilled, if you are viewing artwork as outlines, or if the Object Selection By Path Only preference is selected, you must drag from the object’s path. (See Duplicate selections using drag and drop.)

    Note:

    You can use the Snap To Point command in the View menu to have the cursor snap to an anchor point or guide when you drag an object within 2 pixels of the anchor point or guide.

Move an object using the arrow keys

  1. Select one or more objects.

  2. Press the arrow key for the direction in which you want to move the object. Press Shift+arrow to move the object ten times the value specified by the Keyboard Increment preference.

    The distance the object moves each time you press an arrow key is determined by the Keyboard Increment preference. The default distance is 1 point (1/72 of an inch, or .3528 millimeter). To change the Keyboard Increment preference, choose Edit > Preferences > General (Windows) or Illustrator > Preferences > General (Mac OS).

Move an object by a specific distance

  1. Select one or more objects.

  2. Choose Object > Transform > Move.

    Note:

    When an object is selected, you can also double-click the Selection, Direct Selection, or Group Selection tool to open the Move dialog box.

  3. Do any of the following:

    • To move the object left or right, enter either a negative value (moves left) or a positive value (moves right) in the Horizontal text box.

    • To move the object up or down, enter either a negative value (moves up) or positive value (moves down) in the Vertical text box.

    • To move the object by an angle that’s relative to the object’s x axis, enter either a positive angle (counterclockwise movement) or a negative angle (clockwise movement) in the Distance or Angle text box. You can also enter values between 180° and 360°; these values are converted to their corresponding negative values (for example, a value of 270° is converted to –90°).

  4. If the objects contain a pattern fill, select Patterns to move the pattern. Deselect Objects if you want to move the pattern but not the objects.

  5. Click OK, or click Copy to move a copy of the objects.

    Directions relative to the x axis
    Directions relative to the x axis

Move an object using x and y coordinates

  1. Select one or more objects.

  2. In the Transform panel or Control panel, enter new values in either the X or Y text box, or both.

    To change the reference point, click a white square on the reference point locator  before you enter the values.

Move multiple objects at once

  1. Select one or more objects.

  2. Choose Object > Transform > Transform Each.

  3. Set the distance you want to move the selected objects in the Move section of the dialog box.

  4. Do one of the following:

    • To move the objects by the specified amounts, click OK.

    • To move the objects randomly, but no more than the specified amounts, select the Random option. For example, if you draw a brick wall and want the bricks to appear slightly offset from each other instead of perfectly aligned, you could select the Random option. Then click OK.

Paste an object relative to other objects

  1. Select the object you want to paste.

  2. Choose Edit > Copy or Edit > Cut.

  3. Select the object in front or in back of which you want to paste.

  4. Choose Edit > Paste In Front or Edit > Paste In Back.

    If you paste more than one object, all pasted objects appear in front or in back of the selected artwork. However, the relative painting order among the individual pasted objects remains the same.

Paste objects between layers

The Paste Remembers Layers option determines where artwork is pasted in the layer hierarchy. By default, Paste Remembers Layers is off, and artwork is pasted into whichever layer is active in the Layers panel. When Paste Remembers Layers is on, artwork is pasted into the layer from which it was copied, regardless of which layer is active in the Layers panel.

You set this option by selecting Paste Remembers Layers from the Layers panel menu. A check mark displays when the option is on.

Note:

Turn on Paste Remembers Layers if you’re pasting artwork between documents and you want to automatically place it into a layer of the same name as that from which it originated. If the target document does not have a layer of the same name, Illustrator creates a new layer.

Paste in place and paste on all artboards

The Paste in Place command pastes artwork on the active artboard. To use this command, click Edit > Paste in Place. The keyboard shortcut is Ctrl+Shift+V (Windows) or Cmd+Shift+V (Mac).

The Paste on All Artboards command pastes the selected artwork on all the artboards. Before using the Paste on All Artboards command, make sure that the artboard from which you are copying the object, is the active artboard.

To use the Paste on All Artboards command, click Edit > Paste on All Artboards when you cut or copy the artwork.

If you copy artwork, and then select Paste on All Artboards, the artwork is repasted on the artboard from where it is copied. (Recommended) Cut and then paste objects if you do not need to modify the original objects before using the Paste on All Artboards command.

Note:

Paste in Place and Paste on All Artboards commands paste the object at the same position as the copied objects referenced from the active artboard at the time of copying.

Align and distribute objects

You use the Align panel (Window > Align) and the align options in the Control panel to align or distribute selected objects along the axis you specify. You can use either the object edges or anchor points as the reference point, and you can align to a selection, an artboard, or a key object. A key object is one specific object in a selection of multiple objects.

The Align options are visible in the Control panel when an object is selected. If they do not appear, choose Align from the Control panel menu.

Note:

By default, Illustrator calculates alignment and distribution based on the objects’ paths. However, when working with objects that have different stroke weights, you can use the edge of the stroke to calculate alignment and distribution instead. To do this, select Use Preview Bounds from the Align panel menu.

Align or distribute relative to the bounding box of all selected objects

  1. Select the objects to align or distribute.

  2. In the Align panel or Control panel, select Align To Selection , and then click the button for the type of alignment or distribution you want.

Align or distribute relative to one anchor point

  1. Click the Direct-Selection tool, hold down Shift, and select the anchor points you want to align or distribute. The last anchor point you select becomes the key anchor point.

    The Align To Key Anchor  option is automatically selected in the Align panel and Control panel.

  2. In the Align panel or Control panel, click the button for the type of alignment or distribution you want.

Align or distribute relative to a key object

  1. Select the objects to align or distribute.

  2. Click again on the object you want to use as a key object (you don’t need to hold down Shift as you click this time).

    A blue outline appears around the key object, and Align To Key Object  is automatically selected in the Control panel and Align panel.

  3. In the Align panel or Control panel, click the button for the type of alignment or distribution you want.

    Note:

    To stop aligning and distributing relative to an object, click again on the object to remove the blue outline, or choose Cancel Key Object from the Align panel menu.

Align or distribute relative to an artboard

  1. Select the objects to align or distribute.

  2. Using the Selection tool, Shift-click in the artboard you want to use to activate it. The active artboard has a darker outline than the others.

  3. In the Align panel or Control panel, select Align To Artboard  , and then click the button for the type of alignment or distribution you want.

Distribute objects by specific amounts

You can distribute objects using exact distances between their paths.

  1. Select the objects to distribute.

  2. Use the Selection tool  to click the path of the object you want the other objects to distribute around. The object you click will remain fixed in its position.

  3. In the Align panel, enter the amount of space to appear between objects in the Distribute Spacing text box.

    If the Distribute Spacing options aren’t displayed, select Show Options from the panel menu.

  4. Click either the Vertical Distribute Space button or the Horizontal Distribute Space button.

Adobe logo

Sign in to your account