After upgrading Java version, AEM does not start up | AEM

Issue

After updating from AEM 6.1 + JDK7 to AEM 6.2 + JDK8, the AEM instance fails to start with the following errors in stdout.log:

03.05.2017 21:49:20.352 *ERROR* [FelixStartLevel] ERROR: Bundle '1' Error starting slinginstall:log4j-over-slf4j-1.7.6.jar (org.osgi.framework.BundleException: Unable to resolve log4j.over.slf4j [1](R 1.0): missing requirement [log4j.over.slf4j [1](R 1.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.helpers)(version>=1.6.0)) [caused by: Unable to resolve slf4j.api [16](R 16.0): missing requirement [slf4j.api [16](R 16.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.3.0))] Unresolved requirements: [[log4j.over.slf4j [1](R 1.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.helpers)(version>=1.6.0))])
org.osgi.framework.BundleException: Unable to resolve log4j.over.slf4j [1](R 1.0): missing requirement [log4j.over.slf4j [1](R 1.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.helpers)(version>=1.6.0)) [caused by: Unable to resolve slf4j.api [16](R 16.0): missing requirement [slf4j.api [16](R 16.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.3.0))] Unresolved requirements: [[log4j.over.slf4j [1](R 1.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.helpers)(version>=1.6.0))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.lang.Thread.run(Thread.java:745)
03.05.2017 21:49:20.356 *ERROR* [FelixStartLevel] ERROR: Bundle '2' Error starting slinginstall:org.apache.sling.commons.logservice-1.0.4.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.commons.logservice [2](R 2.1): missing requirement [org.apache.sling.commons.logservice [2](R 2.1)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.6)) Unresolved requirements: [[org.apache.sling.commons.logservice [2](R 2.1)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.6))])
org.osgi.framework.BundleException: Unable to resolve org.apache.sling.commons.logservice [2](R 2.1): missing requirement [org.apache.sling.commons.logservice [2](R 2.1)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.6)) Unresolved requirements: [[org.apache.sling.commons.logservice [2](R 2.1)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.6))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.lang.Thread.run(Thread.java:745)
03.05.2017 21:49:20.367 *ERROR* [FelixStartLevel] ERROR: Bundle '3' Error starting slinginstall:com.adobe.granite.startup-0.6.2.jar (org.osgi.framework.BundleException: Unable to resolve com.adobe.granite.startup [3](R 3.0): missing requirement [com.adobe.granite.startup [3](R 3.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.2)(!(version>=2.0.0))) [caused by: Unable to resolve slf4j.api [16](R 16.0): missing requirement [slf4j.api [16](R 16.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.3.0))] Unresolved requirements: [[com.adobe.granite.startup [3](R 3.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.2)(!(version>=2.0.0)))])

Resolution

  1. Stop AEM.

  2. Remove the following line from crx-quickstart/conf/sling.properties if exist:

    org.osgi.framework.system.capabilities=${eecap-${java.specification.version}}
  3. Start AEM.

 Adobe

Get help faster and easier

New user?

Adobe MAX 2024

Adobe MAX
The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX

The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX 2024

Adobe MAX
The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX

The Creativity Conference

Oct 14–16 Miami Beach and online