Note:

This feature is no longer available in the current version of Photoshop CC. The information in this article applies to earlier versions of Photoshop.

Important: Design Space (Preview) requires Mac OS X 10.10 or Windows 8.1 64-bit OS or higher.

Get started

Design Space (Preview) is a companion experience to Photoshop for web and app designers. Technically, Design Space (Preview) is an HMTL5/CSS/JavaScript layer built on top of Photoshop. Separating this new experience from standard Photoshop in this manner facilitates a fresh UI, smarter interactions, and faster delivery of top-requested features. 

Design Space is currently a Technology Preview. To help shape Design Space (Preview) into the experience you want, give us feedback @psdesign.

For a list of known issues in this release, see Top known issues.

Note:

You can find Design Space (Preview) source code at github.

Switch to Design Space (Preview)

In Photoshop, do one of the following:

  • Select Window > Design Space (Preview).
  • From the workspace selection pop-up menu in the upper-right corner of the screen, choose Design Space (Preview).

Note:

Design Space (Preview) is enabled by default. In the unlikely event that options to switch to the Design Space workspace are unavailable, ensure that Enable Design Space (Preview) under Preferences > Technology Previews is selected.

Photoshop Enabling Design Space
Choose the Design Space (Preview) workspace

Note:

After switching to Design Space (Preview) workspace, select Help > Design Space Introduction for a quick walkthrough of its features and functionality. The introduction is automatically displayed when you switch to Design Space (Preview) for the first time.

A first look at Design Space (Preview)

Photoshop Design Space user interface
Design Space (Preview) UI

A. Toolbar B. Properties C. Layers and Libraries D. Collapse or expand columns 

Note:

Cmd/Ctrl+click icons marked as D to quickly toggle between the Properties and Layers & Libraries columns.

Photoshop Design Space panels
A closer look at available functionality

Adjust the interface

  • If necessary, you can maximize your working space and view properties, layers, and libraries in a single column. Select Window > Single-Column Mode.
Photoshop Window Single-column mode
The single-column mode

  • If you rely extensively on keyboard shortcuts, you can choose to hide the toolbar. Deselect Window > Pin Toolbar.

Create a document

There are multiple ways of creating a document using Design Space (Preview).

  1. Select File > New or use the Cmd/Ctrl+N keyboard shortcut. Design Space (Preview) quickly creates a document with a single artboard that uses the iPhone 6 template.
  2. Choose File > New... to open the New dialog box. Specify the necessary details and click OK.

    For more information, see Create an image and Create an artboard document.
  3. Choose File > New From Template and select one of the following templates:
Photoshop Available templates

Add an artboard to a Design Space (Preview) file

  1. In the Design Space (Preview) interface, do one of the following:
  • Select Layer > Create New Artboard. Design Space (Preview) adds an artboard of default dimensions to the document.
  • To add an artboard for a specific device, select Layer > New Artboard and then select a preset. For example, select Layer > New Artboard > iPad Pro.
  1. Add your design elements to the new artboard.

Note:

You can also add artboards to your document by clicking the + icons that appear alongside artboards currently in the document. These + icons appear wherever an existing artboard is selected and the canvas can accommodate additional artboards.

Tools

The following tools are available in Design Space (Preview):

Photoshop Design Space tools
Tools

Note:

The first letter indicates the shortcut to use the tool. For instance, the shortcut to use Rectangle tool is R.

Select

Aside from regular selection tasks, the new Select tool is special in allowing you to quickly navigate layer and artboard hierarchies.

  • To drill down a nested group or layer hierarchy, double-click it with the Select tool enabled.
  • Press Esc to step up one level in the hierarchy.

Rectangle & Ellipse

Draw shapes. These tools work in much the same way as in standard Photoshop.

Type

Creates a text layer.

Pen

Works in much the same way as the Pen tool in standard Photoshop.

Note:

While modifying the width, height, or other numeric properties of an object, you can enter math operations to get precise values. For example, 500/3 or 20*4.

Sampler

Advanced sampler tool. Lets you copy colors, effects, and other attributes. Follow these steps:

  1. Select the object to which you want to copy an attribute. For example, select a rectangle.
  2. Select the Sampler tool.
  3. Perform the following action with the object from which you want to copy the attribute:

    Click: Copy the color
    Shift+Click: Copy effects
    Spacebar: Invokes a heads-up display revealing the available attributes that you can sample. Whenever applicable, these attributes includes Typeface.

Photoshop Copying an attribute
Click the attribute that you want to copy

Search for documents, commands, and much more

Design Space (Preview) features comprehensive search functionality that lets you search across the following items among others:

  • Menu commands
  • Open documents
  • Recent documents
  • Layers, pixel layers, adjustment layers, group layers, vector layers, and text layers
  • Artboards
  • Libraries—all or a specific one
  • Smart objects
  • Styles
  • Graphics
  • Presets

While searching, you can filter your search results, so that they include only a specific type of items.

Follow these steps:

  1. Select Edit > Search to invoke the search functionality. Alternatively, press Ctrl/Cmd+F or click the Search icon at the left of the title bar.
Photoshop Search functionality
Comprehensive search functionality

Photoshop Filtered search
Filtered search; in this example, we're searching within Creative Cloud libraries

Quickly create vector masks for layers

Design Space (Preview) makes creating masks for images in your project really straightforward.

  1. Select a layer in the Layers panel.
  2. Click the Mask Mode ()icon in the Design Space top bar. Alternatively, press M to use the keyboard shortcut. While the Mask Mode is enabled, the Select tool arrow turns hollow () and the Mask Mode icon turns blue.
  3. Using tools such as the Pen tool and the Rectangle tool, draw a mask for your image.
  4. When you're done creating the mask, exit the Mask Mode in one of the following ways:
  • Click the Mask Mode icon ().
  • Press Esc.
  • Press the Mask Mode keyboard shortcut—M.

Manage and arrange objects

Create guides

Create guides in the Design Space (Preview) workspace to work acuurately with design elements.

  1. Ensure that View > Show Guides is selected.
  2. Click the Select tool and hover the mouse pointer over the edge of the work area. Notice the blue highlight indicating that guide creation is available.
  3. Click and drag out a guide.

    If an artboard or a layer within an artboard is selected, an artboard-specific guide is created. Such a guide is displayed only when that artboard or its sub-layers are selected. If no artboard or a layer within an artboard is selected, a document-specific guide is created.

Distribute objects

  1. Select three or more layers.
  2. Choose Arrange > Distribute Objects and choose a command. Alternatively, select a distribution button from the Distribute and Alignment panel.
  • Horizontally    Spaces the layers evenly, starting from the horizontal center of each layer.
  • Vertically    Spaces the layers evenly, starting from the vertical center of each layer.

Align objects

  1. Select two or more layers.
  2. Choose Arrange > Align Objects and choose a command. Alternatively, select an alignment button from the Distribute and Alignment panel.
  • Left    Aligns the left pixel on the selected layers to the left pixel on the leftmost layer
  • Center    Aligns the horizontal center pixel on the selected layers to the horizontal center pixel of all the selected layers
  • Right    Aligns the right pixel on the linked layers to the rightmost pixel on all selected layers
  • Top    Aligns the top pixel on the selected layers to the topmost pixel on all selected layers
  • Middle    Aligns the vertical center pixel on each selected layers to the vertical center pixel of all the selected layers
  • Bottom    Aligns the bottom pixel on the selected layers to the bottommost pixel on selected layers

Transform objects

You can apply transformations to a single layer or multiple layers. To make a transformation, first select an item to transform and then choose a transformation command. While modifying the width, height, or other numeric properties of an object, you can enter math operations to get precise values. For example, 500/3 or 20*4.

Rotate

  1. Choose Layer > Transform and choose a command.
  • Rotate 180   Rotates the item by 180 degrees
  • Rotate Right    Rotates the item clockwise by 90 degrees
  • Rotate Left   Rotates the item counterclockwise by 90 degrees
  1. You can also rotate an object directly on canvas. With an object selected, hover over the corner and the widget changes to allow for rotation.
Photoshop Rotating an object
Rotate an object on canvas

Flip

  • Select a flip command from the Arrange menu.  
    • Flip Horizontal   Flips the item horizontally
    • Flip Vertical    Flips the item vertically
    • Swap Position   Swap the position of the two selected groups or layers

Change the appearance of objects

You can make changes to the object by modifying the options available in the Appearance panel.

Opacity

A layer’s overall opacity determines to what degree it obscures or reveals the layer beneath it. A layer with 1% opacity appears nearly transparent, whereas one with 100% opacity appears completely opaque.

  1. In the Layers panel, select one or more layers.
  2. Specify a value for opacity in the Appearance panel.

Blending mode

A layer’s blending mode determines how its pixels blend with underlying pixels in the image. You can create various special effects using blending modes.

  1. In the Layers panel, select one or more layers.
  2. Choose one of the following blending modes in the Appearance panel:
  • Normal
  • Dissolve
  • Darken
  • Lighten
  • Screen
  • Overlay
  • Multiply
  • Color Burn
  • Linear Burn
  • Darker Color

If you use any other blend mode in standard Photoshop, that blend mode is honored in Design Space (Preview) as well.

For more information about what each blending mode does, see Blending modes.

Type

  1. In the Layers panel, select the text layer.
  2. Specify the following settings in the Appearance panel:
  • Typeface   Set font from the drop-down.
  • Weight   Set weight based on the font you selected.
  • Text Color Select the Text Color in one of the following ways:
    • Select the color from the color picker.
    • Specify a value for the color. See CSS Legal Color Values for a ready reference of color values.
    • Specify a common name for color, such as tomato or magenta. For the supported list of names, see Extended color keywords.
  • Size   Set size of the selected text.
  • Letter    Set letter spacing.
  • Line   Set line spacing.
  • Align   Align the text left, center, right, or justify.

Vector

With the help of vector tools, you can use Add, Subtract, Intersect, or Exclude options to modify the current shapes on a layer or combine one or more selected shape layers.

  1. In the Layers panel, select the layers you want to combine.
  2. Select Layers > Combine and then choose one of the following:
  • Unite Shape    Adds the new area to the existing shapes or path
  • Subtract Shape    Removes the overlapping area from the existing shapes or path
  • Intersect Shape    Restricts the area to the intersection of the new area and the existing shapes or path
  • Difference Shape    Excludes the overlap area in the consolidated new and existing areas

Fill

  1. In the Layers panel, select one or more layers.
  2. Open the fill color selector in the Appearance panel and then specify a color in one of the following ways:
  • Click a color in the color picker.
  • Specify a value for the color. See CSS Legal Color Values for a ready reference of color values.
  • Specify a common name for color, such as tomato or magenta. For the supported list of names, see Extended Color Keywords.
  1. Specify the alpha value to set the opacity of the fill color.

Stroke

  1. In the Layers panel, select one or more layers.
  2. Open the stroke color selector in the Appearance panel and then specify a color in one of the following ways:
  • Click a color in the color picker.
  • Specify a value for the color. See CSS Legal Color Values for a ready reference of color values.
  • Specify a common name for color, such as tomato or magenta. For the supported list of names, see Extended Color Keywords.
  1. Specify the alpha value to set the opacity of the stroke color.
  2. Specify the size of the stroke.
  3. Specify the alignment of the stroke as Inside, Center, or Outside from the pop-up menu.

Apply layer effects

  1. In the Layers panel, select one or more layers.
  2. In the Effects panel, click the + icon to add a stroke, color overlay, drop shadow, or inner shadow.

Stroke

Adds a stroke effect to the selected layer.

Color Overlay

Fills the layer’s content with a color.

Drop Shadow

Adds a shadow that falls behind the contents on the layer.

Inner Shadow

Adds a shadow that falls just inside the edges of the layer’s content, giving the layer a recessed appearance.

  1. Specify the necessary settings for the effect. 
  • For color overlays, you can specify a blending mode. For information on what each blending mode does, see Blending modes.
  • For inner shadows and drop shadows, you can specify the following settings:
    • Blending mode
    • The X and Y coordinates of the shadow
    • The extent to which you want the shadow to be blurred
    • The spread of the shadow. The Spread setting expands the boundaries of the shadow prior to blurring.

Creative Cloud Libraries integration

You can now use Creative Cloud Libraries to organize, access, and share your assets from right within the Design Space (Preview) interface. You work with libraries in Design Space (Preview) in much the same way as in standard Photoshop. For more information, see these resources:

Export assets

You can export artboards, layers, layer groups, or entire documents as PNG, JPEG, SVG, or PDF assets from directly within the Design Space (Preview) interface.

  1. In the Export panel, click + to specify export settings for the selected layers from which you want to generate assets.
  2. Specify the Scale, Suffix, and Format for the asset you want to export.
  3. If necessary, click + to specify settings for more assets.
  4. Click the icon to save the generated assets to your computer.

Note:

Click the icon to quickly add all available asset types relevant for iOS devices. Similarly, click the icon to quickly add all asset types relevant to HiDPI displays.

Note:

While exporting multiple objects as assets, for ease of use, Design Space follows the canvas order of objects instead of their Z-order in the Layers panel. You can also specify multiple export settings via different layer selections and export them all at once by selecting File > Export or clicking the Export icon on the top title bar.

Top known issues in this release

  • Entering a negative transform value for a Library-Linked Smart Object results in an error. Entering a negative number into the Width or Height field puts Design Space (Preview) into an internal error state where layer is no longer selectable or visible on-canvas and controls are unresponsive.

    Solution/workaround: Select Window > Return To Standard Photoshop and Step Backward In History until the layer becomes visible on canvas.
  • Using the Sampler tool a second time on the same Library Linked Smart Object after Undo of the first attempt results in an error.

    Solution/workaround: Undo twice before attempting the second sample.
  • Opening an Illustrator file (Import PDF) results in an error.

    Solution/workaround: Select Window > Return To Standard Photoshop. Now, return to Design Space (Preview).
  • Sometimes a Library Linked Smart Object has the Swap functionality enabled when only one layer is selected.

    Solution/workaround: Clicking the Swap icon corrects the problem.
  • Creating a shape in standard Photoshop and having it selected while entering Design Space (Preview) changes the shape Fill and Stroke settings.

    Solution/workaround: Either deselect the shape before entering Design Space or Undo after entering Design Space.
  • Trying to export while in the Type edit mode fails and disables the Export panel icon.

    Solution/workaround: Use the menu command or the export icon in the doc header. Returning to standard Photoshop and back to Design Space (Preview) reenables the Export panel icon.
  • When no layer is selected, creating a shape with the Pen tool places it outside the artboard in the Layers panel but inside the artboard on-canvas.

    Solution/workaround: After creating the shape, click the Select tool and nudge (hit an arrow key via the keyboard).
  • Undo after creating a layer mask leaves a reveal an all-mask applied to the layer. This makes the layer appear as though there is no mask applied. However, the Layers panel icon still erroneously shows that the layer has a mask.

    Solution/workaround: Perform the Undo operation twice.
  • Paths are created without the modifier keys after the first path. When you remove the first path drawn, the action acts like a subtraction.

    Solution/workaround: Hold down the Shift key before drawing.
  • Layer highlighting issues. If no layers are selected, hovering the mouse pointer over layers does not highlight them. The Cmd/Ctrl modifier does not work either. If a layer is selected, the Cmd/Ctrl modifier only shows smart guides but not the Design Space (Preview) highlighting (blue).
  • (Windows-only) You can't currently pan the canvas by scrolling with a trackpad on Windows.
  • X and Y coordinates are incorrect after moving the artboard on the canvas.
  • Moving a layer off the artboard and back on corrupts the X-Y coordinates for the layer.
  • Deleting the first mask in a multiple mask situation results in an inverted/subtracted mask.
  • Numbers are not correctly localized. The comma in the numbers display as a dot/period.
  • Exporting assets from a modal tool state results in an error.  

Tips and tricks

  • You can quickly change the background color for the working area. Right-click outside the artboards/other content in the working area and then select a color.
Photoshop Context menu to change background color
Change the background color for the working area

  • Use the following keyboard shortcuts to toggle between the standard Photoshop interface and Design Space (Preview):
    • Cmd+Ctrl+` (Mac)
    • Alt+Ctrl+` (Windows)
  • Double-click a layer name in the Layers panel to rename it.
  • Double-click the canvas to drill down into your layer hierarchy. Press Esc to back your layer selection out and deselect layers at the top level.
  • Double-clicking a single layer on the canvas (Type or Vector) puts you in the Edit mode. Pressing Esc exits the Edit mode.
  • Active layers/groups have a blue highlight around them.
  • Click the + icon next to a selected artboard in the document to add a new artboard.
  • Vector and pixel layers show transform handles to resize and rotate; type layers do not display handles.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy