Determine the level of the problem

Troubleshoot printing problems at the document level

Troubleshoot printing problems at the application level

Troubleshoot printing problems at the printer level

Resolve problems printing to a PostScript printer

Resolve problems printing to a non-PostScript printer

Troubleshoot printing problems at the system level

This document can help you resolve problems that occur when you print from Adobe InDesign. To get the most from this document, perform the tasks in order. Keep track of the tasks you perform and the results of each one, including errors or other problems. Adobe Technical Support can use this information to better assist you, should you need to call.

Known printing problems and solutions to specific errors are documented in the Adobe Support Knowledgebase on the Adobe website at www.adobe.com/support/. If you can't find a specific solution to your problem, follow these procedures to isolate and resolve the issue.

When you attempt to resolve a printing issue, the first step is to determine the conditions under which the problem occurs. For example, was the error a one time problem or can it be reproduced consistently when printing all documents, some documents or a specific document. The steps and tests below will help you define how and when your printing issue occurs so that a solution can be found.

Determine the level of the problem

You should first verify whether the problem is a recurring issue. If the issue recurs consistently, then you can whether it is caused at the document, application, or system level.

1. Restart the computer and try printing again.

If the error doesn't occur, it may have been caused by a temporary communication problem, low system resources, or other temporary environmental factors. If you can print without error when you first restart the computer, but the error occurs again later, troubleshoot the issue at the system level.

2. Turn off the printer, turn it back on, and then try printing again.

If the error doesn't occur, an issue with the printer's memory may have caused the problem. If the error recurs further troubleshooting is required.

3. Create a new document, draw a box on the page using the Rectangle tool, and print the document.

If you can print a new document, but not the original document, troubleshoot the error at the document level.

4. Print from another application.

If you can print from another application (for example, WordPad or TextEdit) but not from InDesign, troubleshoot the problem at the application level.

5. Print to another printer.

If another printer is available, then try printing the document to another printer. If you can print to a different printer, then check to make sure that the original printer is turned on and is online. Remove and reconnect the printer cables, ensure that they are connected properly, and then run a self-test on the printer to check for mechanical failure or damaged cables. If none of these steps identify the problem, then troubleshoot the error at the system level.

Troubleshoot printing problems at the document level

If the error doesn't occur when you print a new document, the document's print settings may be invalid, a particular object or font used in the document may be damaged, or the structure of the document may be damaged. Do one or more of the following tasks to troubleshoot an error that occurs only when you print a particular document.

Note: Problems that occur at the system level may appear to be document-specific if they occur due to the complexity of the document.

1. If you print to a PostScript printer, send the PostScript error handler to the printer.

Windows:

  1. Choose File > Print.
  2. Click the Setup button.
  3. Right-click the printer and choose Properties.
  4. In the General tab, click Printing Preferences.
  5. Click Advanced.
  6. Expand Document Options and then expand PostScript Options. If Send PostScript Error Handler is not set to Yes, click it and choose Yes from the pop-up menu.

Mac OS X:

  1. Choose File > Print.
  2. Click the printer.
  3. Choose Error Handling from the menu below the Presets menu.
  4. Select Print Detailed Report, and then click Print.
  5. Click Print.

If a PostScript error is causing the problem, the PostScript error handler prints a page with error information. For help interpreting PostScript errors, see document 328515, Troubleshoot PostScript errors."

2. Exclude graphics when you print the document.

To exclude graphics when you print the document:

  1. Choose File > Print.
  2. Click Graphics, and then choose None from the Send Data menu.
  3. Click Print.

If the document prints successfully, one or more of the graphic elements on the page may be damaged. Remove the graphics one at a time, and print the document after you remove each graphic to determine whether a damaged graphic is causing the print error. Delete and replace any damaged graphics. You may need to re-export a graphic from the application in which you created it.

A successful print job may also indicate inadequate printer memory. Common symptoms of insufficient printer memory include fonts being substituted and missing data. Simplify the publication to see if it will print with fewer graphics.

Note: If the document contains only graphical elements, then you will receive a blank page when you print only if the option to print blank pages is enabled in InDesign (select Print Blank Pages in the General section of the Print dialog box).

3. If you print to a PostScript printer, exclude fonts when you print.

If you choose to exclude fonts when you print from InDesign, the printer substitutes printer-resident fonts for fonts that are specified in the document instead of downloading the fonts to the printer.

To exclude fonts when you print:

  1. In InDesign, choose File > Print.
  2. Click Graphics.
  3. In the Fonts section, choose None from the Download menu.

If the document prints, the printing problem may be related to one of the fonts used in the document. If the document uses a large number of fonts, excluding the fonts makes the document less complex. Test the fonts that are specified in the document one at a time in a new document to determine if one or more of the fonts is damaged.

When you place graphic and text elements in a document, InDesign creates a link to the original graphic. InDesign relies on the original graphic to obtain information it uses to display and print the file correctly.

To view the status of links, choose Window > Links. Unlink or relink any files where the file name is preceded by a question mark or other symbol. For an explanation of the various symbols that may appear in the Links dialog box, see "About the Links palette" in InDesign Help. For additional information about links in InDesign, see "Managing links and embedded graphics" in InDesign Help.

5. Use the Console utility to identify software conflicts. (Mac OS)

If the problem causes InDesign to freeze, the Console utility can identify software that causes the conflict.

To use the Console utility to identify software conflicts:

  1. Choose Go > Applications, open the Utilities folder, and then double-click Console.
  2. Choose Console > Preferences
    • For Mac OS 10.4.x and earlier, click the Crashes tab and select Log Crash Information in ~/Library/Logs/, and then select Automatically Display Crash Logs.
    • For Mac OS 10.5.x and later, select the Bring log window to front option.
  3. Restart InDesign, and try to re-create the problem. If the problem recurs, reinstall or update the software identified in the crash log.

6. Troubleshoot third-party plug-ins.

Remove third-party plug-ins from the InDesign [version] Plug-ins folder, and then restart InDesign. If the problem recurs, move the plug-ins back to the InDesign Plug-ins folder. If the problem doesn't recur, identify conflicting plug-ins.

To identify conflicting plug-ins:

  1. Choose Help > Configure Plug-Ins (Windows) or InDesign > Configure Plug-Ins (Mac OS).
  2. Select All Plug-Ins for the Set and then deselect all the options in the Display section except Third Party. Create a list of these Plug-Ins.
  3. Quit InDesign and move one third-party plug-in back to the InDesign plug-ins folder:

    • Windows: C:\Program Files\Adobe\Adobe InDesign [version]\Plug-Ins
    • Mac OS X: [Computer]/[Hard Drive]/Applications/Adobe InDesign [version]/Plug-Ins
  4. Restart InDesign and try to re-create the problem:
    • If the problem doesn't occur, repeat steps 3-4.
    • If the problem recurs, contact the developer of the plug-in you last moved to inquire about an update.

7. Print from within a new user account.

Occasionally, a user account can become corrupted and prevent the installer from accessing or creating the necessary files and folders. Create a new account, log in to the new account, and then try to install or run the Adobe application. Do not delete your existing Windows account â” the new account is only for testing purposes, and you can revert back to your original Windows account after you finish testing. Once you have the new account setup, login to it and see if you can reproduce the problem.

On Windows:



On Windows XP, you can create a new user account by going to Start button > Settings> Control Panel > User Accounts.



For Windows Vista, see the " Create new local administrator account " section of "Common Microsoft Windows Vista procedures" (TechNote kb401275 ).

For more details on creating a new Windows user account, consult with your IT administrator or the Windows documentation.

On Mac OS X v10.5.x:

  1. From the Apple menu, choose System Preferences.
  2. Click Accounts.
  3. Click the lock icon in the lower-left corner of the window and enter your administrator password, then click the OK button.
  4. Click the plus sign toward the bottom of the window on the left.
  5. Set the Account type to Administrator.
  6. Enter the user name (for example, type test). Make sure to enter a password that you'll remember, such as test,
  7. Click the Create Account button, and then close the Accounts window.
  8. Choose Log Out from the Apple menu.
  9. When the log in screen displays, choose the test user.

On Mac OS X v10.3.x - 10.4.x:

  1. From the Apple menu, choose System Preferences.
  2. Click Accounts.
  3. If the lock icon in the lower-left corner of the window displays as locked, click it and enter your administrator password, then click the OK button.
  4. Click the plus sign toward the bottom of the window on the left.
  5. Enter the user name (for example, type test). Make sure to enter a password that you'll remember, such as test.
  6. Click the Security button (OS 10.3.x only)
  7. Select the checkbox next to Allow User To Administer This Computer. This makes the test user an administrator.
  8. Click the Create Account button, and then close the Accounts window.
  9. Choose Log Out from the Apple menu.
  10. When the log in screen displays, choose the test user.

8. Troubleshoot the document as a damaged document.

Perform the tasks listed in document kb403982, "Troubleshoot damaged InDesign documents (CS3, CS4)".

Troubleshoot printing problems at the application level

If you receive an error when you print any InDesign document, one of the InDesign resource files may be damaged, or InDesign may be incompatible with the printer driver, video driver, or another device driver on the system. Do one or more of the following tasks to identify the cause of an application-wide problem.

1. Rename or delete the InDesign Defaults and the InDesign SavedData files.

Note: Re-creating the InDesign preference files restores settings to their defaults, so you will lose custom settings associated with the old preference files. Make sure to close InDesign before you re-create the preference files or InDesign may behave unexpectedly.

To re-create the InDesign preference files automatically:

  1. Quit InDesign.
  2. Now launch the application and immediately hold down the appropriate keys for your OS:
    • Mac OS X: Control + Option +Command + Shift
    • Windows: Control + Alt + Shift
  3. A dialog will pop up asking you if you would like to "Delete InDesign Preference Files?" Click Yes.
  4. InDesign will now launch with defaults and regenerated Preferences

To re-create the InDesign preferences files manually:

  1. Delete or rename the preferences files.
    • On Mac OS X:

      InDesign SavedData

      Users/[user]/Library/Caches/Adobe InDesign/Version 5.0/InDesign SavedData

      InDesign Defaults

      Users/[user]/Library/Preferences/Adobe InDesign/Version 5.0/InDesign Defaults
    • On Windows XP:

      InDesign Defaults

      C:\Documents and Settings\[user]\Application Data\Adobe\InDesign\Version 5.0

      InDesign SavedData

      C:\Documents and Settings\[user]\Local Settings\Application Data\Adobe\InDesign\Version 5.0\Caches
    • On Windows Vista:

      InDesign Defaults

      C:\Users\labuser\AppData\Roaming\Adobe\InDesign\Version 5.0\InDesign Defaults

      InDesign SavedData

      C:\Users\labuser\AppData\Roaming\Adobe\InDesign\Version 5.0\Caches\InDesign SavedData
  2. Restart InDesign. InDesign creates new preference files.

If the problem persists, then you can restore the original preferences by deleting the new files and renaming the old preference files back to their original names.

2. Make sure that you have the most recent printer driver installed for the printer to which you're printing. (Windows only)

Install the most recent driver for the printer to which you print:

  • If you print to a PostScript printer, download the Adobe Universal PostScript Windows Driver Installer from the Adobe website at www.adobe.com/support/downloads/ .
  • If you print to a non-PostScript printer, contact the printer manufacturer for the latest version of the driver for the printer.

3. If you print to a PostScript printer, optimize PostScript for speed. (Windows only)

  1. Choose File > Print.
  2. Click Setup, and do one of the following tasks:
    • In Windows Vista or XP, click Setup, select a printer, click Preferences, and then click Advanced.
    • In Windows 2000, click the Layout tab, and then click Advanced.
  3. Expand Document Options, and then expand PostScript Options.
  4. Choose PostScript Output Option.
  5. Choose Optimize for Speed from the pop-up menu, and then click OK.
  6. Click OK and then click Print.

4. Disable the Page Protection feature.

See the documentation included with the printer for instructions on how to disable this feature.

5. If the problem occurs when you print over a network, connect the computer directly to the printer and try printing again.

If you can't connect directly to the printer, then save the document as a PostScript file and then send the file to the printer from a command line on a computer that can be connected directly to a printer. For more information about creating a PostScript file, see "Creating a device- and driver-dependent PostScript file" in InDesign Help.

6. Make sure the printer to which you're printing supports the current printing operations.

For example, you shouldn't print color separations of EPS graphics to a non-PostScript printer. For more information about the printer's capabilities, contact the printer manufacturer.

7. Ensure that you've installed any available updates for the version of InDesign you use.

Adobe posts updates and bug fixes to InDesign periodically on its website at www.adobe.com/support/downloads/.

Troubleshoot printing problems at the printer level

Determine whether you are using a Postscript or a non PostScript printer. Once you have determined which kind of printer you are using, follow the appropriate steps below.

To verify that you are using a Postscript printer, check the printer properties (Windows only):

Note: If you are using a Macintosh computer, then check your printer documentation or contact your printer manufacturer to determine if your printer is a Postscript device.

  1. Open the Printers control panel.
  2. Right-click the desired printer and choose Properties.
  3. Choose the Device Setting tab.
  4. Right-click the driver name at the top of the tree and choose About.

If you are using a PostScript printer, "PostScript Printer Driver" appears at the top of the window along with the driver version, the PPD name, and the PPD version.

Resolve problems printing to a PostScript printer

If you have problems printing to a PostScript printer, do one or more of the following tasks, printing after each task:

1. Use an updated printer driver.

Use the Universal Installer (WinInstaller) to automatically install the PostScript printer driver that is compatible with your version of Windows. The most recent version of the Universal Installer is available on the Adobe website at www.adobe.com/support/downloads/main.html.

Note: If you use a network printer, then the print server may not be set up to run alternate drivers for different operating systems on client computers. You may be using a printer driver that is compatible with the print server's operating system but not with your computer's operating system. To install a printer driver that is compatible with your operating system, reconfigure the network printer using the Add Printer Wizard. For instructions, see task 6 below, "Install a printer driver that is compatible with your operating system."

2. Use an updated PPD file.

A PostScript Printer Description (PPD) file describes the capabilities of a PostScript printer for settings such as margins, color, and resolution. Incorrect or outdated PPD files can increase print times. Configure your printer in the Printers Control Panel with the PPD file recommended by the printer manufacturer.

To obtain a PPD file for your device, contact the printer manufacturer or visit www.adobe.com/support/downloads/main.html.

3. Set up the printer driver to output optimized PostScript code. (Windows only)

If you set up the printer driver to output PostScript code that's optimized for portability and in binary format, the amount of scaling the driver must do is minimized, thus preventing it from losing portions of images.

  1. Choose Start > Settings > Printers.
  2. Right-click the printer, and choose Properties.
  3. Click the General tab.
  4. Click Printing Preferences, and then click Advanced.
  5. Expand the Document Options, and then expand the PostScript Options.
  6. Set PostScript Output Option to Optimize For Portability.

4. Create more free disk space.

Make sure that plenty of free hard disk space is available: Adobe recommends that free space is equivalent to three to five times the size of the file you print. To create more space, search for and delete temporary (.tmp) files on your computer, and clear the disk cache that the web browser uses. For instructions about clearing the disk cache, see the documentation for the browser. You can also free up disk space bypassing the spool file, which stores temporary files to the system disk during printing. For instructions for bypassing the spool file, see the documentation included with Windows.

5. Print from a local printer.

If you print to a network printer, try printing the file from a computer that is connected directly to a local printer. If the file prints correctly, network-related issues may be the cause. Contact the network administrator for assistance.

6. Install a printer driver that is compatible with your operating system.

If you use a network printer, then install a printer driver that is compatible with your operating system. Print servers don't always provide drivers for operating systems running on client computers, so you may be using a printer driver that is appropriate for the print server's operating system but not for your computer's operating system.

  1. Choose Start > Settings, and then double-click Printers And Faxes (Windows XP) or Start > Control Panel > Hardware > Printers (Windows Vista).
  2. Right-click the network printer, and then choose Delete.
  3. Double-click Add Printer, and then click Next.
  4. Select Local Printer Attached To This Computer, deselect Automatically Detect And Install My Plug And Play Printer, and then click Next.
  5. Select Create A New Port.
  6. Choose Local Port from the Type of Port menu, and then click Next.
  7. In the Port Name dialog box, type the path for the print server and printer (for example, \\printservername\printername), and then click OK.
  8. Follow the onscreen instructions to install a driver that matches the brand and model of your network printer.

Resolve problems printing to a non-PostScript printer

If you have problems printing to a non-PostScript printer, do one or more of the following tasks, printing after each task:

Disclaimer: Some of these solutions require you to change the printer driver properties. The locations for specific properties vary by printer and by printer driver. Therefore, Adobe Technical Support cannot provide detailed information about the location for each property. Contact the printer manufacturer or refer to the printer documentation for more information.

1. Try printing as bitmap

By default, InDesign uses GDI commands to print to non-PostScript printers on Windows, and PostScript to print to the Mac OS X CUPS printing architecture, which passes the data as PDF to the printer driver to convert to it's native drawing language. Where possible, InDesign offers an option to send each page as bitmap data encapsulated within standard non-Postscript printing protocols. To enable this option

  1. Choose File > Print.
  2. Click the Advanced pane.
  3. Check the Print as Bitmap checkbox. Select an appropriate resolution for your printer.

2. Ensure that the printer has enough memory.

Ensure that the printer has enough memory to print all page elements. To print at 300 dpi, the printer should have at least 2 MB of available RAM. To print at 600 dpi, the printer should have at least 4 to 6 MB of RAM. For instructions on determining available printer memory, see the printer documentation.

3. Use the printer's PostScript mode.

If the printer has a PostScript option, use the PostScript mode. For details, see the printer documentation.

4. Switch to the standard SVGA driver.

Switch to the standard Windows SVGA driver to determine if your third party video driver causes the problem. If the error doesn't occur when you use the standard SVGA driver, then contact the video card manufacturer for an updated driver. If you already use the current version, then try using a different video resolution (for example, 1024 x 768 rather than something higher).

Troubleshoot printing problems at the system level

If nothing prints from any application, then contact Apple Technical Support, Microsoft Technical Support, or the printer manufacturer. Always check the physical connection between the printer and the computer before calling, as the solution may be as simple as reconnecting a loose cable.

Also, consider what has changed on the system recently that may be impacting the printing process. For example, have you performed any of the following tasks:

  • Updated your hardware
  • Added new software
  • Updated existing software
  • Deleted software
  • Installed or deleted fonts
  • Added or removed hardware components
  • Recently connected to a network
  • Cleaned up the hard drive, or erased unused files
  • Encountered random system errors
  • Encountered errors in any other applications

Often, a change to the system directly corresponds to the appearance of a printing problem. You should keep a record of changes made to the system as a resource for troubleshooting printing and other problems.

Additional Information

kb403982: Troubleshoot damaged InDesign documents ( CS3,CS4)

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy