Problema

L'icona PDFMaker (Converti in Adobe PDF) e il menu Acrobat non vengono visualizzati in un'applicazione Microsoft Office 2003, XP o 2000 (ad esempio Access, Excel, Word).

Soluzione

Provate una o più delle seguenti soluzioni:

Soluzione 1: rimuovete Adobe PDF dall'elenco degli elementi disattivati nell'applicazione di Microsoft Office.

  1. Aprite il programma Microsoft Office (Word, Excel, Publisher).
  2. Scegliete ? > Informazioni su [nome programma].
  3. Fate clic su Elementi disattivati.
  4. Selezionate Adobe PDF dall'elenco e fate clic su Abilita.
  5. Chiudete l'applicazione di Microsoft Office, quindi riavviatela.

Nota: le applicazioni di Microsoft Office disattivano i componenti aggiuntivi come misura di sicurezza, in caso di chiusura improvvisa dell'applicazione (ad esempio se il sistema non è stato chiuso correttamente o se l'applicazione si è arrestata in modo anomalo).

Soluzione 2: verificate che i componenti PDFMaker siano installati.

  1. Scegliete Start > Esegui e digitate appwiz.cpl nella casella di testo Apri, quindi fate clic su OK per aprire la finestra di dialogo Installazione applicazioni.
  2. Individuate e selezionate Adobe Acrobat 7 o Adobe Acrobat 8, quindi fate clic su Cambia/Rimuovi.
  3. Quando viene visualizzata la procedura guidata, fate clic su Avanti.
  4. Selezionate Modifica e quindi fate nuovamente clic su Avanti.
  5. Espandete la vista struttura Crea PDF Adobe e fate clic sulla freccia giù in corrispondenza dell'oggetto Acrobat PDFMaker.
  6. Selezionate "La funzionalità specificata verrà installata sul disco rigido locale", fate clic su Avanti, quindi su Aggiorna.

Soluzione 3: abilitate il file COM del componente aggiuntivo nell'applicazione Office.

  1. Avviate l'applicazione Office.
  2. Scegliete ? > Informazioni su [nome dell'applicazione].
  3. Fate clic su Elementi disattivati.
  4. Verificate nell'elenco la presenza di PDFMakerOfficeAddin:
    • Se è presente, selezionatelo e fate clic su Abilita. Chiudete tutte le finestre di dialogo e riavviate l'applicazione Office.
    • Se non è presente nell'elenco, assicuratevi quindi che PDFMOfficeAddin.dll sia posizionato nella cartella Acrobat 7.0/PDFMaker/Office (Acrobat 7, Acrobat 3D) o Acrobat 8.0/PDFMaker/Office (Acrobat 8). Se il file risulta mancante, reinstallate Acrobat.

Soluzione 4: rinominate il file Normal.dot.

Per impedire che la formattazione, le voci di glossario e le macro archiviate nel modello globale (Normal.dot) modifichino il comportamento di Microsoft Word e di altre applicazioni, rinominate il modello globale (Normal.dot). In tal modo, sarà facile determinare se il modello globale è la causa del problema.

Importante: quando rinominate il modello Normal.dot varie opzioni, tra cui stili personalizzati, barre degli strumenti personalizzate, macro e voci di glossario (AutoText), verranno riportate alle impostazioni predefinite. Pertanto Microsoft consiglia vivamente di non eliminare il file Normal.dot.

Alcune configurazioni potrebbero creare più di un file Normal.dot. Ciò può verificarsi ad esempio se un computer esegue più versioni di Word o se sullo stesso computer coesistono varie installazioni workstation.

Per rinominare il file Normal.dot:

Nota: i seguenti passaggi sono specifici per Microsoft Word, ma possono essere utilizzati con lievi modifiche anche per altre applicazioni di Microsoft Office. Evitate di utilizzare l'opzione /a per il riavvio di Word o di un'altra applicazione dopo il completamento di questa procedura.

In Windows 2000:

  1. Chiudete tutte le istanze di Word, compreso Outlook se Word è impostato come editor di posta elettronica.
  2. Scegliete Start > Cerca > File o cartelle.
  3. Nella finestra Nome digitate Normal.dot.
  4. Nella casella Cerca in selezionate il disco rigido locale.
  5. Fate clic su Cerca per cercare il file.
  6. Per ciascuna ricorrenza del file Normal.dot visualizzata nella finestra di dialogo Risultati ricerca, effettuate le seguenti operazioni:
    • Fate clic con il pulsante destro del mouse sul file, quindi selezionate Rinomina.
    • Assegnate un nuovo nome al file (ad esempio, OldNormal.dot o Normal-1.dot), quindi premete Invio.
  7. Nel menu File fate clic su Chiudi per uscire dalla ricerca, quindi riavviate Word.

In Windows XP:

  1. Chiudete tutte le istanze di Word, compreso Outlook se Word è impostato come editor di posta elettronica.
  2. Selezionate Start > Cerca.
  3. In Scegliere il tipo di oggetto da cercare, selezionate Tutti i file e le cartelle.
  4. Nella casella Nome del file o parte del nome, digitate Normal.dot.
  5. Nella casella Cerca in scegliete il disco rigido locale o una posizione alternativa del modello utente Word è eseguito da un server di rete.
  6. Fate clic su Cerca.
  7. Per ciascuna ricorrenza del file Normal.dot visualizzata nella finestra di dialogo Risultati ricerca, effettuate le seguenti operazioni:
    • Fate clic con il pulsante destro del mouse sul file, quindi selezionate Rinomina.
    • Assegnate un nuovo nome al file (ad esempio, OldNormal.dot o Normal-1.dot), quindi premete Invio.
  8. Nel menu File fate clic su Chiudi, quindi riavviate Word.

Se la ridenominazione del file risolve il problema, significa che il modello Normal.dot è danneggiato.

Soluzione 5: modificate il livello di sicurezza delle macro nell'applicazione Office.

Per far sì che il file COM del componente aggiuntivo sia caricato in Windows, verificate che nella scheda Autori attendibili sia visualizzato Adobe Inc. In caso contrario, è necessario modificare le impostazioni di protezione.

Nelle applicazioni di Office 2000, XP o 2003:

  1. Dal menu Strumenti scegliete Macro > Protezione.
  2. Fate clic sulla scheda Fonti attendibili:
    1. Se è visualizzato Adobe Inc. non è necessaria alcuna modifica.

    2. Se Adobe Inc. non è elencato, procedete con il passaggio 3.

  3. Scegliete una delle seguenti impostazioni:
    • Nella scheda Protezione, impostate il livello di protezione su Molto elevato; nella scheda Autori attendibili selezionate Considera attendibili tutti i modelli e i componenti aggiuntivi installati.
    • Nella scheda Protezione, impostate il livello di protezione su Elevato; nella scheda Autori attendibili deselezionate Considera attendibili tutti i modelli e i componenti aggiuntivi installati.
  4. Chiudete tutte le finestre di dialogo e riavviate l'applicazione.

Soluzione 6: aggiungete il file del componente aggiuntivo COM al registro di Windows.

  1. In Windows Explorer, individuate il file del componente aggiuntivo COM (PDFMOfficeAddin.dll) e annotate il percorso completo, che potrebbe includere spazi.
  2. Scegliete Start > Esegui.
  3. Digitate regsvr32 seguito da uno spazio, quindi digitate il percorso annotato nel passaggio 1, includendolo tra virgolette. Ad esempio:

    regsvr32 "C:\Programmi\Adobe\Acrobat 8.0\PDFMaker\Office"
  4. Fate clic su OK e avviate l'applicazione Office.

Soluzione 7: chiudete tutte le applicazioni ed eseguite il comando Rileva problemi e ripristina.

  1. Chiudete tutte le applicazioni e riavviate Windows.
  2. Avviate Acrobat.
  3. Scegliete ? > Rileva problemi e ripristina e seguite le istruzioni visualizzate.
  4. Al termine del ripristino, riavviate il computer.

Soluzione 8: rimuovete e reinstallate Acrobat in modalità semplificata.

I driver dei dispositivi e i programmi software caricati automaticamente all'avvio di Windows (ad esempio screen saver e utilità di protezione contro i virus) possono entrare in conflitto con il programma di installazione di Acrobat e causare problemi all'interno dell'applicazione. Per impedire l'insorgere di conflitti, ripetete l'installazione di Acrobat eseguendo Windows in modalità semplificata. In questa modalità, i driver dei dispositivi e i programmi software non standard eseguiti all'avvio vengono disabilitati.

Disinstallare Acrobat:

  1. Spostate in un'altra posizione eventuali file personali presenti nella cartella di Acrobat e nelle relative sottocartelle.
  2. Scegliete Start > Impostazioni > Pannello di controllo e fate doppio clic su Installazione applicazioni.
  3. Selezionate Adobe [prodotto Acrobat] e fate clic su Rimuovi. Seguite le istruzioni visualizzate per rimuovere l'applicazione.
  4. Riavviate il computer.

Reinstallare Acrobat in modalità semplificata:

  1. Uscite dalle applicazioni aperte.
  2. In Esplora risorse, spostate tutte le icone e i collegamenti dalle seguenti cartelle in un altro percorso:
    • Documents and Settings/All Users/Menu Avvio/Programmi/Esecuzione automatica
    • Documents and Settings/ [profilo utente] /Menu Avvio/Programmi/Esecuzione automatica
  3. Riavviate Windows.
  4. Fate clic con il pulsante destro del mouse sulla barra delle applicazioni e scegliete Gestione attività.
  5. Fate clic sulla scheda Applicazioni.
  6. Selezionate tutte le applicazioni in esecuzione e scegliete Termina operazione.
  7. Fate doppio clic sul file Setup.exe nel supporto di installazione e seguite le istruzioni visualizzate per completare l'installazione.
  8. Per riattivare gli elementi di avvio automatico al termine dell'installazione, riportate nelle rispettive cartelle Avvio le icone e i collegamenti spostati nel passaggio 2.

Soluzione 9: rimuovete le macro da Word.

  1. Scegliete Strumenti > Modelli e aggiunte.
  2. Selezionate ciascun elemento e fate clic su Rimuovi.
  3. Uscite e riavviate Word.



    Nota:
    se l'icona Converti in PDF continua a non essere visualizzata, scegliete Strumenti > Modelli e aggiunte e verificate che gli elementi eliminati non siano visualizzati. Se gli elementi eliminati vengono visualizzati, rimuovete la macro da Word o rimuovete l'applicazione con cui è stata installata la macro in Word.

Soluzione 10: rimuovete gli altri file di componenti aggiuntivi COM da Word.

  1. Avviate Word.
  2. Scegliete Strumenti > Personalizza.
  3. Fate clic sulla scheda Comandi e scegliete Strumenti nell'elenco Categorie.
  4. Selezionate Componenti aggiuntivi COM e trascinate la voce sulla barra degli strumenti di Word.
  5. Fate clic sul menu Componenti aggiuntivi COM della barra degli strumenti di Word.
  6. Selezionate e rimuovete tutti i componenti aggiuntivi in Creazione guidata pagina Web e nello strumento Caratteri di Microsoft Word.
  7. Uscite e riavviate Word.

Soluzione 11: ripristinate Access. (solo Access)

Se Access 2000 è stato installato successivamente all'installazione di Office XP o Office 2003, effettuate un'operazione di ripristino di Office per visualizzare il menu PDFMaker.

  1. Scegliete Start > Impostazioni > Pannello di controllo > Installazione applicazioni (Windows 2000) o Start > Pannello di controllo > Installazione applicazioni (Windows XP).
  2. Selezionate Microsoft Office e fate clic su Cambia.
  3. Nella finestra di dialogo Programma di installazione scegliete Reinstalla (Office 2003) o Ripristina (Office XP), quindi fate clic su Avanti.
  4. Scegliete Rileva problemi e ripristina l'installazione di Office, quindi fate clic su Installa.

Soluzione 12: personalizzate le opzioni delle barre degli strumenti. (solo Access)

  1. Selezionate Vista > Barre degli strumenti > Personalizza.
  2. Nella scheda Barre degli strumenti selezionate le opzioni Utilità 1 e Barra dei menu.
  3. Fate clic su Proprietà.
  4. Selezionate Attiva/disattiva.

Soluzione 13: rimuovete dal sistema i file PDFMaker della versione precedente.

  1. Selezionate Start > Cerca.
  2. Selezionate Tutti i file e le cartelle.
  3. Nella casella di testo "Nome del file o parte del nome" digitate PDFMaker.* .
  4. Fate clic su Cerca.

    Nota: la ricerca può richiedere vari minuti a seconda della velocità del sistema.
  5. Eliminate tutti i risultati corrispondenti a file di sistema (ad esempio PDFMaker.DOT o PDFMaker.XLA). Non è necessario eliminare documenti che avete creato e denominato PDFMaker (ad esempio PDFMaker.doc o PDFMaker.pdf).

Soluzione 14: rimuovete Microsoft Works.

Adobe ha verificato che Microsoft Works può entrare in conflitto con Microsoft Word e impedire la visualizzazione in Word del menu Converti in Adobe PDF. Microsoft Works è preinstallato in molti computer.

Per rimuovere Microsoft Works:

  1. Scegliete Start > Esegui e digitate appwiz.cpl nella casella di testo Apri, quindi fate clic su OK per aprire la finestra di dialogo Installazione applicazioni.
  2. Individuate e selezionate Microsoft Works, quindi fate clic su Cambia/Rimuovi.
  3. Quando viene visualizzata la procedura guidata, fate clic su Avanti.
  4. Selezionate Rimuovi, fate clic su Avanti e seguite le istruzioni visualizzate.

Informazioni aggiuntive

Acrobat 7.0-8.0 installa un file componente aggiuntivo COM nella cartella Acrobat 7.0/PDFMaker/Office o Acrobat 8.0/PDFMaker/Office. Il file fornisce icone e comandi dei menu di PDFMaker per Word, Excel, PowerPoint, Access, Publisher e Project. Il file componente aggiuntivo COM deve essere archiviato nel registro di Windows per poter essere disponibile nelle applicazioni.

Le icone PDFMaker non sono visualizzate nella barra degli strumenti se un'applicazione di Office si chiude improvvisamente e disattiva il file del componente aggiuntivo COM.

È possibile che altri file del componente aggiuntivo e macro COM entrino in conflitto con il file del componente aggiuntivo COM per PDFMaker e impediscano la visualizzazione delle icone Converti in PDF sulla barra degli strumenti.

In Access, se non è attivata la visualizzazione della barra degli strumenti Utilità 1, le icone PDFMaker non vengono visualizzate.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online