Guida utente Annulla

Usare i riferimenti visivi per il layout

  1. Guida utente di Dreamweaver
  2. Introduzione
    1. Nozioni di base sul design responsive
    2. Novità di Dreamweaver
    3. Sviluppo Web con Dreamweaver - Panoramica
    4. Dreamweaver / Domande frequenti
    5. Scelte rapide da tastiera
    6. Requisiti di sistema di Dreamweaver
    7. Riepilogo delle funzioni
  3. Dreamweaver e Creative Cloud
    1. Sincronizzare le impostazioni di Dreamweaver con Creative Cloud
    2. Creative Cloud Libraries in Dreamweaver
    3. Utilizzare i file Photoshop in Dreamweaver
    4. Operazioni con Adobe Animate e Dreamweaver
    5. Estrarre file SVG ottimizzati per il Web da Libraries
  4. Aree di lavoro e viste di Dreamweaver
    1. Area di lavoro di Dreamweaver
    2. Ottimizzare l'area di lavoro di Dreamweaver per lo sviluppo visivo
    3. Eseguire ricerche nei file in base al nome file o al contenuto | Mac OS
  5. Configurare i siti
    1. Siti di Dreamweaver
    2. Configurare una versione locale del sito
    3. Collegamento a un server di pubblicazione
    4. Configurare un server di prova
    5. Importare ed esportare le impostazioni di un sito Dreamweaver
    6. Passaggio di siti Web esistenti da un server remoto alla cartella principale del sito locale
    7. Funzioni di accessibilità in Dreamweaver
    8. Impostazioni avanzate
    9. Impostazione delle preferenze del sito per il trasferimento dei file
    10. Specificare le Impostazioni del server proxy in Dreamweaver
    11. Sincronizzare le impostazioni di Dreamweaver con Creative Cloud
    12. Utilizzo di Git in Dreamweaver
  6. Gestire i file
    1. Creare e aprire file
    2. Gestire file e cartelle
    3. Scaricamento e caricamento dei file da e verso il server
    4. Depositare e ritirare i file
    5. Sincronizzare i file
    6. Confrontare file per verificare le differenze
    7. Applicare la maschera file a file e cartelle del sito Dreamweaver
    8. Attivare le Design Notes per i siti di Dreamweaver
    9. Impedire un potenziale attacco exploit del Gatekeeper
  7. Layout e progettazione
    1. Usare i riferimenti visivi per il layout
    2. Informazioni sull'utilizzo di CSS per creare il layout della pagina
    3. Progettazione di siti Web reattivi con Bootstrap
    4. Creazione e utilizzo di media query in Dreamweaver
    5. Presentare il contenuto mediante le tabelle
    6. Colori
    7. Responsive design con i layout a griglia fluida
    8. Extract in Dreamweaver
  8. CSS
    1. Nozioni sui fogli di stile CSS
    2. Creazione del layout delle pagine con CSS Designer
    3. Utilizzare i preprocessori CSS in Dreamweaver
    4. Impostare le preferenze di stile CSS in Dreamweaver
    5. Spostare le regole CSS in Dreamweaver
    6. Convertire CSS in linea in una regola CSS in Dreamweaver
    7. Utilizzare i tag div
    8. Applicare sfumature allo sfondo
    9. Creare e modificare effetti di transizione CSS3 in Dreamweaver
    10. Formattazione del codice
  9. Contenuto e risorse delle pagine
    1. Impostare le proprietà di pagina
    2. Impostare le proprietà dei collegamenti CSS e le proprietà dei collegamenti CSS
    3. Lavorare con il testo
    4. Ricercare e sostituire testo, tag e attributi
    5. Pannello DOM
    6. Modifica nella vista Dal vivo
    7. Codifica dei documenti in Dreamweaver
    8. Selezionare e visualizzare gli elementi nella finestra del documento
    9. Definire le proprietà del testo nella finestra di ispezione Proprietà
    10. Eseguire il controllo ortografico di una pagina Web
    11. Utilizzo dei filetti orizzontali in Dreamweaver
    12. Aggiungere e modificare le combinazioni di caratteri in Dreamweaver
    13. Operazioni con le risorse
    14. Inserire e aggiornare le date in Dreamweaver
    15. Creare e gestire le risorse preferite in Dreamweaver
    16. Inserire e modificare le immagini in Dreamweaver
    17. Aggiungere oggetti multimediali
    18. Aggiunta di video in Dreamweaver
    19. Inserire video HTML5
    20. Inserire file SWF
    21. Aggiungere effetti audio
    22. Inserire l'audio HTML5 in Dreamweaver
    23. Operazioni con le voci di libreria
    24. Utilizzare testo in arabo e in ebraico in Dreamweaver
  10. Collegamenti e navigazione
    1. Informazioni sui collegamenti e sulla navigazione
    2. Collegamenti
    3. Mappe immagine
    4. Risoluzione dei problemi di collegamenti
  11. Widget ed effetti jQuery
    1. Utilizzare i widget jQuery UI e Mobile in Dreamweaver
    2. Usare effetti jQuery in Dreamweaver
  12. Programmazione dei siti Web
    1. Programmazione in Dreamweaver
    2. Ambiente di codifica in Dreamweaver
    3. Impostare le preferenze di codifica
    4. Personalizzare la colorazione del codice
    5. Scrivere e modificare codice
    6. Suggerimenti sul codice e completamento del codice
    7. Comprimere ed espandere codice
    8. Riutilizzo del codice con gli snippet
    9. Comando Lint
    10. Ottimizzare il codice
    11. Modificare il codice nella vista Progettazione.
    12. Utilizzo del contenuto dell'intestazione delle pagine
    13. Inserimento di server-side include in Dreamweaver
    14. Uso delle librerie di tag in Dreamweaver
    15. Importazione di tag personalizzati in Dreamweaver
    16. Utilizzare i comportamenti JavaScript (istruzioni generali)
    17. Applicare comportamenti JavaScript incorporati
    18. Informazioni su XML e XSLT
    19. Eseguire trasformazioni XSL server-side in Dreamweaver
    20. Esecuzione di trasformazioni XSL client-side in Dreamweaver
    21. Aggiungere entità di carattere per XSLT in Dreamweaver
    22. Formattazione del codice
  13. Flussi di lavoro di interazione con altri prodotti
    1. Installazione e uso delle estensioni in Dreamweaver
    2. Aggiornamenti in app in Dreamweaver
    3. Inserire documenti Microsoft Office in Dreamweaver (solo Windows)
    4. Operazioni con Fireworks e Dreamweaver
    5. Modificare il contenuto nei siti Dreamweaver mediante Contribute
    6. Integrazione tra Dreamweaver e Business Catalyst
    7. Creare campagne e-mail personalizzate
  14. Modelli
    1. Informazioni sui modelli di Dreamweaver
    2. Riconoscere i modelli e i documenti basati sui modelli
    3. Creare un modello di Dreamweaver
    4. Creare aree modificabili nei modelli
    5. Creare aree e tabelle ripetute nei modelli in Dreamweaver
    6. Usare le aree opzionali nei modelli
    7. Definire attributi di tag modificabili in Dreamweaver
    8. Creare modelli nidificati in Dreamweaver
    9. Modificare, aggiornare ed eliminare modelli
    10. Esportare e importare contenuti xml in Dreamweaver
    11. Applicare o rimuovere un modello da un documento esistente
    12. Modificare il contenuto nei modelli di Dreamweaver
    13. Regole di sintassi per i tag di modello in Dreamweaver
    14. Impostare le preferenze di evidenziazione per le aree dei modelli
    15. Vantaggi dell'uso dei modelli in Dreamweaver
  15. Dispositivi mobili e multischermo
    1. Creare media query
    2. Cambiamento dell'orientamento della pagina per i dispositivi mobili
    3. Creare web app per dispositivi mobili utilizzando Dreamweaver
  16. Siti, pagine e moduli Web dinamici
    1. Applicazioni Web
    2. Configurare il computer per lo sviluppo di applicazioni
    3. Risoluzione dei problemi relativi alle connessioni di database
    4. Rimozione di script di connessione in Dreamweaver
    5. Progettare pagine dinamiche
    6. Panoramica sulle origini di contenuto dinamico
    7. Definire le origini di contenuto dinamico
    8. Aggiungere contenuto dinamico alle pagine
    9. Modifica del contenuto dinamico in Dreamweaver
    10. Visualizzare i record di database
    11. Fornire dati dal vivo e risoluzione dei problemi in Dreamweaver
    12. Aggiungere comportamenti server personalizzati in Dreamweaver
    13. Creazione di moduli con Dreamweaver
    14. Usare moduli per raccogliere informazioni dagli utenti
    15. Creare e attivare i moduli ColdFusion in Dreamweaver
    16. Creare moduli Web
    17. Supporto HTML5 avanzato per gli elementi modulo
    18. Sviluppare un modulo con Dreamweaver
  17. Sviluppo visivo delle applicazioni
    1. Creare pagine principali e di dettaglio in Dreamweaver
    2. Creare pagine di ricerca e di risultati
    3. Creare una pagina di inserimento record
    4. Costruire una pagine di aggiornamento record in Dreamweaver
    5. Costruzione di pagine di eliminazione record in Dreamweaver
    6. Utilizzare comandi ASP per modificare un database in Dreamweaver
    7. Creare una pagina di registrazione
    8. Creare una pagina di login
    9. Creare una pagina accessibile solo agli utenti autorizzati
    10. Protezione delle cartelle in ColdFusion utilizzando Dreamweaver
    11. Utilizzo di componenti ColdFusion in Dreamweaver
  18. Verifica, anteprima e pubblicazione dei siti Web
    1. Anteprima delle pagine
    2. Visualizzare in anteprima pagine web di Dreamweaver su più dispositivi
    3. Verificare il sito Dreamweaver
  19. Risoluzione dei problemi
    1. Problemi risolti
    2. Problemi noti

 

 

Usare i riferimenti visivi per il layout in Dreamweaver, inclusi l'impostazione dei righelli e delle guide di layout, l'uso delle guide con i modelli, l'uso di una griglia di layout e l'uso di un'immagine di ricalco.

Impostare i righelli

I righelli permettono di misurare, organizzare e pianificare il layout. Possono essere visualizzati sul bordo sinistro e sul bordo superiore della pagina, in pixel, pollici o centimetri.

  • Per attivare e disattivare i righelli, selezionate Visualizza > Opzioni vista Progettazione > Regole > Mostra/Nascondi.
  • Per modificare l'origine, trascinate l'icona dell'origine del righello (nell'angolo superiore sinistro della vista Progettazione della finestra del documento) in un punto qualunque della pagina.
  • Per ripristinare la posizione predefinita dell'origine, selezionate Visualizza > Opzioni vista Progettazione > Righelli > Ripristina origine.
  • Per cambiare l'unità di misura, selezionate Visualizza > Righelli, quindi selezionate Pixel, Pollici o Centimetri.

Impostare le guide di layout

Le guide sono linee che vengono trascinate sul documento a partire dai righelli. Fungono da riferimento visivo per facilitare il posizionamento e l'allineamento di precisione degli oggetti. Possono essere utilizzate anche per misurare le dimensioni degli elementi di pagina o per simulare le aree visibili dei browser Web.

Per facilitare l'allineamento degli elementi, potete agganciare gli elementi alle guide o viceversa. (Per utilizzare la funzione di aggancio, è necessario che gli elementi siano posizionati in modo assoluto.) Potete anche bloccare le guide per impedirne lo spostamento accidentale da parte di un altro utente.

Creare una guida orizzontale o verticale

  1. Trascinate il puntatore dal righello corrispondente.
  2. Posizionate la guida nella finestra del documento, quindi rilasciate il pulsante del mouse (per riposizionare la guida, trascinatela di nuovo).
    Nota:

    per impostazione predefinita, le guide vengono registrate come distanze assolute in pixel dal lato superiore o sinistro del documento e vengono visualizzate in relazione all'origine del righello. Per registrare la guida come percentuale, tenete premuto il tasto Maiusc mentre create o spostate la guida.

Mostrare o nascondere le guide

  1. Selezionate Visualizza > Guide > Mostra guide.

Agganciare elementi alle guide

  • Per agganciare gli elementi alle guide, selezionate Visualizza > Opzioni vista Progettazione > Guide > Aggancia alle guide.
  • Per agganciare le guide agli elementi, selezionate Visualizza > Opzioni vista Progettazione > Guide > Aggancia guide agli elementi.
Nota:

quando ridimensionate degli elementi (ad esempio elementi PA, tabelle e immagini), gli elementi ridimensionati vengono agganciati alle guide.

Bloccare o sbloccare tutte le guide

Selezionate Visualizza > Opzioni vista Progettazione > Guide > Blocca guide.

Visualizzare e spostare una guida in una posizione specifica

  1. Tenete il puntatore del mouse sopra la guida per visualizzarne la posizione.
  2. Fate doppio clic sulla guida.
  3. Inserite la nuova posizione nella finestra di dialogo Sposta guida, quindi fate clic su OK.

Visualizzare la distanza tra due guide

Tenendo premuto il tasto Ctrl (Windows) o Comando (Macintosh), collocate il puntatore del mouse in un punto qualunque tra le due guide.
Nota:

l'unità di misura è uguale a quella utilizzata per i righelli.

Simulare l'area visibile di un browser Web

Selezionate Visualizza > Opzioni vista Progettazione > Guide, quindi selezionate le dimensioni preimpostate di un browser dal menu.

Rimuovere una guida

Trascinate la guida fuori del documento.

Modificare le impostazioni delle guide

  1. Selezionate Visualizza > Opzioni vista Progettazione > Guide > Modifica guide, impostate le opzioni seguenti e fate clic su OK.

    Colore guida

    Specifica il colore delle linee di guida. Fate clic sul campione di colore e selezionate un nuovo colore dal selettore di colori o digitate un numero esadecimale nella casella di testo.

    Colore distanza

    Specifica il colore delle linee visualizzate come indicatori di distanza quando si passa il puntatore del mouse nello spazio tra due guide. Fate clic sul campione di colore e selezionate un nuovo colore dal selettore di colori o digitate un numero esadecimale nella casella di testo.

    Mostra guide

    Rende visibili le guide nella vista Progettazione.

    Aggancia alle guide

    Aggancia gli elementi della pagina alle guide quando vengono spostati.

    Blocca guide

    Blocca le guide nella posizione in cui si trovano.

    Aggancia guide agli elementi

    Aggancia le guide agli elementi della pagina quando vengono trascinate.

    Annulla tutto

    Elimina tutte le guide dalla pagina.

Usare le guide con i modelli

Quando le guide vengono aggiunte a un modello di Dreamweaver, tutte le istanze del modello ereditano le guide. Tuttavia, le guide presenti nelle istanze del modello vengono considerate aree modificabili e possono quindi essere modificate dagli utenti. Le guide modificate presenti nelle istanze di un modello vengono riportate nella posizione originale quando l'istanza viene aggiornata con il modello master.

Gli utenti possono anche aggiungere le proprie guide alle istanze di un modello. Le guide aggiunte in questo modo non vengono sovrascritte quando l'istanza viene aggiornata con il modello master.

Utilizzare la griglia di layout

La griglia è costituita da uno schema di linee orizzontali e verticali nella finestra del documento ed è utile per posizionare con precisione gli oggetti. Potete agganciare automaticamente alla griglia gli elementi di pagina con posizione assoluta e modificare la griglia o controllarne la funzione di aggancio specificandone le impostazioni. L'aggancio funziona anche se la griglia non è visibile.

Visualizzare o nascondere la griglia

Selezionate Visualizza > Opzioni vista Progettazione > Griglia > Mostra griglia.

Attivare o disattivare la funzione di aggancio

Selezionate Visualizza > Opzioni vista Progettazione > Griglia > Aggancia alla griglia.

Modificare le impostazioni della griglia

  1. Selezionate Visualizza > Opzioni vista Progettazione > Griglia > Impostazioni griglia.

  2. Impostate le opzioni desiderate e fate clic su OK per applicare le modifiche.

    Colore

    Specifica il colore delle linee della griglia. Fate clic sul campione di colore e selezionate un nuovo colore dal selettore di colori o digitate un numero esadecimale nella casella di testo.

    Mostra griglia

    Rende visibile la griglia nella vista Progettazione.

    Griglia calamitata

    Aggancia gli elementi della pagina alle linee della griglia.

    Spaziatura

    Controlla la distanza tra le linee della griglia. Inserite un numero e selezionate Pixel, Pollici o Centimetri dal menu.

    Display

    Specifica se la griglia visualizzata è composta da linee o puntini.

    Nota:

    se Mostra griglia non è selezionato, la griglia non viene visualizzata e le modifiche non sono visibili.

Usare un'immagine di ricalco

L'immagine di ricalco è un'immagine che viene utilizzata come guida per riprodurre una struttura di pagina originariamente creata in un'applicazione grafica come Adobe Freehand o Fireworks.

Si tratta di un'immagine JPEG, GIF o PNG che viene collocata sullo sfondo della finestra del documento. Potete nascondere l'immagine, impostarne la trasparenza e modificarne la posizione.

L'immagine di ricalco è visibile solo in Dreamweaver e non viene mai visualizzata nei browser. Quando l'immagine di ricalco è visibile, l'immagine e il colore di sfondo reali della pagina non appaiono nella finestra del documento, ma vengono visualizzati se si apre la pagina in un browser.

Posizionare un'immagine di ricalco nella finestra del documento

  1. Effettuate una delle operazioni seguenti:
    • Selezionate Visualizza > Opzioni vista Progettazione > Immagine di ricalco > Carica.

    • Selezionate File > Proprietà di pagina, quindi nella categoria Immagine di ricalco, fate clic su Sfoglia (accanto alla casella di testo Immagine di ricalco).

  2. Passate al file di immagine e fate clic su OK.

  3. Nella finestra di dialogo Proprietà di pagina, specificate la trasparenza dell'immagine trascinando l'apposito cursore, quindi fate clic su OK.

    Per passare a un'altra immagine di ricalco o modificare la trasparenza dell'immagine di ricalco corrente in qualunque momento, selezionate File > Proprietà di pagina.

Visualizzare o nascondere l'immagine di ricalco

Selezionate Visualizza > Opzioni vista Progettazione >Immagine di ricalco > Mostra.

Modificare la posizione di un'immagine di ricalco

  1. Selezionate Visualizza > Opzioni vista Progettazione > Immagine di ricalco > Regola posizione.

    • Per specificare con precisione la posizione dell'immagine di ricalco, inserite i valori delle coordinate nelle caselle di testo X e Y.

    • Per spostare l'immagine di 1 pixel per volta, utilizzate i tasti freccia.

    • Per spostare l'immagine di 5 pixel per volta, premete contemporaneamente Maiusc e un tasto freccia.

Ripristinare la posizione dell'immagine di ricalco

  1. Selezionate Visualizza > Opzioni vista Progettazione > Immagine di ricalco > Ripristina posizione.

    L'immagine di ricalco ritorna nell'angolo superiore sinistro della finestra del documento (0,0).

Allineare l'immagine di ricalco rispetto a un elemento selezionato

  1. Selezionate un elemento nella finestra del documento.
  2. Selezionate Visualizza > Opzioni vista Progettazione > Immagine di ricalco > Allinea alla selezione.

    L'angolo superiore sinistro dell'immagine di ricalco viene allineato al corrispondente angolo dell'elemento selezionato.

 Adobe

Ottieni supporto in modo più facile e veloce

Nuovo utente?

Adobe MAX 2024

Adobe MAX
La conferenza sulla creatività

14-16 ottobre Miami Beach e online

Adobe MAX

La conferenza sulla creatività

14-16 ottobre Miami Beach e online

Adobe MAX 2024

Adobe MAX
La conferenza sulla creatività

14-16 ottobre Miami Beach e online

Adobe MAX

La conferenza sulla creatività

14-16 ottobre Miami Beach e online