Nessun dato analitico dalle versioni iOS delle applicazioni AEM Mobile Apps
Nell'interfaccia di Adobe Mobile Services, nessun dato analitico è visibile da un'applicazione mobile iOS AEM Mobile.

Ambiente

Applicazioni iOS AMS Mobile

Causa

L'applicazione è stata impostata per consentire le chiamate HTTPS, ma Adobe Mobile Services è impostato per utilizzare HTTP per Analytics.

Risoluzione

Impostare Analytics per utilizzare HTTP

  1. Accedi a http://mobilemarketing.adobe.com (assicurati di cliccare sull'opzione per utilizzare un account Analytics).
  2. Fai clic su Gestisci applicazioni.
  3. Fai clic sul nome dell'applicazione.
  4. Spostati su Opzioni analitiche SDK.
  5. Seleziona l'opzione per utilizzare HTTPS.
  6. Scorri verso il basso e fai clic su Salva.
  7. Ricompila l'applicazione utilizzando il portale on-demand di AEM Mobile e fornendo tale aggiornamento agli utenti finali.

Informazioni aggiuntive

Quando si utilizza il portale on-demand di AEM Mobile per creare un'applicazione iOS, una delle opzioni è "Consentire solo connessioni HTTPS"

Sopra questa opzione nell'interfaccia utente, è riportato il seguente avviso:
"Prima di selezionare la casella di controllo, assicurarsi che le opzioni di Mobile Marketing SDK Analytics siano impostate per l'utilizzo di HTTPS. Per saperne di più". "Per saperne di più" è un link a questa pagina:
https://helpx.adobe.com/it/digital-publishing-solution/help/building-ios-apps.html

In quella pagina, nella sezione "Connettività HTTPS", si legge:
"Se si seleziona Consenti solo connessioni HTTPS, compila una versione di sviluppo della tua applicazione e testala a fondo. Assicurati che i collegamenti ipertestuali, i banner dinamici e le funzioni di accesso funzionino correttamente. Inoltre, per garantire che i dati analitici siano riportati correttamente, accedi alla dashboard di Adobe Mobile Services e configura le impostazioni dell'applicazione per l'utilizzo di HTTPS. (Vedi Analytics per le applicazioni AEM Mobile: Configurazione delle impostazioni delle applicazioni di Mobile Marketing.)"

Configurazione delle applicazioni di Mobile Marketing" è un link che conduce a questa pagina e all'ancoraggio:
https://helpx.adobe.com/it/digital-publishing-solution/help/analytics.html#configure-mobile-marketing

In quella pagina sono elencati i passaggi e la sequenza per abilitare HTTPS per il servizio di analisi che la tua applicazione sta utilizzando:
"Configurazione delle impostazioni delle applicazioni di Mobile Marketing
Utilizza la Dashboard di Mobile Marketing per configurare le impostazioni di analisi per il progetto. Per esempio, se si compila un'applicazione che richiede domini HTTPS invece che HTTP, è possibile modificarne le impostazioni"

  1. Vai su https://mobilemarketing.adobe.com e accedi.
  2. Seleziona Gestisci applicazioni > Tutte le applicazioni.
  3. Crea un'applicazione o seleziona un'applicazione.
  4. Modifica le impostazioni come desiderato. Ad esempio, seleziona Usa HTTPS per assicurarti che le chiamate di analisi siano conformi a HTTPS.
  5. Dopo aver salvato le impostazioni, ricompila l'applicazione. La ricompilazione della tua applicazione è necessaria per rilevare eventuali modifiche di configurazione effettuate nella Dashboard di Mobile Marketing.