Problema

Durante l'installazione di AEM6.2 SP1 si vede questo errore in error.log:

Could not Install Package
"javax.jcr.nodetype.ConstraintViolationException: OakConstraint0001: /etc/cloudsettings/default/contexthub[[nt:folder]]: No matching definition found for child node relatedproducts with effective type [nt:unstructured]"

Causa

Il tipo di nodo della cartella /etc/cloudsettings/default/contexthub (nt:folder) è incompatibile con le modifiche incluse nel service pack.

Risoluzione

Prima di installare SP1, procedere come segue:

  1. Vai su http://aem-host:port/crx/packmgr/index.jsp

  2. Creare un pacchetto di backup di /etc/cloudsettings/default/contexthub

  3. Vai su http://aem-host:port/crx/de/index.jsp web app

  4. Sfoglia ed elimina la cartella /etc/cloudsettings/default/contexthub

  5. Salva

  6. Installare SP1

  7. Applica di nuovo le modifiche personalizzate apportate alla configurazione predefinita del contexthub.

Gravità

Gravità 2

Messaggio specifico

javax.jcr.nodetype.ConstraintViolationException: OakConstraint0001: /etc/cloudsettings/default/contexthub[[nt:folder]]: No matching definition found for child node relatedproducts with effective type [nt:unstructured]

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online