Problema

Quando installi una versione di Communiqué prima della 4.2.1 su un server Linux a 64 bit con JDK 1.5.0, ottieni un errore simile al seguente:

CLASSPATH:/tmp/install.dir.30430/InstallerData:/tmp/install.dir.30430/InstallerData/installer.zip: grep: errore durante il caricamento di librerie condivise: libc.so.6: non può aprire file oggetto condiviso: Nessun file o directory ========================================================================== /opt/jdk1.5.0_12/bin/java: errore durante il caricamento di librerie condivise: libpthread.so.0: non può aprire file oggetto condiviso: Nessun file o directory di questo tipo

Soluzione

Disattivare LD_ASSUME_KERNEL nello script di installazione:

cat cq4-2-0-20070327-db.sh | sed "s/export LD_ASSUME_KERNEL/#xport LD_ASSUME_KERNEL/" > cq4-inst.sh

Informazioni aggiuntive

Questo errore è il risultato di un problema all'interno del Communiqué installer. Il problema è stato risolto nella versione 4.2.1.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online