Sintomi

Quando un utente viene creato (tramite CQ o LDAP), l'utente non può accedere alla sua casella di posta in arrivo delle notifiche a meno che l'utente non sia membro del gruppo di amministratori utenti (o amministratori privilegiati). Quale autorizzazione è necessaria per consentire all'utente di vedere la propria casella di posta in arrivo delle notifiche senza concedere loro i privilegi di amministrazione utente?

Inoltre, quando l'utente tenta di accedere alla casella di posta in arrivo della notifica, viene generato un errore seguente nel log:

26.10.2009 15:42:41.833 *ERROR* [127.0.0.1 [1256586161833] GET /bin/wcm/notification/inbox/messages.json HTTP/1.1] com.day.cq.wcm.notification.inbox.impl.InboxServlet Unable to query inbox for user xxxxxx javax.jcr.AccessDeniedException: xxxxxx not allowed to access UserManager

Causa

Per impostazione predefinita, un utente ha il pieno permesso di accedere alla propria cartella di casa nell'area di lavoro crx.default. Gli utenti standard non hanno accesso all'area di lavoro di crx.system. Quando si accede alla casella di posta in arrivo della notifica, c'è un ulteriore controllo nel codice che genera un AccessDeniedException se l'utente non ha accesso all'area di lavoro crx.system.

Così, solo gli utenti che sono membri di (1) amministratori, (2) amministratori con privilegi o (2) gruppi di amministratori utenti non saranno in grado di cambiare la propria casella di posta in arrivo delle notifiche.

Risoluzione

L'attuale soluzione è quella di creare un nuovo gruppo e concedere l'accesso allo spazio di lavoro al sistema crx.system. L'utente viene aggiunto a questo gruppo.

  1. Accedi all'area di lavoro crx.system con l'account amministratore
  2. Apri l'Explorer di contenuti
  3. Passa a "/rep:workspaces/crx.system"
  4. Utilizza il pulsante "Sicurezza" per consentire al nuovo gruppo di accedere a questo archivio

Si applica a

CQ 5.2.1

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