Correggere gli ACLs mancanti dell'utente del sistema

Il sistema ACLs in AEM è stato accidentalmente cancellato e la funzionalità AEM è stata interrotta.

Causa

Le cause possono essere molteplici, ma le più comuni sono:

  • Rimozione accidentale delle autorizzazioni da parte degli utenti
  • Installazione del pacchetto ACL con valore di "Sovrascrittura" impostato nell'opzione AC Handling del pacchetto

Risoluzione

Per risolvere il problema, procedi nel modo seguente:

  1. Installa un autore AEM pulito o pubblica l'istanza localmente e imposta l'opzione -r nosamplecontent durante l'installazione (abbina il tipo di istanza con l'istanza mancante delle ACLs).  Per esempio: java -Xmx2048m -jar cq-author-p4502.jar -r nosamplecontent
  2. Vai al gestore di pacchetti AEM http://host:port/crx/packmgr/index.jsp e accedi come amministratore
  3. Scarica e installa ACS Commons
  4. Usa ACL Packager per impacchettare tutte le ACL predefinite.  Quando si configura il pacchetto ACL, imposta "/.*"come unico valore in Include Patterns. Quindi imposta l'opzione AC Handling su Merge.
  5. Vai al gestore dei pacchetti e crea il pacchetto ACL.
  6. Scarica il pacchetto
  7. Una volta ottenuto l'hotfix, installalo nell'ambiente interrotto facendolo cadere nella cartella crx-quickstart/install 
  8. Dopo che l'hotfix è stato installato completamente (convalidare tramite il file error.log) quindi riavvia AEM
  9. Quindi lasciar cadere il pacchetto ACL nella cartella crx-quickstart/install dell'istanza danneggiata
  10. Dopo che il pacchetto è stato installato, riavvia nuovamente AEM

Ora gli ACL originali predefiniti sono stati ripristinati.

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