Problema

Dopo aver aggiornato un'istanza di CQ5.2.x a 5.3, alcuni percorsi dei componenti sono cambiati e ora sono presenti collegamenti corrotti e i componenti non funzionano correttamente.

Causa

Il processo di aggiornamento del CQ utilizza un file con un elenco di percorsi per sostituire il percorso durante l'aggiornamento. Alcuni dei percorsi modificati non sono stati inclusi in quel file. Questo fa sì che alcuni percorsi che devono essere cambiati vengano meno durante un aggiornamento.

Risposta

Segui i seguenti passi per risolvere il problema

  • Vai a /libs/cq/compat/components/codeupgrade/5.3/resourcetypes.txt (puoi farlo tramite l'applicazione web crxde lite)
  • Aggiungi una mappatura del percorso | <old-path> | <new-path> | poco prima della voce # Tipi di risorse.
  • Vai su http://<host>:<port>/libs/cq/compat/components/codeupgrade.html e inserisci /libs sotto Elenco dei percorsi da elaborare (separati da virgole)
  • Ripeti il processo e inserisci /apps la volta successiva.
  • Puoi applicare lo stesso processo anche per qualsiasi modifica del percorso di un componente personalizzato.

Si applica a

Aggiornamento CQ5.3

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online