Problema

Dopo l'aggiornamento da CQ5.x o AEM 6.0 a AEM 6.0 SP3, 6.1 o 6.2, gli utenti LDAP esistenti non possono più accedere a AEM. 

Causa

Si tratta di un problema noto perché le proprietà sui nodi utente connessi con LDAP sono cambiate.

Risoluzione

Elimina gli utenti LDAP esistenti e lascia che vengano ri-sincronizzati automaticamente oppure segui le seguenti istruzioni:

  1. Scarica la versione di oak-run che corrisponde alla tua versione di Oak installata in AEM.

  2. Scarica l'allegato setRepExternalId.groovy.

  3. Carica sia oak-run che lo script groovy sul tuo server AEM.

  4. Interrompi AEM.

  5. Per aprire la console gestita da oak, esegui il seguente comando. (Sostituisci crx-quickstart/repository/segmentstore con il percorso all'istanza AEM repository/segmenstore).

    java -Xmx2048m -jar oak-run-*.jar console crx-quickstart/repository/segmentstore
  6. Esegui i seguenti comandi nella console. (Sostituisci il parametro LDAP in modo che corrisponda al nome della configurazione OSGi del tuo provider di identità LDAP. Per esempio, se il tuo nome IDP è configurato nella configurazione di OSGi come LDAP, allora cambia anche il nome in jsp.

    :load setRepExternalId.groovy
    new FixLDAPUsers().setRepUserProps(session, "/home", "ldap")

    Di conseguenza esegue una prova con il risultato mentre tutti gli utenti e i gruppi LDAP su AEM che mostrano il rep: externalId e rep: authorizableId sono impostati.  

  7. Se sei soddisfatto del risultato, vai al passaggio successivo.

  8. Esegui nuovamente il comando dal passaggio 6, ma questa volta, aggiungi alla fine il parametro false. Applica le modifiche. (Assicurati ancora una volta di cambiare LDAP in modo che corrisponda al nome della tua configurazione).

    :load setRepExternalId.groovy
    new FixLDAPUsers().setRepUserProps(session, "/home", "ldap", false)
  9. Vai a http://aem-host:port/crx/de/index.jsp e accedi come amministratore.

  10. Sfoglia fino a /oak: indice.

  11. Imposta la proprietà reindex=true sui seguenti indici, se esistono:

    • /oak:index/externalId
    • /oak:index/authorizableId
    • /oak:index/authorizables
  12. Fai clic su Salva tutto.

    L'indicizzazione causa la sospensione del sistema fino a quando non è terminata. 

  13. Monitora i log fino al termine del processo.
    Di conseguenza, gli utenti possono accedere al sistema.

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