Problema: Come posso aggiornare il launchpad?

Sono presenti alcune correzioni nell'ultimo framework di Apache Felix, come posso aggiornarlo in Adobe Experience Manager?

Soluzione

Segui questi passaggi:

  1. Scarica il nuovo file JAR base dall'archivio ufficiale Maven all'indirizzo http://search.maven.org/#search%7Cga%7C1%7Corg.apache.sling.launchpad.base. Puoi scegliere la versione. Alla stesura di questo articolo, si raccomanda 5.0.1-2.6.2 (usa ancora javax.servlet.api 2.5). Ma, puoi usare 5.2.0-2.6.4 se non hai dipendenze dalla versione precedente dall'API del servlet.
  2. Chiudi l'istanza.
  3. Sostituisci il JAR base nell'installazione (impostazione predefinita in crx-quickstart/launchpad).
  4. Riavvia l'istanza con -Dorg.apache.sling.launchpad.startupmode=RESTART.

Convalida dal tuo lato se questo aiuta a risolvere questo problema e prendi nota del disclaimer generale per l'uso in produzione

DISCLAIMER: LA LIBRERIA DI TERZE PARTI VIENE FORNITA "COSÌ COM'È" E SENZA GARANZIE DI ALCUN TIPO, INCLUSE GARANZIE O CONDIZIONI DI COMMERCIABILITÀ, IDONEITÀ PER UN PARTICOLARE SCOPO, QUALITÀ SODDISFACENTE, MANCANZA DI VIRUS, TITOLO, NON VIOLAZIONE, PRECISIONE O COMPLETEZZA DELLE RISPOSTE, RISULTATI, MANCANZA DI NEGLIGENZA E/O MANCANZA DI IMPEGNO A REGOLA D'ARTE. ADOBE NON GARANTISCE CONTRO QUALSIASI BUG, ERRORE, OMISSIONE, DIFETTO, DEFICIENZA O NON CONFORMITÀ NELLA LIBRERIA DI TERZE PARTI. LE LIBRERIE DI TERZE PARTI NON SONO TESTATE DA QA. USALO A TUO RISCHIO. ADOBE RACCOMANDA DI UTILIZZARE QUESTA LIBRERIA DI TERZE PARTI PER SCOPI DI SVILUPPO. SE DEVI APPLICARE QUESTA LIBRERIA DI TERZE PARTI AD UN SISTEMA DI PRODUZIONE, TESTA A FONDO L'APPLICAZIONE. ADOBE NON PUÒ ESSERE RITENUTO RESPONSABILE PER EVENTUALI DANNI CHE POTREBBERO ESSERE CAUSATI DA QUESTA LIBRERIA DI TERZE PARTI.

Si applica a: CQ 5.x/AEM 6.x qualsiasi versione che utilizza questo JAR base per il launchpad

Informazioni sulle dipendenze API Servlet: Servlet API è fornito dal motore di servlet CQSE, Felix/Jetty HTTP bundle o altro (Websphere, Weblogic, Tomcat, JBoss e così via). Controlla se funziona con la base del launchpad disponibile nell'archivio Maven (puoi controllare pom.xml per informazioni sulla dipendenza dalle API di servlet).

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online