Fireworks importa file di Photoshop (PSD) nativi e mantiene molte funzioni di Photoshop. È inoltre possibile esportare elementi grafici di Fireworks in Photoshop per la modifica dettagliata dell’immagine.

Inserire immagini di Photoshop in Fireworks

Le immagini di Photoshop possono essere inserite in Fireworks mediante i comandi File > Importa e File > Apri o trascinando i file nell’area di lavoro. Il comando Importa consente di accedere a opzioni individuali per i livelli di sfondo e le cartelle dei livelli. Al contrario, il comando Apri e il metodo di trascinamento del file consentono di accedere alle opzioni per le guide e gli stati.

Funzioni di Photoshop convertite e non supportate in Fireworks

Quando si apre o si importa un file Photoshop, in Fireworks l’immagine viene convertita in formato PNG secondo le preferenze di importazione specificate. Consultate Preferenze di importazione e apertura da Photoshop.

  • Le singole maschere livelli vengono convertite in maschere di Fireworks. Le maschere di gruppo non sono supportate.

  • Le maschere di ritaglio vengono convertite in maschere oggetto, con leggere modifiche nell’aspetto. Per mantenere l’aspetto perdendo però la possibilità di modifica, selezionate la preferenza Maschere di ritaglio.

  • I metodi di fusione dei livelli vengono convertiti in modalità di fusione per oggetti di Fireworks, se esistono le modalità corrispondenti.

  • Per impostazione predefinita, vengono mantenuti gli effetti livello. Se si preferisce convertire questi effetti in filtri attivi corrispondenti, selezionate la preferenza Effetti di livello. Tuttavia, effetti e filtri simili potrebbero produrre risultati leggermente diversi.

  • Il primo canale alfa della tavolozza Canali viene convertito in aree trasparenti nell’immagine di Fireworks. Fireworks non supporta ulteriori canali alfa di Photoshop.

  • Tutte le profondità e i metodi di colore di Photoshop vengono convertiti in RGB a 8 bit.

Trascinare, aprire o importare immagini di Photoshop in Fireworks

Ciascuna immagine trascinata, aperta o importata diventa un nuovo oggetto bitmap.

Nota:

In Windows, i nomi dei file devono includere l’estensione PSD affinché Fireworks possa riconoscere il tipo di file.

  1. Effettuate una delle seguenti operazioni:

    • Trascinate un’immagine o file di Photoshop in un documento di Fireworks aperto.

    • Selezionate File > Apri o File > Importa e individuate un file di Photoshop (PSD).

  2. Fate clic su Apri.

  3. Nella finestra di dialogo visualizzata, impostate le opzioni per l’immagine e fate clic su OK.

  4. Se è stato utilizzato il comando File > Importa, viene visualizzato un cursore che ha la forma di una L invertita. Nell’area di lavoro, fate clic sul punto in cui collocare l’angolo superiore sinistro dell’immagine.

Opzioni di importazione per i file di Photoshop

Quando si importa o apre un file di Photoshop in Fireworks, viene visualizzata una finestra di dialogo che consente di specificare come importare l’immagine. Le opzioni scelte determinano l’aspetto e la modificabilità del testo importato.

  1. Specificate le dimensioni dell’immagine in pixel o percentuale e la risoluzione dei pixel. Per mantenere il rapporto larghezza/altezza corrente, selezionate Vincola proporzioni.

  2. Se il file di Photoshop contiene composizioni di livelli, selezionate quale versione dell’immagine importare. Selezionate Mostra anteprima per visualizzare un’anteprima della composizione selezionata. La casella di testo Commenti visualizza i commenti presenti nel file di Photoshop.

  3. Dal menu a comparsa inferiore, scegliete come aprire l’immagine Photoshop in Fireworks:

    Mantieni modificabilità del livello rispetto all’aspetto

    Mantiene quanto possibile la struttura del livello e la modificabilità del testo senza sacrificare l’aspetto dell’immagine stessa. Se il file include funzioni non supportate da Fireworks, l’applicazione mantiene l’aspetto del documento unendo e rasterizzando i livelli. Di seguito sono riportati alcuni esempi:

    • I livelli CMYK, i livelli di regolazione e i livelli che utilizzano un’opzione di foratura vengono uniti con i livelli sottostanti.

    • I livelli che utilizzano effetti non supportati possono essere uniti, in base al metodo di fusione del livello e alla presenza di pixel trasparenti.

    Mantieni aspetto del livello Photoshop

    Appiattisce tutti gli oggetti di ciascun livello di Photoshop e converte ciascun livello di Photoshop in un oggetto bitmap. Questa opzione non consente di modificare i livelli di Photoshop in Fireworks. Tuttavia, i gruppi di livelli vengono mantenuti.

    Impostazioni personali da preferenze

    Importa il file utilizzando le impostazioni di conversione file personalizzate specificate nella finestra di dialogo Preferenze. Consultate Preferenze di importazione e apertura da Photoshop.

    Riduci livelli Photoshop in immagine singola

    Importa il file di Photoshop come immagine appiattita priva di livelli. Il file convertito non ha più singoli oggetti, ma è un’unica immagine bitmap. L’opacità viene mantenuta, ma non è modificabile.

  4. Se è stato utilizzato il comando File > Importa, è possibile selezionare le seguenti opzioni:

    Includi livelli di sfondo

    Importa gli oggetti dal livello di sfondo dell’immagine.

    Importa in nuova cartella

    Importa l’immagine in una nuova cartella di livelli denominata Importazione Photoshop.

  5. Se è stato utilizzato il comando File > Apri o il file di Photoshop è stato trascinato in Fireworks, è possibile selezionare le seguenti opzioni:

    Includi guide

    Mantiene le guide di Photoshop nelle posizioni originali.

    Converti livelli in stati

    Colloca ciascun gruppo di livelli di Photoshop in un proprio stato.

L’importazione di testo da Photoshop

Nota:

Per importare in modo rapido testo specifico in un file di Photoshop, copiatelo direttamente in Fireworks. Il testo copiato mantiene tutti gli attributi di testo.

Quando si importano file di Photoshop contenenti del testo, Fireworks controlla i tipi di carattere necessari nel sistema. Se i caratteri non sono installati, Fireworks richiede di sostituirli o di mantenerne l’aspetto.

Se al testo del file di Photoshop sono stati applicati effetti supportati da Fireworks, questi vengono applicati anche a Fireworks. Tuttavia, dal momento che Fireworks e Photoshop applicano gli effetti in modo diverso, questi possono avere un aspetto differente in ciascuna applicazione.

Quando i file di Photoshop 6 o 7 che contengono testo vengono aperti o importati in Fireworks, con l’opzione Mantieni aspetto selezionata, viene visualizzata un’immagine in cache del testo in modo che il suo aspetto rimanga identico a quello che aveva in Photoshop. Una volta modificato il testo, l’immagine memorizzata nella cache viene sostituita con il testo effettivo. L’aspetto del testo potrebbe essere leggermente diverso rispetto a quello del testo originale. Tuttavia, i dati dei tipi di carattere originali sono memorizzati nel file PNG, quindi è possibile utilizzare i caratteri originali memorizzati nel sistema anziché quelli installati.

Nota:

Fireworks non può esportare il testo in formato Photoshop 6 o 7. Se si modifica un documento che contiene testo in questo formato e lo si riesporta in Photoshop, il file viene esportato in formato Photoshop 5.5. Se invece non si effettuano modifiche al testo, il file viene esportato in formato Photoshop 6.

Importare ed esportare gradienti da Photoshop

La qualità del gradiente dopo l’importazione e l’esportazione dipende dal tipo di gradiente. Si potrebbe verificare una leggera variazione nel colore e nell’opacità dei gradienti.

Gradiente

Qualità di importazione

Lineare

Quasi perfetta.

Radiale

Quasi perfetta.

Riflesso

Quasi perfetta.

Rombo

Corrispondenza approssimativa (mappata alla rettangolare)

Angolo

Corrispondenza approssimativa (mappata alla conica)

   

Gradiente

Qualità di esportazione

Lineare

Quasi perfetta.

Radiale

Quasi perfetta.

Righe

Quasi perfetta.

Rettangolare

Corrispondenza approssimativa (mappata al rombo)

Conica

Corrispondenza approssimativa (mappata all’angolo)

Ellisse

Corrispondenza approssimativa (mappata alla radiale)

Increspature

Corrispondenza approssimativa (mappata alla radiale)

Starburst

Corrispondenza imperfetta (mappato a shapeburst)

Contorno, seta, onde

Corrispondenza imperfetta (mappato a lineare)

Mantenere l’aspetto del livello di regolazione dopo l’importazione

Quando si importa un file PSD contenente un livello di regolazione, l’aspetto dei singoli livelli viene mantenuto dopo l’importazione.

  1. Nella finestra delle preferenze, selezionate Importazione/Apertura Photoshop.

  2. Selezionate Mantieni aspetto dei livelli regolati.

Mantieni aspetto dei livelli regolati

Quando si importa un file PSD contenente un livello di regolazione, l’aspetto dei singoli livelli viene mantenuto dopo l’importazione. Assicuratevi di selezionare Impostazioni personali da Preferenze nella finestra di dialogo.

Utilizzare filtri e plug-in di Photoshop

È possibile utilizzare diversi filtri e plug-in di Photoshop e di terzi parti, sia nella finestra dei filtri attivi sia nel menu Filtri.

Nota:

I plug-in e i filtri per Photoshop 5.5 e versioni precedenti sono supportati. I plug-in e filtri di Photoshop 6 e versioni successive non sono compatibili con Fireworks.

Attivare i plug-in di Photoshop mediante la finestra di dialogo Preferenze

  1. Scegliete Modifica > Preferenze (Windows) o Fireworks > Preferenze (Mac OS).

  2. Fate clic sulla categoria dei plug-in.

  3. Selezionate Plug-in Photoshop.

    Viene visualizzata la finestra di dialogo Seleziona una cartella (Windows) o Scegli una cartella (Mac OS).

    Nota:

    Se la finestra di dialogo non si apre, fate clic su Sfoglia.

  4. Individuate la cartella nella quale sono installati i filtri e i plug-in di Photoshop o altri programmi, quindi fate clic su Seleziona (Windows) o Scegli (Mac OS).

  5. Fate clic su OK per chiudere la finestra di dialogo Preferenze.

  6. Riavviate Fireworks.

Attivare i plug-in di Photoshop mediante la finestra di dialogo dei filtri attivi

  1. Selezionate un oggetto vettoriale, un oggetto bitmap o un blocco di testo nell’area di lavoro e fate clic sul pulsante più (+) accanto all’etichetta Filtri nella finestra di ispezione Proprietà.

  2. Selezionate Opzioni > Individua plug-in dal menu a comparsa.

  3. Individuate la cartella nella quale sono installati i filtri e i plug-in di Photoshop o altri programmi, quindi fate clic su Seleziona (Windows) o Scegli (Mac OS). Se compare un messaggio che richiede di riavviare Fireworks, fate clic su OK.

  4. Riavviate Fireworks per caricare i filtri e i plug-in.

    Nota:

    In alternativa, è possibile installare i plug-in direttamente nella corrispondente cartella di Fireworks.

Inserire gli elementi grafici di Fireworks in Photoshop

Fireworks garantisce un supporto esteso per l’esportazione dei file in formato Photoshop (PSD). Le immagini di Fireworks esportate in Photoshop mantengono le stesse caratteristiche di modificabilità una volta riaperte in Fireworks, così come gli altri elementi grafici di Photoshop. Gli utenti di Photoshop possono intervenire sulle immagini in Fireworks e quindi proseguire la fase di modifica in Photoshop.

Nota:

È possibile utilizzare l’estensione Salva PSD per esportare rapidamente le pagine e gli stati del documento Fireworks come file separati PSD. Questa estensione è disponibile alla pagina http://www.adobe.com/go/learn_fw_psdsave_en

Esportare un file in formato Photoshop

  1. Selezionate File > Salva con nome.

  2. Assegnate un nome al file e scegliete Photoshop PSD dal menu Salva con nome.

  3. Per specificare le impostazioni di esportazione preimpostate per oggetti, effetti e testo, fate clic su Opzioni. Quindi, scegliete una preimpostazione dal menu Impostazioni.

    Mantieni modificabilità rispetto all’aspetto

    Converte gli oggetti in livelli, conserva la modificabilità degli effetti e converte il testo in livelli di testo modificabili di Photoshop. Selezionate questa opzione se si prevedono interventi importanti sulle immagini di Photoshop e non è quindi necessario conservare l’aspetto preciso dell’immagine di Fireworks.

    Mantieni aspetto Fireworks

    Converte ogni oggetto in un singolo livello di Photoshop, gli effetti e il testo in immagini diventano quindi non modificabili. Selezionate questa opzione per mantenere il controllo sugli oggetti di Fireworks in Photoshop e conservare contemporaneamente l’aspetto originale dell’immagine di Fireworks.

    File Photoshop ridotto

    Appiattisce ogni livello in un’immagine pienamente renderizzata. Selezionate questa opzione se si esporta un file contenente un numero elevato di oggetti Fireworks.

    Personalizzata

    Consente di specificare impostazioni specifiche per oggetti, effetti e testo.

  4. Fate clic su Salva per esportare il file di Photoshop.

    Nota:

    Photoshop 5.5 e versioni precedenti non possono aprire i file contenenti più di 100 livelli. È necessario eliminare o unire gli oggetti se il documento di Fireworks che si sta esportando contiene più di 100 oggetti.

Personalizzare le impostazioni di esportazione di Photoshop

  1. Nella finestra di dialogo Salva con nome, selezionate Photoshop PSD come tipo di file e fate clic su Opzioni.

  2. Nel menu a comparsa Impostazioni, scegliete Personale.

  3. Nel menu a comparsa Oggetti, scegliete una delle opzioni seguenti:

    Converti in livelli Photoshop

    Converte oggetti singoli di Fireworks in livelli di Photoshop e le maschere di Fireworks in maschere livello di Photoshop.

    Riduci a livello singolo ogni livello Fireworks

    Appiattisce tutti gli oggetti di ogni singolo livello di Fireworks e trasforma ogni livello di Fireworks in un livello in Photoshop. Quando si sceglie questa opzione, si perde la capacità di modificare gli oggetti di Fireworks in Photoshop. Andranno perse anche altre caratteristiche associate agli oggetti di Fireworks, come le modalità di fusione.

  4. Nel menu a comparsa Effetti, scegliete una delle opzioni seguenti:

    Mantieni modificabilità

    Converte i filtri attivi di Fireworks nel loro equivalente Photoshop. Gli eventuali effetti privi di corrispondenti in Photoshop vengono scartati.

    Rendering degli effetti

    Appiattisce gli effetti in oggetti. Quando si sceglie questa opzione, l’aspetto degli effetti viene mantenuto, ma non è possibile modificare gli effetti in Photoshop.

  5. Nel menu a comparsa Testo, scegliete una delle opzioni seguenti:

    Mantieni modificabilità

    Converte il testo in un livello modificabile di Photoshop. Le caratteristiche di formattazione del testo non supportate in Photoshop vanno perse.

    Rendering del testo

    Trasforma il testo in un oggetto immagine. Quando si sceglie questa opzione, l’aspetto del testo viene mantenuto, ma non è possibile modificare il testo.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online