Guida utente Annulla

Ottimizzare le prestazioni di Photoshop

  1. Guida utente di Photoshop
  2. Introduzione a Photoshop
    1. Sognare e creare.
    2. Novità di Photoshop
    3. Modificare la prima foto
    4. Creare documenti
    5. Photoshop | Domande comuni
    6. Requisiti di sistema per Photoshop
    7. Scopri Photoshop
  3. Photoshop e altri servizi e prodotti Adobe
    1. Lavorare con la grafica di Illustrator su Photoshop
    2. Operazioni con file Photoshop in InDesign
    3. Materiali Substance 3D per Photoshop
    4. Usare l’estensione Capture in-app in Photoshop
  4. Photoshop su iPad (non disponibile nella Cina continentale)
    1. Photoshop su iPad | Domande comuni
    2. Scoprire l’area di lavoro
    3. Requisiti di sistema | Photoshop per iPad
    4. Creare, aprire ed esportare i documenti
    5. Aggiungi foto
    6. Utilizzare i livelli
    7. Disegnare e dipingere con i pennelli
    8. Effettuare selezioni e aggiungere maschere
    9. Ritoccare le composizioni
    10. Operazioni con i livelli di regolazione
    11. Regolare la tonalità dei compositi con Curve
    12. Applicare le operazioni di trasformazione
    13. Ritagliare e ruotare le composizioni
    14. Rotazione, panning, zoom e reimpostazione dell’area di lavoro
    15. Operazioni con i livelli di testo
    16. Operazioni con Photoshop e Lightroom
    17. Ottenere font mancanti in Photoshop su iPad
    18. Testo giapponese in Photoshop su iPad
    19. Gestire le impostazioni dell’app
    20. Scorciatoie e movimenti touch
    21. Scelte rapide da tastiera
    22. Modificare le dimensioni dell’immagine
    23. Livestream durante la creazione in Photoshop su iPad
    24. Correggere le imperfezioni con il Pennello correttivo
    25. Creare pennelli in Capture e usarli in Photoshop su iPad
    26. Lavorare con i file Camera Raw
    27. Creare e lavorare con gli oggetti avanzati
    28. Regolare l’esposizione nelle immagini con Scherma e brucia
    29. Comandi di regolazione automatica in Photoshop su iPad
    30. Sfumare aree nelle immagini con Photoshop su iPad
    31. Aggiungere o togliere saturazione alle immagini con lo strumento Spugna
    32. Riempimento in base al contenuto per iPad
  5. Photoshop per il Web (non disponibile nella Cina continentale)
    1. Domande frequenti
    2. Requisiti di sistema
    3. Scelte rapide da tastiera
    4. Tipi di file supportati
    5. Introduzione all’area di lavoro
    6. Aprire e lavorare con i documenti cloud
    7. Funzioni di IA generativa
    8. Concetti di base dell’editing
    9. Azioni rapide
    10. Utilizzare i livelli
    11. Ritoccare le immagini e rimuovere le imperfezioni
    12. Effettuare selezioni rapide
    13. Migliorare le immagini con i livelli di regolazione
    14. Spostare, trasformare e ritagliare le immagini
    15. Disegnare e dipingere
    16. Operazioni con i livelli di testo
    17. Collaborare con chiunque sul Web
    18. Gestire le impostazioni dell’app
    19. Genera immagine
    20. Genera sfondo
    21. Immagine di riferimento
  6. Photoshop (beta) (non disponibile nella Cina continentale)
    1. Introduzione alle versioni beta delle app Creative Cloud
    2. Photoshop (beta) per desktop
    3. Generare immagini con prompt di testo descrittivi
    4. Generare sfondi con prompt di testo descrittivi
  7. IA generativa (non disponibile nella Cina continentale) 
    1. Domande frequenti sulla IA generativa in Photoshop
    2. Riempimento generativo di Photoshop per desktop
    3. Espansione generativa in Photoshop per desktop
    4. Riempimento generativo in Photoshop su iPad
    5. Espansione generativa in Photoshop su iPad
    6. Funzioni di IA generativa in Photoshop per il Web
  8. Autenticità dei contenuti (non disponibile nella Cina continentale)
    1. Credenziali del contenuto in Photoshop
    2. Identità e provenienza dei NFT
    3. Connettere un account per l’attribuzione creativa
  9. Documenti cloud (non disponibili nella Cina continentale)
    1. Documenti cloud di Photoshop | Domande comuni
    2. Documenti cloud di Photoshop | Domande sul flusso di lavoro
    3. Gestione e lavoro con i documenti cloud in Photoshop
    4. Aggiornare l’archiviazione cloud per Photoshop
    5. Impossibile creare o salvare un documento cloud
    6. Risolvere i problemi dei documenti cloud di Photoshop
    7. Raccogliere i registri di sincronizzazione dei documenti cloud
    8. Invitare altri utenti a modificare i documenti cloud
    9. Condividere file e commenti direttamente dall’app
  10. Area di lavoro
    1. Nozioni di base sull’area di lavoro
    2. Preferenze
    3. Imparare più velocemente con il pannello Discover di Photoshop
    4. Creare documenti
    5. Inserire file
    6. Scelte rapide da tastiera predefinite
    7. Personalizzare le scelte rapide da tastiera
    8. Panoramica degli strumenti
    9. Preferenze per le prestazioni
    10. Utilizzare gli strumenti
    11. Predefiniti
    12. Griglia e guide
    13. Movimenti touch
    14. Usare la Touch Bar con Photoshop
    15. Funzionalità touch e aree di lavoro personalizzabili
    16. Anteprime tecnologiche
    17. Metadati e note
    18. Funzionalità touch e aree di lavoro personalizzabili
    19. Inserire immagini di Photoshop in altre applicazioni
    20. Righelli
    21. Visualizzare o nascondere gli elementi extra non stampabili
    22. Specificare le colonne per un’immagine
    23. Annullare e il pannello Storia
    24. Pannelli e menu
    25. Posizionare elementi con allineamento
    26. Posizionare con lo strumento righello
  11. Creazione di contenuti per il Web, per lo schermo e app
    1. Photoshop per la progettazione
    2. Tavole da disegno
    3. Anteprima dispositivo
    4. Copiare CSS dai livelli
    5. Dividere in sezioni una pagina Web
    6. Opzioni HTML per sezioni
    7. Modificare la disposizione delle sezioni
    8. Lavorare con la grafica per il Web
    9. Creare gallerie di foto per il Web
  12. Concetti di base sul colore e sulle immagini
    1. Come ridimensionare le immagini
    2. Utilizzare immagini raster e vettoriali
    3. Dimensioni e risoluzione dell’immagine
    4. Acquisire le immagini da fotocamere e scanner
    5. Creare, aprire e importare le immagini
    6. Visualizzare immagini
    7. Errore: Marcatore JPEG non valido | Apertura immagini
    8. Visualizzare più immagini
    9. Personalizzare i selettori colore e i campioni
    10. Immagini HDR (High Dynamic Range)
    11. Ottenere colori corrispondenti nell’immagine
    12. Convertire le immagini in un altro metodo di colore
    13. Metodi di colore
    14. Cancellare parti di un’immagine
    15. Metodi fusione
    16. Scegliere i colori
    17. Personalizzare le tavole dei colori per immagini in scala di colore
    18. Informazioni sulle immagini
    19. I filtri di distorsione sono non disponibili
    20. Il colore
    21. Regolazioni a colori e monocromatiche con i canali
    22. Scegliere i colori nei pannelli Colore e Campioni
    23. Campionare
    24. Metodo di colore o Metodo di immagine
    25. Dominante di colore
    26. Aggiungere una modifica di metodo condizionale a un’azione
    27. Aggiungere campioni da file HTML, CSS e SVG
    28. Profondità di bit e preferenze
  13. Livelli
    1. Nozioni di base sui livelli
    2. Modifiche non distruttive
    3. Creare e gestire livelli e gruppi
    4. Selezionare, raggruppare e collegare i livelli
    5. Inserire immagini nelle cornici
    6. Opacità e fusione dei livelli
    7. Mascherare i livelli
    8. Applicare filtri avanzati
    9. Composizioni di livelli
    10. Spostare, sovrapporre e bloccare i livelli
    11. Mascherare i livelli con maschere vettoriali
    12. Gestire livelli e gruppi
    13. Stili ed effetti di livello
    14. Modificare le maschere di livello
    15. Estrarre le risorse
    16. Rivelare i livelli con maschere di ritaglio
    17. Generare risorse di immagini dai livelli
    18. Utilizzare gli oggetti avanzati
    19. Metodi fusione
    20. Combinare più immagini in un ritratto di gruppo
    21. Combinare le immagini con Fusione automatica livelli
    22. Allineare e distribuire i livelli
    23. Copiare CSS dai livelli
    24. Caricare selezioni dai bordi di un livello o di una maschera di livello
    25. Foratura per rivelare il contenuto di altri livelli
  14. Selezione
    1. Introduzione alle selezioni
    2. Effettuare selezioni nella composizione
    3. Area di lavoro Seleziona e maschera
    4. Selezionare con gli strumenti di selezione
    5. Selezionare con gli strumenti lazo
    6. Regolare selezioni di pixel
    7. Spostare, copiare ed eliminare i pixel selezionati
    8. Creare una maschera veloce temporanea
    9. Selezionare un intervallo di colori in un’immagine
    10. Convertire i tracciati in bordi di selezione e viceversa
    11. Nozioni di base sui canali
    12. Salvare selezioni e maschere di canali alfa
    13. Selezionare le aree di interesse di un’immagine
    14. Duplicare, dividere e unire i canali
    15. Calcoli per le operazioni con i canali
  15. Regolazioni delle immagini
    1. Sostituire il colore degli oggetti
    2. Alterare la prospettiva
    3. Ridurre la sfocatura causata da fotocamera mossa
    4. Esempi di utilizzo del pennello correttivo
    5. Esportare le tavole di consultazione del colore
    6. Regolare la nitidezza e la sfocatura dell’immagine
    7. Le regolazioni di colore
    8. Applicare una regolazione Luminosità/contrasto
    9. Regolare i particolari nelle aree di ombra e di luce
    10. Regolazioni Valori tonali
    11. Regolare tonalità e saturazione
    12. Regolare la vividezza
    13. Regolare la saturazione dei colori in un’area dell’immagine
    14. Effettuare regolazioni tonali rapide
    15. Applicare effetti speciali di colore alle immagini
    16. Migliorare l’immagine con le regolazioni di Bilanciamento colore
    17. Immagini HDR (High Dynamic Range)
    18. Visualizzare istogrammi e valori dei pixel
    19. Ottenere colori corrispondenti nell’immagine
    20. Ritagliare e raddrizzare le foto
    21. Convertire un’immagine a colori in bianco e nero
    22. Livelli di regolazione e riempimento
    23. Regolazioni Curve
    24. Metodi fusione
    25. Preparare immagini per la stampa
    26. Regolare colore e tonalità con i contagocce di Valori tonali e Curve
    27. Effettuare regolazioni con Esposizione HDR e Viraggio HDR
    28. Schermare o bruciare un’area dell’immagine
    29. Eseguire regolazioni selettive del colore
  16. Adobe Camera Raw
    1. Requisiti di sistema per Camera Raw
    2. Novità in Camera Raw
    3. Introduzione a Camera Raw
    4. Creare panorami
    5. Obiettivi supportati
    6. Effetti Vignettatura, Granulosità e Rimuovi foschia in Camera Raw
    7. Scelte rapide da tastiera predefinite
    8. Correzione prospettica automatica in Camera Raw
    9. Filtro radiale in Camera Raw
    10. Gestione delle impostazioni di Camera Raw
    11. Aprire, elaborare e salvare le immagini in Camera Raw
    12. Riparare le immagini con lo strumento rimozione macchie ottimizzato di Camera Raw
    13. Ruotare, ritagliare e ritoccare le immagini
    14. Regolare la riproduzione dei colori in Camera Raw
    15. Versioni di processo in Camera Raw
    16. Apportare regolazioni locali in Camera Raw
  17. Ritocco e riparazione delle immagini
    1. Rimuovere oggetti dalle foto con Riempimento in base al contenuto
    2. Correzione e spostamento in base al contenuto
    3. Ritoccare e riparare le foto
    4. Correzione della distorsione e del disturbo di un’immagine
    5. Procedure di base per la risoluzione della maggior parte dei problemi
  18. Miglioramento e trasformazione delle immagini
    1. Sostituire il cielo nelle immagini
    2. Trasformare gli oggetti
    3. Regolare il ritaglio, la rotazione e la dimensione del quadro
    4. Come ritagliare e raddrizzare le foto
    5. Creare e modificare immagini panoramiche
    6. Alterare immagini, forme e tracciati
    7. Fuoco prospettico
    8. Ridimensionamento in base al contenuto
    9. Trasformare immagini, forme e tracciati
  19. Disegnare e colorare
    1. Disegnare pattern simmetrici
    2. Disegnare rettangoli e modificare le opzioni di traccia
    3. Il disegno
    4. Disegnare e modificare le forme
    5. Strumenti di pittura
    6. Creare e modificare i pennelli
    7. Metodi fusione
    8. Aggiungere colore ai tracciati
    9. Modificare i tracciati
    10. Colorare con lo strumento pennello miscela colori
    11. Pennelli predefiniti
    12. Sfumature
    13. Interpolazione sfumatura
    14. Applicare riempimento e traccia a selezioni, livelli e tracciati
    15. Disegnare con gli strumenti penna
    16. Creare i pattern
    17. Generare un pattern con Crea pattern
    18. Gestire i tracciati
    19. Gestire le librerie di pattern e i predefiniti
    20. Disegnare o colorare con una tavoletta grafica
    21. Creare pennelli con texture
    22. Aggiungere elementi dinamici ai pennelli
    23. Sfumatura
    24. Colorare con tratti stilizzati con lo strumento pennello artistico storia
    25. Applicare un pattern
    26. Sincronizzare i predefiniti su più dispositivi
    27. Migrazione di predefiniti, azioni e impostazioni
  20. Testo
    1. Aggiungere e modificare il testo
    2. Unified Text Engine
    3. Utilizzare i font SVG OpenType
    4. Formattare i caratteri
    5. Formattare i paragrafi
    6. Come creare effetti di testo
    7. Modificare il testo
    8. Spaziatura tra righe e caratteri
    9. Testo in arabo e in ebraico
    10. Font
    11. Risoluzione dei problemi relativi ai font
    12. Testo asiatico
    13. Creare il testo
  21. Filtri ed effetti
    1. Utilizzare la Galleria sfocatura
    2. Nozioni di base sui filtri
    3. Presentazione degli effetti dei filtri
    4. Aggiungere effetti di luce
    5. Usare il filtro Grandangolo adattato
    6. Usare il filtro Dipinto a olio
    7. Utilizzare il filtro Fluidifica
    8. Stili ed effetti di livello
    9. Applicare filtri specifici
    10. Sfumare un’area dell’immagine
  22. Salvataggio ed esportazione
    1. Salvare i file in Photoshop
    2. Esportare i file in Photoshop
    3. Formati di file supportati
    4. Salvare i file in formati grafici
    5. Spostare i progetti tra Photoshop e Illustrator
    6. Salvare ed esportare video e animazioni
    7. Salvare i file PDF
    8. Protezione Digimarc del copyright
  23. Gestione del colore
    1. Comprendere la gestione del colore
    2. Mantenere i colori coerenti
    3. Impostazioni del colore
    4. Immagini a due tonalità
    5. Utilizzare i profili colore
    6. Gestione del colore nei documenti da visualizzare online
    7. Gestione del colore dei documenti durante la stampa
    8. Gestione del colore nelle immagini importate
    9. Prove colore
  24. Creazione di contenuti per il Web, per lo schermo e app
    1. Photoshop per la progettazione
    2. Tavole da disegno
    3. Anteprima dispositivo
    4. Copiare CSS dai livelli
    5. Dividere in sezioni una pagina Web
    6. Opzioni HTML per sezioni
    7. Modificare la disposizione delle sezioni
    8. Lavorare con la grafica per il Web
    9. Creare gallerie di foto per il Web
  25. Video e animazioni
    1. Modifiche video in Photoshop
    2. Modificare i livelli di animazioni e video
    3. Panoramica su video e animazioni
    4. Anteprima di video e animazioni
    5. Colorare i fotogrammi nei livelli video
    6. Importare file video e sequenze di immagini
    7. Creare animazioni di fotogrammi
    8. Creative Cloud 3D Animation (anteprima)
    9. Creare animazioni nella timeline
    10. Creare le immagini per i video
  26. Stampa
    1. Stampare oggetti 3D
    2. Stampare da Photoshop
    3. Stampa con la gestione del colore
    4. Provini a contatto e presentazioni PDF
    5. Stampare le foto con un layout Pacchetto d’immagini
    6. Stampa di tinte piatte
    7. Stampare immagini con una macchina da stampa
    8. Migliorare le stampe a colori da Photoshop
    9. Risoluzione dei problemi di stampa | Photoshop
  27. Automazione
    1. Creazione delle azioni
    2. Creare la grafica basata su dati
    3. Script
    4. Elaborare i file in batch
    5. Eseguire e gestire le azioni
    6. Aggiungere azioni condizionali
    7. Le azioni e il pannello Azioni
    8. Registrare gli strumenti nelle azioni
    9. Aggiungere una modifica di metodo condizionale a un’azione
    10. Toolkit dell’interfaccia utente di Photoshop per plug-in e script
  28. Risoluzione dei problemi
    1. Problemi risolti 
    2. Problemi noti
    3. Ottimizzare le prestazioni di Photoshop
    4. Risoluzione dei problemi di base
    5. Risoluzione dei problemi di blocco o arresto anomalo
    6. Risoluzione dei problemi dovuti a errori nel programma
    7. Risoluzione dell’errore “Disco di memoria virtuale pieno”
    8. Risoluzione dei problemi relativi a GPU e driver della scheda grafica
    9. Trovare strumenti mancanti
    10. Photoshop | Domande frequenti sulla rimozione delle funzioni 3D

Provate le tecniche e i suggerimenti descritti in questo documento se Photoshop viene eseguito più lentamente del previsto sul computer

  Interruzione delle funzioni 3D in Photoshop

Le funzioni 3D di Photoshop verranno rimosse in seguito agli aggiornamenti futuri. Gli utenti che lavorano con 3D sono incoraggiati ad esplorare la nuova raccolta 3D di Adobe Substance, che rappresenta la nuova generazione di strumenti 3D di Adobe. Ulteriori dettagli sull’interruzione delle funzioni 3D di Photoshop sono disponibili qui: Photoshop 3D | Domande comuni sull’interruzione delle funzioni 3D.

Consigli generali per migliorare le prestazioni

Per ottenere le prestazioni migliori in Photoshop, è necessario adottare una combinazione di tecniche che varia di volta in volta in base alle circostanze. Leggete tutti i suggerimenti contenuti in questo documento e stabilite quali implementare in base alla configurazione informatica, al tipo di file utilizzati e al flusso di lavoro prescelto. Esistono quattro modi principali per influire sulle prestazioni in Photoshop: Ottimizzare la configurazione hardwareOttimizzare il sistema operativo per PhotoshopImpostare le preferenze relative alle prestazioniOttimizzare le funzioni di Photoshop.

Il modo più semplice per migliorare le prestazioni, senza alcun costo in denaro, consiste nell’impostare le preferenze e regolare le funzionalità di Photoshop in modo da trarre vantaggio dall’utilizzo dell’applicazione e dai file più utilizzati.

Il modo più drastico di aumentare le prestazioni è investire in hardware più veloce e più potente. Affinché Photoshop venga eseguito in modo ottimale, il computer deve rispettare alcuni requisiti di sistema minimi. Se Photoshop viene eseguito su un hardware non supportato o con una potenza non sufficiente, ad esempio un computer con un processore grafico (GPU) incompatibile, le prestazioni potrebbero risentirne.

Impostazione delle preferenze relative alle prestazioni

Guardate questo breve video per scoprire come ottimizzare rapidamente le preferenze relative alle prestazioni in Photoshop.

Photoshop fornisce un insieme di preferenze (Preferenze > Prestazioni) che contribuisce a ottimizzare l’utilizzo delle risorse del computer, ad esempio memoria, cache, processore grafico, monitor ecc. A seconda dell’utilizzo principale di Photoshop e del tipo di documenti su cui lavori di solito, potreste avere bisogno di una combinazione di tali impostazioni.

Vi sono altre impostazioni, ad esempio Dischi memoria virtuale, disponibili in altre schede della finestra di dialogo Preferenze, che potrebbero avere un’influenza diretta sulla velocità e la stabilità del computer.

Preferenze per le prestazioni di Photoshop

Regolare la memoria allocata in Photoshop

Potete migliorare le prestazioni aumentando la quantità di memoria/RAM allocata a Photoshop. L'area Uso memoria della finestra di dialogo Preferenze prestazioni (Preferenze > Prestazioni) indica quanta RAM è disponibile per Photoshop e mostra l'intervallo di allocazione di memoria a Photoshop ideale per il sistema in uso.

Per impostazione predefinita, Photoshop utilizza il 70% della RAM disponibile.

  1. Potete assegnare più o meno RAM a Photoshop modificandone il valore nella casella Consenti a PS di usare. In alternativa, regolate il cursore Uso memoria.
  2. Riavviate Photoshop per rendere effettive le modifiche.

Per determinare l’allocazione di RAM adatta al sistema, modificate il valore predefinito di incrementi del 5%, monitorando le prestazioni nell’indicatore di stato dell’efficienza. 

Si consiglia di non allocare più dell’85% della memoria del computer a Photoshop. In caso contrario, le prestazioni potrebbero risultare compromesse, poiché non rimarrebbe memoria sufficiente per altre applicazioni di sistema essenziali.

Nota:

Se si verificano errori determinati da RAM o memoria insufficiente in Photoshop, aumentate la RAM allocata a questo programma. Tuttavia, se la RAM allocata a Photoshop è troppo alta (>85%), le prestazioni di altre applicazioni in uso potrebbero risentirne, rendendo instabile il sistema. 

La soluzione migliore a questo problema è l'espansione della RAM del computer. Verificate con il produttore del computer le specifiche di RAM e la compatibilità.

Regolare i livelli di cache

Nozioni di base sulla cache

Photoshop utilizza la cache delle immagini per velocizzare l’aggiornamento dei documenti ad alta risoluzione mentre lavori su di essi. Potete specificare fino a otto livelli di dati immagine memorizzati nella cache e scegliere una delle quattro dimensioni delle porzioni di cache disponibili.

Impostando i livelli di cache su un valore più elevato, otterrete tempi di risposta più rapidi durante l’utilizzo di Photoshop, ma il caricamento delle immagini richiederà più tempo. Le dimensioni della porzione di cache determinano la quantità di dati su cui Photoshop può operare contemporaneamente. Le porzioni più grandi consentono di velocizzare operazioni complesse, quali ad esempio l’utilizzo dei filtri di contrasto, mentre modifiche di entità minore, come i tratti del pennello, risultano più rapide quando si utilizzano porzioni più piccole.

Predefiniti cache

Nelle preferenze Prestazioni, sono disponibili tre valori predefiniti per la cache. Scegliete quella più adatta all’utilizzo principale di Photoshop:

  • Progettazione Web/interfaccia utente: scegli questa opzione se utilizzi Photoshop principalmente per la progettazione di siti Web, app o schermate. Questa opzione è consigliata per i documenti che presentano diversi livelli di risorse con dimensioni in pixel da basse a medie.
  • Predefinita/foto: scegliete questa opzione se utilizzi Photoshop principalmente per ritoccare o modificare immagini con dimensioni medie. Ad esempio, utilizzatela se di norma modifichi con Photoshop foto scattate con il cellulare o la fotocamera digitale.
  • Dimensioni in pixel molto grandi: scegliete questa opzione se lavorate spesso in Photoshop su documenti di dimensioni molto grandi, ad esempio panorami, pitture di sfondi ecc.

Livelli cache

Per un controllo più dettagliato, specificate i livelli di cache manualmente; il valore predefinito è 4.

  • Se utilizzate file di dimensioni relativamente contenute (circa 1 megapixel o 1.280 x 1.024 pixel) e numerosi livelli (50 o più), imposta i livelli di cache su 1 o 2. Impostando l’opzione Livelli cache su 1, potete disattivare la cache delle immagini; in questo caso, solo l’immagine della schermata corrente viene immessa nella cache.
  • Se utilizzate file di dimensioni maggiori (ad esempio, 50 megapixel o superiori), impostate Livelli cache su un livello superiore a 4. Livelli di cache elevati consentono di velocizzare l’aggiornamento.
Nota:

Se il valore dei livelli di cache è impostato su 1, potrebbe non essere possibile ottenere risultati di alta qualità con alcune funzionalità di Photoshop.

Limitare gli stati storia

Potete risparmiare spazio sul disco di memoria virtuale e migliorare le prestazioni limitando o riducendo il numero di stati che Photoshop può salvare nel pannello Storia. La quantità di spazio risparmiato dipende dal numero di pixel modificati durante un’operazione. Ad esempio, lo stato storia relativo a un piccolo tratto di pennello o a un’operazione non distruttiva, come la creazione o la modifica di un livello di regolazione, consuma un esiguo spazio di memoria virtuale. Al contrario, l’applicazione di un filtro a un’immagine intera richiede molto più spazio.

Photoshop può salvare fino a 1000 stati storia; il numero predefinito è 50.

Per ridurre tale numero, accedete alla finestra di dialogo delle preferenze Prestazioni. Nella sezione Cronologia e cache
impostate il numero di Stati storia su un valore inferiore.

Configurare le impostazioni del processore grafico (GPU)

Il modo migliore per ottimizzare l’accelerazione GPU e, di conseguenza, velocizzare gli aggiornamenti dello schermo, consiste nel mantenere aggiornato il driver della scheda video.  Per istruzioni sull'aggiornamento dei driver della scheda video

Vedi Aggiornare il driver grafico.

Per ulteriori informazioni su come Photoshop utilizzate il processore grafico, le schede testate e i requisiti minimi del processore grafico e del display. 

Vedete Domande frequenti sull’uso di schede video (GPU) in Photoshop.

Preferenze GPU

Photoshop offre impostazioni dedicate per la GPU sia nella sezione Prestazioni sia in quella 3D della finestra di dialogo Preferenze.

Impostazioni nella sezione Preferenze > Prestazioni

Se nel sistema viene rilevata una scheda video appropriata, il nome e il modello vengono visualizzati in Processore grafico rilevato nell'area Impostazioni processore grafico della sezione Prestazioni.

  • Se la scheda grafica è supportata, la casella di controllo "Usa processore grafico" è abilitata e spuntata per impostazione predefinita.
  • Se la scheda grafica non è supportata, la casella di controllo è disattivata e non spuntata per impostazione predefinita.
  • Se la scheda grafica è supportata e la casella di controllo "Usa processore grafico" non è spuntata, è probabile che Photoshop abbia rilevato un arresto causato da un driver grafico difettoso o da una configurazione errata. Vedi Risoluzione dei problemi del processore grafico (GPU) di Photoshop e dei driver della scheda grafica.

Altre impostazioni avanzate:

  • Usa OpenCL: disattivate questa opzione se Galleria sfocatura, Nitidezza avanzata, Seleziona area di interesse selezionata o Dimensione immagine con mantieni particolari non funzionano come previsto.
  • Guide e tracciati anti-alias: disattivate l'opzione se le guide e i tracciati appaiono troppo pesanti o troppo ampi
  • Monitor a 30 bit: attivate l'opzione per aumentare la fedeltà del colore su un monitor che supporta 30 bit.
Disattivare Open CL

Nota:

L’attivazione di OpenCL potrebbe migliorare le prestazioni durante l’utilizzo delle funzioni di Photoshop seguenti:

  • Galleria sfocatura: Campo Sfoca, Sfocatura diaframma, Scostamento inclinazione, Sfocatura percorso, Sfocatura rotazione (OpenCL accelerato)
  • Nitidezza avanzata (Riduzione del rumore: OpenCL accelerato)
  • Selezione e maschera (OpenCL accelerato)

Impostazioni nella sezione Preferenze > 3D

La sezione 3D della finestra di dialogo Prestazioni contiene un cursore VRAM simile al controllo della memoria situato nella sezione Prestazioni. Utilizzate il cursore per determinare il limite superiore della RAM video (VRAM) disponibile per il motore 3D di Photoshop. Il valore totale equivale a una percentuale della VRAM totale disponibile. Anche se si imposta il valore sul 100%, una parte della VRAM totale verrà comunque destinata al sistema operativo. Valori superiori possono migliorare le prestazioni 3D generali, ma potrebbero pregiudicare quelle di altre applicazioni con funzionalità GPU abilitata.

3D: uso della memoria

Gestire i dischi di memoria virtuale

Nota:

Se non è possibile avviare Photoshop a causa di spazio insufficiente nel disco di memoria, tieni premuti i tasti Comando+Opzione (macOS) o Ctrl+Alt (Windows) all'avvio per impostare un nuovo disco di memoria virtuale.

Mentre lavorate al vostro processo creativo in Photoshop, potrebbe verificarsi un errore del disco di memoria virtuale che vi impedisce di completare l’attività desiderata. Ma che cos’è un disco di memoria virtuale?

Per ulteriori informazioni sulla gestione delle preferenze del disco di memoria virtuale e sulle impostazioni consigliate, consultate Configurare i dischi di memoria virtuale.

Per ulteriori informazioni sulla risoluzione dei problemi legati ai dischi di memoria virtuale, consultate Risoluzione dei problemi dei dischi di memoria virtuale in Photoshop.

Indicatore Efficienza

Quando lavori in Photoshop, controlla l’indicatore dell’efficienza per monitorare le prestazioni. Fate clic sul menu a comparsa nella parte inferiore della finestra dell’immagine e scegliete Efficienza dal menu a comparsa.

Se il valore dell’indicatore è inferiore al 100%, Photoshop ha utilizzato tutta la RAM disponibile e sta utilizzando il disco di memoria virtuale, rallentando così le prestazioni. Se l’efficienza è inferiore al 90%, assegna più RAM a Photoshop in Preferenze prestazioni Oppure, aggiungi ulteriore RAM al sistema.

Indicatore Efficienza

Ottimizzazione delle funzionalità di Photoshop per le prestazioni

Disattivazione di righelli e sovrapposizioni

Righelli e sovrapposizioni (come griglie, sezioni e guide sensibili) possono rallentare alcune operazioni, ad esempio la pittura, la trasformazione e il trascinamento dei livelli sull’area di lavoro.

  • Per disattivare i righelli, deselezionate Righelli nel menu Visualizza.
  • Per disattivare le sovrapposizioni, spostatevi al menu Visualizza > Mostra e selezionate Nessuna o disattivate le singole voci.

Vedete Visualizzare o nascondere gli elementi extra non stampabili.

Rispettare i limiti di dimensioni del file

I file di grandi dimensioni causano spesso problemi a livello di prestazioni.

Photoshop supporta file di dimensioni massime pari a 300.000 x 300.000 pixel, tranne che per i file PDF, il cui limite è 30.000 x 30.000 pixel e 200 x 200 pollici, e per Camera Raw, che supporta immagini con lunghezza o altezza fino a 65.000 pixel e fino a 512 megapixel.

Capacità di dimensioni file per Photoshop:

  • File PDS: 2 GB
  • File TIFF: 4 GB
  • File PSB: 4 exabyte (4.096 petabyte o 4 milioni di terabyte)
  • File PDF: 10 GB (dimensioni massime delle pagine: 200 pollici)

Chiudere finestre di documenti non necessari

Se ricevete un messaggio di errore di esaurimento RAM o se Photoshop funziona lentamente, è possibile che siano aperte troppe immagini contemporaneamente. Se ci sono più finestre aperte, provate a chiuderne alcune.

Riduzione del numero di impostazioni predefinite

Per ridurre la quantità di spazio utilizzata da Photoshop nel disco di memoria virtuale, riducete il numero dei predefiniti che mantieni caricati. I motivi e le punte dei pennelli sono alcuni dei predefiniti più grandi. Salvate i predefiniti che non dovete usare in questo momento in un file di predefiniti, quindi rimuoveteli e caricateli solo quando ne avete bisogno.

Per ulteriori informazioni sulla gestione dei predefiniti, vedere Predefiniti.

Ridurre o disattivare le miniature di anteprima dei pannelli

Ogni volta che il documento viene modificato, Photoshop aggiorna tutte le miniature visibili nei pannelli Livelli e Canali.. L’aggiornamento può influire sui tempi di risposta quando si utilizzano opzioni rapide di disegno, spostamento o sfioramento di livelli. Maggiore è il numero di miniature visibili, migliore sarà l'effetto.

Per ridurre o disattivare le miniature di anteprima, fate clic sul menu del pannello e scegliete Opzioni pannello. Selezionate una dimensione inferiore per la miniatura o selezionate Nessuno, quindi fate clic su OK.

Modificare le opzioni di compatibilità dei file

Se non dovete utilizzare i file PSD e PSB con versioni precedenti di Photoshop o con applicazioni che non supportano i livelli, potete disattivare una funzione di compatibilità dei file per velocizzare il salvataggio del documento:

  1. Per i documenti PSD e PSB a 16 e a 32 bit, selezionate Disattiva compressione di file PSD e PSB in Preferenze > Gestione file.

  2. Dal menu Massimizza compatibilità per file PSD e PSB, selezionate Chiedi o Mai.

Utilizzare il metodo immagine a 8 bit

Photoshop consente di effettuare numerose operazioni con le immagini a 16 e 32 bit. L’elaborazione di queste immagini richiede tuttavia una maggior quantità di memoria e spazio di memoria virtuale e tempi più lunghi rispetto alle immagini a 8 bit.

Per convertire l'immagine in formato 8 bit per canale, selezionate Immagine > Modalità > 8 bit/canale.

Vedete Profondità bit e preferenze.

Nota:

La conversione a 8 bit/canale comporta l’eliminazione di alcuni dati dall’immagine. Prima di effettuare la conversione a 8 bit/canale, salvate una copia dell’immagine originale a 16 o 32 bit.

Disattivare l'anteprima dei caratteri

Per velocizzare l'elaborazione dei caratteri in Photoshop, disattivate l'elenco delle anteprime dei caratteri selezionando Tipo > Dimensione anteprima carattere > Nessuno.

Ridurre la risoluzione dell’immagine

Più alta è la risoluzione dell’immagine, maggiore è la quantità di memoria e di spazio su disco richiesta da Photoshop per visualizzare, elaborare e stampare tale immagine. A seconda dell’output finale, una risoluzione più alta non è necessariamente sinonimo di maggiore qualità dell’immagine; al contrario, potrebbe comportare un rallentamento delle prestazioni e del processo di stampa e l’utilizzo di ulteriore spazio sul disco di memoria virtuale. La risoluzione ottimale delle immagini dipende dal modo in cui vengono visualizzate o stampate. 

Per le immagini da presentare sullo schermo, è opportuno ragionare in pixel. Per ridurre le dimensioni di un’immagine, scegliete Immagine > Dimensione immagine. Nella finestra di dialogo Dimensione immagine, verificate che l’opzione Ricampiona sia selezionata. Immettete un nuovo valore di larghezza o altezza (specificando il valore di una delle due dimensioni, entrambe vengono modificate).

Aumentare la risoluzione delle immagini stampate oltre 360 DPI, nella maggior parte dei casi comporta vantaggi insignificanti o nulli. Se producete un elevato numero di stampe, effettuate alcune prove per individuare la risoluzione ideale. Per ridurre la risoluzione di un’immagine, selezionate Immagine > Dimensione immagine. Nella finestra di dialogo Dimensione immagine, selezionate l’opzione Ricampiona. Modificate i valori di larghezza e altezza in modo tale che rispecchino le dimensioni fisiche del documento stampato. Riducete quindi il valore della risoluzione e fate clic su OK.

Se intendete aumentare, anziché ridurre, la risoluzione dell’immagine da stampare, eseguite questa operazione in coda, poco prima di stampare l’immagine. Questa modalità vi consente di non dover elaborare tutte queste informazioni supplementari nei primi passaggi.

Svuotare la memoria

Per migliorare le prestazioni del sistema, potete liberare memoria e spazio sul disco virtuale non utilizzati da Photoshop e renderli disponibili per altri programmi. Per farlo, scegliete una delle seguenti opzioni:

  • Modifica > Svuota memoria > Tutto
  • Modifica > Svuota memoria > Annulla
  • Tenete premuto il tasto Opzione (macOS) o Alt (Windows) e selezionate Informazioni su Photoshop

Se altri programmi stanno cercando di allocarsi o utilizzare la memoria, liberarla in Photoshop consentirà di migliorare le prestazioni. In caso di esaurimento del volume di un disco, potrebbe tornare utile liberare spazio sul disco di memoria virtuale. Quando viene liberata una notevole quantità di memoria o spazio su disco, la successiva apertura di file Photoshop di grandi dimensioni richiede più tempo, perché Photoshop deve allocare lo spazio.

Se desiderate che Photoshop utilizzi sempre una minor quantità di memoria, selezionate Modifica > Preferenze > Prestazioni (Windows) oppure Photoshop > Preferenze > Prestazioni (macOS) e spostate il dispositivo di scorrimento Uso memoria verso sinistra.

Consultate Regolare l’utilizzo della memoria.

Nota:

La registrazione delle modifiche da parte delle applicazioni di monitoraggio e gestione delle attività e delle utilità di controllo del disco può richiedere alcuni secondi. In effetti, per alcune utilità potrebbe essere necessario richiedere esplicitamente l’aggiornamento.

Svuotare la memoria degli Appunti

Il contenuto degli Appunti è spesso voluminoso se i dati vengono copiati e incollati in documenti di grandi dimensioni. Inoltre, una volta terminata l’operazione, tale contenuto non si rivela di grande utilità. Per liberare la memoria RAM utilizzata dai dati immagine negli Appunti, selezionate Modifica > Svuota memoria > Appunti.

Nota:

Non è possibile annullare l’operazione Svuota memoria.

Utilizzare la Galleria filtri

La Galleria filtri consente di provare uno o più filtri su un'immagine prima di applicarne gli effetti per accelerare i tempi di tale operazione e risparmiare memoria.

Vedete Panoramica della Galleria filtri.

Trascinare elementi da un file all’altro piuttosto che copiare e incollare

Trascinare i livelli o i file è più efficace di copiarli e incollarli, poiché è possibile saltare il passaggio della copia negli Appunti, trasferendo i dati direttamente. Copiare e incollare può comportare il trasferimento di una maggiore quantità di dati, riducendo l’efficienza.

Salvataggio di file TIFF senza compressione ZIP

Per esportare più velocemente i file TIFF, non selezionate la compressione ZIP. La compressione ZIP consente tuttavia di ridurre al minimo le dimensioni dei file TIFF.

Non eseguire l’esportazione degli Appunti

L’opzione Esporta Appunti consente a Photoshop di rendere disponibile il contenuto degli Appunti agli altri programmi. Se copiate elevate quantità di dati in Photoshop, che tuttavia non intendete copiare in altre applicazioni, risparmierete tempo disattivando questa opzione.

  1. Scegliete Photoshop > Preferenze > Generali (macOS) oppure Modifica > Preferenze > Generali (Windows).

  2. Deselezionate Esporta Appunti.

  3. Fate clic su OK.

Disattivazione del pannello Librerie

  1. Nel menu a comparsa Librerie, scegliete Chiudi.

  2. Riavviate Photoshop.

Disattivazione di Generator

  1. Scegliete Modifica > Preferenze > Plug-in.

  2. Deselezionate Abilita Generator.

  3. Fate clic su OK.

Composizione Photoshop

La composizione consiste nel combinare insieme diversi elementi visivi in un singolo fotogramma che rappresenta il documento. Il compositore interno di Photoshop effettua migliaia di calcoli mentre usate il programma, visualizzando costantemente ogni modifica apportata all’immagine insieme come un’unica composizione.

Composizione con multithread

Con la versione di aprile 2022 di Photoshop 22.3, è possibile attivare la composizione con multithread andando su Preferenze > Prestazioni e selezionando la casella di controllo Composizione con multithread. Per rendere effettiva questa modifica, non è necessario riavviare Photoshop.

Composizione con multithread

I livelli di regolazione, le maschere di livello, i metodi di fusione, i filtri, gli stili e gli effetti aggiungono complessità di elaborazione al documento che può ridurre la velocità di elaborazione di Photoshop. Potete notare che diverse regolazioni del cursore non aggiornano lo schermo con la stessa velocità con cui si usava prima che venissero aggiunti tutti questi livelli ed effetti. La composizione con multithread consente alle attività di composizione basate su CPU e GPU di lavorare più velocemente suddividendo il lavoro di elaborazione in parti più piccole che possono essere eseguite in parallelo, spesso più velocemente di quanto potrebbe essere calcolato in un singolo “thread”.

Anche se vi sono numerosi motivi per cui i documenti potrebbero diventare meno reattivi quando si lavora in Photoshop, velocizzare la composizione tra il 100% e il 250% con la composizione con multithread contribuisce in modo significativo a garantire che Photoshop possa essere tanto reattivo e fluido quanto necessario.

Se notate errori di ridisegno e sospettate che la composizione con multithread sia un problema, potete disattivare la funzione in Preferenze > Prestazioni. Per eventuali domande o per condividere un problema relativo a questa impostazione, visitate la community di Adobe Photoshop. Ci fa sempre piacere ricevere feedback!

Nota:

La composizione con multithread sostituisce l’avvertenza precedente sulla rimozione della composizione precedente, che non è più necessaria e che è stata rimossa.

Composizione con accelerazione GPU

Con la versione di aprile 2022 di Photoshop 22.3 è stata aggiunta la composizione GPU a Photoshop, per migliorare la velocità di risposta di alcune operazioni sui livelli all’interno di un documento. La composizione GPU può essere utilizzata solo se Photoshop rileva correttamente la GPU all’avvio. Per conferma, andate su Preferenze > Prestazioni e verificate che la GPU sia elencata nella sezione Impostazione processore grafico con una spunta accanto a Usa processore grafico.

Per trovare la casella di conferma che attiva o disattiva la composizione GPU, fate clic sul pulsante Impostazioni avanzate...

Composizione GPU

Con documenti più piccoli e meno complessi che contengono pochi livelli e poche regolazioni basate su livelli (ad esempio, metodi di fusione e livelli di regolazione), potreste non notare alcuna riduzione delle prestazioni quando attivate o disattivate i metodi di fusione o la visibilità dei livelli. Tuttavia, documenti più complessi e di dimensioni maggiori possono richiedere l’intervento del compositore di Photoshop per eseguire più elaborazioni in tempo reale con un conseguente aumento del tempo necessario per visualizzare i risultati sullo schermo. Con documenti molto complessi, potreste notare che lo schermo richiede una frazione di secondo maggiore per aggiornarsi e visualizzare i risultati quando si spostano i contenuti da un livello o si modifica l’opacità. Con la composizione GPU attivata, Photoshop utilizzerà una maggiore potenza di elaborazione della GPU per una composizione più veloce e un editing più fluido.

In caso di risultati imprevisti quando si effettuano modifiche basate su livelli, potete provare a disattivare la composizione GPU per vedere se ci sono state modifiche ai risultati. 

Hai una domanda o un’idea?

Chiedete alla community di utenti

Se avete domande o un’idea da condividere, partecipate alla community Adobe Photoshop. Saremmo lieti di conoscere le vostre opinioni!


 Adobe

Ottieni supporto in modo più facile e veloce

Nuovo utente?