Problema

Viene visualizzato un errore “è necessario installare il runtime Java SE 6 precedente” all’apertura di qualsiasi applicazione Adobe.

Legacy Java error

Soluzione

Con Mac OS 10.7 (Lion) e versioni successive, il runtime Java non è più installato automaticamente come parte dell’installazione del sistema operativo. Utilizza i metodi seguenti per installare il runtime Java.

Metodo 1

Puoi scaricare e installare il runtime Java più recente dal sito web Java - Download gratuito di Java.

Nota:

Su Mac OS 10.10 (Yosemite), all’avvio di qualsiasi prodotto Adobe, potresti ricevere l’avviso “L’applicazione è stata spostata e il percorso cambiato...”.

Fai clic su Correggi ora o Aggiorna per aggiornare la posizione e risolvere il problema. Quando viene richiesta lapasswordimmetti la password del sistema per completare.

Messaggio di avviso di spostamento dell’applicazione

Metodo 2

Se il runtime Java non è installato, viene richiesta l’installazione al primo avvio di qualsiasi prodotto Adobe. Segui le istruzioni visualizzate nella finestra di dialogo di notifica richiesta di Java per installare.

Metodo 3 (Mac OS 10.7 e 10.8)

Utilizza il metodo seguente per avviare l’installazione del runtime Java o confermare l’installazione.

  1. Vai a Applicazioni > Utility > Preferenze Java.
  2. Apri le preferenze Java.
  3. Se Java non è installato, ricevi il seguente messaggio: “Per aprire le preferenze Java, è necessario un runtime Java. Installarne uno ora?”

    Messaggio “Java non installato”
  4. Fai clic su Installa e accetta il contratto di licenza. Il runtime Java viene scaricato e installato.
    Avanzamento del download Java
    Le preferenze Java lo mostrano installato

Informazioni aggiuntive

Molte applicazioni Adobe dipendono da Oracle Java Runtime Environment (JRE) per il funzionamento di alcune funzionalità. Apple ha recentemente modificato il modo in cui include Java in Mac OS e con Lion Java non è più preinstallato. Si tratta ora di un’installazione facoltativa da selezionare. 

Poiché i programmi di installazione e le applicazioni di Adobe sono stati creati prima di tali modifiche da parte di Apple, il software Adobe presuppone che Java sia installato. Adobe e Apple si sono impegnate ad assicurare la possibilità di installare Java al momento dell’installazione del sistema operativo. In alternativa può essere installato in un secondo momento prima dell’installazione delle applicazioni Adobe. Al runtime, quando avvii un’applicazione Adobe, ti viene richiesto di installare Java se non è ancora installato. Se non installi Java prima dell’esecuzione di un’applicazione Adobe, alcune funzionalità potrebbero essere mancanti o comportarsi in maniera anomala. In caso di problemi, installa Java per risolverli. Adobe consiglia alle organizzazioni IT aziendali di installare preventivamente Java (o assicurarsi che Java possa essere installato tramite il firewall/la protezione) per evitare conflitti con le applicazioni Adobe.

Se il runtime Java non è installato, alcuni problemi noti includono -  

  • Impossibile avviare.
  • Messaggi di richiesta di installazione del runtime Java quando tenti di utilizzare le applicazioni.
  • Blocco o chiusura delle applicazioni.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online