この文書では、Acrobat PDFMaker の問題のトラブルシューティングについて説明しています。

Adobe Acrobat PDFMaker (「Adobe PDF への変換」コマンド)は、 Microsoft Office アプリケーションから PDF ファイルを作成するマクロです。PDFMaker は、Adobe Acrobat Standard/Professional アプリケーションと一緒にインストールされます。同じく、Acrobat アプリケーションとともにインストールされる Adobe Acrobat Distiller は、プリンタをシミュレートすることによって PDF ファイルを作成します。Acrobat Distiller は単体で PDF を作成しますが、PDFMaker は PDF 作成の際に Acrobat Distiller を使用します。

Office アプリケーションから PDFMaker を使用して PDF ファイルを作成する際に、ご使用の環境や設定によってはトラブルやエラーが生じることがあります。この文書は、PDFMaker を使用する際に生じる問題に対処するための方法を紹介します。文書内では、主に Microsoft Word を想定した記載となっていますが、ほとんどの操作手順は Microsoft PowerPoint、Microsoft Excel にも適用することができます。PDFMaker について詳しくは、Acrobat ヘルプを参照してください。

Office と Acrobat の互換性の確認

トラブルシューティングを始める前に Acrobat がお使いの Office のバージョンと互換性があるのかを確認してください。

Acrobat 6.0 Professional/Standard は、Office XP/2000/97との互換性があります。Acrobat 7.0 Professional/Standard は Office 2003/XP/2000 との互換性があります。

注意:

Acrobat 6.0 は、弊社 Web サイトよりアップデータをダウンロードして適用していただくことによって、Office 2003 に対応することが可能です。

Acrobat Distiller と Adobe PDF プリンタのトラブルシューティング

PDFMaker は Adobe PDF プリンタを使用するため、結果として Acrobat Distiller が Word 文書の変換時に使用されることになります。トラブルシューティングの最初のステップとして、Acrobat Distiller が正常に動作しているか確認します。

以下の手順を順番に行い、Acrobat Distillerが適切に動作しているかを確認します。

Adobe PDF プリンタから PDF を作成

問題の原因を特定するために、以下の操作手順を行い、Adobe PDF プリンタから PDF を作成します。

  1. Word で文書を開き、「ファイル」メニューから「印刷」を選択します。

  2. 「プリンタ名」ポップアップメニューから「Adobe PDF」を選択して「OK」をクリックします。

- PDF ファイルを Adobe PDF プリンタで作成できるが、PDFMaker では作成できない場合

問題の原因は、PDFMaker の機能にある可能性があります。「PDFMaker のトラブルシューティング」へ進みます。

- PDF ファイルを Adobe PDF プリンタで作成できない場合

次の手順へ進みます。

Acrobat Distiller から PDF を作成

以下の操作手順を行い、Acrobat Distiller から PDF を作成します。

注意:

この方法は、リンクや文書構造を維持するなどの PDFMaker の高度な機能をサポートしません。

  1. Word 文書を開き、「ファイル」メニューから「印刷」を選択します。

  2. 「プリンタ名」ポップアップメニューから PostScript プリンタ(例えば、Adobe PDF プリンタ)を選択します。

    ※ PostScript プリンタが無い場合、以下の弊社 Web サイト http://www.adobe.co.jp/support/downloads/ から PostScript プリンタドライバをダウンロードし、インストールを行ってください。

  3. 「ファイルへ出力」にチェックを入れて「OK」をクリックします。

  4. PostScript(*.ps/*.prn)ファイルが作成されます。

  5. Acrobat を起動し、 「アドバンスト」メニューから「Acrobat Distiller」を選択します。

  6. 「デフォルト設定」ポップアップメニューから任意の設定を選択します。

  7. 「ファイル」メニューから「開く」を選択します。

  8. 「ファイルの種類」ポップアップメニューから「すべてのファイル」を選択し、手順 4. で作成した PostScript(*.ps/*.prn)ファイルを選択し、「開く」を選択します。

  9. PDF のファイル名と保存場所を指定して「保存」をクリックします。(自動的に PDF 変換される場合もあります。)

    - Acrobat Distiller が PDF を作成する場合

    C. PDFMaker のトラブルシューティング へ進みます。

    - Acrobat Distiller が PDF を作成しない場合

    次の手順へ進みます。

「message.log」ファイル

PostScript エラーが生じた場合、「message.log」ファイルにそのエラーが記録されます。以下のフォルダに保存されている、「message.log」ファイルの内容を確認します。

- Windows 2000/XP

Documents and Settings¥<ユーザ名>¥Application Data¥Adobe¥Acrobat¥Distiller <バージョン>

- Windows NT

WINNT¥Profiles¥<ユーザ名>¥Application Data¥Adobe¥Acrobat¥Distiller 6

エラーの原因が記録されている場合

弊社サポートデータベース http://www.adobe.com/go/support_faq_jp で類似の文書を検索します。例えば、ファイルが PostScript エラーをリストアップしていた場合は、一般情報 (プリント):ポストスクリプトエラーのトラブルシューティング の手順に従ってトラブルシュートを行います。

エラーの原因が記録されていない場合

単語を少しだけ入力した新規文書を Word で作成し、Adobe PDF プリンタ および Acrobat Distiller を使用して再度 PDF ファイルを作成します。

  • 新規文書から PDF を作成できた場合

    問題の原因は、 PDFMaker に関連している可能性があります。「PDFMaker のトラブルシューティング」へ進みます。
  • 新規文書から PDF を作成できない場合

    そのファイルを他のアプリケーションで使用し、Acrobat Distiller を使用してPDF を作成してみます。問題が再現する場合は、 Acrobat Distiller を再インストールします。問題が再現しない場合は、文末の「その他の関連ヘルプ」を参照して特定の動作についてトラブルシューティングを行うか、弊社サポートデータベース http://www.adobe.com/go/support_faq_jp で検索を行います。もしくは、弊社テクニカルサポートにお問い合わせください。

Acrobat PDFMaker のトラブルシューティング

Adobe PDF プリンタや Acrobat Distiller では PDF ファイルを作成できるが、PDFMaker
ではできない場合、問題の原因は PDFMaker の機能にあると考えられます。どの機能が問題を引き起こしているのかを確認するために、以下の操作手順を行い、機能を無効にして PDF ファイルを作成します。

  1. Word 上で 「Adobe PDF」メニューから「変換設定の変更」を選択します。

  2. 「PDF 設定」ポップアップメニューから「Smallest File Size」(Acrobat 6.0)/「最小ファイルサイズ」(Acrobat 7.0)を選択します。

  3. 「Word」タブをクリックし、すべての Word 機能オプションのチェックをはずします。

  4. 「しおり」タブをクリックし、すべてのしおりオプションのチェックをはずします。

  5. 「セキュリティ」タブをクリックし、すべてのセキュリティオプションのチェックをはずします。

  6. 「OK」をクリックします。

  7. PDF ファイルを作成します。

PDF ファイルを作成できない場合

文書固有の問題に対するトラブルシューティング」へ進みます。

PDF ファイルを作成できる場合

どの機能が問題を引き起こしていたのかを確かめます。機能の 1 つを有効にして PDF ファイルの作成を行います。有効にする機能を 1 回ごとに切り替えて繰り返し、どの機能が有効になっていた時に問題が生じたかを確認します。問題が生じた時点で、単語を少しだけ入力した新規文書を Word で作成し、 その文書から同じ PDFMaker 設定を使用して PDF 作成を行います。

- 新規文書から PDF を作成できた場合

問題は文書に固有のものです。「文書固有の問題に対するトラブルシューティング」へ進みます。

- 新規文書から PDF を作成できない場合

一番最後に有効にした機能が問題を引き起こしています。Acrobat PDFMaker を再インストールします。問題が再現する場合は、弊社テクニカルサポートにお問い合わせください。

文書固有の問題に対するトラブルシューティング

特定の文書でのみ問題が発生していると判断できた場合は、以下のトラブルシューティングを行います。

文書が使用している PDFMaker の機能だけを有効にします。

文書が「見出し 1」、「見出し 2」などの見出しスタイルだけを含んでいる場合、「Acrobat PDFMaker」 ダイアログボックスで他の見出しスタイルを無効にします。以下の操作手順を行います。

  1. Word を起動し、PDF に変換する文書を開きます。

  2. 「Acrobat PDF」メニューから「変換設定の変更」を選択します。

  3. 「しおり」タブをクリックします。

  4. 文書で使用している機能以外のチェックをすべてはずします。

  5. 「OK」をクリックして、「Acrobat PDFMaker」ダイアログボックスを閉じます。

Word の表示形式を変更

Word の表示形式を「下書き表示」に変更し、PDFMaker を使用して PDF ファイルを作成します。以下の操作手順を行います。

  1. Word を起動し、PDF に変換する文書を開きます。

  2. 「表示」メニューから「下書き」を選択します。

  3. PDF へ変換できるか確認します。

Word 文書の再作成

Word 文書内の破損部分などを削除するために、以下のいずれか、または複数を行い文書を再作成します。

- Word 文書の内容を新規文書にコピー&ペーストし、PDF ファイルを作成します。

- 文書内のすべてのテキストを選択し、フォントを変更して別名保存します。Word は文書を書き換え、PDFMaker と競合していたすべての要素が排除されます。保存後に任意のフォントを指定してデザインし直します。

- 他のバージョンの Word で作成した文書を開いて PDF を作成しようとした場合、文書内に少しだけ修正を加えて別名保存します。これにより Word は文書を書き換えて、PDFMaker と競合を起こすような要素を排除します。

見出しスタイルの再作成

Word 文書内のカスタマイズした見出しスタイルを作り直し、PDF を作成します。スタイルの作成方法については、Word に付属のヘルプを参照してください。

競合を起こす要素の特定

以下の操作手順を行い、文書に含まれている競合要素を特定します。

  1. オリジナルの Word 文書の内容の半分をコピーします。

  2. 新規 Word 文書にペーストします。

  3. 新規 Word 文書を PDFMaker を使用して PDF 変換します。

    問題が発生する場合

    競合する要素が新規 Word 文書内にあります。手順 1. ~ 3. を繰り返し、新規 Word 文書内で更に内容の半分を別の新規 Word 文書にコピーして、競合要素を絞りこんで特定していきます。

    問題が発生しない場合

    競合要素は、元の Word 文書内にあります。問題をさらに特定するために、手順 1. ~ 3. を繰り返し、元の Word 文書内の半分を別の新規 Word 文書にコピーします。どちらの文書も正確に変換された場合、 Office アプリケーションを含めた他のアプリケーションを終了し、*.tmp ファイルを削除します。(通常、「Windows¥Temp」フォルダ内にあります)

Office アプリケーションと Acrobat の再インストール

Acrobat と Office アプリケーションをアンインストールします。Acrobat をアンインストールするには、「コントロールパネル」の「プログラムの追加と削除」(Windows XP)/「アプリケーションの追加と削除」(Windows 2000/98/NT)を使用します。

Office アプリケーションをインストールし、次に Acrobat をインストールします。

Office アプリケーションのアンインストール方法については、Office のマニュアルを参照するか、Microsoft 社にお問い合わせください。

Acrobat のインストールおよびアンインストールの方法については、その他の関連ヘルプを参照してください。

文書保護の解除

Word 文書が保護されている場合、保護を削除します。保護の削除方法については Word のヘルプを参照するか、Microsoft 社にお問い合わせください。

他のマクロとの競合についてのトラブルシューティング

PDFMaker は、他のマクロ(例えば、ウィルス検出やファックスソフトウェア)と競合する可能性があります。上記のトラブルシューティングを行っても解決しなかった場合、または PDFMaker がサードパーティ製のマクロをインストールした後に問題を起こすようになった場合、他のマクロとの競合に対してトラブルシューティングを行います。

Duden Korrektor Plus 2.0 や ViaVoice 10 以前、Personal Translator 2002 Office Plus、OfficeReady Stuffit、Leuchter Informatic AG WordPlus、GoldMine Link to Word などに含まれるマクロは非互換の原因となるとされています。

PDFMaker が他のマクロと競合しているのか確認するには、他のマクロを一度に 1 つずつ削除、または無効にし、PDFMaker を使用して文書を PDF 変換を行います。問題が起きない場合は、競合しているマクロの製造元にお問い合わせください。

起動および作業時の問題のトラブルシューティング

以下の手順は、Microsoft 社の技術情報に基づいています。Word のトラブルシューティングの詳細については、Microsoft 社の Web サイトを参照してください。

注意:

この文書は、レジストリの修正情報を含んでいます。レジストリを修正する前に、必ずバックアップを取り、また問題が発生した場合のレジストリの復元方法を確認してください。レジストリのバックアップ、復元、および編集の詳細については、Microsoft Windows レジストリの説明を参照してください。

「/a」スイッチを使用して Word を起動します。

「/a」スイッチを使用して Word を起動した場合、Word は一時的にすべてのオプションに対してデフォルトのビルトイン設定を使用し、アドイン、環境設定、ユーザ設定、およびマクロの読み込みを無効にします。これは、「Office セーフモード」と呼ばれます。

注意:

「/a」スイッチで起動している状態で、環境設定やユーザ設定、マクロなどの設定を変更しても、Word の終了時に消去されます。さらに、すべての Microsoft Office 2003 プログラムには、セーフモード起動オプションがあります。

Office セーフモードの詳細については、[WD2002] Office セーフ モードについてを参照してください。

「/a」 スイッチを使用して Word を起動するには、以下の操作手順を行います。

  1. 「スタート」メニューから「ファイル名を指定して実行」を選択します。

  2. 「winword.exe /a」と入力し、「OK」をクリックします。

  3. Word が起動します。

Acrobat 6.0 の場合、PDFMaker を手動で読み込むには、以下の操作手順を行います。

  1. 「ツール」メニューから「テンプレートとアドイン」を選択します。

  2. 「PDFMaker.dot」にチェックを入れます(「PDFMakerA.dot」ではありません)。

  3. 「OK」をクリックします。これによって「PDFMaker」アイコンが表示されます。

テスト用の Word 文書を作成し、PDFMaker を起動するには、以下の操作手順を行います。

  1. Word 文書にいくつかの単語を入力します。

  2. 「ファイル」メニューから「保存」を選択し、テスト用の文書をデスクトップに保存します。

  3. 「Adobe PDF への変換」ボタンをクリックします。

「/a」スイッチで Word を起動した場合に問題が解決した場合は、 Word の起動時に読み込まれるコンポーネントをすべて削除します。これらのコンポーネントは、 表示される順に、1 つずつ削除します。

以下のコンポーネントが Word 起動時に読み込まれます。

- Word の自動マクロ

- Windows レジストリ内の Word の Data キー

- 全文書対象のテンプレート(Normal.dot)

- Word および Office Startup フォルダ内のアドイン(WLL)およびテンプレート

- COM アドイン

- Windows レジストリ内の Word の Option キー

注意:

Microsoft Product Support Service には「トラブルシュート ユーティリティ」 (「Support.dot」ファイルを含む)があります。これは、自動的に Word の起動時に読み込まれるコンポーネントの削除と復元を自動化します。

「Normal.dot」テンプレートファイルの名前を変更します。

全文書対象のテンプレート(「Normal.dot」ファイル)に格納された書式、AutoText、およびマクロによって Word の動作と開いた文書への影響を防ぐには、全文書対象のテンプレート(Normla.dot)のファイル名を変更します。これを行うと、このテンプレートが問題の原因かどうかを確認することができます。

注意:

「Normal.dot」テンプレートのファイル名を変更すると、デフォルト設定に対して、カスタムスタイル、カスタムツールバー、マクロ、および AutoText エントリーなどの再設定が行われます。そのため、Microsoft 社では「Normal.dot」ファイルを削除しないよう、強く推奨しています。

例えば、複数のバージョンの Word がインストールされている場合など、設定によっては複数の「Normal.dot」ファイルが作成されている可能性があります。

「Normal.dot」ファイルのファイル名を変更するには、以下の操作手順を行います。

注意:

この手順を行った後は、Word の再起動時に、「/a」スイッチを使用しないでください。

Windows XP の場合

  1. Word を終了します。電子メールエディタとして Word を使用している場合は、Outlook も終了します。

  2. 「スタート」メニューから「検索」を選択します

  3. 「ファイルとフォルダすべて」をクリックし、「ファイル名のすべてまたは一部」テキストボックスに「Normal.dot」と入力します。

  4. 「探す場所」にローカルハードディスクを選択します。またはネットワークから Word を実行している場合は、ユーザのテンプレートの場所を選択します。

  5. 「検索」をクリックします。

  6. 「検索結果」ダイアログボックスに表示されたすべての Normal.dot ファイルに対して、以下の手順を行います。

    1. ファイルを右クリックし、[ファイル名を変更] を選択します。
    2. 新しい名前に変更し、Enter キーを押します。例えば、「OldNormal.dot」または「Normal-1.dot」など、後で識別しやすい名前に変更します。
  7. 検索を終了し、 Word を再起動します。

Windows 2000 の場合

  1. Word を終了します。電子メールエディタとして Word を使用している場合は、Outlook も終了します。

  2. 「スタート」メニューから 「検索」- 「ファイルやフォルダ」を選択します。

  3. 「ファイルまたはフォルダの名前」テキストボックスに「Normal.dot」と入力します。

  4. 「探す場所」にローカルハードディスクを選択し、「検索開始」をクリックします。

  5. 「検索結果」ダイアログボックスに表示されたすべての Normal.dot ファイルに対して、以下の手順を行います。

    1. ファイルを右クリックし、「ファイル名を変更」を選択します。
    2. 新しい名前に変更し、Enter キーを押します。例えば、「OldNormal.dot」 または 「Normal-1.dot」など、後で識別しやすい名前に変更します。
  6. 検索を終了し、Word を再起動します。

問題が解決する場合、Normal.dot テンプレートの破損が原因であると考えられます。以前の環境を復元するには、いくつかの設定を変更する必要があるかもしれません。「Normal.dot」ファイルにスタイルやマクロや AutoText エントリーなどのカスタマイズが含まれていた場合は、[構成内容変更] ダイアログボックスで、新規「Normal.dot」ファイルに以前の「Normal.dot」ファイルの情報をコピーします。詳細は Word に付属のヘルプを参照してください。

問題が解決できなかった場合に、以前の Normal.dot テンプレートを使用するには、新規 Normal.dot ファイルのファイル名を変更し、以前の Normal.dot テンプレートのファイル名を元に戻します。

以上の作業をすべて行っても PDFMaker の問題が解決できなかった場合は、弊社テクニカルサポートにお問い合わせください。

本作品は Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License によってライセンス許可を受けています。  Twitter™ および Facebook の投稿には、Creative Commons の規約内容は適用されません。

法律上の注意   |   プライバシーポリシー