キャンペーン内のワークフローの開始ボタンをクリックしていない場合は、いくつかのケースがある。開始することの代わりに、キャンペーン内のワークフローは「可能な限り早く開始する」状態になる。

環境

すべての Campaign V6.0、V6.1.0 および V6.1.1。
ウィンドウズ、リナックス Debian などすべての OS。

原因

この問題に対する2つの原因がある:

1> キャンペーンにワークフローの並行処理制限が到達し、新しいワークフローが開始できない。これにより、キャンペーン内で実行中のワークフローの数をチェックすることで確認され、プラットフォーム下の NmsOperation_LimitConcurrency の値をチェックする>オプション。

注意:

この制限に達すると、実行中のワークフローの数が並行制限の上にある限り、ワークフローが「可能な限り早く開始する」ことに保持される。数は制限を下回ると、ワークフローがキックオフされる。したがって、「できるだけ早く開始する」状態が永続状態になる。

2> キャンペーンにワークフローの開始が失敗した最も一般的な理由は、キャンペーンジョブ(オペレーション mgt)ワークフローが失敗した。これは管理者>製品>技術的なワークフローノードの下にあるキャンペーンのプロセスフォルダーに見つけた技術的なワークフローである。このワークフローはキャンペーン内のジョブやワークフローを管理する。これが失敗すると、ワークフローが開始または停止できないようになる。

キャンペーンワークフローの運行を再開始することに失敗した場合は、このワークフローを再起動することができる。

解決策

最初の障害については、次のことができる:

>> ビジネスが必要な場合、または並行閾値が復元された時点でワークフローが開始することが説明できる場合は、並行制限を増やす。

2番目の障害については次のことが実行できる。

>> ジョブが失敗した場合、キャンペーンジョブ(オペレーション mgt) ワークフローを再起動する。再起動したら、任意の活動に再失敗したかどうかをチェックするために、スケジューラに「保留中のタスクを実行する」ことを確保する必要がある。

  • ワークフローが一時停止している場合は、再開始する。もし再開始が失敗すると、再起動を試す。
  • ワークフローが停止している場合は、起動する。
  • 再度失敗が発生した場合は、特定のエラーに関する監査ログを確認し、それに従ってトラブルシューティングを行う必要がある。


例:失敗が発生した可能性がある:

キャンペーンジョブのワークフロー(オペレーション mgt)は、次のエラーが発生して失敗した:
25/08/2016 17:34:25スケジューラー JavaScript: スクリプトを評価する時にエラーが発生 'operationMgt/scheduler'。
25/08/2016 17:34:25スケジューラ、ユーザーのアップデートを実行するためのアクセストークンが見つからない。
25/08/2016 17:34:25 スケジューラ、ターゲットワークフロー「xyz_wkf_engage_4」或いはキャンペーン「01 - エンゲージキャンペーン(xyz_engage_campaign)」を開始する。

したがって、ワークフロー xyz_wkf_engage_4 を起動しようとしたが、できなかった。ほとんどの場合、このワークフローはすぐに完了状態になり、再開始することはできない。これに対して、ワークフロー xyz_wkf_エンゲージ_4のために無条件停止を行い、それからキャンペーンジョブ(オペレーション mgt)を再起動する。

本作品は Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License によってライセンス許可を受けています。  Twitter™ および Facebook の投稿には、Creative Commons の規約内容は適用されません。

リーガルノーティス   |   プライバシーポリシー