この情報は、米国アドビシステムズ社が提供している情報をもとにローカライズし、作成したものです。

日本語環境での動作保証はしておりませんのでご了承ください。

内容 (What's Covered)

Adobe Creative Suite 3/4 アプリケーションでは、インストールプロセスに関する膨大なログが記録されます。インストールのログファイルは、インストール時に発生したエラーの内容を確認する際に役立ちます。サイレントインストールを行った場合、エラー内容はログファイルでのみ確認することができます。

A. ログファイルの保存場所

B. エラー内容の確認

C. Adobe Support Advisor の使用

 A. ログファイルの保存場所

Creative Suite 3/4 アプリケーションのログファイルは、アプリケーションのインストール完了後に、単一のフォルダ内に保存されます。

例 :

Adobe Creative Suite 3 Web Premium 1.0.log.gz

Adobe Creative Suite 4 Master Collection 4.0 12-27-2008.log.gz

初期設定では、Creative Suite 3/4 アプリケーションのインストールログは以下の場所に保存されます。

Windows(32 ビット) : C:\Program Files\Common Files\Adobe\Installers\

Windows(64 ビット) : C:\Program Files (x86)\Common Files\Adobe\Installers\

Macintosh : Macintosh HD/Library/Logs/Adobe/Installers/

これらのファイルは gzip (.gz)形式で圧縮されています。ファイルを開くには、この形式をサポートする WinAce、WinZip、WinRAR、Stuffit などの解凍ユーティリティが必要です。解凍されたファイルはプレーンテキストのため、メモ帳などのテキストエディタで開くことができます。

 注意 : Mac OS X の初期設定ログファイルはコンソールアプリケーションで開かれ、エラーログ内の最新のエントリのみを表示します。検索機能で特定の単語を検索するか、または Command + R キーで再読み込みをすることで初期表示で読み込まれなかったログを表示させることができます。

Macintosh でログファイルが見つからない場合

Mac OS X では、インストール中にログファイルが生成されない場合があります。ログファイルを生成するには、コンソールアプリケーションを使用します。

ログファイルを生成するには、以下の操作を行います。

  1. 「ユーティリティ」フォルダを開きます。

    - Macintosh HD/アプリケーション/ユーティリティ
  2. 「ユーティリティ」フォルダ内の [コンソール] をダブルクリックします。
  3. [ログ] アイコンをクリックします。
  4. ウインドウの左側に表示されるログの一覧から [console.log] をクリックします。
  5. コンソールウインドウを開いたまま、Creative Suite のインストールを開始します。
  6. コンソールウインドウにインストールログが表示されます。
  7. インストール完了後、コンソールウインドウの [ファイル] メニューから [コピーを保存] を選択し、コンソールウインドウにログを保存します。

 

 B. エラー内容の確認

ログファイル内の記述を確認するには、以下のいずれか、または両方の操作を行います。

新しいログのみを確認する

ログファイルのファイル名を変更するか、既存のログファイルを別のフォルダに移動してから再インストールすることで、新しいログファイルが生成されます。

アプリケーションのインストール時にログファイルが自動で生成されている場合、ログを追加すると既存のファイルの最後尾に保存されます。そのため、1 つのファイルに複数の情報が混在している可能性があります。既存のログファイルのファイル名を変更し、インストールを行うことで新しいログのみのファイルを生成することができます。

エラーメッセージの詳細を確認する

「Return value 3」や、「Error」、「FATAL」などの特定の文字列でログ内を検索します。

 重要 : インストールログ内のエラーの記述を確認したら、他にもエラーが記録されていないか確認します。1 つのログの中に複数のエラーコードが含まれていることもあります。

- Windows の場合

  注意 : Windows でログファイルが保存されているフォルダが見つからない場合、追加情報を参照して隠しフォルダの表示設定を変更します。

  1. 解凍したログファイルをメモ帳などのテキストエディタで開きます。
  2. 「Returan Value 3」で検索します。

    注意 : 「Return Value 3」は大文字小文字を区別しなくても検索可能です。

  3. サポートデータベースで技術文書を検索し、生成されたエラーメッセージの原因を特定します。



     注意 : 上記のログの場合、エラーメッセージは「Returan Value 3」の前に表示されている「Error 1714.The older version of Adobe Flash Player 9 ActiveX cannot be removed. Contact your technical support group.」が該当します。技術文書を検索する際は、このエラーメッセージで検索します。該当する情報が見つからない場合は、次の手順に進みます。

     
  4. 「ERROR」で検索します。



     注意 : 「error」という記述はログ内に多数含まれている可能性があるため、大文字小文字を区別して検索を行ってください。

  5. サポートデータベースで技術文書を検索し、生成されたエラーメッセージの原因を特定します。



     注意 : 上記のログの場合、エラーメッセージは「ERROR」の後に表示されている「"Default installation language not valid, falling back to first supported language."」が該当します。技術文書を検索する際は、このエラーメッセージで検索します。該当する情報が見つからない場合は、次の手順に進みます。

     
  6. 「FATAL」で検索します。

    注意 : 大文字小文字を区別して検索を行ってください。

  7. サポートデータベースで技術文書を検索し、生成されたエラーメッセージの原因を特定します。



     注意 : 上記のログの場合、エラーメッセージは「FATAL」の後に表示されている「Exiting from installation due to blocking error. Exit code: 7」が該当します。技術文書を検索する際は、このエラーメッセージで検索します。該当する情報が見つからない場合は、弊社テクニカルサポートにお問い合わせください。

- Macintosh の場合

  1. 解凍したログファイルをテキストエディットなどのテキストエディタで開きます。
  2. 「ERROR」で検索します。

     注意 : 「error」という記述はログ内に多数含まれている可能性があるため、大文字小文字を区別して検索を行ってください。

  3. サポートデータベースで技術文書を検索し、生成されたエラーメッセージの原因を特定します。



     注意 : 上記のログの場合、エラーメッセージは「ERROR」の後に表示されている「"Uncaught JavaScript exception: Unexpected directory found instead of a file or symlink at /Applications/Adobe Dreamweaver CS4/Adobe Dreamweaver CS4.app/Contents/Frameworks/AdobePIP.framework/Resources"」が該当します。技術文書を検索する際は、このエラーメッセージで検索します。該当する情報が見つからない場合は、次の手順に進みます。
  4. 「FATAL」で検索します。

     注意 : 大文字小文字を区別して検索を行ってください。

  5. サポートデータベースで技術文書を検索し、生成されたエラーメッセージの原因を特定します。



     注意 : 上記のログの場合、エラーメッセージは「FATAL」の後に表示されている「"Uncaught JavaScript exception: Unable to read Adobe file version for path /Library/Fonts/MinionPro-Bold.otf" 」が該当します。技術文書を検索する際は、このエラーメッセージで検索します。該当する情報が見つからない場合は、弊社テクニカルサポートにお問い合わせください。

 

C. Adobe Support Advisor の使用

インストールログのトラブルシューティングに Adobe Support Advisor を使用します。

Adobe Support Advisor は無償です。Creative Suite 製品のログファイルを読み込む AIR ベースのアプリケーションで、解決方法が記載される文書のリンクを提供します。詳細については、以下の弊社技術文書を参照してください。

文書番号 234471 Adobe Support Advisor(ASA)の使用方法

 

追加情報 (Additional Information)

該当する技術文書が見つからない場合は、弊社テクニカルサポートにお問い合わせください。または弊社ユーザフォーラムを参照します。

Windows の隠しファイルや隠しフォルダを表示する

  1. [スタート] メニューから [コンピューター](Windows 7/Vista)/[マイコンピュータ](WIndows XP)を選択します。
  2. 以下のいずれかの操作を行います。

    Windows 7/Vista : [整理] メニューから [フォルダと検索のオプション] を選択します。

    Windows XP : [ツール] メニューから [フォルダオプション] を選択します。
  3. [表示] タブを選択します。
  4. [すべてのファイルとフォルダを表示する] を選択し、[OK] をクリックします。

本作品は Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License によってライセンス許可を受けています。  Twitter™ および Facebook の投稿には、Creative Commons の規約内容は適用されません。

法律上の注意   |   プライバシーポリシー