AEM モバイルアプリの iOS バージョンからの Analytics データがない
Adobe Mobile Services インターフェイスでは、iOS AEM モバイルアプリからの Analytics データは表示されません。

環境

iOS AMS モバイルアプリケーション

原因

アプリが HTTPS 呼び出しを許可するように設定されていますが、Adobe Mobile Services は Analytics 用に HTTP を使用するように設定されています。

解決策

HTTP を使用するための Analytics の設定

  1. http://mobilemarketing.adobe.com にログインします(Analytics アカウントを使用するオプションをクリックしてください)。
  2. 「アプリ管理」をクリックします。
  3. アプリ名をクリックします。
  4. SDK Analytics オプションにスクロールします。
  5. HTTPS を使用するオプションをオンにします。
  6. 下にスクロールして「保存」をクリックします。
  7. AEM Mobile オンデマンドポータルを使用してアプリを再構築し、エンドユーザーにアップデートを提供します。

追加情報

AEM Mobile オンデマンドポータルを使用して iOS アプリを構築する場合、いずれかのオプションは「HTTPS 接続のみを許可する」です。

UI のそのオプションの上に、次を読み込む注意があります。
「ボックスをオンにする前に、モバイルマーケティング SDK Analytics オプションが HTTPS を使用するように設定されていることを確認してください。さらに詳しく".「さらに詳しく」は、次のページにリンクされています。
https://helpx.adobe.com/jp/digital-publishing-solution/help/building-ios-apps.html

セクション見出し「HTTPS 接続」のそのページでは、次を読み込みます。
「HTTPS 接続のみを許可する」を選択した場合は、アプリの開発バージョンを構築して、詳細にテストします。ハイパーリンク、動的バナー、およびサインイン機能が正しく動作することを確認してください。さらに、Analytics データが適切に報告されるようにするには、Adobe Mobile Services ダッシュボードに移動し、HTTPS を使用するようにアプリの設定を行います。(「AEM Mobile アプリ用の Analytics:モバイルマーケティングアプリの設定を行う」を参照してください。)」

モバイルマーケティングアプリの設定を行う」は、次のページおよびアンカーにリンクされています。
https://helpx.adobe.com/jp/digital-publishing-solution/help/analytics.html#configure-mobile-marketing

このページでは、手順のリストと、アプリが使用する Analytics サービスの HTTPS を有効にするシーケンスが表示されます。
「モバイルマーケティングアプリの設定を行う
プロジェクトに対して Analytics の設定を行うには、モバイルマーケティングダッシュボードが使用されます。例えば、HTTP の代わりに HTTPS ドメインを必要とするアプリケーションを構築する場合、設定を編集できます。」

  1. https://mobilemarketing.adobe.com に移動して、サインインします。
  2. アプリケーションの管理/すべてのアプリケーションを選択します。
  3. アプリケーションを作成するか、アプリケーションを選択します。
  4. 必要に応じて設定を変更します。例えば、「HTTPS を使用」を選択して、分析の呼び出しが HTTPS 準拠であることを確認します。
  5. 設定を保存したら、アプリケーションを再構築します。 アプリケーションを再構築することで実行されたモバイルマーケティングダッシュボード設定変更を取得する必要があります。