現在表示中:

画像をアップロードするときに、フォルダーにイメージプロファイルを適用することで、アップロード時に自動的に画像を切り抜くことができます。

切り抜き

画像の端から切り抜くには、画像の任意の辺または四辺からの切り抜きのサイズ(ピクセル数)を入力します。画像がどれだけ切り抜かれるかは、画像ファイル内の ppi(インチあたりピクセル数)設定によって変わります。例えば、画像が 150 ppi で表示される場合に、「上」、「下」、「右」および「左」テキストボックスに 75 と入力すると、各辺から 0.5 インチ(1.27 cm)が切り取られます。

アンシャープマスク

アンシャープマスク」を使用すると、ダウンサンプリングされた最終的な画像に対するシャープフィルター効果を細かく調整できます。効果の強さ、効果の半径(ピクセル単位)、無視されるコントラストのしきい値を調整できます。この効果では、Adobe Photoshop の「アンシャープマスク」フィルターと同じオプションが使用されます。

注意:

アンシャープマスクは、50%以上ダウンサンプリングされた ptiff 内のダウンスケールされたレンディションにのみ適用されます。つまり、ptiff 内の最大サイズのレンディションはアンシャープマスクの影響を受けませんが、サムネールなどの小さいサイズのレンディションは変更されます(また、アンシャープマスクが表示されます)。 

アンシャープマスク」には次のオプションがあります。

  • 数量 - 端のピクセルに適用するコントラストを制御します。デフォルトは 1.75 ですが、画像が高解像度の場合は 5.0 まで上げられます。数字の大きさはフィルターの強さだと考えてください。
  • 半径 - シャープに影響するエッジピクセルの周囲のピクセル数を指定します。高解像度の画像に対しては、1 ~ 2 を入力します。値が小さい場合、エッジのピクセルのみがシャープされます。値が大きい場合、より広い範囲のピクセルがシャープされます。画像のサイズによって適切な値が変わります。デフォルト値は 0.2 です。
  • しきい値 - アンシャープマスクフィルターが適用される場合のコントラストの範囲を指定します。つまり、このオプションは、シャープされるピクセルが周囲の領域とどの程度違えば、そのピクセルをエッジのピクセルと見なしてシャープするかを決定するものです。ノイズが入るのを防ぐため、0.02 ~ 0.2 の範囲で様々な値を試してください。デフォルト値は 2 です。

シャープについては、画像のシャープで説明しています。

イメージプロファイルの作成

他のアセットタイプ向けに詳細な処理パラメーターを定義するには、アセット処理の設定を参照してください。

イメージプロファイルを作成するには、次の手順を実行します。

  1. AEM のロゴをクリックまたはタップし、ツールアセットイメージプロファイルの順に移動します。

  2. 新しいイメージプロファイルを追加するには、「作成」をクリックまたはタップします。

  3. プロファイル名、切り抜き情報およびアンシャープマスク情報を入力します。

    chlimage_1
  4. 完了」をクリックします。新しく作成されたプロファイルが、使用可能なプロファイルのリストに表示されます。

イメージプロファイルの変更または削除

  1. AEM のロゴをクリックまたはタップし、ツールアセットイメージプロファイルの順に移動します。

  2. 編集または削除するイメージプロファイルを選択します。編集するには、「画像処理プロファイルを編集」を選択します。削除するには、「画像処理プロファイルを削除」を選択します。

    chlimage_1
  3. 編集の場合は、変更内容を保存します。削除の場合は、プロファイルの削除を確定します。

フォルダーへのイメージプロファイルの適用

フォルダーにイメージプロファイルを割り当てると、サブフォルダーは自動的に親フォルダーのプロファイルを継承します。つまり、フォルダーに 1 つのイメージプロファイルのみを適用すればよいことになります。そのため、アセットをアップロード、保存、使用およびアーカイブする場所のフォルダー構造については入念に検討してください。

フォルダーに異なるイメージプロファイルを割り当てた場合、新しいプロファイルが以前のプロファイルよりも優先されます。以前に存在していたフォルダーのアセットは変更されずに維持されます。新しいプロファイルは、その後にフォルダーに追加されるアセットに対して適用されます。 

プロファイルが割り当てられているフォルダーには、ユーザーインターフェイス上でカード内に表示されたときに、そのプロファイルの名前が示されます。

chlimage_1

イメージプロファイルは、特定のフォルダーに適用することも、全アセットにグローバルに適用することもできます。 

特定のフォルダーへのイメージプロファイルの適用

ツールメニュー内から、またはフォルダー内にいる場合は「プロパティ」から、特定のフォルダーにイメージプロファイルを適用できます。このセクションでは、イメージプロファイルをフォルダーに適用するための方法を両方とも説明します。

既にプロファイルが割り当てられているフォルダーには、フォルダー名のすぐ下にプロファイルの名前が表示されます。

プロファイルユーザーインターフェイスからのフォルダーへのイメージプロファイルの適用

  1. AEM のロゴをクリックまたはタップし、ツールアセットイメージプロファイルの順に移動します。

  2. 1 つまたは複数のフォルダーに適用するイメージプロファイルを選択します。

    chlimage_1
  3. 処理プロファイルをフォルダーに適用」をタップまたはクリックし、新規にアップロードするアセットを置くために使用するフォルダーを 1 つまたは複数選択して、「完了」をタップまたはクリックします。既にプロファイルが割り当てられているフォルダーには、フォルダー名のすぐ下にプロファイルの名前が表示されます。

プロパティからのフォルダーへのイメージプロファイルの適用

  1. AEM のロゴをタップまたはクリックして「アセット」に移動してから、イメージプロファイルを適用するフォルダーに移動します。

  2. チェックマークをタップまたはクリックして対象のフォルダーを選択し、「プロパティ」をタップまたはクリックします。

  3. イメージプロファイル」タブを選択し、ドロップダウンメニューからプロファイルを選択して、「保存」をクリックします。既にプロファイルが割り当てられているフォルダーには、フォルダー名のすぐ下にプロファイルの名前が表示されます。

    chlimage_1

グルーバルなイメージプロファイルの適用

特定のフォルダーにプロファイルを適用できるだけでなく、グローバルにプロファイルを適用することもできます。これにより、AEM アセットにアップロードされている、すべてのフォルダー内にあるすべてのコンテンツに、選択したプロファイルを適用できます。

プロファイルを全体的に適用するには、次のいずれかの操作をおこないます。

  • http://<AEM server>/mnt/overlay/dam/gui/content/assets/foldersharewizard.html/content/dam に移動し、適切なプロファイルを適用して、「保存」をタップまたはクリックします。

    chlimage_1
  • CRXDE Lite で、ノード /content/dam/jcr:content に移動します。プロパティ imageProfile:/etc/dam/image/dynamicmedia/<name of image profile> を追加して、「すべて保存」をタップまたはクリックします。

    chlimage_1

フォルダーからのイメージプロファイルの削除

フォルダーからイメージプロファイルを削除すると、サブフォルダーは自動的に親フォルダーのプロファイルの削除状態を継承します。ただし、フォルダー内で実行されたファイルの処理はそのまま維持されます。

ツールメニュー内から、またはフォルダー内にいる場合は「プロパティ」で、特定のフォルダーからイメージプロファイルを削除できます。このセクションでは、イメージプロファイルをフォルダーから削除するための方法を両方とも説明します。

プロファイルユーザーインターフェイスを使用したフォルダーからのイメージプロファイルの削除

  1. AEM のロゴをクリックまたはタップし、ツールアセットイメージプロファイルの順に移動します。

  2. 1 つまたは複数のフォルダーから削除するイメージプロファイルを選択します。

  3. フォルダーから処理プロファイルを削除」をタップまたはクリックし、プロファイルを削除するフォルダーを 1 つまたは複数選択して、「完了」をタップまたはクリックします。

    名前がフォルダー名の下に表示されなくなっていることで、イメージプロファイルがフォルダーに適用されていないことを確認できます。 

プロパティを使用したフォルダーからのイメージプロファイルの削除

  1. AEM のロゴをタップまたはクリックして「アセット」に移動してから、イメージプロファイルを削除するフォルダーに移動します。

  2. チェックマークをタップまたはクリックして対象のフォルダーを選択し、「プロパティ」をタップまたはクリックします。

  3. イメージプロファイル」タブを選択し、「プロファイル名」ドロップダウンメニューから「なし」を選択して、「保存」をクリックします。既にプロファイルが割り当てられているフォルダーには、フォルダー名のすぐ下にプロファイルの名前が表示されます。

本作品は Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License によってライセンス許可を受けています。  Twitter™ および Facebook の投稿には、Creative Commons の規約内容は適用されません。

法律上の注意   |   プライバシーポリシー