現在表示中:

メタデータプロファイルを使用すると、フォルダー内のアセットにデフォルトのメタデータを適用できます。メタデータプロファイルを作成し、フォルダーに適用します。後からフォルダーにアップロードしたすべてのアセットは、メタデータプロファイルで設定したデフォルトのメタデータを継承します。

メタデータプロファイルの追加

  1. AEM のロゴをクリックまたはタップし、ツールアセットメタデータプロファイルの順に移動して、「作成」をクリックします。

  2. メタデータプロファイルのタイトル(「サンプルメタデータ」など)を入力し、「送信」をクリックします。メタデータプロファイルの「フォームを編集」が表示されます。

    chlimage_1
  3. コンポーネントをクリックし、「設定」タブでプロパティを設定します。例えば、説明コンポーネントをクリックして、そのプロパティを編集します。

    chlimage_1

    説明コンポーネントについて、次のプロパティを編集します。

    • フィールドラベル:メタデータプロパティの名前。ユーザーの参照用のみで使用します。
    • プロパティにマッピング:このプロパティの値には、リポジトリに保存される場所にあるアセットノードへの相対パスまたは名前を指定します。この値は、パスがアセットのノード以下にあることを示すので、必ず「./」から始めます。

     

    chlimage_1

    プロパティにマッピング」に指定した値は、アセットの metadata ノードの下のプロパティとして保存されます。例えば、「プロパティにマッピング」の名前として /jcr:content/metadata/dc:desc を指定した場合、アセットの metadata ノードに値 dc:desc が保存されます。

    • デフォルト値:メタデータコンポーネントのデフォルト値を追加するには、このプロパティを使用します。例えば、"My description" と指定すると、この値がアセットの metadata ノードの dc:desc プロパティに割り当てられます。
    chlimage_1

    注意:

    新しいメタデータプロパティ(/jcr:content/metadata ノードに未だ存在していないもの)にデフォルト値を追加しても、デフォルトではアセットのプロパティページにそのプロパティと値が表示されません。アセットのプロパティページで新しいプロパティを表示するには、対応するスキーマフォームを変更します。

  4. (オプション)「フォームを作成」タブから、「フォームを編集」にコンポーネントを追加し、「設定」タブでプロパティを設定します。「フォームを作成」タブでは、次のプロパティを使用できます。

    コンポーネント プロパティ
    セクションヘッダー
    • フィールドラベル
    • 説明
    1 行のテキスト
    • フィールドラベル
    • プロパティにマッピング
    • デフォルト値
    複数値テキスト
    • フィールドラベル
    • プロパティにマッピング
    • デフォルト値
    数値
    • フィールドラベル
    • プロパティにマッピング
    • デフォルト値
    日付
    • フィールドラベル
    • プロパティにマッピング
    • デフォルト値
    標準タグ
    • フィールドラベル
    • プロパティにマッピング
    • デフォルト値
    • 説明
    chlimage_1
  5. 完了」をクリックします。メタデータプロファイルが、メタデータプロファイルページのプロファイルのリストに追加されます。

    chlimage_1

メタデータプロファイルのコピー

  1. メタデータプロファイルページで、コピーを作成するメタデータプロファイルを選択します。

    chlimage_1
  2. ツールバーの「コピー」をクリックします。

  3. メタデータプロファイルをコピーダイアログで、メタデータプロファイルの新しいコピーのタイトルを入力します。

  4. コピー」をクリックします。メタデータプロファイルのコピーが、メタデータプロファイルページのプロファイルのリストに表示されます。

    chlimage_1

メタデータプロファイルの削除

  1. メタデータプロファイルページで、削除するプロファイルを選択します。

    chlimage_1
  2. ツールバーの「メタデータプロファイルを削除」をクリックします。

  3. ダイアログで、「削除」をクリックして、削除操作を確定します。メタデータプロファイルがリストから削除されます。

フォルダーへのメタデータプロファイルの適用

フォルダーにメタデータプロファイルを割り当てると、サブフォルダーは自動的に親フォルダーのプロファイルを継承します。つまり、フォルダーに適用できるのは 1 つのメタデータプロファイルのみとなります。そのため、アセットをアップロード、保存、使用およびアーカイブする場所のフォルダー構造については入念に検討してください。

フォルダーに異なるメタデータプロファイルを割り当てた場合、新しいプロファイルが以前のプロファイルよりも優先されます。以前に存在していたフォルダーのアセットは変更されずに維持されます。新しいプロファイルは、その後にフォルダーに追加されるアセットに対して適用されます。 

プロファイルが割り当てられているフォルダーは、ユーザーインターフェイスでカード名にプロファイルの名前が表示されます。

chlimage_1

特定のフォルダーまたはすべてのアセットにグローバルにメタデータプロファイルを適用できます。

特定のフォルダーへのメタデータプロファイルの適用

ツールメニュー内から、またはフォルダー内にいる場合は「プロパティ」から、メタデータプロファイルをフォルダーに適用できます。このセクションでは、メタデータプロファイルをフォルダーに適用する両方の方法について説明します。

既にプロファイルが割り当てられているフォルダーには、フォルダー名のすぐ下にプロファイルの名前が表示されます。

プロファイルユーザーインターフェイスからのフォルダーへのメタデータプロファイルの適用

プロファイルユーザーインターフェイスからフォルダーにメタデータプロファイルを適用するには:

  1. AEM のロゴをクリックまたはタップし、ツールアセットメタデータプロファイルの順に移動します。

  2. 1 つまたは複数のフォルダーに適用するメタデータプロファイルを選択します。

    chlimage_1
  3. メタデータプロファイルをフォルダーに適用」をタップまたはクリックし、新たにアップロードしたアセットの受け取る 1 つまたは複数のフォルダーを選択して、「完了」をタップまたはクリックします。既にプロファイルが割り当てられているフォルダーには、フォルダー名のすぐ下にプロファイルの名前が表示されます。

「プロパティ」からのフォルダーへのメタデータプロファイルの適用

「プロパティ」からフォルダーにメタデータプロファイルを適用するには:

  1. 左側のレールで、「アセット」をクリックまたはタップし、メタデータプロファイルを適用するフォルダーに移動します。

  2. チェックマークをタップまたはクリックして対象のフォルダーを選択し、「プロパティ」をタップまたはクリックします。

  3. メタデータプロファイル」タブを選択し、ドロップダウンメニューからプロファイルを選択して、「保存」をクリックします。

    chlimage_1

    既にプロファイルが割り当てられているフォルダーには、フォルダー名のすぐ下にプロファイルの名前が表示されます。

メタデータプロファイルのグローバルな適用

特定のフォルダーにプロファイルを適用する以外に、1 つのプロファイルを全体に適用し、フォルダーに AEM アセットとしてアップロードされたすべてのコンテンツに選択したプロファイルを適用することもできます。

プロファイルを全体的に適用するには、次のいずれかの操作をおこないます。

  • http://<AEM server>/mnt/overlay/dam/gui/content/assets/foldersharewizard.html/content/dam に移動し、適切なプロファイルを適用して、「保存」をタップまたはクリックします。

    chlimage_1
  • CRXDE Lite で、/content/dam/jcr:content ノードに移動します。プロパティ metadataProfile:/etc/dam/metadata/dynamicmedia/<name of metadata profile> を追加し、「すべて保存」をタップまたはクリックします。

    chlimage_1

フォルダーからのメタデータプロファイルの削除

フォルダーからメタデータプロファイルを削除すると、サブフォルダーは自動的に親フォルダーのプロファイルの削除状態を継承します。ただし、フォルダー内で実行されたファイルの処理はそのまま維持されます。

ツールメニュー内から、またはフォルダー内にいる場合は「プロパティ」から、メタデータプロファイルをフォルダーから削除できます。このセクションでは、メタデータプロファイルをフォルダーから削除する両方の方法について説明します。

プロファイルユーザーインターフェイスを使用したフォルダーからのメタデータプロファイルの削除

プロファイルユーザーインターフェイスを使用してフォルダーからメタデータプロファイルを削除するには:

  1. AEM のロゴをクリックまたはタップし、ツールアセットメタデータプロファイルの順に移動します。

  2. 1 つまたは複数のフォルダーから削除するメタデータプロファイルを選択します。

  3. フォルダーからメタデータプロファイルを削除」をタップまたはクリックし、プロファイルを削除する 1 つまたは複数のフォルダーを選択して、「完了」をタップまたはクリックします。

    名前がフォルダー名の下に表示されなくなっていることで、メタデータプロファイルがフォルダーに適用されていないことを確認できます。 

「プロパティ」を使用したフォルダーからのメタデータプロファイルの削除

「プロパティ」を使用してフォルダーからメタデータプロファイルを削除するには:

  1. AEM のロゴをタップまたはクリックして「アセット」に移動し、その後メタデータプロファイルを削除するフォルダーに移動します。

  2. チェックマークをタップまたはクリックして対象のフォルダーを選択し、「プロパティ」をタップまたはクリックします。

  3. メタデータプロファイル」タブを選択し、ドロップダウンメニューから「なし」を選択して、「保存」をクリックします。既にプロファイルが割り当てられているフォルダーには、フォルダー名のすぐ下にプロファイルの名前が表示されます。

本作品は Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License によってライセンス許可を受けています。  Twitter™ および Facebook の投稿には、Creative Commons の規約内容は適用されません。

法律上の注意   |   プライバシーポリシー