現在表示中:

画像をアップロードするときに、フォルダーにイメージプロファイルを適用することで、アップロード時に自動的に画像を切り抜くことができます。

注意:

スマート切り抜きは、Dynamic Media - Scene7 モードでのみ使用できます。

切り抜きツールオプション

選択可能な 2 つの画像切り抜きオプションと、カラーおよび画像スウォッチの作成を自動化するためのオプションがあります。

オプション 用途 説明
ピクセル切り抜き 画像サイズにのみ基づいて画像を一括で切り抜きます。

このオプションを使用するには、「切り抜きオプション」ドロップダウンリストで「ピクセル切り抜き」を選択します。

画像の各辺から切り抜くには、画像の任意の辺または四辺からの切り抜きのサイズ(ピクセル数)を入力します。画像がどれだけ切り抜かれるかは、画像ファイル内の ppi(1 インチあたりのピクセル数)の設定によって変わります。

イメージプロファイルのピクセル切り抜きは以下の方法で実行されます。

  • 値は「上」、「下」、「左」、「右」です。
  • 左上隅が 0,0 とみなされ、ここからピクセル切り抜きが計算されます。
  • 切り抜きの開始点:「左」が X、「上」が Y です。
  • 水平方向の計算:元の画像の水平方向のピクセルサイズから「左」と「右」を差し引きます。
  • 垂直方向の計算:垂直方向の高さ(ピクセル)から「上」と「下」を差し引きます。

例えば、4000 x 3000 ピクセルの画像があるとします。値として「上」= 250、「下」= 500、「左」= 300、「右」= 700 を使用します。

左上 (300,250) から、(4000-300-700, 3000-250-500) つまり (3000,2250) のフィルスペースを使って切り抜きます。

スマート切り抜き 視焦点位置に基づいて画像を一括で切り抜きます。

スマート切り抜きでは、Adobe Sensei の人工知能の能力を利用して、自動的に画像を一括ですばやく切り抜きます。画面サイズに関係なく、あらゆる画像の焦点位置を自動的に検出して切り抜き、目的の箇所を抜き出します。

スマート切り抜きを使用するには、「切り抜きオプション」ドロップダウンリストで「スマート切り抜き」を選択し、「レスポンシブ画像の切り抜き」の右側で、この機能を有効(オン)にします。

大、中および小のデフォルトのブレークポイントサイズでは、通常、モバイル、タブレットデバイス、デスクトップおよびバナーで使用されるほとんどの画像のすべてのサイズに対応できます。大、中および小のデフォルト値は、必要に応じて編集できます。

ブレークポイントを追加するには、「切り抜きを追加」をクリックします。切り抜きを削除するには、ごみ箱アイコンをクリックします。

カラーおよび画像スウォッチ 各画像の画像スウォッチを一括で生成します。

注意:Dynamic Media Classic ではスマートスウォッチはサポートされません。

商品画像から色やテクスチャを示す高品質のスウォッチを自動的に検出して生成します。

カラーおよび画像スウォッチを使用するには、「切り抜きオプション」ドロップダウンリストで「スマート切り抜き」を選択し、「カラーおよび画像スウォッチ」の右側で、この機能を有効(オン)にします。「幅」と「高さ」テキストフィールドにピクセル値を入力します。

画像の切り抜きはすべてレンディションレールから使用できますが、スウォッチを使用するには URL をコピー機能を利用しなければなりません。サイトでスウォッチをレンダリングするには、独自の表示コンポーネントを使用する必要があります(カルーセルバナーは例外です。カルーセルバナーで使用されるスウォッチについては、Dynamic Media が表示コンポーネントを提供します)。

画像スウォッチの使用

画像スウォッチの URL は簡単です。次のとおりです。

/is/image/company/<asset_name>:Swatch

:Swatch がアセット要求に追加されます。

カラースウォッチの使用

カラースウォッチを使用するには、次のように req=userdata 要求を作成します。

/is/image/<company_name>/<swatch_asset_name>:Swatch?req=userdata

例えば、Dynamic Media Classic(Scene7)のスウォッチアセットは次のとおりです。

http://my.company.com:8080/is/image/DemoCo/Sleek:Swatch

スウォッチアセットの対応する req=userdata URL は次のとおりです。

http://my.company.com:8080/is/image/DemoCo/Sleek:Swatch?req=userdata

req=userdata 応答は次のとおりです。

SmartCropDef=Swatch
SmartCropHeight=200.0
SmartCropRect=0.421671,0.389815,0.0848564,0.0592593,200,200
SmartCropType=Swatch
SmartCropWidth=200.0
SmartSwatchColor=0xA56DB2

次の URL の例のように、XML 形式または JSON 形式の req=userdata 応答を要求することもできます。

http://my.company.com:8080/is/image/DemoCo/Sleek:Swatch?req=userdata,json

http://my.company.com:8080/is/image/DemoCo/Sleek:Swatch?req=userdata,xml

注意:独自の WCM コンポーネントを作成してカラースウォッチを要求し、24 ビットの 16 進数 RGB 値で表される SmartSwatchColor 属性を解析する必要があります。

ビューアリファレンスガイドの「userdata」も参照してください。

アンシャープマスク

アンシャープマスク」を使用すると、ダウンサンプリングされた最終的な画像に対するシャープフィルター効果を細かく調整できます。効果の強さ、効果の半径(ピクセル単位)、無視されるコントラストのしきい値を調整できます。この効果では、Adobe Photoshop の「アンシャープマスク」フィルターと同じオプションが使用されます。

注意:

アンシャープマスクは、PTIFF(Pyramid TIFF)内のダウンスケールされたレンディション(50 %以上ダウンサンプルされたもの)にのみ適用されます。つまり、ptiff 内の最大サイズのレンディションはアンシャープマスクの影響を受けませんが、サムネールのような小さいサイズのレンディションは変更されます(そしてアンシャープマスクを表示します)。 

アンシャープマスク」には次のフィルタリングオプションがあります。

オプション 説明
端のピクセルに適用するコントラストを制御します。デフォルトは 1.75 です。高解像度の画像ではこの値を 5 まで増やすことができます。「量」は、フィルター強度の尺度だと考えてください。範囲は 0~5 です。
半径 シャープに作用する端のピクセル周辺のピクセル数を決定します。高解像度の画像の場合は、1~2 を入力します。小さい値は端のピクセルのみをシャープにし、大きい値は広範囲のピクセルをシャープにします。適切な値は画像のサイズによって異なります。デフォルト値は 0.2 です。範囲は 0~250 です。
しきい値

アンシャープマスクフィルターが適用される場合のコントラストの範囲を指定します。つまり、このオプションは、シャープされるピクセルが周囲の領域とどの程度違えば、そのピクセルをエッジのピクセルと見なしてシャープするかを決定するものです。ノイズが入らないように、0~255 の範囲で様々な整数値を試してください。

シャープニングについては、画像のシャープニングで説明しています。

イメージプロファイルの作成

他のアセットタイプ向けに詳細な処理パラメーターを定義するには、アセット処理の設定を参照してください。

イメージプロファイルを作成するには

  1. AEM のロゴをクリックまたはタップし、ツールアセットイメージプロファイルの順に移動します。

  2. 作成」をタップまたはクリックして、新しいイメージプロファイルを追加します。

  3. プロファイル名を入力し、アンシャープマスクのほか、切り抜きとスウォッチのいずれかまたは両方の値を入力します。

    目的を具体的に表すプロファイル名を使用すると便利です。例えば、スウォッチのみを生成するプロファイルを作成する(つまり、スマート切り抜きが無効(オフ)になっていて、カラーと画像スウォッチが有効(オン)になっている)場合、「スマートスウォッチ」というプロファイル名を使用できます。

    スマート切り抜きとスマートスウォッチオプションおよびアンシャープマスクも参照してください。

     

    Crop
  4. 保存」をクリックします。新しく作成されたプロファイルが、使用可能なプロファイルのリストに表示されます。

イメージプロファイルの編集または削除

  1. AEM のロゴをクリックまたはタップし、ツールアセットイメージプロファイルの順に移動します。

  2. 編集または削除するイメージプロファイルを選択します。編集するには、「画像処理プロファイルを編集」を選択します。削除するには、「画像処理プロファイルを削除」を選択します。

    chlimage_1
  3. 編集の場合は、変更内容を保存します。削除の場合は、プロファイルの削除を確定します。

フォルダーへのイメージプロファイルの適用

フォルダーにイメージプロファイルを割り当てると、サブフォルダーは自動的に親フォルダーのプロファイルを継承します。つまり、フォルダーに 1 つのイメージプロファイルのみを適用すればよいことになります。そのため、アセットをアップロード、保存、使用およびアーカイブする場所のフォルダー構造については入念に検討してください。

フォルダーに異なるイメージプロファイルを割り当てた場合、新しいプロファイルが以前のプロファイルよりも優先されます。以前に存在していたフォルダーのアセットは変更されずに維持されます。新しいプロファイルは、その後にフォルダーに追加されるアセットに対して適用されます。 

プロファイルが割り当てられているフォルダーには、ユーザーインターフェイス上でカード内に表示されたときに、そのプロファイルの名前が示されます。

既存のイメージプロファイルにスマート切り抜きを追加する際に、アセットリポジトリ内の既存のアセットの切り抜きを生成したい場合は、DAM アセットの更新ワークフローを再実行する必要があります。

イメージプロファイルは、特定のフォルダーに適用することも、全アセットにグローバルに適用することもできます。 

特定のフォルダーへのイメージプロファイルの適用

ツールメニュー内から、またはフォルダー内にいる場合は「プロパティ」から、特定のフォルダーにイメージプロファイルを適用できます。このセクションでは、イメージプロファイルをフォルダーに適用するための方法を両方とも説明します。

既にプロファイルが割り当てられているフォルダーには、フォルダー名のすぐ下にプロファイルの名前が表示されます。

プロファイルユーザーインターフェイスからのフォルダーへのイメージプロファイルの適用

  1. AEM のロゴをクリックまたはタップし、ツールアセットイメージプロファイルの順に移動します。

  2. 1 つ以上のフォルダーに適用するイメージプロファイルを選択します。

    chlimage_1
  3. 処理プロファイルをフォルダーに適用」をタップまたはクリックし、新規にアップロードするアセットを置くために使用するフォルダーを 1 つ以上選択し、「適用」をタップまたはクリックします。既にプロファイルが割り当てられているフォルダーには、フォルダー名のすぐ下にプロファイルの名前が表示されます。

プロパティからのフォルダーへのイメージプロファイルの適用

  1. AEM のロゴをタップまたはクリックして「アセット」に移動してから、イメージプロファイルを適用するフォルダーに移動します。

  2. チェックマークをタップまたはクリックして対象のフォルダーを選択し、「プロパティ」をタップまたはクリックします。

  3. イメージプロファイル」タブをタップします。「プロファイル名」ドロップダウンリストからプロファイルを選択し、「保存して閉じる」をクリックします。既にプロファイルが割り当てられているフォルダーには、フォルダー名のすぐ下にプロファイルの名前が表示されます。

    chlimage_1

グルーバルなイメージプロファイルの適用

特定のフォルダーにプロファイルを適用できるだけでなく、グローバルにプロファイルを適用することもできます。これにより、AEM アセットにアップロードされている、すべてのフォルダー内にあるすべてのコンテンツに、選択したプロファイルを適用できます。

プロファイルを全体的に適用するには、次のいずれかの操作をおこないます。

  • http://<AEM server>/mnt/overlay/dam/gui/content/assets/foldersharewizard.html/content/dam に移動し、適切なプロファイルを適用して、「保存」をタップまたはクリックします。

    chlimage_1
  • CRXDE Lite で、/content/dam/jcr:content ノードに移動します。

    プロパティ imageProfile:/conf/global/settings/dam/adminui-extension/imageprofile/<name of image profile> を追加し、「すべて保存」をタップします。

    configure_image_profiles

単一の画像のスマート切り抜きまたはスマートスウォッチの編集

注意:

スマート切り抜きは、Dynamic Media - Scene7 モードでのみ使用できます。

画像のスマート切り抜きウィンドウの位置の再調整またはサイズの変更を手動でおこなって、焦点位置を細かく調整することができます。

スマート切り抜きを編集して保存すると、その画像の切り抜きを使用しているすべての場所で変更が反映されます。

必要に応じてスマート切り抜きを再実行して、追加の切り抜きを再度生成することができます。

複数の画像のスマート切り抜きまたはスマートスウォッチの編集も参照してください。

  1. AEM ロゴをタップまたはクリックし、アセットに移動した後、スマート切り抜きまたはスマートスウォッチのイメージプロファイルが適用されているフォルダーに移動します。

  2. フォルダーをタップまたはクリックして開きます。

  3. スマート切り抜きまたはスマートスウォッチを調整したい画像をタップまたはクリックします。

  4. ツールバーで、「スマート切り抜き」をタップまたはクリックします。

  5. 次のいずれかの操作をおこないます。

    • ページの右上隅にあるスライダーバーを左右にドラッグして画像表示を拡大または縮小します。
    • 画像のコーナーハンドルをドラッグして、切り抜きまたはスウォッチの表示可能領域のサイズを調整します。
    • 画像上のボックスまたはスウォッチを新しい場所にドラッグします。画像スウォッチは編集できますが、カラースウォッチは静的です。
    • 画像の上部にある「元に戻す」をタップまたはクリックして、すべての編集作業を取り消し、元の切り抜きまたはスウォッチを復元します。
  6. ページの右上にある「保存」をタップまたはクリックし、「閉じる」をタップまたはクリックして、アセットのフォルダーに戻ります。

複数の画像のスマート切り抜きまたはスマートスウォッチの編集

スマート切り抜きを含むイメージプロファイルをフォルダーに適用すると、そのフォルダー内のすべての画像に切り抜きが適用されます。必要に応じて、複数の画像のスマート切り抜きウィンドウの位置の再調整またはサイズの変更を手動でおこなって、その焦点位置を細かく調整することができます。

スマート切り抜きを編集して保存すると、その画像の切り抜きを使用しているすべての場所で変更が反映されます。

必要に応じてスマート切り抜きを再実行して、追加の切り抜きを再度生成することができます。

  1. AEM ロゴをタップまたはクリックし、アセットに移動した後、スマート切り抜きまたはスマートスウォッチのイメージプロファイルが適用されているフォルダーに移動します。

  2. フォルダーで、その他のアクション(...)アイコンをタップまたはクリックし、「スマート切り抜き」をタップまたはクリックします。

  3. スマート切り抜きを編集ページで、次のいずれかの操作をおこないます。

    • スマート切り抜きを編集ページで画像の表示サイズを調整します。
      ブレークポイント名のドロップダウンリストの右側にあるスライダーバーを左右にドラッグして表示可能な画像表示のサイズを変更します。
    edit_smart_crops-sliderbar
    • ブレークポイント名に基づいて表示可能な画像のリストを絞り込みます。以下の例では、「中」というブレークポイント名で画像を絞り込んでいます。
      ページの右上隅にあるドロップダウンリストから、ブレークポイント名を選択して、表示する画像を絞り込みます(上記の画像を参照してください)。
    edit_smart_crops-dropdownlist
    • スマート切り抜きボックスのサイズを変更します。次のいずれかの操作をおこないます。
      • 画像にスマート切り抜きまたはスマートスウォッチのみが適用されている場合は、画像の切り抜きボックスのコーナーハンドルをドラッグして、切り抜きの表示可能領域のサイズを調整します。
      • 画像にスマート切り抜きとスマートスウォッチの両方が適用されている場合は、画像の切り抜きボックスのコーナーハンドルをドラッグして、切り抜きの表示可能領域のサイズを調整します。または、画像の下部にあるスマートスウォッチをタップまたはクリックしてから(カラースウォッチは静的です)、切り抜きボックスのコーナーハンドルをドラッグして、スウォッチの表示可能領域のサイズを調整します。
    画像のスマート切り抜きのサイズ変更。
    • スマート切り抜きボックスを移動します。次のいずれかの操作をおこないます。
      • 画像にスマート切り抜きまたはスマートスウォッチのみが適用されている場合は、画像の切り抜きボックスを新しい場所にドラッグします。
      • 画像にスマート切り抜きとスマートスウォッチの両方が適用されている場合は、画像の切り抜きボックスを新しい場所にドラッグします。または、画像の下部にあるスマートスウォッチをタップまたはクリックしてから(カラースウォッチは静的です)、スマートスウォッチの切り抜きボックスを新しい場所にドラッグします。
    画像のスマート切り抜きボックスの移動。
    • すべての編集作業を取り消し、元のスマート切り抜きまたはスマートスウォッチを復元します(現在の編集セッションにのみ適用されます)。
      画像の上部にある「元に戻す」をタップまたはクリックします。
    画像のスマート切り抜きの編集の取り消し。
  4. ページの右上隅にある「保存」をタップまたはクリックします。「閉じる」をタップまたはクリックして、アセットのフォルダーに戻ります。

フォルダーからのイメージプロファイルの削除

フォルダーからイメージプロファイルを削除すると、サブフォルダーは自動的に親フォルダーのプロファイルの削除状態を継承します。ただし、フォルダー内で実行されたファイルの処理はそのまま維持されます。

ツールメニュー内から、またはフォルダー内にいる場合は「プロパティ」で、特定のフォルダーからイメージプロファイルを削除できます。このセクションでは、イメージプロファイルをフォルダーから削除するための方法を両方とも説明します。

プロファイルユーザーインターフェイスを使用したフォルダーからのイメージプロファイルの削除

  1. AEM のロゴをクリックまたはタップし、ツールアセットイメージプロファイルの順に移動します。

  2. 1 つ以上のフォルダーから削除するイメージプロファイルを選択します。

  3. フォルダーから処理プロファイルを削除」をタップし、プロファイルを削除するフォルダーを 1 つ以上選択して、「削除」をタップします。

    名前がフォルダー名の下に表示されなくなっていることで、イメージプロファイルがフォルダーに適用されていないことを確認できます。 

プロパティを使用したフォルダーからのイメージプロファイルの削除

  1. AEM のロゴをタップまたはクリックして「アセット」に移動してから、イメージプロファイルを削除するフォルダーに移動します。

  2. チェックマークをタップまたはクリックして対象のフォルダーを選択し、「プロパティ」をタップまたはクリックします。

  3. イメージプロファイル」タブを選択し、「プロファイル名」ドロップダウンメニューから「なし」を選択して、「保存して閉じる」をクリックします。既にプロファイルが割り当てられているフォルダーには、フォルダー名のすぐ下にプロファイルの名前が表示されます。

本作品は Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License によってライセンス許可を受けています。  Twitter™ および Facebook の投稿には、Creative Commons の規約内容は適用されません。

リーガルノーティス   |   プライバシーポリシー