欠落しているシステムユーザー ACL を修正

AEM でシステム ACL が誤って削除されたため、AEM 機能が壊れています。

原因

これには多くの原因が考えられますが、最も一般的なものは次のとおりです。

  • ユーザーによる権限の偶発的な削除
  • ACL パッケージの AC ハンドリングオプションでの「Overwrite」値による ACL パッケージのインストール

解決策

この問題を解決するには、次の操作を実行します。

  1. クリーンな AEM オーサーインスタンスまたはパブリッシュインスタンスをローカルにインストールし、インストール時に -r nosamplecontent オプションを設定します(インスタンスタイプと、ACL が欠落しているインスタンスを照合します)。例:java -Xmx2048m -jar cq-author-p4502.jar -r nosamplecontent
  2. AEM パッケージマネージャー http://host:port/crx/packmgr/index.jsp にアクセスし、管理者としてログインします
  3. ACS Commons をダウンロードしてインストールします
  4. ACL Packager を使用して、追加設定不要の ACL をパッケージ化します。ACL パッケージを設定する場合は、"/ を設定します。*"パターンを含めるの唯一の値として。次に AC の処理オプションを「統合」に設定します。
  5. パッケージマネージャーに移動し、ACL パッケージを構築します。
  6. パッケージをダウンロードします
  7. このホットフィックスを取得して、crx-quickstart/install フォルダーにドロップすると、壊れた環境にインストールされます。
  8. ホットフィックスが完全にインストール(error.log によって検証)されたら、AEM を再起動します。
  9. 次に、壊れたインスタンスの crx-quickstart/install フォルダーに ACL パッケージをドロップします
  10. パッケージがインストールされたら、AEM をもう一度再起動します。

これで、追加設定不要の元の ACL が復元されました。

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