AEM 6.4.2 以降から AEM 6.5 へのアップグレードに関する既知の問題

問題

6.4.2(以降)から 6.5 にアップグレードし、このインスタンスが以前に AEM 6.1 または AEM 6.2 からアップグレードされた場合、アップグレードが失敗し、要件が見つからないエラーが発生する可能性がある

04.12.2019 15:14:33.439 *ERROR* [FelixStartLevel] ERROR: Bundle '827' Error starting/stopping bundle. (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.scripting.javascript [827](R 827.0): missing requirement [org.apache.sling.scripting.javascript [827](R 827.0)] osgi.wiring.package; (&(osgi.wiring.package=javax.jcr)(version>=2.0.0)) Unresolved requirements: [[org.apache.sling.scripting.javascript [827](R 827.0)] osgi.wiring.package; (&(osgi.wiring.package=javax.jcr)(version>=2.0.0))])
org.osgi.framework.BundleException: Unable to resolve org.apache.sling.scripting.javascript [827](R 827.0): missing requirement [org.apache.sling.scripting.javascript [827](R 827.0)] osgi.wiring.package; (&(osgi.wiring.package=javax.jcr)(version>=2.0.0)) Unresolved requirements: [[org.apache.sling.scripting.javascript [827](R 827.0)] osgi.wiring.package; (&(osgi.wiring.package=javax.jcr)(version>=2.0.0))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2281)
at org.apache.felix.framework.Felix.setBundleStartLevel(Felix.java:1727)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:338)
at java.lang.Thread.run(Unknown Source)
04.12.2019 15:14:33.440 *ERROR* [FelixStartLevel] ERROR: Bundle '828' Error starting/stopping bundle. (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.scripting.jst [828](R 828.0): missing requirement [org.apache.sling.scripting.jst [828](R 828.0)] osgi.wiring.package; (&(osgi.wiring.package=javax.jcr)(version>=1.0.0)(!(version>=3.0.0))) Unresolved requirements: [[org.apache.sling.scripting.jst [828](R 828.0)] osgi.wiring.package; (&(osgi.wiring.package=javax.jcr)(version>=1.0.0)(!(version>=3.0.0)))])
org.osgi.framework.BundleException: Unable to resolve org.apache.sling.scripting.jst [828](R 828.0): missing requirement [org.apache.sling.scripting.jst [828](R 828.0)] osgi.wiring.package; (&(osgi.wiring.package=javax.jcr)(version>=1.0.0)(!(version>=3.0.0))) Unresolved requirements: [[org.apache.sling.scripting.jst [828](R 828.0)] osgi.wiring.package; (&(osgi.wiring.package=javax.jcr)(version>=1.0.0)(!(version>=3.0.0)))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2281)
at org.apache.felix.framework.Felix.setBundleStartLevel(Felix.java:1727)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:338)
at java.lang.Thread.run(Unknown Source)

またはこのエラー:

11.12.2019 10:26:32.102 *ERROR* [FelixDispatchQueue] com.adobe.granite.crypto FrameworkEvent ERROR (org.osgi.framework.BundleException: Unable to resolve com.adobe.granite.crypto [158](R 158.3): missing requirement [com.adobe.granite.crypto [158](R 158.3)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.commons.io)(version>=2.0.1)(!(version>=3.0.0))) Unresolved requirements: [[com.adobe.granite.crypto [158](R 158.3)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.commons.io)(version>=2.0.1)(!(version>=3.0.0)))])
org.osgi.framework.BundleException: Unable to resolve com.adobe.granite.crypto [158](R 158.3): missing requirement [com.adobe.granite.crypto [158](R 158.3)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.commons.io)(version>=2.0.1)(!(version>=3.0.0))) Unresolved requirements: [[com.adobe.granite.crypto [158](R 158.3)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.commons.io)(version>=2.0.1)(!(version>=3.0.0)))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2281)
at org.apache.felix.framework.Felix$RefreshHelper.restart(Felix.java:5349)
at org.apache.felix.framework.Felix.refreshPackages(Felix.java:4516)
at org.apache.felix.framework.FrameworkWiringImpl.run(FrameworkWiringImpl.java:188)
at java.lang.Thread.run(Thread.java:748)

解決策

  1. 6.5 にアップグレードした後で(または最終的なアップグレードコマンドを実行する前に)、インスタンスを停止してください。
  2. この commons-io jar をサーバーにダウンロードし、crx-quickstart/install の下に配置します。
  3. 以下のコマンドを使用してインスタンスを再起動します
    java -server -Xmx1024m -XX:MaxPermSize=256M -Djava.awt.headless=true -Dsling.run.modes=author,crx3,crx3tar -jar cq-quickstart-6.5.0.jar  -p 4502 -Dsling.properties=conf/sling.properties -Dorg.apache.sling.launchpad.startupmode=UPDATE &
  4. /system/console/bundles を確認し、すべてのバンドルがアクティブ状態になり、システムが完全にアップグレードされたら、インスタンスを再び停止します。
  5. 以下のコマンドでインスタンスを再起動します
    java -server -Xmx1024m -XX:MaxPermSize=256M -Djava.awt.headless=true -Dsling.run.modes=author,crx3,crx3tar -jar cq-quickstart-6.5.0.jar -p 4502 -Dsling.properties=conf/sling.properties &
  6. アップグレードは正常に完了するはずです。

追加情報

この問題は、以前に AEM 6.1 または AEM 6.2 からアップグレードした AEM 6.4.2 以降のインスタンスをアップグレードする場合に発生します

アドビのロゴ

アカウントにログイン