キャンペーン同期により AEM からの正しい HTML が受信されない

「Adobe Campaign にパブリッシュ」ワークフローを実行し、Adobe Campaign で同期した後は、キャンペーンに正しい HTML が表示されていないことがわかります。

環境

AEM 6.x

原因

間違った HTML がキャンペーンに配信される原因として、多くの原因が考えられます。

  • パブリック URL は、CDN、ロードバランサー、または Dispatcher を介してサイトに移動する AEM Campaign 統合 - 設定で設定できます。  アーキテクチャスタックの任意のレイヤーで破損している可能性があります - CDN キャッシュの問題、間違ったディスパッチャーをポイントするロードバランサー、正しくない設定がされているまたは失敗している Dispatcher、エラーまたは間違ったコードで失敗している AEM パブリッシュインスタンス。
  • パブリッシュインスタンスからコンテンツを直接配信する場合は、パブリッシュインスタンスの設定が誤っている、エラーが発生した、誤ったコードがインストールされているなどの可能性があります。

解決策

  1.  キャンペーンをパブリッシュする前に、AEM でニュースレターページをアクティベート/公開したことを確認します。

  2. AEM Campaign 統合 OSGi 設定 [1] でパブリック URL を確認します。パブリック URL は、Adobe Campaign に送信される HTML を取得するためにワークフローが使用する URL です。  このフィールドに値が入力されている場合は、クリップボードに URL をコピーします。

    [1] http://host:port/system/console/configMgr/com.day.cq.mcm.campaign.impl.IntegrationConfigImpl

  3. パブリック URL がこの設定で空である場合、システムは Externalizer 設定 [2] でパブリッシュ用の URL にフェールオーバーします。  このパブリッシュ URL をクリップボードにコピーします。

    [2] http://host:port/system/console/configMgr/com.day.cq.commons.impl.ExternalizerImpl

  4. 前の手順から取得した URL を使用し、パブリッシュインスタンスの /path/to/newsletter.publish.html を使用してニュースレターページにアクセスします。 

    例:/content/site/en/newsletters/test.publish.html

  5. ほとんどの場合、HTML がキャンペーンの表示と同じ方法で正しく表示されずに失敗することがわかります。  これは、ワークフローによって Adobe Campaign に取得および送信される URL です。  この URL を参照することにより、問題が CDN のキャッシュ、ロードバランシング、Dispatcher のキャッシュ、または AEM パブリッシュインタンスまたはコードの問題(例:パブリッシュインスタンスでデプロイされた間違ったコード)である場合、デバッグすることができます。

アドビのロゴ

アカウントにログイン