問題点

一部の .js および .css ファイルが、AEM ページまたは AEM UI から欠落しています。 

原因

この問題については、次の 1 つ以上の理由が考えられます。
  • AEM Client Library Manager(HTMLLibraryManager)で使用された xpath クエリー [1] は、/oak: index/nodetype インデックス以外の一部のインデックスを使用しています。
  • nodetype インデックスにはエラーがあるため、更新されていないか、破損しています。
  • clientlibs-service ユーザーの権限が欠落しています。
/jcr: root//element(*, cq :ClientlibraryFolder)

解決策

I. サービスユーザーの権限を確認します

clientlibs-service ユーザー権限が欠落している場合は、この記事を参照してください。

II.クエリーが正しい結果を取得していることを確認します

  1. http://aem-host:porl/crx/de/index.jsp に移動し、管理者としてログインします。

  2. 「ツール」>「クエリー」に移動します

  3. 下の「クエリー」ボックスで、次のクエリーを入力します。
    /jcr: root//element(*, cq: ClientlibraryFolder)

  4. 欠落しているクライアントライブラリが結果にあるかどうかを検証します。これがある場合は、AEM カスタマーケアに連絡し、より詳細な検索を使用してヘルプを取得してください。さもなければ、引き続き次の手順に進みます。

  5. 欠落しているクライアントライブラリを除外した結果が見つかった場合は、http://aem-host:port/libs/granite/operalions/content/diagnosis/tool.html/granite:queryperformance に移動します。

     

  6. クエリーをもう一度入力し、「説明」をクリックします。

  7. この出力には、クエリーを実行するために使用されるインデックスが表示されます。リストされたインデックスが nodetype インデックスでない場合、何かが間違っています。

     

  8. 異なるインデックスがそのクエリーに対して低コストの見積りを返す原因となるものをデバッグできます。クエリーの分析のためのデバッグログ記録を有効にする方法について詳しくは、この記事を参照してください。

  9. 正しいインデックスを選択したが正しい結果が返されない場合は、破損しています。この場合、nodetype インデックスをインデックス再作成できます。

  10. インデックスを非同期的でインデックス再作成するには、この記事の手順に従います。

    警告:

    インデックス再作成中に、一部の検索が古い結果を表示し、システムが応答しない場合があることに注意してください。  システム上のユーザーが最も少ない場合は、このタスクのインデックス再作成または実行を停止することをお勧めします。

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