問題点

「SSL ロードバランサーの終了」[1] システムの AEM 6.3 SP1 + CFP1 以降を適用した後に(または Web サーバー)は、ユーザーは、AEM にログインできません。

[1] ロードバランサーやディスパッチャーで終わる SSL は、使用している https:// ロードバランサーを介してアクセスするのではなく、AEM が http:// を介してアクセスします。

環境

AEM 6.3 以降のバージョン

原因

これは既知の問題であり、Apache Felix から CFP、SslFilter を適用した後、認証前には実行しません。

Apache Felix は、jetty サーブレットエンジンを介して、この設定の異なるメカニズムを提供します。技術的な詳細については、FELIX-5207 を参照します。

解決策

AEM 6.3 SP1 + CFP1 以降のサービスパック/CFP をインストール後に、次の設定変更を行います。

  1. http://aem-host:port/system/console/configMgr へログインします。
  2. Jetty Http サービスに基づいた Apache Felix を検索し、設定を開きます。
  3. 有効な Proxy/ロードバランサー接続の設定を有効にし、保存します。
  4. Sling 認証サービスを検索し、設定を開きます。
  5. 匿名のアクセスを許可のチェックを解除し、設定を保存します。

この設定は、X-Forwarded-Proto: https ヘッダーのみに適用します。  ユーザーが https 経由で接続している場合は、ロードバランサーまたは Web サーバーがこれを AEM に送信していることを確認します。

これらの設定を変更した後で、ロードバランサー/ディスパッチャーを使用して、ログインできるようにする必要があります。

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